Reports

Reports

ThinManager has the ability to run reports to show and collect data on the ThinManager system. These
reports can show the event log, configurations, uptimes, and other data.

A Reports tab on the Details pane will show a report for a highlighted ThinManager Server, terminal, terminal
group, terminal server, TermSecure user, or TermSecure user group.

Reports can be scheduled to be run and saved as * . html files for storage or further analysis.

Report Template Installation

ThinManager will install a number of reports into the ThinManager folder (C-\Program
Files\Automation Control Products\ThinManager\ReportTemplates) during
installation.

Additional report templates can be downloaded from www.thinmanager.com/support/downloads.shtml as they
become available.

New reports are installed by selecting Install > Reports from the ThinManager menu. This launches the
Reports window.
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Reports |

f* Report Templates i~ S0L Files i~ |mages, Finished Reports ete.
R eport Description | Fepart Type | Fepart Template
Terminal Login Settings Fpghem TeminaldutologinS ettingsT emplate. b
Terminal Configuration Chan...  terminal TerminalConfigChanges T emplate. html
Terminal Configuration zWztem TerminalConfigurationT emplate. html
Properties of All Terminalz zpztem TeminalPropertiesT emplate. kil
Teminal Server Resource E...  terminal server TeminalServerResourcel ventzTemp
Terminal Seszion Events Log  terminal TerminalS ezsionkE ventsT emplate. htrml
Termminal Shadow Events terminal TerminalshadowE ventsT emplate. html
Terminalz Properties zpztem TerminalzRepart T emplate. html
TemSecure LogindLogout E... wser IlzerLoginE wentT emplate. html
Ewent Log Fpghem eventlogtemplate. himl
Terminal Lptime Repaort zWztem terminialuptimetenmplate. html
1] | 0

[nztall Delete

Reports Window

Select the Install button to launch a file browser.

e Report Templates — If this radio button is selected the file browser will browse for
*_html files.

e SQL Files — If this radio button is selected the file browser will browse for *_sql
files.

e Images, Finished Reports, etc. — If this radio button is selected the file browser
will browse for assorted files.

Open E3

Lok, jr: I I ReportTemplates j = ¥ ER-
|§_°°| kerminals, sgl 5’] userlogins, sl

Ej terminalserverresourcesyents, sl

E’J terminalsessions.sql

Ej terminalshadowewvents, sql

Ej terminaluptime. sql
E,l termprops.sql

Kl [

File name; | Open I
Filez af ype: ISE!L Cueries j Cancel |

[~ Open as read-only

A

File Browser
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Each report has a * . html component and a * . sq I component. Select the Report Templates radio
button, browse to the new * . html file, and select Open to install. Select the SQL Files radio button,
browse to the new * . s file and select Open to install. Once these two components are added the report
will be available.

Selecting Reports

The reports are displayed on a Report tab in ThinManager. To select which report will be displayed on the
Report tab select View > Reports from the ThinManager menu to launch the Select Reports window.

select Reports | x| |

J | Cancel |

System Fepart IF'ru:nperties of All Terminals
Termninal Fepaort ITerminaI Configuration Changes j
Terminal 5 erver Feport ITerminaI Server Aesource Eventfj

TemSecure User Report I TermSecure Login/Logout Eventj

Select Reports Window

The Select Reports window has four fields that determine which report is displayed on the report tab.

e System Report — This selects the report to display on the report tab when the
ThinManager Server is highlighted.

e Terminal Report — This selects the report to display on the report tab when a
terminal or terminal group is highlighted.

e Terminal Server Report — This select the report to display on the report tab when
a terminal server is highlighted.

e TermSecure User Report — This selects the report to display on the report tab
when a TermSecure User or TermSecure User Group is highlighted.

Use the drop-down list to select the desired report.
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Report Tab

The reports selected in the Select Reports window will be displayed on the Report tab in ThinManager.

fs?{Thinl-ia nager

Edit Manage Instal Tools View RemoteView Help

=] B3

=g Cobalt
EI,L!_.E Terminals
J..I.!:H Groupl
,L%l Alpha
& MultiMonitor 1
II_%L Sierra
E| ﬁ Display Servers
i Terminal Servers
Cameras
GJ VCenter Servers
E| Display Clients
ﬂ TermSecure Users

For Help, press F1

.Eu:unfiguraticunl Mu:udulesl Schedulel F'ru:upertiesl Event Lu:ugl Shadow Report |

THINMAMNAGER

b=l

Description
Terminal Created
Terminal Configuration

Changed

Terminal Configuration
Changed

Terminal Configuration
Changed

Terminal Configuration

Time
04/08M11
23:34:55
041111
18:22.04
041111
18:28:58

041111
18:56:57

User

phurns

phurns

phurns

phurns

=

Report Tab

Highlight the desired ThinManager Server, terminal, terminal group, terminal server, TermSecure user, or
TermSecure group, and then select the Report tab to display the report.
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Print Report

A Report can be printed by selecting the Report tab then selecting View > Print from the ThinManager menu.
A Print window will be displayed to allow the selection of the printer.

L >

General | I:Iptigngl

— Select Printer

=2 HP Laser Jet 5000 Series PCL
HP Lasetlet P100G
4 KOMICA MINOLTA magicolor 543000

(s Macromedia FlashPaper
iz Microsoft ¥PS Docurnent W

| fL

Status: Feady [ Frnttofile  Preferences |

Location:

Rl Find Printer... |
— Page Hanage

e Al Mumber of copies: I'I 3:

{ Selection ) Current Page

" Pages |1 ¥ Collate

E nter either a single page number or a single

page range. For example, 5-12

Frint I

Caricel | Apply

Print Window

Highlight the desired printer and select the Print button to print the report.
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Scheduling Reports

Reports can be scheduled to be run once at a specified time or to be run regularly at a specific time. The
reports are saved as * . html files for storage or further analysis.

To schedule report generation open the ThinManager Server Configuration Wizard by highlighting the
ThinManager Server and selecting File > Modify.

& ThinManager Server Configuration Yizard El

System Schedule ﬂ

Edit the systern zchedule
A

Syztem Schedule

Edit Schedule

Finizh Cancel Help

¢ Back

ThinManager Server Configuration Wizard — System Schedule

Navigate to the System Schedule page and select the Edit Schedule button to launch the Event Schedule
window.
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Event Schedule |

Select Event Categaony I systerm j

Event Type | Tirne |

&dd Edit Delete

Event Schedule Window

Select the Add button to open the Schedule window.
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Schedule |
— Ewvent Type

I Run Report j
— Repart Template File

T erminal Uptime B eport

— Report Output File
¥ Auto Generate Filename

— Repeat Interval

" Once Only £ Time Interval
&+ weekly / Daily £ Monthly i Yearly
—weekly Scheduls

[ Monday

[T Tuesday 4|Ever_l,l Day
[T wednesday

[T Thursday

[ Friday

[T Saturday

[T Sunday

| F:00 P =

Cancel | ]9 I

Schedule Window

Time

The Schedule window allows system events to be configured.

Event Type — This drop-down allows the event to be chosen. There are two types:

Backup Configuration Database — This allows a scheduling of automatic
configuration backups.

Run Report — This allows a report to be run and saved as a *.html file on a
regular basis.

Report Template File - This drop-down allows the selection of the report to run.
Report Output File — This applies the naming convention to the saved reports.

Auto Generate Filename — This checkbox, if selected, will save the file to the
ThinManager folder with the report name and a time stamp as its title.

If the Auto Generate Filename is unselected, the field allows entry of the desired
filename. The filename needs to end in .html.

There are a few switches that allow the file name to be modified with a timestamp for
identification purposes. If you do not use a timestamp, the file will be overwritten each time
the report is run.

. %c — Adds date and time
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e 96h — adds hour (0-24)

e 9%M — adds minute (0-59)
e 96X — adds date

e 90X — adds time

e Repeat Interval — These radio buttons allow the frequency of the report generation
to be set.

e Time — The fields to set the time of the report generation changes to match the
Report Interval selected by the radio button. The Time field may allow dates,
days, hours, or intervals to be set for the report.

Once the report is configured, select OK to accept the report schedule.

Event Schedule |
Select Event Categaony I systerm j
Event Type | Time |
Fun Report everny Wednesday Friday at 06:00 PM
Run Report every Friday at 05:00 Pk
Fun Repaort an day 07 at 08:00 Akd

Edit [Nelete k. |

Event Schedule

The scheduled report will be displayed in the Event Schedule window.
e Select Add to add another report schedule.
e Select Edit to edit the schedule of a highlighted report.
e Select Delete to delete the schedule of a highlighted report.
e Select OK to accept the schedules and close the window.

When a report is run the files are saved for viewing.
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J File Edit ‘iew Favorites Tools  Help | : ‘.'

J Qeack ~ €3 - [ F | - search Folders | & 3 X ) | =

J Address L0 C:\Program Files\aukomation Control Productsh ThinManager|\Repaorts
Mame I Size I Dake Modified | Type AI
& eventlog_2008_04_20_17_00, html 18 KE 4/20/2008 5:00 PM Firefax ..
i;| kerminaluptime_2008_02_15_21_00.html 3KE  2/15/2008 10:00 PM Firefowx D,
_ﬂ; kerminaluptime_2008_0Z_03_21_00.html 3KE  2/8/2005 10:00 PM Firefow D...
@ kerminaluptime_2008_0Z_01_21_00.html 3KE  2/1)2005 10;00 PM Firefow D,..
_ﬂ; kerminaluptime_2008_01_18_21_00.html 3KE  1/158/2008 10:00 PM Firefox D...
ﬂ; kerminalupkime_2003_01_11_21_00.html 3KBE  1/11[2008 10:00 PM Firefaowx D...
.ﬂ; kerminaluptime_2003_01_04_21_00.html IEB  1/4)2008 10:00 PM Firefox D...
ﬂ; terminaluptime_2007_12_23_21_00.html IKB  12/28/2007 10:00PM  Firefox D...
_ﬂ; terminaluptime_2007_12_21_21_00.html IKB 120212007 10:00PM  Firefox D...
i;| kerminaluptime_2007_12_14_21_00.html I3KE  12/14)2007 10:00PM Firefox D,
_ﬂ; kerminaluptime_2007_12_07_21_00.html 3KE  1207[2007 10:00 PM Firefow D...
@ kerminaluptime_2007_11_30_21_00.html 3KE  11f3002007 10:00PM Firefox D...
_ﬂ; kerminaluptime_2007_11_23_21_00.html 3KE  11[23/2007 10:00PM Firefox D...
ﬂ; kerminalupkime_2007_11_16_21_00.html IKBE 11018f2007 10:00PM  Firefox D...
.ﬂ; kerminaluptime_2007_11_09_21_00.html IEB  11/9/2007 10:00 PM Firefox D,
ﬂ; terminaluptime_2007_11_09_20_00.html IKE 1192007 9:00 PM Firefox D...
_ﬂ; terminaluptime_2007_11 _02_21_00.html 3B 11)2/2007 ;00 PM Firefox D...
i;| kerminaluptime_2007_0%_21_21_00.html 3KE  9/21/2007 ;00 PM Firefowx D,
_ﬂ; kerminaluptime_2007_0%_14_21_00.html 3KE  9/14/2007 200 PM Firefow D...
@ kerminaluptime_2007_09_07_21_00.html 3KE 97 2007 9:00 PM Firefow D,..
_-.i‘fl kerminaluptime_2007_08_31_21_00.html 3KE  8/31/2007 9:00 PM Firefox D, T
J Gl

Dimensions: 150 x 50 Type: JPEG Image Size: 2.75KE 2,75 KB | 4 My Computer p

Saved Reports

Once the report has run it can be opened in a web browser.
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{= c:\Program Files', Automation Control Products’, ThinManagerReports'.eventlog_2009_10_08_1... [H[=]
AL Ié, C\Program Files)Aukarmation (j X Iﬁ Google }'J.:.v;
J File Edit \iew Favorites Tools  Help J x %Canvert - @ Select
T:? @C:'I,F‘rcugram Files'Automation Conkrol Productsi ThinMa, ., i J iy?i’ Y s
THINMANAGER -
=
Event Log
10108109
Event Type Type Name Description Time User
Synchronization systemn systemn Mot Synchronized agfggfgg
Firrmware 10/08/09
Firmware system systemn firmware.acpv04.00.999 release 07-23:96 system
installed o
Terminal Capabilities Database 10/08/09
TermCap systemn systemn fermcap.db.4.0.0release’ 07-23-38 system
installed o
Synchronization systemn systemn Mot Synchronized ag’gg’lgg
) Configuration database restored 10/08/09
Caonfiguration systemn systemn from Gold_backup.db 07-35:19 systemn
Connection terminalserver Green Diata collection failed ag’lgg’lgg
Caonnection terminalserver Green Data collection established 10{08{09
07:35:20 -
4| | 3
|D-:|ne |_|_|_|_|_|_| 3’ My Compuber | L T | '7':",', 0% -~ =

Report Shown in Internet Explorer

Once the report is generated the data can be saved or reformatted as desired using standard HTML tools.

Changing the Report Logo

Each report template has a ThinManager TM3 logo as part of the report header. This can be changed to your

company logo.

1. Create a copy of the desired logo in * . J pg format with a size of 150x50 pixels. A white background

is helpful if the logo is irregularly shaped.
2. Name the file 10go150x50. jpg.

3. Copy the l0go150x50. jpg into the ThinManager folder ( C:\Program Files\Automation

Control Products\ThinManager\Reports by default).

4. Open the report to see the change.
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= ThinManager =10 x|

Edit Manage Insktall Tools Wew RemoteWiew Help

2F

EIQ Terminals _I
H e
@ TermiGroupl

- M Termz PB, GD&E

Q Term3

H- a Display Servers Terminal PrD
E||:| Display Clients
[ ﬂ TermSecure Users

'Licensesl F'ru:upertiesl Uersinnsl Synchrunizatinnl Event Log Repart | ﬂ_’l

... 151

. Bool
Hardware Firmware
Name Mac IP Aiddress Model T Vgrﬂs';:

Term3 O0Z0EFBT04CZ 99.95.97.71 BoxPC140 v04.00.999 5.5

w
Kl | »
Far Help, press F1 | l_ P

Report with New Company Logo

The new logo will be displayed on all reports.
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