[image: image311.jpg]



 ThinManager 2.5
Doc-To-Help Standard Manual
[image: image312.jpg][\





Revision 1

August 27, 2004

Atlanta, Georgia, USA

www.thinmanager.com
Contents

7Introduction

ACP ThinManager
8
What’s New in Version 2.5
9
New - Terminal Server Groups
9
New - Firmware
9
New - ThinManager Licensing
9
New - ThinManager Security Groups
10
New - Event Messages
10
New - Tree
10
New - Details Pane
10
New - Shadowing
11
New - Wizards
11
New - Disable
11
New - Find
11
New – USB Mouse and Keyboard Support
11
New Module – RDP Serial Port Redirection Module
11
New Module – Screen Saver
12
New Module – USB Memory Card Reader
12
New Module – Key Block
12
Quick Start, Components, and System Configuration
13
Quick Start Checklist
14
Required Components
15
Windows Terminal Server Operating System
15
Client Communication Protocol
15
ThinManager Administrative Software
15
ThinManager Ready Thin Client Hardware
16
Standard TCP/IP Network Infrastructure
16
Network Overview
17
Connection Overview
20
Terminal Server Group Overview
21
Failover Overview
22
Installation and Licensing of ThinManager
23
Standard ThinManager Installation On Windows 2000/2003 Server
24
Trialware ThinManager Installation
26
ThinManager Licensing
27
ThinManager License File Download
28
ThinManager License File Installation
37
ThinManager Module Licensing
39
ThinManager 2.5 Interface
41
Opening ThinManager
42
ThinManager Graphic User Interface
43
Tree Pane
45
Icons
46
Tree Icons
46
Details Pane
54
Changing a Terminal’s Group
59
Modifying a Terminal
59
Deleting a Terminal
60
Rebooting a Terminal
60
Renaming a Terminal
60
Menu Items
63
Edit
64
Add Terminal
64
Add Group
64
Add ThinManager Server
64
Delete
66
Modify
67
Rename
67
Lock
67
Unlock
68
Find
68
Find Next
68
Tools
69
Reboot Terminals
69
Calibrate Touch Screen
69
Disable Terminals
70
Enable Terminals
71
Shadowing
71
ThinManager Server
72
Licensing
72
Modules
72
Install New TermCap Database
73
Install New Firmware
74
Server List Management
75
Terminal Server List
75
Terminal Server Group List
82
ThinManager Server List
89
DNS Configuration
94
Restore Configuration
97
Backup Configuration
97
Synchronize Configuration
98
Settings
101
Configure Default Terminal
107
Reconnect
107
Disconnect
107
View
108
Status Bar
108
Use Wizards
108
Show Connected Only
108
Options
108
Interactive Shadow
109
Shadow scaled to Window
109
Help
110
Help Topics
110
About ThinManager
110
Adding Thin Client Hardware
111
The Boot Process
112
IP Address Assignment
113
DHCP
113
Static IP
114
Configuring New Hardware
117
Create New Terminal Mode
118
Replace or Create New Terminal Mode
119
Auto-Creation of Terminals
120
Configuration Wizards
123
Introduction to Wizards
124
List Wizards
125
Terminal Server List Wizard
126
Terminal Server Group List
133
ThinManager Server List
141
DNS Configuration
145
Group Configuration Wizard
148
Groups Using Individual Terminal Servers
149
Groups Using Terminal Server Groups
155
Continuation of the Group Configuration
159
Terminal Configuration Wizard
166
Terminals Using Individual Terminal Servers
168
Terminals Using Terminal Server Groups
174
Continuation of the Terminal Configuration
178
Classic Mode of Configuration
186
Classic Mode of Group Configuration
186
Classic Mode of Terminal Configuration
200
Terminal Server Groups
213
Terminal Server Group Overview
214
SmartSession
216
Instant Failover with Terminal Server Groups
220
MultiSession
222
AppLink
226
AppLink and MultiSession
228
Additional ThinManager Functionality
235
Module Overview
236
Module List
237
Touch Screen Modules
237
Sound Modules
237
Mouse Modules
238
Screen Saver Module
238
Additional Modules
239
Installing a Module
240
Changing Module Parameters
242
Disk-On-Chip
247
Disk-On-Chip Configuration
247
Updating Disk-On-Chip
247
Disk-On-Chip Update Module
248
Disk-On-Chip Update Program
249
Initial Program
250
Failover
252
Instant Failover
254
Key Block Module
259
Local Print Module
260
Mouse Modules
263
Mouse Configuration Module
263
PS/2 Mouse Module
264
Serial Mouse Driver
264
Share Keyboard and Mouse Module
265
USB Memory Card Reader Module
267
X Terminal Module
268
ThinManager Security
269
ThinManager Security Groups
269
ThinManager Server Security
270
Windows Security
271
Shadowing
272
Shadow Access
272
Disable Shadow
273
Shadow Keystrokes
273
Serial Communications
274
RDP Serial Port Redirection Module for Windows 2003
274
Serial Port Mapping with ICA
275
High Speed Serial Driver
277
Installation Requirements
277
High-Speed Serial Driver Installation
277
High-Speed Serial Driver Configuration
277
ThinAdapter and the ThinAdapter Plus
280
ThinAdapter Plus
280
Non-ThinManager Components
281
Configuring RDP for Auto-Login
282
Configuring Windows 2003 Terminal Services for Multiple Logins
284
Single Session Per User
284
Licensing Mode
285
Permission Compatibility
286
Command Prompt
287
DHCP Server Setup
288
Creating Microsoft User Profiles
298
Microsoft TS CALs – Terminal Server Client Access Licenses
300
Microsoft Client Access Licenses (CALs)
300
Microsoft Terminal Server Client Access Licenses (TS CALs)
300
Windows 2003 TS CALS
301
Microsoft Terminal Server Licensing Activation
302
Microsoft TS CAL License Authorization
309
Software Installation On Windows 2000/2003
315
Terminal Services Management
319
Glossary of Terms
327
Index
335


Introduction

[image: image313.png]THINMANAGER RIADY




ACP ThinManager

ThinManager is a server-side configuration, management, and hardware enabling software for Terminal Services based thin client systems. 

ThinManager is a software program that allows ACP Enabled, ThinManager Ready Thin Clients to boot, receive a configuration, and connect to a terminal server. ThinManager provides terminal configuration, session management, and session status monitoring. ACP ThinManager provides quick replacement of terminals and an almost seamless switch from terminal server to terminal server in case of terminal server failure.

A thin client is a device that connects to a server, logs onto a separate independent session, and runs its applications on the server and not locally on the thin client. ThinManager Ready Thin Clients first connect to a ThinManager Server where it receives its configuration. This configuration sends the terminal to a terminal server where it logs in.

Note: The terms Thin Client and Terminal are used interchangeably in this document.

The keystrokes and mouse movements from the thin client are sent to the terminal server. The terminal server session determines the response and sends the screen display back to the terminal. This simplifies maintenance and management by eliminating the need to install and configure operating systems and applications on the thin client. All configuration, management, installation and applications are on the server, not the thin client.

Note: All trademarks, service marks, and copyrights belong to their respective company.

Microsoft, Windows, Windows XP, Windows 2000, Windows 2000 Server, Windows 2003, and Windows 2003 Server are trademarks of the Microsoft Corporation, Redmond, Washington.

Citrix, MetaFrame, ICA, and Citrix Device Services are trademarks of Citrix Systems, Fort Lauderdale, Florida.

ACP, ACP Enabled, ThinManager, ThinManager Ready, ThinServer, SmartSession, MultiSession, and AppLink are trademarks of Automation Control Products, Atlanta, Georgia.

What’s New in Version 2.5

New - Terminal Server Groups

Terminal Server Groups are collections of Terminal Servers. ThinManager Ready thin clients can connect to one or more of these Terminal Server Groups. The specific terminal server that the terminal connects to is based on the Terminal Server Group configuration and options.

· A standard Terminal Server Group has the terminal servers listed in a pre-defined order. The terminal connects to the first available member of the group.

· The SmartSession option of Terminal Services Groups provides load balancing by using CPU availability, memory, and the number of sessions on the member terminal servers to determine the availability of resources on member terminal servers. ThinManager Ready thin clients connect to the terminal server in the Terminal Server Group with the most available resources.

· The Instant Failover option allows a terminal to connect to two terminal servers in the Terminal Server Group. The terminal will have an active session on two terminal servers but will only display one session. If the first terminal server fails, the session of the second terminal server is immediately displayed, eliminating any downtown due to terminal server failure.

· The AppLink option provides the Initial Program function to members of a Terminal Server Group. The Initial Program function launches a program instead of the desktop. Closing the program will end the connection and force a reconnection to a session running the application.

· MultiSession is a terminal configuration that allows a ThinManager Ready thin client to connect to multiple Terminal Server Groups. The user can switch between groups using an on-screen menu or hot keys. These groups may be standard Terminal Server Groups, Terminal Server Groups with SmartSession, AppLink, and/or Terminal Server Groups with Instant Failover.

These Terminal Server Group options can be combined on the same Terminal Server Group, for example a Terminal Server Group could use SmartSession to choose the server connection order, Instant Failover to maintain a backup, while using AppLink to limit the terminal to a single application. Additionally, a terminal server may be a member of several Terminal Server Groups.

See Terminal Server Groups
 for details.

New - Firmware

New ThinManager firmware has been released with new functions, including support for Windows 2003 Server enhancements like high color (16-bit), sound redirection, and disk redirection. The latest firmware is available on www.thinmanager.com.  

New - ThinManager Licensing

ThinManager Licensing now has two modes, Standard and Enterprise.

Standard Licensing is terminal based. Licenses are sold in 5, 10, and 25 packs. This is a concurrent licensing model and applies to terminal connection licenses and modules that require a license. This is the model that has been used in previous versions. SmartSession and MultiSession server licenses are available for adding these options to Terminal Server Groups.

Enterprise Licensing is server based. ThinManager Servers are licensed and allow unlimited terminal connections. Enterprise licensing includes a number of SmartSession and MultiSession server licenses for configuring Terminal Server Groups.

· Enterprise Server allows two computers to be ThinManager Servers for redundancy. Any number of ThinManager Ready thin clients can boot from them and be sent to an unlimited number of terminal servers. 

· Enterprise Site allows an unlimited number of ThinManager Servers to be created at one site for one company. This allows a company to distribute control to various independent departments. Any number of ThinManager Ready thin clients can boot from them and be sent to an unlimited number of terminal servers.

· Enterprise Global allows an unlimited number of ThinManager Servers to be created by one company at any of their sites. This allows a company to distribute control to various independent locations. Any number of ThinManager Ready thin clients can boot from them and be sent to an unlimited number of terminal servers.

See ThinManager Licensing
 for details.

New - ThinManager Security Groups

ThinManager allows different levels of access and functionality based on standard Windows groups. If ThinManager Administrators, ThinManager Power Users, and ThinManager Users groups are created, members of these groups will be granted different rights and privileges. 

· Administrators and members of the ThinManager Administrators group are permitted by ThinManager to do anything within ThinManager including configuring; deleting, updating, synchronizing, rebooting, and controlling shadowed sessions.

· ThinManager Power Users can logoff sessions, kill processes, send messages, reboot terminals, and calibrate touch screens. They cannot change terminal configurations, update firmware, update the TermCap, and restore configurations. ThinManager Power Users can view a shadowed terminal session but they cannot take interactive control over it.

· ThinManager Users can view only. They cannot logoff sessions, kill processes, send messages, reboot terminals, shadow sessions, or calibrate touch screens.

See ThinManager Security Groups
 for details

New - Event Messages

ThinManager can send notification of events by e-mails or Windows messaging. The triggering events include thin client configuration changes, firmware upgrades, TermCap upgrades, and license installations.

See Settings
 for details.

New - Tree

The tree adds a branch for Terminal Server Groups. This expands to show the member terminal servers and the terminals connected to them.

Terminals using Terminal Server Groups will show the Terminal Server Group and the terminal servers that they are connected to.

The tree has a Find function to allow the search for devices by name.

See Tree Pane
 for details. 

New - Details Pane

The Details pane has been re-organized with colored headers and tabs to aid in organization. Details include includes CPU information, CPU load, and terminal uptime.

The Details tabs include the information that is provided in the Terminal Services Manager. This increases the information available and increases functionality; adding Terminal Services Manager tools like Send Message, Shadow, and Kill Process.

See Details Pane
 for details.

New - Shadowing

ThinManager v2.5 allows the shadowing of terminals from the Details pane of ThinManager. 

Administrators and ThinManager Administrators can shadow interactively. Members of the ThinManager Power Users group can shadow but cannot control the shadowed session. Users and ThinManager Users are denied the ability to shadow.

 The interactive shadow can be turned off.

The shadowed session can be scaled to the window or shown full size.

See Shadowing
 for details.

New - Wizards

Additional Wizards where added to configure the ThinManager Server and Terminal Server Groups. The existing wizards have been modified to reflect some increased functionality. 

See Configuration Wizards
 for details.

New - Disable

The Disable tool, found at Tools>Disable Terminal, no longer requires a terminal reboot to activate it. The terminal now becomes disabled as soon as the disable is applied, and it remains in this state until it is enabled.

See Disable Terminals
 for details.

New - Find

The tree in ThinManager now has a Find tool to search for groups and terminals by name. This, and Find Next are on the Edit menu.

See Find
 for details.

New – USB Mouse and Keyboard Support

The latest version of ThinManager firmware allows the usage of USB mice and keyboards.

See Mouse Modules
 for details.

New Module – RDP Serial Port Redirection Module

The new RDP Serial Port Redirection Module makes serial connections easy when using Windows 2003. When this module is added to a terminal, the serial ports in a session are automatically mapped to the serial ports on the client.

See RDP Serial Port Redirection Module for Windows 2003
 for details.

New Module – Screen Saver

This module XE "Screen Saver"  loads a screen saver on the client to run when the terminal is idle to protect the monitor. Since the screen saver runs on the client, it saves CPU on the terminal server. 

The screen saver can be set to be deactivated during a specified time period 

See Screen Saver Module
 for details.

New Module – USB Memory Card Reader

This module XE "USB"  allows the use of USB memory card readers and USB memory sticks to provide remote storage for ThinManager Ready thin clients. This module requires Windows 2003.

See USB Memory Card Reader Module
 for details.

New Module – Key Block 

This module XE "Key Block"  traps key strokes and prevents them from being passed to the terminal server to increase security.

See Key Block Module
 for details.

Quick Start, Components, and System Configuration

Quick Start Checklist XE "Quick Start" 
1. Build a terminal server whose operating system is either: 

· Microsoft Windows 2000 Server with Terminal Services enabled.
· Microsoft Windows 2003 Server with Terminal Services enabled.
2. Create a Licensing Server and add a TS CAL (Terminal Server Client Access License) for each thin client. 

See Microsoft Terminal Services Licensing Activation
.
3. Install ACP ThinManager software onto a computer to create a ThinManager Server.

Note: 
The ThinManager Server can be a terminal server, but doesn't have to be. It can be a Windows 2000 or XP Workstation. The clients will connect to the ThinManager Server and download the firmware and configuration. 

See ThinManager Installation
.
4. Install a ThinManager License for each ThinManager Ready thin client. 

See ThinManager Licensing
.

5. Select a Client-Communication protocol. The default RDP Client-Communication Protocol installs with Terminal Services. If using Citrix MetaFrame, available separately, install and license on each terminal server. 

Note: Citrix no longer licenses Citrix Device Services. ThinManager will connect to terminal servers with existing Device Services licenses, but no new ones can be created.

See Client Communication Protocol
.
6. Create a Microsoft user profile for each user on the terminal server or the domain. 

See Creating Microsoft User Profiles
.

7. Apply appropriate security to each user profile using the standard Microsoft techniques.

8. Establish the IP addressing scheme for the thin clients, using either DHCP or Static IP.

If using DHCP, configure Option 066 to list the IP address of the ThinManager Server and configure 067 to list "firmware.acp" as the bootfile name.

See IP Address Assignment
.
9. Attach the terminals to ThinManager by either:

· Turning on the terminal and selecting the "Create New Terminal" option when the unit boots.

· Pre-creating the terminals in ThinManager and selecting the proper terminal name when the terminal is turned on and offline terminals are listed.
See Adding Thin Client Hardware
.
Required Components 

ThinManager Ready Thin Clients require a number of components to function properly. These include:

· Terminal Services from Microsoft

· Client Communication Protocol, either RDP or Citrix ICA

· ACP ThinManager software

· ThinManager Ready Thin Client Hardware

· Standard TCP/IP network infrastructure

Windows Terminal Server Operating System

The first component is the Terminal Server XE "Terminal Server" . This is a computer with a version of Microsoft's Windows 2000 Server or 2003 Server that have the Terminal Services functionality activated. The operating system allows multiple users to log into the server and run independent, isolated sessions. The operating system controls the server, provides security, controls user access, and runs the applications.  XE "Operating System" 

 XE "Components"  

The terminal server needs Windows 2000 and 2003 Server with Terminal Services enabled XE "TS CAL"  and TS CALs added.

See Microsoft TS CALs
 for details.

Client Communication Protocol XE "Client Communication Protocol" 
The second component is the Client Communication Protocol. This can be either the ICA protocol available from Citrix or the RDP protocol that is installed by default with any Windows Terminal Server operating systems. 

The Client Communication Protocol is the protocol used for client-to-server communications in the Terminal Services Environment. The protocol handles all video, information, and user input such as keyboard and mouse input. 

The RDP (Remote Desktop Protocol) is the Client-Communication Protocol that is included with Microsoft Terminal Services and can be used by ThinManager Ready Thin Clients to connect to Windows 2000 Terminal Servers and Windows 2003 Terminal Servers. The RDP connection to a Windows 2000 Terminal Server is limited to a 256-color depth (8-bit) while the Windows 2003 Server connection can be made at a higher color depth.

The ICA (Independent Computer Architecture) Protocol is available by installing Citrix MetaFrame on the Terminal Servers. 

ThinManager Administrative Software

The third component is ACP ThinManager software from Automation Control Products. ThinManager is used to configure, manage, and control the ThinManager thin clients. Although ThinManager is treated as a single entity, it really has two main components, the ThinManager interface and the ThinServer service.  XE "ThinManager" 
ThinServer is a service that is the engine of the program. It starts automatically and runs in the background and provides essential functions to control the thin clients. ThinServer is installed during ThinManager installation if selected.  XE "ThinServer" 
ThinManager is the administrative software that facilitates the configuration and organization of the thin clients. This is the visible component of the ThinManager software. ThinManager displays information generated by ThinServer. ThinManager can be installed on any computer on the network, including the terminal server. 

Note: ThinManager Server is used to describe a computer running ThinManager and ThinServer that provides control and configuration to ThinManager Ready Thin Clients, even if the computer is a workstation.

One instance of ThinManager can provide client connection to several terminal servers. The thin clients would boot from the ThinManager server, but could be assigned to any of several terminal servers. 

ThinManager Ready Thin Client Hardware XE "ThinManager Ready" 
ACP ThinManager is designed to control and configure ACP Enabled Thin clients. These are ThinManager Ready thin clients produced by a variety of manufacturing partners and display the ThinManager Ready sticker. The ACP website (http://www.thinmanager.com) has links to the ACP Partners.
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ThinManager Ready Logos

Standard TCP/IP Network Infrastructure

ThinManager Ready Thin Clients use a standard TCP/IP network. This can include hubs, routers, gateways, cables, and wireless components. ThinManager Ready thin clients behave on a network as a PC would, but because the thin clients are connected to a terminal server where the actually processing takes place, thin clients are more sensitive to poorly deployed networks.

Network Overview

The simplest thin client network consists of a single computer, configured as a terminal server, with the TS CALs, ThinManager, ThinServer, and the applications installed on it. All the ThinManager Ready thin clients connect to this single computer.

A more common scenario includes the use of multiple computers. These might be additional terminal servers for failover functionality, additional terminal servers for increased capacity, domain controllers, e-mail servers, file servers, database servers, and workstations. One of the strengths of ThinManager and ThinManager Ready Thin Clients is their versatility in networking. They do not demand a rigid proprietary network configuration, but have the flexibility to run in almost any network configuration.

ACP Networks require:

1. A ThinManager Server, that is, a computer running ThinManager. This does not have to be a “server”, but can be any Windows computer, including a workstation.

2. A Microsoft Terminal Server with a Client Communication Protocol and all desired applications. This computer may also be the ThinManager Server.

3. A Microsoft Terminal Server Licensing Server for the TS CALs (Microsoft Terminal Server Client Access Licenses). This does not need to be a separate computer, but can run on a terminal server or a domain controller.

4. A DHCP Server or Static IP addresses for the thin clients.

5. ThinManager Ready Thin Client hardware.

6. A standard Ethernet network.

Note: ThinManager does not have to be installed on a terminal server, but can be installed on a workstation.
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Sample ACP Thin Client Network – Single Terminal Server

Note: One server is shown. The ACP ThinManager thin client network functions can be combined into one server, or be spread to multiple servers.
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Sample ACP Thin Client Network – Separate Subnet

Connection Overview

When a terminal is powered on

· An IP address is requested from a DHCP server by default. The DHCP server needs to have Option 066 set to the ThinManager Server IP address and Option 067 set to firmware.acp to specify a ThinManager Server IP address. See DHCP Server Setup
 for details.

· Alternately, the terminal may be assigned a static IP address and the ThinManager Server IP address.  XE "Network" 
· The terminal connects to the ThinManager Server to download its configuration.

· The ThinManager configuration will tell the terminal which terminal server to login to.

· The terminal will connect to that terminal server and display the Windows login dialog box or will automatically login with help from the ThinManager configuration.

· The terminal will create a session on the terminal server, allowing applications to run.

The ThinManager Ready Thin client can be assigned to a single terminal server, or it can be assigned to multiple terminal servers in case of terminal server failure. ThinManager 2.5 introduces Terminal Server Groups. These are groups of terminal servers that control the added functionality for the thin client.

Terminal Server Group Overview

Terminal Server Groups are collections of Terminal Servers. A ThinManager Ready thin client can connect to one or more terminal servers that are members of a Terminal Server Group. Instead of specifying individual terminal server that a terminal will connect to a terminal server defined in a terminal server group. The specific terminal server that the terminal connects to is based on the Terminal Server Group configuration and options.

· A standard Terminal Server Group has the terminal servers listed in a pre-defined order. The terminal connects to the first available member of the group.

· The SmartSession option of Terminal Services Groups provides load balancing by using CPU availability, memory, and the number of sessions on the member terminal servers to determine the resource availability on member terminal servers. A ThinManager Ready thin client connects to the terminal server in the Terminal Server Group with the most available resources.

· The Instant Failover option allows a terminal to connect to two terminal servers within a Terminal Server Group. The terminal will have an active session on two terminal servers but will only display one session. If the first terminal server fails, the session of the second terminal server is immediately displayed, eliminating any downtown due to terminal server failure.

· The AppLink option provides the Initial Program function to members of a Terminal Server Group. When specifying the Initial Program function, a program is started instead of the desktop. Closing the program will terminate the connection.

· MultiSession is a terminal configuration that allows a ThinManager Ready thin client to connect to multiple terminal servers from multiple Terminal Server Groups. The user can switch between groups using an on-screen menu or hot keys. These groups may be standard Terminal Server Groups, Terminal Server Groups with SmartSession, AppLink, and/or Terminal Server Groups with Instant Failover.

These Terminal Server Group options can be combined on the same Terminal Server Group, for example a Terminal Server Group could use SmartSession to choose the server connection order, Instant Failover to maintain a backup, while using AppLink to limit the terminal to a single application. Additionally, a terminal server may be a member of several Terminal Server Groups.

See Terminal Server Groups
 for details.

Failover Overview XE "Failover" 
Server failures in any network or system can disrupt productivity and data management. ACP ThinManager (version 2.3 and later) has a failover capability built into it that allows terminals to connect to a secondary terminal server if the terminal server that they are logged into fails. This will lessen the effect of server failures on the terminal server network. The terminals can detect the server crash, drop the connection to it, and connect to a secondary server in seconds. 

To initiate ACP ThinManager Failover protection, four steps are needed.

· Multiple Servers: The first step is to have multiple terminal servers, with a Client Communication Protocol and appropriate licenses added.

· Sufficient Memory: The second step is to have sufficient memory capacity on the servers to accommodate the addition of terminals during failover. If you do not plan for the extra capacity, the servers can be taxed with the addition of the new terminals.

· User Permissions: Each terminal server needs the appropriate Windows 2000/2003 user profiles and permissions. The terminals will not log into a secondary session unless it has a user profile on that server.

· IP Addressing In ThinManager: When configuring the terminal, list the terminal servers, in the order of preferred connection, in ThinManager. Upon boot, each terminal will try to connect to the first server in the list (the primary server). If it is not available, it will try the next on the list (a secondary server) until a connection is made

ACP ThinManager allows the use of several terminal servers, defined as the primary and as backups. If the primary terminal server fails, the ThinManager Ready thin client will detect the server failure and will initiate a new session on a backup server. This allows the operator to continue their work and minimize the effect of a server failure.

Note: ThinManager can be installed on any computer including the terminal servers, domain controllers, file servers, or workstations.

See Failover
 for further details.

Installation and Licensing of ThinManager

Standard ThinManager Installation On Windows 2000/2003 Server XE "Installation" 

 XE "ThinManager Installation" 
In Microsoft Windows 2000 and Windows 2003 with Terminal Services enabled, software needs to be added in the Install Mode through the Control Panel> Add/Remove Programs. Failure to use the Install Mode can prevent an application from working properly. XE "Add Programs" 

 XE "Remove Programs" 

 XE "Add Remove" 
Select Start>Settings>Control Panel>Add/Remove Programs to open the Add/Remove Programs dialog box.  XE "Installation" 

 XE "ThinManager Installation" 
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Add/Remove Programs

Select the CD or Floppy button on the Add/Remove Programs Properties dialog box to open the Installation wizard. The wizard will prompt for the insertion of the ThinManager CD. When the CD is inserted, the wizard will ask for the path to the setup program. The setup program path is X:\setup.exe, where “X” is the CD-ROM drive that contains ThinManager. 

Enter the path, or select the Browse button and select setup.exe through Explorer, and continue with the wizard. 

Note: ThinManager does not need to be reinstalled to add more licenses. Add additional licenses as described in ThinManager Licensing
.
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ThinManager Installation – Application Selection

An Application dialog box will open that displays the available software programs on the ThinManager CD. 

Although ThinManager appears to be a seamless program, it has two major components.

· ThinManager is the graphic user interface. It is installed to view and control the program. 

· ThinServer is the engine that drives the program. It is a vital component that needs to be installed with ThinManager to allow ThinManager Ready thin clients to boot and be configured. ThinServer is the component that requires licensing. It is separated from ThinManager in the installation to allow additional instances of ThinManager to be installed for remote administration. 

· ThinManager Utilities includes tools like the touch screen calibration program. These utilities need to be installed on every terminal server that have clients with touch screens connected to them. XE "Touch Screens" 
Note: If touch screens are being used with ThinManager Ready thin clients, the ThinManager Utilities program needs installed on every terminal server to provide the Calibrate Touch program for connected thin clients.

Check the desired components and select Next. 

Trialware ThinManager Installation  XE "Trialware" 
ACP has a demonstration version of ThinManager that provides customers with a 30-day trial. This version is downloaded from the ThinManager web site (www.thinmanager.com) as a self-extracting file.

· A user must register on the ThinManager web site to access the download

· The software must be installed on a computer that hasn’t had ThinManager installed before.

· The software can be installed on a workstation or a terminal server. Be sure to install in the Install Mode by using the Add and Remove Programs if the Trialware is installed on a terminal server.

· The software doesn’t need license activation and will provide licenses for 30 days.

· The Trialware version won’t accept normal ThinManager licenses, but needs replaced with the standard ThinManager version to become a regularly licensed program.

[image: image7.png]Quick Links

aep o

Trialware Download

Download Now!





Trialware Download at www.thinmanager.com 

ThinManager Licensing XE "Licensing" 

 XE "ThinManager Licensing" 
ThinManager will allow a single client to connect without a license as Demo Mode, but will require a ThinManager license for more than one terminal. This license is included with the purchase of ThinManager software. Activation of this license is done within the ThinManager web site at http://www.thinmanager.com. 

When an unlicensed copy of ThinManager is run, a message box will appear with notification that a license needs to be installed.
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No Valid License Message Box

ThinManager has two licensing modes, Standard and Enterprise. Several Terminal Server Group functions and modules require licenses.

Standard ThinManager licenses are sold per-connection and are available in 5, 10, and 25-user units. These licenses allow any 5, 10 or 25 ThinManager Ready thin clients to boot and connect to terminal servers and terminal server groups. The licenses are pooled and are released once the terminal is turned off.

Enterprise Licenses provide unlimited connections and are available as Server, Site, and Global versions.

· Enterprise Server includes two license numbers that are installed on two computers to provide redundant ThinManager Servers. 

· Enterprise Site has a single license number that can be installed on an unlimited number of computers at a single company location to provide redundancy and departmental control. ThinManager Servers using this license will display the licensed company’s name and site in the title bar of ThinManager.

· Enterprise Global has a single license number that can be installed on an unlimited number of computers at an unlimited number of locations for a single company location to provide redundancy, departmental and site control. ThinManager Servers using this license will display the licensed company’s name in the title bar of ThinManager.

Additional Licenses include:

· A MultiSession Server License XE "MultiSession License" 

 XE "MultiSession"  allows a terminal server to be added to a Terminal Server Group that is available for MultiSession. A number of MultiSession Server Licenses are included with Enterprise Licenses or they can be purchased for use with Standard ThinManager licenses. 

· A SmartSession Server License XE "SmartSession License" 

 XE "SmartSession"  allows a terminal server to be added to a Terminal Server Group that uses SmartSession. A number of SmartSession Server Licenses are included with Enterprise Licenses or they can be purchased for use with Standard ThinManager licenses.

· The High Speed Serial Driver License XE "High Speed Serial Driver License" 

 XE "High Speed Serial Driver "  allows a terminal to use the High Speed Serial Driver module. This is an additional purchase.

· The Instant Failover License XE "Instant Failover License" 

 XE "Instant Failover "  allows a terminal to use the Instant Failover module when using individual terminal servers, or to connect to a Terminal Server Group that is configured to use the Instant Failover option. This is an additional purchase.

· The Share Keyboard Mouse License XE "Share Keyboard Mouse License" 

 XE "Share Keyboard Mouse "  allows a terminal to use the Share Keyboard and Mouse Master module. This is an additional purchase. This license is not required for Share Keyboard and Mouse slave units.

The ThinManager Licensing dialog box shows the available licenses and shows the Installation ID. It is opened by selecting Tools>Licensing from the ThinManager menu bar.
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Licensing Dialog box

The Installation ID XE "Installation ID"  at the bottom left-hand corner of the screen is used to obtain the License File from ACP.

Note: The Installation ID is required for obtaining a License File.

ThinManager License File Download

To obtain a license file you need two numbers:  XE "ThinManager License Site" 

 XE "License File" 

 XE "License" 
· The Installation ID that is generated by ThinManager during installation. 

· The License Number that is provided with the ACP ThinManager CD.

The License File XE "License File"  needed to activate ThinManager is obtained from the ACP web site at www.thinmanager.com or www.acpthinclient.com.

Note: Since web sites are dynamic, the exact layout of the web screens may change, but the functionality should remain the same. If you have problems, please contact your distributor or e-mail support@acpthinclient.com for help.
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www.thinmanager.com

Select the Support > License Activation link. This will launch the ThinManager License Site.
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ThinManager License Site

There are three links at the ACP Licensing Site:

· Login - This link allows previously registered users to enter the site.

· Passcode - This link allows previously registered users who have forgotten their username and password to receive an entrance code through e-mail. XE "Passcode" 
· New User - This link allows a person to become a registered user of the site so that they can activate a license.

If you are a new user, select the New User link. Previously registered users should login by selecting the Login link.

Note: The login to the license site is separate from any login to www.thinmanager.com. 
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New User Login

Enter a name to be your ACP User Name. Select Submit to continue.
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User Information Form

Fill in the User Information form. 

Note: The e-mail address is very important because all correspondence. Your password will be sent to that address.

Select Submit when finished.
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New Account Completion

Your user name and password will be promptly sent to your e-mail address. 

Select the Login link to continue.
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Licensing Site Login

Enter the user name and password that you received in your e-mail into the appropriate fields.

Select the Login button to continue.
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ACP Licensing Site

Inside of the ACP Licensing Site are four functions for the registered user. 

· Logout - This link will allow exiting from the secure site.

· Manage Account - This link allows user information to be changed or updated. Passwords are changed here.

· Activate License - This link allows the activation of a license and the retrieval of a license file.  XE "Activate License" 
· History - This link displays past actions for the user account.

Select the Activate License link to activate a license and retrieve a license file.

Note: The initial password that is sent is complex and hard to remember. Going to Manage Account will allow the password to be changed to one of your choosing.
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License Request Page

Logging on to the ACP License site and selecting Activate License XE "Activate License"  will display a License Activation page. This web page will have a field for the License Number XE "License Number"  and a field for the Installation ID XE "Installation ID" .

Note: The License Number is located on a label inside of the ThinManager CD case. The Installation ID is on the ThinManager Licensing dialog box that is launched by selecting Tools>Licensing from the ThinManager menu bar.

Fill in both fields with the correct numbers. These numbers are case sensitive and cannot have extra spaces added. 

Select the Submit button to continue. 
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Download License File

Print a copy of this page for your records.

The License File will begin to download. A dialog box will appear that allows the option of opening the file from its current location or saving the file to disk. Saving the file to disk is recommended.
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Saving File to Disk

Select OK to continue. 

A dialog box will appear that allows the selection of the download directory.
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Save As Window

Select a directory or drive to copy the file, and select Save.

The license file is now ready for installation.

ThinManager License File Installation XE "License File" 

 XE "License File Installation" 
Open the Licensing dialog box by selecting Tools>Licensing from the ThinManager menu bar.
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Licensing Dialog Box

Select the Install License button on the Licensing dialog box. An Open File dialog box will be displayed.  XE "License File" 

 XE "License Installation" 
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Open License File

Select the License File that was downloaded from the ACP web site and select Open. This will install the License File.
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Add License

When the License File has been successfully installed, a message box will appear to confirm it. The License Number and properties will appear in the Licensing dialog box.

Select OK to close the message box.

Selecting the Delete License button on the Licensing dialog box will open a message box that will allow the deletion of a selected license.

Selecting the Details button on the Licensing dialog box when a license is selected will display a window with the details of the selected license.
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License Details

Double-clicking a license in the Licensing dialog box can also open this window. Selecting OK will close the License Details window.

Selecting the Done button on the Licensing dialog box will close the Licensing dialog box.

ThinManager Module Licensing XE "Module Licensing" 
Certain modules, like the High Speed Serial Driver, Instant Failover, and the Share Keyboard and Mouse module require an ACP license to activate. These are activated through the ACP web site using the same procedures as the ThinManager license.

See Module Overview
 for details.

ThinManager 2.5 Interface

Opening ThinManager  XE "ThinManager" 
ThinManager is used for the configuration of ThinManager Ready Thin Clients in the ACP thin client environment.

ThinManager can be started using any of the traditional Windows methods, based on the administrator's preference:

· Run from the Start Menu, Start>Programs>ACP>ThinManager.

· Run from the Run line, Start>Run> C:\Program Files\Automation Control Products\ThinManager\ThinManager.exe (default path).

· Run from a command prompt, C:\Program Files\Automation Control Products\ThinManager\ThinManager.exe (default path). 

· Run from a shortcut on the desktop.

· Run from a ThinManager icon in the system tray, if this option is selected in View>Options from the menu bar. 

· Run from Windows Explorer. 

Note: ThinManager can be run on a terminal with full privileges if the user is an administrator or a member of the ThinManager Administrator’s group.

ThinManager Graphic User Interface XE "Graphic User Interface" 
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ACP ThinManager 2.5 Graphic User Interface

The ThinManager administrative interface provides "at-a-glance management". The groups and terminals are displayed in the tree pane. The configuration data is displayed in the detail panel. Color-coded icons in the tree pane show the on-line status of terminals.

The sections of the ThinManager interface include:

· A Title Bar  XE "Title Bar"  with the standard Windows Minimize/Maximize/Close shortcut icons.

· A Menu Bar  XE "Menu Bar"  with commands. 

· A Tree Pane  XE "Tree pane" 

 XE "Pane"  with an expandable/collapsible tree showing the ThinManager Servers, Terminal Servers, Terminal Server Groups, Groups, and Terminals in the ThinManager network. Terminals that are on-line have a green monitor icon, while stopped or rebooting terminals have a red monitor icon. 

· A Details Pane  XE " Detail pane "  with information about settings and configurations. The blue group icon denotes a property that was obtained from the group. The details pane is tabbed for organization. The tabs that are shown depend on the tree item that is highlighted.

· A Status Bar  XE "Status Bar"  that shows advice and tips. 

· The Communication Indicator  XE " Communication Indicator "  shows green when ThinManager is talking to a ThinManager Server. ThinManager will wait until this communication is finished before processing additional requests.

Tree Pane XE "Tree" 

 XE "Tree pane" 
The tree pane shows the members of the ACP Thin Client Network in an expandable tree.
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ACP ThinManager 2.5 With Tree

The current version of the Tree separates the ThinManager Servers, Terminal Servers, and Terminal Server Groups. Although a single computer can be a ThinManager Server, a Terminal Server, and a member of a Terminal Server Group, as shown in the example, these are three distinct functions that are displayed in the tree to reflect its function. 

ThinManager Servers can be expanded to show the Groups and Terminals under them. Groups can be expanded to show the Terminals underneath them. Terminals can be expanded to show the Terminal Servers or Terminal Server Groups they are assigned to. Terminal Server Groups can be expanded to show the member Terminal Servers.

Icons

Tree Icons XE "Icons" 
Several of the menu tools and other features are dependent on what icon is highlighted in the tree.
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Three Tree Branches

The tree is divided into three branches, ThinManager Servers, Terminal Servers, and Terminal Server Groups. 

· A blue icon of ThinMan represents the ThinManager Servers

· A blue server represents the Terminal Servers 

· A pair of blue servers represents the Terminal Server Groups.

Each of the branches of the tree can be expanded.
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ThinManager Server Icons

A Blue ThinManager Server icon represents the top level of the tree and can be collapsed or expanded. This branch shows the local ThinManager Server by default. Other ThinManager Servers can be displayed by selecting Edit>Add ThinManager Server from the menu bar. See Add ThinManager Server
 for details.

A Green ThinManager Server icon represents a ThinManager Server that has an active communication link with the program. These can be collapsed or expanded to show the Group and Terminal icons that nest under the ThinManager Server icons.

A Red ThinManager Server icon represents a ThinManager Server that is not communicating with the program.
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Terminal Server Icons

A Blue Server icon represents the top level of the Terminal Server tree and can be collapsed or expanded.

A Gray Server icon represents individual terminal server. These can be collapsed or expanded to show the Terminal icons that nest under the Terminal Server icons.
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Terminal Server Group Icons

A Blue Terminal Server Group icon represents the top level of the Terminal Server Group tree and can be collapsed or expanded.

A Gray Terminal Server Group icon represents individual terminal server groups. These can be collapsed or expanded to show the terminal server icons that nest under the Terminal Server Group icons and the terminals assigned to that terminal server.
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Group and Terminal Icons

A Group is represented by an icon of two monitors with a blue screen.

A Terminal is represented by an icon of a single monitor.

A Red terminal screen indicates that the Terminal is off or not communicating with the ThinManager Server.

A Green terminal screen indicates that the Terminal is on and communicating with the ThinManager Server.

A Locked terminal or  XE "Lock" 

 XE "Unlock" group icon means that that terminal or group is being modified and cannot be changed by another user. If the Group or Terminal remains locked after the Properties is closed, they can be unlocked by using Edit>Unlock from the menu bar. 

Each item of this tree level can be expanded to show what Terminal Server Groups or Terminal Servers it is assigned to.
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Expanded Tree Showing Icon Variety

The tree in ThinManager example has been expanded to provide greater detail about the status of the terminals. 
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Group and Terminal Nesting

Each Group can be expanded to show the terminals that are members of the group.

Each Terminal can be expanded to show the Terminal Server Groups or Terminal Servers that it is assigned to.

Each Terminal Server Group can be expanded to show the Terminal Servers that are assigned to it.

Each color represents a status state.
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Terminal Server Connection Icons

Under each Terminal are icons representing the Terminal Servers that they are assigned to. The lightning bolt color indicated the connection status.

· A Red lightning bolt represents a lack of connection to the terminal server.

· A Green lightning bolt represents a connection to the terminal server with an active session.

· A Yellow lightning bolt represents a connection to the terminal server with an active session that is the backup in Instant Failover mode. 
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Terminal Server Nesting

The top level Terminal Server icon can be expanded to show the Terminal Servers that have terminals assigned to them. The Monitor Screen color and the Lightning Bolt color indicate the terminal’s status on the Terminal Server. 
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Terminal Server Connection Icons

The monitor screen color indicates the ThinManager Server connection status.

· A Red monitor screen indicates that the terminal is off or unable to communicate to the ThinManager Server.

· A Green monitor screen indicates that the terminal is on and able to communicate to the ThinManager Server.

· The lightning bolt color indicates the Terminal Server connection status.

· A Red lightning bolt represents a lack of active connection to the terminal server.

· A Green lightning bolt represents a connection to the terminal server with an active session.

· A Yellow lightning bolt represents a connection to the terminal server with a session that is the backup session in Instant Failover mode.
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Disabled Terminal Icons

If a Group or Terminal is disabled using the Tools>Disable function, it will be displayed with a red X over the terminal icon. An entire ThinManager Server or an entire Group can be disabled, but the ThinManager Server icon and the Group icon will not show an X, just the terminal icons.

Once a terminal is disabled, a disabling screen will appear on the terminal until the terminal has been enabled.

· A Red terminal screen with a Red X indicates that the Terminal is disabled and is either turned off or rebooted and waiting to be enabled.

· A Green terminal screen with a Red X indicates that the disabling has been applied to terminal that is turned on. The terminal has a disabling screen and is waiting for enabling.
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Disabling Screen

If a terminal is active when it is disabled, it will display the Disable Screen with a message indicating the disabled status in the upper left corner.
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Disabled Terminal

If a terminal is booted when disabled, the boot process will be halted until the terminal is enabled.

See Disable Terminals
 for details.

Details Pane XE "Details Pane" 

 XE "Tabs" 
The Details Pane has been reorganized in ThinManager 2.5 with tabs to sort information. Highlighting a ThinManager Server, Group, Terminal, Terminal Server, or Terminal Server Group in the tree will display a different set of tabs and the corresponding set of information.

Highlighting the Blue ThinManager Server icon will show no details.

Highlighting a ThinManager Server will show:

· Configuration - These are the configuration parameters set in the ThinManager Server Configuration Wizard and include the Event Messaging summary.

· Licenses - This displays the installed licenses, the quantity used and the quantity available.

· Versions - This displays the version numbers of ThinManager, the firmware, and the TermCap database.

[image: image40.png]E8 thinManager v2.5
Edt_Tools Thintlanagerserver

vew telp

[_[CIx]

2

Thinianager Servers

¥

§ Termin servers
8 i server croups

Chattosga

For Help, press F1

ot Loerses | verss |

License.

Used / Avaiable

Teminal Connection Lizense
Instart Falover

MulSession Server License:
Smart Session Server License:
High Speed Seial Difver
Share Keyboard Mouse

X Temminal License.

1715
[
4%
4%
0/10
0/10
0/10





ThinManager Server Tabs - Licenses

Highlighting a Group will show:

· Configuration - These are the configuration parameters set in the Group Configuration Wizard and include Terminal Server assignments, video settings, and monitoring settings.

· Modules - This lists the assigned modules and parameters for the Group.

· Properties - This is blank for a Group.

· Shadow – This is blank for a Group
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Group Tabs - Modules

Highlighting a Terminal will show:

· Configuration - These are the configuration parameters set in the Terminal Configuration Wizard and include Terminal Server assignments, video settings, and monitoring settings.

· Modules - This lists the assigned modules and parameters for the Terminal.

· Properties - This shows the IP address, firmware version, make and model, CPU, memory usage, Terminal Up Time, CPU load, and BootRom version of the Terminal. 

· Shadow XE "Shadow"  – This tab shows what the terminal is displaying on its monitor. Administrators can interact with the session while ThinManager Power Users can view the session, but not control it.

See Shadowing
 for details.
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Terminal Tabs - Shadow

Highlighting the blue Terminal Server icon will show:

· Status - This shows the status of the communication connection between the local ThinManager Server and the defined Terminal Servers and ThinManager Servers. This shows whether the local ThinManager Server is able to retrieve the updated resource information used in determining the SmartSession Server Ranking.
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Terminal Servers Tabs - Status

The Connection Status of the ThinManager Server may have different messages:

· OK indicates a good connection.

· WTSAPI32.dll connection failed occurs XE "WTSAPI32"  when the terminal server is off or unreachable.

· User specified does not have permission to connect  XE "permission" indicates that the Terminal Server has the wrong login information.
See the Terminal Server List
 wizard for details. 

Highlighting a Terminal Server will show:

· Configuration - This shows the installed Client Communication Protocols and the SmartSession settings for the Terminal Server.

· Users - This tab displays information from the Terminal Services Manager. It shows users that are logged into the Terminal Server. Right clicking on a user will show options that allow the session to be Reset (logged off), Disconnected, or have a message sent to it.

· Sessions - This tab displays information from the Terminal Services Manager. It shows users that are logged into the Terminal Server. Right clicking on a user will show options that allow the session to be Reset (logged off), Disconnected, or have a message sent to it.

· Processes - This tab displays information from the Terminal Services Manager. It shows the processes running on the Terminal Server and can have them sorted by Session ID (users) or Process Name. Right clicking on a process will give the option to kill the process.
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Terminal Server Tabs - Processes

Highlighting the blue Terminal Server Group icon will show no details.

Highlighting a Terminal Server Group will show:

· Configuration – This will show the members of the Terminal Server Group and details about SmartSession, Multi-Session, and AppLink.

· Server Rank XE "Server Rank"  - SmartSession ranks terminal servers based on the available resources. The server with the lowest number has the lightest load. The server with the highest ranking has the highest load.
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Terminal Server Group Tabs – Server Rank

Changing a Terminal’s Group XE "Changing a Terminal’s Group" 
To change the Group membership of a terminal, open the Terminal Configuration Wizard or the Terminal Properties by either:

· Highlight the terminal in the ThinManager tree pane by clicking on the terminal name or icon and select Edit>Modify from the ThinManager menu bar.

· Right-click on the terminal icon in the ThinManager tree pane and select Modify.
· Double-click on a terminal icon in the ThinManager tree pane.

This will launch the Terminal Configuration Wizard in Wizard mode or the Terminal Properties in Classic mode. On the Identity tab of the Terminal Properties dialog box, use the Group drop-down box to select the new group that the terminal is to be placed in. This will apply the new group configuration to the terminal. If “None” is selected, the terminal will keep its configuration, but will be removed from the group and is treated as an independent terminal.

Note: The terminal will need to be rebooted for the changes to take effect. 

Modifying a Terminal XE "Modifying" 
Modifying a terminal allows you to reconfigure the terminal or change group settings such as touch screen usage, video resolution, or to assign it to a terminal server. 

To modify a terminal open the Terminal Configuration Wizard or the Terminal Properties by either:

· Highlight the terminal in the ThinManager tree pane by clicking on the terminal name or icon and select Edit>Modify from the ThinManager menu bar.

· Right-click on the terminal icon in the ThinManager tree pane and select Modify.
· Double-click on a terminal icon in the ThinManager tree pane.

This will launch the Terminal Configuration Wizard in Wizard mode or the Terminal Properties in Classic mode.

Note: The terminal will need to be rebooted for the changes to take effect. 

Deleting a Terminal XE "Deleting" 
A terminal can be deleted from the ThinManager by:

· Highlighting the terminal in the ThinManager tree pane and selecting Edit>Delete from the ThinManager menu bar 

· Right-clicking a terminal icon in the tree pane of ThinManager and selecting Delete Terminal. 

Rebooting a Terminal XE "Rebooting" 
A terminal or group can be rebooted by: 

· Selecting Tools>Reboot Terminals from the ThinManager menu bar. This will reboot all the terminals on the server if the server is highlighted. If a group is highlighted, all members of the group will be highlighted. If a terminal is highlighted, the terminal is rebooted.

· Right-clicking a group icon in the tree pane of ThinManager and selecting Reboot Terminals. This will reboot all the terminals in the group.

· Right-clicking a terminal icon in the tree pane of ThinManager and selecting Reboot Terminal. This will reboot only the highlighted terminal.

Renaming a Terminal XE "Renaming a Terminal" 

 XE "Renaming" 
Terminals can be renamed by:

· Highlighting the Terminal and selecting Edit>Rename.
· Right-clicking the Terminal and selecting Rename.

Note: Renaming a terminal can be accomplished the same way that files or directories are renamed in Windows Explorer. Single click twice on the terminal name; this will draw a box around the name and highlight it. Type the new terminal name.
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Renaming a Terminal

The terminal name should be less than 15 characters because of limitations on the terminal server.

Tip on single clicking  XE "Single clicking"  twice: Click once to highlight the name, move the mouse slightly and click again. This will prevent Windows from confusing the two single clicks with a double click.

Menu Items

Edit XE "Edit" 
Edit contains commands for adding, deleting, and changing configurations.

Add Terminal XE "Add Terminal" 
Add Terminal will launch the Terminal Creation Wizard in Wizard Mode or the Create New Terminal dialog box in Classic Mode to start the process of adding a new terminal. 

See Terminal Configuration Wizard
 for details.

Add Group XE "Add Group" 
Add Group will launch the Group Creation Wizard in Wizard Mode or Create New Group dialog box in Classic Mode to start the process of adding a new group. 

See Group Configuration Wizard
 for details.

Add ThinManager Server XE "Add ThinManager Server" 
ThinManager allows the remote administration of multiple ThinManager Servers. A user logged in with administrative rights can connect to multiple ThinManager servers for management.  XE "Menu Items" 
Selecting Add ThinManager Server will launch a dialog box.
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Add ThinManager Server Dialog Box

Enter the IP address or computer name of a ThinManager server. This adds the ThinManager Server and its configuration to the tree pane of the local ThinManager. 

Note: The ThinManager Server may need to be defined in the ThinManager Server List Wizard.
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ThinManager with a Second Synchronized  ThinManager Server Added

Members of the Administrator group or the ThinManager Administrators group have full control of the remote ThinManager Server and can make changes as needed. Members of the ThinManager Power Users group can monitor the connection.

See ThinManager Security Groups
 for more details.

If ThinManager is installed on a Windows XP Pro  XE "Windows XP" workstation, it cannot be added to a ThinManager on a Windows 2003 unless a security option is changed.

On the Windows XP Pro select Start > Control Panel > Administrative Tools > Local Security Policy.
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Windows XP Pro – Local Security Settings

Highlight the Security Options folder in the Local Security Settings program. Change the Network access: Sharing and Security model for local accounts from the default Guest Only to Classic to match the setting of the Windows 2003 terminal server.  XE "Network Access" 

 XE "Security" 

 XE "Windows 2003" 
Delete XE "Delete" 
Delete will launch a message box that will remove a highlighted ThinManager Server, group or terminal. Deleting a remote ThinManager Server will remove it from the local list.
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Delete Group Message Box

Deleting a group will give the option of deleting the group terminals or moving them under the server without a group.

Modify XE "Modify" 
The function of Modify depends on what tree icon is highlighted when Modify is selected.

· Modify will launch the ThinManager Server Configuration Wizard XE "ThinManager Server Configuration Wizard"  for a highlighted ThinManager Server. This allows the ThinManager Server to be configured as described in Settings
.

· Modify will launch the Group Creation Wizard XE "Group Creation Wizard"  in Wizard Mode or the Group Properties in Classic Mode for a highlighted group. Modifications can be made as described in Group Configuration Wizard
.

· Modify will launch the Terminal Creation Wizard XE "Terminal Creation Wizard"  in Wizard Mode or the Terminal Properties in Classic Mode for a highlighted terminal. Modifications can be made as described in Terminal Configuration Wizard
.

· Modify will launch the Terminal Server Group Configuration Wizard XE "Terminal Server Group Configuration Wizard"  for a highlighted Terminal Server Group. This allows the Terminal Server Group to be configured as described in Terminal Server Group List
.

· Modify will launch the Terminal Server Configuration Wizard XE "Terminal Server Configuration Wizard"  for a highlighted Terminal Server. This allows the Terminal Server to be configured as described in Terminal Server List Wizard
.

Rename XE "Rename" 
Rename will allow a highlighted group or terminal to have its name changed in the tree of ThinManager.

Note: The terminal name should be less than 15 characters because of limitations of the terminal server.

Lock XE "Lock" 
When a group property or a terminal property is opened for modification, the entry in the configuration is automatically locked to prevent two people from making changes at one time. 

Lock will manually lock the configuration of a group or terminal to prevent it from being changed. A lock icon will designate a locked group or terminal.
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Lock Icons

When a terminal server or terminal server group are being modified, they will also be locked to prevent two people from making changes at the same time. These will not show a locked icon. Instead, a warning will be displayed to alert the user.
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Lock Warning Message

Unlocking a locked unit can cause a loss of configuration data if it is being modified by another user.

Unlock XE "Unlock" 
Unlock will manually unlock a terminal or group that was locked while being modified. This is used if the server was shut down while the terminal was locked, preventing the terminal from being unlocked automatically when the modifications are done.

Note: This tool is to be used only when a terminal remains locked due to an unexpected server shut down while a terminal is being configured. Using this tool while another is configuring that terminal can lead to corruption of the database.

Find XE "Find" 
The Find menu item launches a Find dialog that searches the tree for the item typed into the Find field.
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Find Dialog Box

CTRL+F is the short cut key to launch Find.

Find Next XE "Find Next" 
Find Next will continue searching the tree for the next instance of the text in the Find field of the Find dialog box. 

F3 is the shortcut key for this function.

Tools XE "Tools" 
Tools contain commands that affect the terminals.

Reboot Terminals XE "Reboot Terminals" 

 XE "Reboot" 
Selecting this command will restart the terminals, reload the firmware, and reconnect them to the terminal server. 

Note: Rebooting a terminal does not close the session on the terminal server nor does it unlock a frozen session. It reboots and reloads the firmware and configuration independent of the session on the terminal server. It will reconnect to the same session without changing the session.

· Highlight a terminal in the ThinManager tree pane and select this command to reboot a terminal. 

· Highlight a group in the ThinManager tree pane and select this command to reboot all the terminals of the group.

· Highlight a ThinManager Server in the ThinManager tree pane and select this command to reboot all the terminals on the ThinManager Server.

Calibrate Touch Screen XE "Calibrate Touch Screen" 

 XE "Calibrate" 
ThinManager has a touch screen configuration utility that can calibrate a thin client touch screen. The utility can be started two ways:  XE "Calibrate Touch Screen" 

 XE "Touch Screen" 
· On the thin client, select Start>Program Files>Automation Control Products>Calibrate Touch Screen (or Start>Program Files>Acp>CalTouchScreen). This is useful because it allows the operator to calibrate the touch screen without administrative support.

· On the ThinManager Server, Highlight the desired terminal in ThinManager and select Tools>Calibrate Touch Screen from the menu bar. This will launch the calibration on the selected terminal. 
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Touch Screen Calibration Screen

When the calibration image appears, first touch the center of the lower left X and then touch the center of the upper right X to provide touch screen mapping to the system. 

Note: The touch screen module must first be added through the Module screen in the Terminal Configuration wizard or through the Module tab in Terminal Properties.
The ThinManager Utilities will need to be installed on each terminal server. See Standard ThinManager Install
 for details.

Note: Touch each X only one time.

Disable XE "Disable"  Terminals

The Disable Terminal command will disable any highlighted Group or Terminal by displaying a lockout screen. The terminal will wait until it is enabled with the Tools > Enable Terminal function to be functional again. This allows terminals to be locked down for security reasons, or to prevent the terminals from accessing the terminal servers.

Highlighting a ThinManager Server, a Terminal Server, or Group in the ThinManager tree and selecting Tools > Disable Terminal will disable every terminal assigned to it.
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Disabled Terminal Icons

If a Group or Terminal is disabled using the Tools>Disable function, it will be displayed with a red X over the terminal icon. An entire ThinManager Server or an entire Group can be disabled, but only the terminal icons will show the X, not the ThinManager Server icon or the Group icons.

· A Red terminal screen with a Red X indicates that the Terminal is disabled and is either turned off or rebooted and waiting to be enabled.

· A Green terminal screen with a Red X indicates that the disabling has been applied to a logged on terminal. The terminal has a disabling screen and is waiting for enabling.

Once a terminal is disabled, a disabling screen will appear on the terminal until the terminal has been enabled.
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Disabled Screen

A logged on terminal will display a screen indicating that the terminal is disabled. 
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Disabled Boot Screen

Terminals that are booted while disabled will halt on a blue screen indicating that the terminal is disabled. 

Enable XE "Enable"  Terminals

The Enable Terminal command will remove the disabling and allow a disabled Group or Terminal to continue functioning or resume the boot process.

Shadowing XE "Shadowing" 
Shadowing allows the sending of the Ctrl+Alt+Del and Ctrl+Esc commands to the shadowed session because these keystrokes are normally saved for the local machine and don’t function in shadowing.

Select the Tools>Shadowing>Send Ctrl+Alt+Del to send the Ctrl+Alt+Del command and select Tools>Shadowing>Send Ctrl+Esc to send the Ctrl+Esc command to the shadowed terminal session.

Note: The Key Block module will block this command if it is used on the terminal. See Key Block Module
 for details.

ThinManager Server XE "ThinManager Server Menu" 
The ThinManager Server contains commands for configuring the ThinManager Server. These options will be grayed out unless the ThinManager Server is highlighted in the tree.

Note: Highlighting a remote ThinManager Server in the tree will perform the commands on that remote ThinManager Server.

Licensing XE "Licensing" 
Licensing opens up the Licensing dialog box. See ThinManager Licensing
 for details.

Modules XE "Modules" 
 

Modules open the Modules dialog box. This displays the modules that are available to the ACP Enabled thin clients. See Module Overview
 for details.
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Installed Modules Windows

Selecting Install Module… will launch a dialog box that allows modules files to be selected.

A module can be added to the list of available modules by highlighting the desired module file and selecting Open. 
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Open Module File

See Module Overview
 for details

Install New TermCap Database XE "Install New TermCap Database" 

 XE "TermCap Database" 
ThinManager has a Terminal Capability Database (termcap.db) that provides ThinManager with the configuration parameters for each thin client model. At each terminal connection, the TermCap database is checked and an integrity check is performed. If the configuration does not match the terminal specifications, ThinManager may reconfigure the terminal to acceptable parameters.
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Terminal Capabilities Integrity Check

The Terminal Capability database can be updated with the current release from the ThinManager web site (www.thinmanager.com).

To update the Terminal Capabilities Database, select Tools>Install New TermCap Database.
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Install New TermCap Database

An Open dialog box will be launched.  XE "TermCap" 

 XE "Terminal Capability" 
Select the new version of the termcap.db and select the Open button. This will install the new version.

Install New Firmware XE "Install New Firmware" 

 XE "Firmware" 
ThinManager allows the firmware for the ThinManager Ready thin client to be upgraded with the latest version from the ThinManager web site (www.thinmanager.com).  XE "Firmware" 
Select Tools>Install New Firmware to launch a file browser. 
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Install New Firmware

Select the new version of the firmware.acp and select Open. This will install the new version of the firmware.

Server List Management XE "List Wizards" 

 XE "Server List Management" 
Server List Management is a launching point for the four server wizards. These allow the usage of names to identify the computers during configuration without the need of a DNS Server. The Server List Wizards are:

· The Terminal Server List Wizard

· The Terminal Server Group List Wizard

· The ThinManager List Wizard

· The DNS List Wizard 

Terminal Server List XE "Terminal Server List" 
Selecting ThinManagerServer>Server List Management>Terminal Server List will launch the Terminal Server List Wizard to allow terminal servers to be defined by name.
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Terminal Server List Wizard

The opening window of the Terminal Server List Wizard will show any Terminal Servers that are defined, or will be blank if none have been defined.

· Edit Server will open the properties for a highlighted terminal server in the list.

· Add Server will allow a new terminal server to be defined.

· Remove Server will remove a highlighted terminal server from the list.

· Cancel closes the wizard without action.

· OK closes the wizard after accepting changes.

Selecting Add Server will open the Terminal Server Wizard Introduction page.
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Terminal Server List Wizard Introduction

The Terminal Server List Wizard allows each Microsoft Terminal Server to be listed for easy selection by name during group and terminal configuration.

Select Next to continue.
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Terminal Server List Wizard – Terminal Server Name

The Terminal Server Name XE "Terminal Server Name"  page defines the Terminal Server on the network. 

ThinManager uses a connection to the terminal server to pull the process, user, and session information for the detail pane tabs and to determine the load for SmartSession load balancing. Entering a username and password in the User Name and Password fields allows ThinServer to connect to the server for this data.

The Terminal Server Name fields are:

· Terminal Server Name - Enter the computer name as found in the Microsoft System Properties.

· Terminal Server IP – Entered the IP address of the terminal server.

· Username - Enter either the domain and an administrative account or the computer name and an administrative account for that machine. 
Use the Domain\Username or Computername\Username format, as shown in the example.

· Password - Enter the password for the administrative account used in the username field. 

· Verify Password – Re-enter the password for the administrative account used in the username field. Passwords that do not match will be indicated by a warning message on the page.

Select Next to continue with the Terminal Server Capabilities page.
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Terminal Server Capabilities

The Terminal Server Capabilities page determines whether a terminal server is configured for SmartSession and Multi-Session and determines what client communication protocols are used. 

· Check the Smart Session Server checkbox to make the terminal server available for Terminal Server Groups with SmartSession. See SmartSession
 for more details.

· Check the Make this server available for MultiSession configurations checkbox to make the terminal server available for Terminal Server Groups with MultiSession. See MultiSession
 for details.

Supported Connections contains a list of the client communication protocols that the terminal server can use to talk to the ThinManager Ready thin client.

· Check the Citrix MetaFrame checkbox if that program is installed on the terminal server to provide the ICA protocol. Citrix MetaFrame XE "Citrix MetaFrame" 

 XE "MetaFrame"  is an optional program sold by Citrix.

· Check the Citrix Device Services checkbox if Citrix Device Services XE "Citrix Device Services"  is installed and licensed on the terminal server. Citrix Device Services XE "Device Services"  is a legacy deployment of the ICA client but is no longer supported by Citrix. ThinManager Ready thin clients can still connect to terminal servers with Device Services, but no new Device Services terminal servers can be licensed.

· Microsoft Remote Desktop Protocol XE "Remote Desktop Protocol"  (RDP)  XE "RDP" is installed by default on Windows Terminal Servers. Uncheck the Microsoft Remote Desktop Protocol checkbox if you don’t want to access to the terminal server with the protocol.

Selecting Next will open the Data Gathering page.
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Data Gathering

The Data Gathering page allows configuration of the intervals that ThinManager uses to poll data from the terminal server. Preset intervals can be used, or custom intervals can be applied.

· Smart Session Data Update Interval is the amount of time between the retrieval of SmartSession data, CPU usage, memory usage, and session count, from the terminal server. This setting affects the update speed of the Server Rankings used in SmartSession load balancing.

· Process Update Interval is the amount of time between the retrieval of the process information on the terminal server. This setting affects the speed of the update of the process information for the sessions on the terminal server.

· Session Update Interval is the amount of time between the retrieval of session data from the terminal server. This setting affects the speed of the update of the user information for the sessions on the terminal server.

If this terminal server is configured for SmartSession, the Next button will go to a SmartSession Configuration page. If this terminal server is not configured for SmartSession, the Next button will be grayed out and the Finish button will close the wizard.
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Terminal Server List Wizard – SmartSession Configuration

ThinManager uses the CPU utilization, Memory utilization, and number of sessions on the terminal server to define the SmartSession terminal server’s available resources. ThinManager uses these values to rank the SmartSession servers according to available resources and supplies this data to the terminals to allow the terminals to connect to the terminal server with the greatest resources. 

The SmartSession Configuration XE "SmartSession Configuration"  page allows the configuration of the three parameters that ThinManager uses to determine availability for SmartSession. 

· The Minimum field is the percentage that ThinManager will consider the parameter to be unused. 

· The Maximum field is the value that ThinManager will consider a parameter exceeded and unavailable.

The Finish button will close the configuration of that terminal server and return to the beginning of the Terminal Server List Wizard for the configuration of other terminal servers.
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Terminal Server List Wizard

Once all the Terminal Servers are defined and configured in the Terminal Server List Wizard, the wizard can be closed by selecting the OK button.

Terminal Server Group List

Selecting ThinManagerServer > Server List Management >Terminal Server Group List will launch the Terminal Server Group List Wizard to allow terminal servers groups to be defined and configured.

See Terminal Server Groups
 for more details.
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Terminal Server Group List Wizard

The opening window of the Terminal Server Group List Wizard will show any Terminal Server Groups that are defined, or will be blank if none have been defined.

· Add Group will allow a new Terminal Server Group to be defined. 

· Edit Group will open the properties for a highlighted Terminal Server Group in the list.

· Delete Group will remove a highlighted Terminal Server Group from the list.

· Cancel closes the wizard without action.

· OK closes the wizard after accepting changes.

Selecting Add Group will open the Group Name page.
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Group Name Page

Enter the desired name of the group in the Group Name field.

Each group can contain members of one type of Client Communication Protocol. These are configured during the Terminal Server Configuration. 

Select the desired Client Communication Protocol and select Next to configure the group options.
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Citrix MetaFrame Options

If Citrix MetaFrame is the Client Communication Protocol chosen, the Citrix MetaFrame XE "Citrix MetaFrame"  page will be displayed to allow the setting of Citrix options for the Terminal Server Group including Encryption Level and the use of Published Applications. The ICA Browser Address allows aid in connection across routers, subnets, and domains.

If a published application is used, check the Use a Citrix Published Application checkbox and enter the published application in the Enter the name of a Published Application field.

Note: Published Application should have a continuous name and not contain spaces.

Select Next to continue.
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Group Options

The Group Options allow the configuration of terminal server group parameters.

Group Type Options include:

· SmartSession Group –  XE "SmartSession" Selecting this option allows the terminal server group to provides load balancing by using CPU availability, memory, and the number of sessions on the member terminal servers to determine the availability of resources on member terminal servers. ThinManager Ready thin clients connect to the terminal server in the terminal server group with the most available resources

· Make group available for MultiSession Configurations –  XE "MultiSession" This allows the terminal server group to be available to ThinManager Ready thin clients that use MultiSession to connect to two or more terminal server groups.

· Application Link Group –  XE "Application Link" 

 XE "AppLink" This option, AppLink, provides the Initial Program XE "Initial Program"  function to ThinManager Ready thin clients that connect to members of the terminal server group. The Initial Program function launches a program instead of the desktop. Closing the program will end the connection and force a reconnection to a session running the application.

Group Options include:

· Enforce Primary XE "Enforce Primary"  - This allows a ThinManager Ready thin client to connect to its original terminal server if that terminal server has failed and recovered. 

Note: Enforce Primary is not available with SmartSession.

· Instant Failover XE "Instant Failover"  - Allows a terminal to connect to two terminal servers in the Terminal Server Group. The terminal will have an active session on two terminal servers but will only display one session. If the first terminal server fails, the session of the second terminal server is immediately displayed, eliminating any downtown due to terminal server failure.

Note: A terminal requires an Instant Failover license to use this function. 

· Always maintain a session for this group – If checked, if the user closes his session, another session will be started automatically. If unchecked, the user can close a session and another session won’t start automatically. 

· Start a session at boot-up for this group – If checked, the terminal will start a session for this terminal server group at boot up. If unchecked, a user action is required to start the session.

· Allow Auto-Login XE "Auto-Login" 

 XE "Auto Login"  - If checked, the terminal will use the login information supplied in the terminal configuration to automatically logon to the terminal server. If unchecked, the user will be required to manually login to the terminal server. 

Once the Terminal Server Group parameters are configured, select Next to select the terminal servers for the group.
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Terminal Server Group Members

Once the Terminal Server Group is configured, the available Terminal Servers are listed in the Terminal Server Group Members page. Highlight the desired terminal server from the left-hand list and use the arrow to move it into the right-hand column. Use the Up arrow and Down arrow to prioritize the order of connection unless SmartSession is being used.

Select the Edit Server List button to configure additional Terminal Servers.

If the Terminal Server Group is using the SmartSession option, the Next button will launch the SmartSession Settings page. 

If the Terminal Server Group is not SmartSession Group the Finish button will complete the Terminal Server Group configuration.
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Smart Session Settings

The SmartSession Settings page sets the weight of the three parameters that ThinManager uses to determine availability for SmartSession.

ThinManager multiplies the CPU utilization, Memory utilization, and number of sessions on the terminal server by the Weight XE "Weight"  shown to define the SmartSession terminal server’s available resources. 

The higher the Weight, relative to the others, the greater the importance of that parameter has in determining the load for SmartSession.

Note: The Weighs are relative. Increasing all three Weights from “1” to “10” doesn’t change the relative values.

The Finish button will close the configuration of that terminal server and return to the beginning of the Terminal Server List Wizard for the configuration of other terminal servers.

If the Terminal Server Group uses the AppLink option, a Link Application page will be displayed by selecting the Next button.
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Linked Application Path

The Linked Application page allows a single application to be defined for the AppLink XE "AppLink"  session. Enter the path to the desired application in the Enter the path to the Linked Application field as shown in the example. 

Note: The path used must be valid for each and every terminal server in the AppLink group.

Note: Quotation marks may be needed when there is a space in the path.

Selecting the Finish button will close the Terminal Server Group List wizard and display the created terminal server groups.
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Available Groups

Selecting the New Group button can configure additional groups. 

The Terminal Server Group List wizard can be closed by selecting OK.

ThinManager Server List XE "ThinManager Server List" 
Selecting ThinManagerServer > Server List Management > ThinManager Server List will launch the ThinManager Server List Wizard to allow the definition of ThinManager Servers.
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ThinManager Server List Wizard - Introduction

The ThinManager Server List Wizard begins with an introduction screen. 

Select Next to proceed or click Finish to close.
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ThinManager Server List Wizard

The ThinManager Server List is the collection of ThinManager Servers on the network. These include ThinManager Servers that the terminal will communicate with to keep the connection status lights in the ThinManager tree updated. It also allows access to remote ThinManager Servers that allow network wide monitoring, control, and management.

· Remove Server clears a highlighted ThinManager Server from the list.

· Add Server will launch a window that allows the entry of a ThinManager Server name and IP address.

· Edit Server will launch a window that allows the change of a highlighted ThinManager Server name and IP address.

Selecting Add Server will launch a ThinManager Server Definition window that allows the entry of the ThinManager Server name and IP address. 
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ThinManager Server Definition

Entering the network name of the ThinManager Server and its IP address allows the ThinManager Servers to be tied to a convenient name without the need of a DNS server. 

Enter the computer name as found in the Microsoft System Properties in the ThinManager Server field. Type the IP address in the ThinManager Server Address field, and select OK. This adds the ThinManager Server to the ThinManager Server list.
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ThinManager Server List

When all of the desired ThinManager Servers are added to the list, select Finish to close the ThinManager Server List wizard.

DNS Configuration XE "DNS Configuration" 

 XE "DNS" 
Selecting ThinManagerServer  > Server List Management > DNS Configuration will launch the ThinManager Server List Wizard to allow the definition of Domain Name Servers. 
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Domain Name Service Wizard – Introduction

The Domain Name Service Wizard Introduction screen will allow the use of DNS if a DNS server is being used.

· If the System without a DNS server radio button is selected, no configuration is needed. Select the Finish button to close the wizard.

· If the System using a DNS server radio button is selected, the Next button will launch the Domain Name Service Configuration screen.

[image: image83.png][Domain Name Server Wizard

w

AddDNS Server Remave DNS Server

Domain

Search Domain

Flead DNS Setting fomthis computer

ok | o | [ERET] | oo ||





Domain Name Server Configuration

The Domain Name Service Configuration page allows DNS settings to be configured.

· The Add DNS Server button will launch a dialog box that allows a DNS Server to be added to the list.

· The Remove DNS Server button will remove a highlighted DNS server from the list.

· The Up and Down arrow keys will change the order of DNS servers used. Highlight a DNS server in the list and select the appropriate arrow.

· Domain  XE "Domain"  is a field for the DNS domain name.

· Search Domain  XE " Search Domain "  will add the contents of the field as a prefix to any DNS searches. 

· Selecting the Read DNS Setting from this computer button will transfer the DNS settings from the current computer into ThinManager. 

Selecting the Add DNS Server will launch a dialog box that allows the IP address of the DNS server to be added.
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Domain Name Server Configuration – Add DNS Server

Add the IP address of the DNS server into the DNS Server dialog and select OK. Additional IP addresses can be listed by selecting the Add DNS Server button again.

Select the Finish button when the DNS configuration is done.

Restore Configuration XE "Restore Configuration" 

 XE "Restore" 
Restore Configuration will allow a backed up ThinManager configuration to be applied to the ThinManager Server. Select Restore Configuration to launch the desired ThinManager Configuration file in the browse window and select Open. The backup copy will overwrite the existing configuration.
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Restore ThinManager Configuration 

Backup Configuration XE "Backup Configuration" 

 XE "Backup" 
Backup Configuration allows the ThinManager Configuration to be saved. Select Backup Configuration to launch a browse window and select the Save button to save a backup copy.
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Backup ThinManager Configuration

Synchronize Configuration XE "Synchronize Configuration" 

 XE "Synchronize" 
Synchronize Configuration allows the configuration of multiple ThinManager Servers to be kept identical so that a terminal will boot with the same configuration regardless of what ThinManager Server the terminal connects to. This is useful for multiple Thin Manager Servers and ThinManager Redundancy.

Selecting Synchronize Configuration will launch the Synchronize ThinManager Server Configurations Wizard.

[image: image87.png][E3 Synchronize ThinManager Server Confi

ThinManager Server Configuration Synchronization

Select a Thinanager Server o be the soutce of the configuation, and
select one of mote ThinManager Servers o eceive the configuation.

Configuration Source: Configuration Destination
Ble

(Green Gieen

Slate

cak | [ 1| [





Synchronize ThinManager Server Configuration Wizard

Highlight the Configuration Source ThinManager Server and the Configuration Destination ThinManager Server, and select Next. 

Note: You may highlight multiple destinations to synchronize multiple ThinManager Servers by holding down the CTRL key while you select them with a mouse.
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Synchronization Differences

The ThinManager Synchronization Wizard will list the files being updated, including the firmware, TermCap database, modules, and the configuration. It synchronizes everything but the license.

Note: The Synchronization tool does not compare and contrast, then make changes back and forth. Synchronization will take the files and configuration from the source ThinManager Server and overwrite the corresponding files on the destination ThinManager Server.

Select Next to continue. 
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ThinManager Server Synchronization Confirmation

The ThinManager Server Configuration Wizard will prompt for a confirmation of the synchronization before proceeding. Select Finish to finalize the synchronization. 
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Synchronization Progress Meter

ThinManager will display the progress of the synchronization as it updates the files.

Settings XE "Settings" 
Selecting Settings will launch the ThinManager Server Configuration wizard that allows the configuration of global ThinManager settings.
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ThinManager Server Configuration Wizard

Select Next to Configure the ThinManager Server settings.
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Unknown Terminals

The Allow unknown terminals to connect checkbox lets new terminals be added to the ThinManager Server. Replacements and new terminals are prevented if this box is un-selected.

The Require password on unknown terminals checkbox allows use of a password so that only authorized personnel can add terminals to the ThinManager Server. If checked, the password fields become active and allow the addition of a password.

The Enable AutoCreate XE "Auto-Create"  checkbox allows the auto-creation of an array of terminals as described in Auto-Creation of Terminals
. The AutoCreate Mask field is the base name used in the array.
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Terminal Replacement

The Enable replacement checkbox gives global permission for terminals to be replaced. Un-selecting this will prevent all terminals from showing up in the replacement list when a new terminal is added, making “Create New Terminal” the only option. This feature is also available for the Group and terminal level on the first page of the Wizard mode or the Other tab in classic mode.

Select Next to continue.
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Event Selection

ThinManager 2.5 adds event notification. E-mails XE "E-mail"  or windows messages can be sent by ThinManager to identify changes in the setup, configuration or status.

Check the desired events, the method of notification, and select Next to proceed.
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Email or Windows Messaging Recipients 

The desired recipients of the event information can be specified on the Email or Windows Messaging Recipients page.

Enter the SMTP (Simple Mail Transfer Protocol) server used by the ThinManager Server in the SMTP Server field.

Select the Add button in the E-mail frame to list the e-mail recipients.
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E-mail Address Entry Form

Enter the desired e-mail address in the entry form and select OK. 

Select the Add button in the E-mail frame to add additional e-mails.

To send a Windows message to a terminal, select the Add button in the Messages frame to launch a selection window.
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Terminal Selection Window

The Select Terminal(s) windows will list the terminals configured on the ThinManager Server. Highlight the desired terminals and select the OK button. 
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Email or Windows Messaging Recipients 

When the addresses are configured as desired, select Finish.

Configure Default Terminal XE "Configure Default Terminal" 

 XE "Configure Default " 

 XE " Default Terminal" 
Selecting Configure Default Terminal will launch the Terminal Properties for the “Default” terminal. This default terminal is used as a template that terminals created during Auto-Create are based on. See Auto-Creation of Terminals
 for details on Auto-Creation of terminals.

Reconnect XE "Reconnect"  

Selecting Reconnect will reinitialize the connection to the selected ThinManager Server.

Disconnect XE "Disconnect"  

Selecting Disconnect will stop the connection to the selected ThinManager Server.

View XE "View" 
 Status Bar XE "Status Bar" 
The Status Bar shows advice and comments on the bottom of the ThinManager window. When the Status Bar command is checked, the Status Bar text is visible. When the Status Bar command is unchecked, the Status Bar text is invisible.

Use Wizards XE "Use Wizards" 
Use Wizards allows group and terminal configuration in the Wizard Mode if checked. 

If un-checked, the Group Properties and Terminal Properties will launch in the ThinManager v2.3 Classic Mode. See Classic Mode
 for details.

Note: Post-2.3.1 features like RDP, Shadowing, and Terminal Server Groups are not available in the Classic Mode.

Show Connected Only XE "Show Connected Only" 
If checked, Show Connected Only will hide any unconnected terminal or Terminal Server Group. This can make the tree easier to read by hiding un-connected terminals.

Options XE "Options" 
Selecting Options will launch the Options dialog box.
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Options

The Display “Create New Terminal” dialog for unknown terminals check box, if selected, will display the Create New Terminal option when new terminals are attached.

The Minimize to the System Tray checkbox will send the ThinManager icon in the system tray when ThinManager is minimized. 

Warn if license will expire within __ day(s) will set the warning period before license expiration. This is useful for time-limited demonstration and Trialware licenses.

Interactive Shadow XE "Shadow" 

 XE "Interactive Shadow" 
Interactive Shadow, if checked, allows Administrators and members of the ThinManager Administrators group to interact and control a shadowed terminal session. If this value is unchecked the sessions will be viewable, but observers cannot take control of the session.

Shadow scaled to Window XE "Shadow scaled to Window" 
Shadow scale to Windows, if checked, will scale the shadowed terminal session to fit the Details pane of ThinManager. If this value is unchecked the session will be viewed life-sized. This may require the use of scroll bars to view portions of the screen.

 Help XE "Help" 
 Help Topics XE "Help Topics" 
ThinManager has a help file. Selecting Help Topics will launch the ThinManager Help file.

 About ThinManager

Selecting About ThinManager will display a dialog box with ThinManager version information, copyright information, and contact information for ThinManager.

Adding Thin Client Hardware

The Boot Process  XE "Boot" 
There are two methods that an ACP Enabled thin client can use to boot. The standard method is to connect to a ThinManager Server and download the firmware and its configuration across the network. This allows for an easy update of the firmware and ensures that all the terminals share the same firmware. Disk-On-Chip ThinManager Ready thin clients have the firmware embedded in them and boot locally then connect to a ThinManager Server to download its configuration. See Disk-0n-Chip
 for details.

A ThinManager Ready thin client goes through a number of steps from the initial power on to the complete connection to a terminal server. Understanding this process will aid in terminal configuration and troubleshooting.  XE "Boot" 
The steps are:

POST: Once a ThinManager Ready thin client is turned on it begins the Power On Self-Test to examine the hardware and to test the memory. 

IP Address Assignment: The terminal needs an IP address to connect to the network. By default, it receives an IP Address from a DHCP server, but this can be changed to use an assigned static IP. See IP Address Assignment
 for details.

ThinManager Server Connection: After receiving an IP address the terminal will connect to the ThinManager Server. This is the Boot Server Host as defined in the DHCP scope Option 066 or the Primary ThinManager Server defined in the static IP address configuration. 

Firmware Loading: Next the terminal will download the firmware from the ThinManager Server. 
Terminal Configuration Download: Established terminals will receive their configuration and proceed. New terminals will need to be defined on the ThinManager Server, either through the Terminal Configuration Wizard
 or the Create New Terminal
 method.
ACP Logo Screen: After the terminal receives its configuration, it will display an ACP splash screen with the ACP logo. 

Client Communication Connection: Next the terminal will launch its Client Communication protocol. If using ICA it will display a Citrix splash screen while it makes an ICA connection to the terminal server. 

Terminal Server Connection: The thin client will connect to the terminal server(s) that it is assigned to in its configuration.

Windows Login: Next the terminal will display the Windows Login dialog box, prompting for a valid username and password. If these have been entered into the username and password fields on the Sessions tab of ThinManager, the terminal will login automatically and display the Windows desktop or a defined initial program. 

Note: Windows 2000 prevents auto-login with RDP by default. To allow auto-login see Configuring RDP for Auto-Login
 for details.

Windows Session: The terminal logs onto a session on terminal server.  The terminal will pass mouse clicks and keystrokes to the session on the terminal server. The terminal server will process the data and send the graphics back to the terminal for display, giving a full Windows experience to the user.

IP Address Assignment XE "IP Address" 
ThinManager Ready thin clients are set by default to automatically receive an IP address from a DHCP server. Most ThinManager Ready thin clients may use a manually assigned Static IP address instead. 

Note: The ThinAdapter and ThinAdapter Plus require DHCP.

DHCP XE "DHCP" 
ThinManager Ready thin clients are set to use DHCP (Dynamic Host Configuration Protocol) by default. The DHCP Server needs two options configured for ThinManager Ready thin clients.
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DHCP Options

Option 066 - Boot Server Host Name  XE "Option 066" 

 XE "DHCP Options" must be set to the IP address of the ThinManager Server. If redundant ThinManager Servers are being used, the IP addresses of multiple ThinManager Servers can be entered, separated with a space.

Option 067  - Bootfile Name  XE "Option 067" must be set to firmware.acp.

Details are at DHCP Server Setup
 for details.

ThinManager Ready thin clients use DHCP (Dynamic Host Configuration Protocol) by default. If they have been set to use a static IP they can be reset to DHCP from static IP by pressing any key when prompted during the boot sequence to open the IP Configuration Menu. 

[image: image101.png]ACP Network Boot Loader va.5
Copyright 1999-2003 Automation Control Products

P Configuration Menu

(%) Torminal Ip Address 192.168.3.115
(8) Primary ThindManager Server P Address = 192.168.3.11
(C) Secondary Thintanager Server Ip Address = 192.168.3.12
(D) Router IP Address = 0.0.0.0

(E) Subnet Mask = 255.255.255.0

(F) Password Status : Disabled

() Holp

(@) Abort Changes and Exit

(S) Save Changes and Exit

Enter new Terminal IP Address

Enter 'D' for DHCP or Static IP as X.X.X.X : D





IP Configuration Menu - DHCP

Press the A key to allow a change to DHCP.  XE "DHCP"  and enter D key to set the configuration to DHCP. Press the Enter key to return to main menu. XE "IP Configuration" 
Press the S key to save the configuration and continue with the boot process.
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Boot Process - Firmware Download

The terminal will connect to the ThinManager Server and download the firmware.

Static IP XE "Static IP" 
Most models of ThinManager Ready thin clients allow the usage of static IPs. These are set by interrupting the boot process to launch the IP Configuration Menu and adding the static IPs. 
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Boot Process - Press Any Key Prompt

To set the terminal to use a static IP, press any key at the appropriate moment of the boot sequence.

[image: image104.png]ACP Network Boot Loader va.5
Copyright 1999-2003 Automation Control Products

P Configuration Menu
(%) Terminal Ip Address = DHCP

(F) Password Status = Disabled

) Holp

(@) Abort Changes and Exit

(S) Save Changes and Exit

Enter New Terminal Address

Enter 'D' for DHCP or Static IP as X.X.X.X : 192.168._





IP Configuration Menu – Static IP

Press the A to allow the client IP to change from DHCP.

Type in the static IP address for the client, including the separating periods and press the Enter key.
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IP Configuration Menu - Options

Once the Terminal has a static IP assigned, the IP Configuration Menu XE "IP Configuration"  will be shown to allow the setting of other values.

· (A) Terminal IP Address - This should be a unique address for the terminal. XE "Terminal IP Address" 

 XE "IP Address" 
· (B) Primary ThinManager Server IP Address - This should be the unique address for your main ThinManager Server. XE "ThinManager IP Address" 
· (C) Secondary ThinManager Server IP Address  - The Secondary ThinManager field allows the terminal to use two ThinManager Servers. If the terminal cannot connect to the Primary ThinManager Server, it will connect to the Secondary ThinManager Server to receive its configuration. If you are not using a Secondary ThinManager Server, set the IP address to 0.0.0.0.

· (D) Router IP Address  - Fill in the IP address of the router or gateway if one is being used. If not this should be set to 0.0.0.0. XE "Router" 
· (E) Subnet Mask - Set this to your subnet mask. 255.255.255.0. is a standard setting. XE "Subnet Mask" 
· (F) Password Status  - Allows a password to be set to prevent unauthorized people from changing the configuration.  XE "Password" 
· (H) Help - Will launch a Help to explain the IP Configuration Menu. XE "Help" 
· (Q) Abort Changes and Exit - This will cancel any setting changes and let the terminal continue to boot with the old settings.

· (S) Save Changes and Exit - This will apply any changes and allow the terminal to continue to boot with the new settings.

Type the letter of the desired setting and type the IP address, with periods. Press the Enter key on the keyboard to accept each change.

Once configured the terminal will connect to the ThinManager Server and download the firmware and configuration.

Configuring New Hardware XE "New Hardware" 
The configuration of terminals is done in ThinManager on the ThinManager Server, and not on each individual terminal. When a new, undefined ThinManager Ready Thin Client is first connected to a ThinManager Server one of three things will happen. XE "Adding Terminals" 
· If the ThinManager Server has no terminals that are configured and offline, then the terminal will go into the Create New Terminal Mode and launch the Terminal Configuration Wizard on the ThinManager Server. Once the terminal is configured on the Terminal Server it will automatically download its configuration upon boot up.

· If the ThinManager Server has terminals that are created and offline, the terminal will go into Replace or Create Mode and list the offline terminals that are available for selection. Once a configuration is selected, the terminal will take that identity. During any following boot up the terminal will automatically download its configuration.

· A third scenario is to use the Auto-Create Terminal Mode to create an array of terminals. 

Create New Terminal Mode XE "Create New Terminal"   XE "Create New Terminal Mode" 
Turning on a terminal for the first time will initiate the Create New Terminal mode if:

· No terminals are defined in ThinManager, or 

· All the defined terminals are currently connected, or

· All the defined terminals that are turned off have the Allow This Terminal To Be Replaced If Off Line check box unselected.
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Create New Terminal Mode Screen

When a terminal enters the Create New Terminal Mode, the terminal will launch the Terminal Configuration Wizard on the ThinManager Server. The terminal will display a screen indicating that it will wait until the configuration is finished before progressing further. 

Replace or Create New Terminal Mode XE "Replace or Create New Terminal" 

 XE "Replace or Create New Terminal Mode" 
Turning on a terminal for the first time will initiate the Replace or Create New Terminal Mode if one or more of the defined terminals are offline and they have the Allow This Terminal To Be Replaced If Off Line check box selected.
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Replace or Create Mode

The screen will display all the offline terminals that the terminal can replace. Highlight the desired terminal name using the keyboard and press the Enter button. The terminal will retrieve the selected configuration and assume its identity. 

Auto-Creation of Terminals

Auto-Create XE "Auto-Create"  allows new terminals to be created and configured in an array, using the Default Terminal as a template.

Turning on a terminal for the first time will initiate the Replace or Auto-Create Terminal mode if:

· The Auto-Create mode XE "Auto-Create mode"  is enabled by the selection of the Enable AutoCreate check box on the Server Properties window.
The Server Properties is launched by selecting ThinManagerServer>Settings from the ThinManager menu.

And

· The Default terminal is configured as a template for the new terminals. 
This is done by selecting ThinManagerServer>Configure Default Terminal on the ThinManager menu.

And

· The user selects Auto-Create from the Replace or Action Menu. The user can do a replacement instead of an Auto-Create.
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Replace or Action Menu

The terminal will be given the name of the Auto-Create Mask XE "Auto-Create Mask"  and a number, starting with “0”. The Auto-Create Mask is configured in the ThinManager Server Configuration Wizard. Open the ThinManager Server Configuration Wizard by right clicking on the ThinManager Server in the tree and selecting Modify, or select ThinManager Server> Settings from the menu.

[image: image109.png]ThinManager Server Configuration Wizar

Unknown Terminals
Chaase whether urknown terminals are ta be aloved to cornest to
this ThinManager server.

-Unknown Terminals

Alow unkiown terminals to connect ~
Rlequite password on urknown teminals r
Passward
Confim

-Automalic Termina Creation

Enable Autolreate. 2

AutolCreate Mask [autoTem

<ok | I |





Unknown Terminals

Check the Enable AutoCreate checkbox and enter an AutoCreate Mask name.

New terminals can be added to the system and configured without additional input from the server.  XE "Auto-Creation" 
Configuration Wizards

Introduction to Wizards XE "Wizards" 
ACP ThinManager Version 2.4 introduced Configuration Wizards to simplify the creation and configuration of ACP Enabled Thin Clients. ThinManager 2.5 extends the scope of the wizards to provide more configuration power.

The Wizard is the default method of configuration. The original Classic Mode can be turned on by going to the menu bar of ThinManager and un-checking the View>Use Wizard option. However, recent features like RDP, SmartSession, Multi-Session, and AppLink are unavailable in Classic Mode.

Wizards take two forms.

· List Wizards associate Terminal Server and ThinManager Servers with their IP addresses or assign server functions to groups of Terminal Servers.

· Configuration Wizards set the parameters and options for individual terminals or groups of terminals. This is where the terminal and its settings are defined.

The List Wizards can be launched by:

· Selecting ThinManager Server>Server List Management

· Right clicking on a ThinManager Server in the tree and selecting Server List Management.

The Configuration Wizards can be launched by:

· Selecting a ThinManager Server in the ThinManager tree and selecting Edit>Add Group or Edit>Add Terminal from the menu bar, or 

· Selecting a ThinManager Server in the ThinManager tree, right-clicking on the ThinManager Server icon, and selecting the Add Group or Add Terminal option, or

· Selecting a Group in the ThinManager tree, right-clicking on the Group icon, and selecting the Add Terminal option. This puts the terminal in that group.

List Wizards XE "List Wizards" 
ThinManager has List wizards that allow the names of Terminal Servers, Terminal Server Groups, ThinManager Servers, and Domain Name Servers to be associated with their IP address for easy use. This is similar in function to a host table.

Each of the List Wizards are launched in the appropriate place during group and terminal configuration in the Group Configuration Wizard and Terminal Configuration Wizard, but they can also be run individually to identify the members ahead of time.

Terminal Server List Wizard  XE "Terminal Server List"   XE "Terminal Server List Wizard" 
Selecting ThinManagerServer >Server List Management>Terminal Server List or right clicking on a ThinManager Server in the tree and selecting Server List Management> Terminal Server List will launch the Terminal Server List Wizard to allow terminal servers to be defined by name.
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Terminal Server List Wizard

The opening window of the Terminal Server List Wizard will show any Terminal Servers that are defined, or will be blank if none have yet been defined.

· Edit Server will open the properties for a highlighted terminal server in the list. XE "Edit Server" 
· Add Server will allow a new terminal server to be defined. XE "Add Server" 
· Remove Server will remove a highlighted terminal server from the list.

· Cancel closes the wizard without action.

· OK closes the wizard after accepting changes.

Selecting Add Server will open the Terminal Server Wizard Introduction page.
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Terminal Server List Wizard Introduction

The Terminal Server List Wizard allows each Microsoft Terminal Server to be listed for easy selection by name during group and terminal configuration.

Select Next to continue.
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Terminal Server List Wizard – Terminal Server Name

The Terminal Server Name XE "Terminal Server Name"  page defines the Terminal Server on the network. 

ThinManager uses a connection to the terminal server to pull the process, user, and session information for the detail pane tabs and to determine the load for SmartSession load balancing. Entering a username and password in the User Name and Password fields allows ThinServer to connect to the server for this data.

The Terminal Server Name fields are:

· Terminal Server Name - Enter the computer name as found in the Microsoft System Properties.

· Terminal Server IP – Entered the IP address of the terminal server.

· Username - Enter either the domain and an administrative account or the computer name and an administrative account for that machine. 
Use the Domain\Username or Computername\Username format as shown in the example.

· Password - Enter the password for the administrative account used in the username field. 

· Verify Password – Re-enter the password for the administrative account used in the username field. Passwords that do not match will be indicated by a warning message on the page.

Select Next to continue with the Terminal Server Capabilities page.
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Terminal Server Capabilities

The Terminal Server Capabilities page determines whether a terminal server is configured for SmartSession and Multi-Session and determines what client communication protocols are used. 

· Check the Smart Session Server checkbox to make the terminal server available for terminal server groups using SmartSession to provide load balancing. See SmartSession
 for more details.

· Check the Make this server available for MultiSession configurations checkbox to make the terminal server available for terminal server groups configured for MultiSession. See MultiSession
 for details.

Supported Connections contains a list of the client communication protocols that the terminal server can use to talk to the ThinManager Ready thin client. XE "MetaFrame" 

 XE "Device Services" 

 XE "RDP" 
· Check the Citrix MetaFrame checkbox if that program is installed on the terminal server to provide the ICA protocol. Citrix MetaFrame XE "Citrix MetaFrame" 

 XE "MetaFrame"  is an optional program sold by Citrix.

· Check the Citrix Device Services checkbox if Citrix Device Services XE "Citrix Device Services"  is installed and licensed on the terminal server. Citrix Device Services XE "Device Services"  is a legacy deployment of the ICA client but is no longer supported by Citrix. ThinManager Ready thin clients can still connect to terminal servers with Device Services, but no new Device Services terminal servers can be licensed.

· Microsoft Remote Desktop Protocol XE "Remote Desktop Protocol"  (RDP XE "RDP" ) is installed by default on Windows Terminal Servers. Uncheck the Microsoft Remote Desktop Protocol checkbox if you don’t want to access to the terminal server with the protocol.

Selecting Next will open the Data Gathering page.
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Data Gathering

The Data Gathering page  XE "Data Gathering" 

 XE "SmartSession" allows configuration of the intervals that ThinManager uses to poll data from the terminal server. Preset intervals can be used, or custom intervals can be applied.

· Smart Session Data Update Interval is the amount of time between the retrieval of SmartSession data, CPU usage, memory usage, and session count, from the terminal server. This setting affects the update speed of the Server Rankings used in SmartSession load balancing.

· Process Update Interval is the amount of time between the retrieval of the process information on the terminal server. This setting affects the speed of the update of the process information for the sessions on the terminal server.

· Session Update Interval is the amount of time between the retrieval of session data from the terminal server. This setting affects the speed of the update of the user information for the sessions on the terminal server.

If this terminal server is used as a SmartSession server, the Next button will go to a SmartSession Configuration page. If this terminal server is not configured as a SmartSession server, the Next button will be grayed out and the Finish button will close the wizard.

[image: image115.png]B Terminal Server Wizard [x]

Smart Session Configuration ACR,
Erterthe Smart Session Liis for s Teminal Server p]

-CPU Utiization
Mirimum [T %
Masimum |90.0 %
~Memoy Utizatin————————————————————————
Mirium | 00 %
Masinum  [300 %
- Sessions
Mirimum
Masimum |50

<ok | o> | [hmn ] | o | |t





Terminal Server List Wizard - SmartSession Configuration

ThinManager uses the CPU utilization, Memory utilization, and number of sessions on the terminal server to define the SmartSession terminal server’s available resources. ThinManager uses these values to rank the SmartSession servers according to available resources and supplies this data to the terminals to allow the terminals to connect to the terminal server with the greatest resources. 

The SmartSession Configuration XE "SmartSession Configuration"   XE "SmartSession" page allows the configuration of the three parameters that ThinManager uses to determine availability for SmartSession. 

· The Minimum field is the percentage that ThinManager will consider the parameter to be unused. 

· The Maximum field is the value that ThinManager will consider a parameter exceeded and unavailable.

The Finish button will close the configuration of that terminal server and return to the beginning of the Terminal Server List Wizard for the configuration of other terminal servers.
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Terminal Server List Wizard

Once all the Terminal Servers are defined and configured in the Terminal Server List Wizard it can be closed by selecting the OK button.

Terminal Server Group List XE "Terminal Server Group List" 

 XE "Terminal Server Group" 
Selecting ThinManagerServer > Server List Management > Terminal Server Group List or right clicking on a ThinManager Server in the tree and selecting Server List Management > Terminal Server Group List will launch the Terminal Server Group List Wizard to allow terminal servers groups to be defined and configured.
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Terminal Server Group List Wizard

The opening window of the Terminal Server Group List Wizard will show any Terminal Server Groups that are defined, or will be blank if none have been defined.

· Add Group will allow a new Terminal Server Group to be defined.  XE "Add Group" 
· Edit Group will open the properties for a highlighted Terminal Server Group in the list. XE "Edit Group" 
· Delete Group will remove a highlighted Terminal Server Group from the list.

· Cancel closes the wizard without action.

· OK closes the wizard after accepting changes.

Selecting Add Group will open the Group Name page.
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Group Name Page

Enter the desired name of the group in the Group Name field.

Each group can contain members of one type of Client Communication Protocol These are configured during the Terminal Server Configuration. 

Select the desired Client Communication Protocol and select Next to configure the group options.
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Citrix MetaFrame Options

If Citrix MetaFrame is the Client Communication Protocol chosen, the Citrix MetaFrame XE "Citrix MetaFrame"  page will be displayed to allow the setting of Citrix options including Encryption Level and the use of Published Applications. The ICA Browser Address allows aid in connection across routers, subnets, and domains.

If a published application is used, check the Use a Citrix Published Application checkbox and enter the published application in the Enter the name of a Published Application field.

Note: Published Application should have a continuous name and not contain spaces.

Select Next to continue
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Group Options

The Group Options allow the configuration of terminal server group parameters.

Group Type Options include:

· SmartSession Group –  XE "SmartSession" Selecting this option allows the terminal server group to provides load balancing by using CPU availability, memory, and the number of sessions on the member terminal servers to determine the availability of resources on member terminal servers. ThinManager Ready thin clients connect to the terminal server in the terminal server group with the most available resources

· Make group available for MultiSession Configurations –  XE "MultiSession" This allows the terminal server group to be available to ThinManager Ready thin clients that use MultiSession to connect to two or more terminal server groups.

· Application Link Group –  XE "Application Link" 

 XE "AppLink" This option, AppLink, provides the Initial Program XE "Initial Program"  function to ThinManager Ready thin clients that connect to members of the terminal server group. The Initial Program function launches a program instead of the desktop. Closing the program will end the connection and force a reconnection to a session running the application.

Group Options include:

· Enforce Primary XE "Enforce Primary"  - This allows a ThinManager Ready thin client to connect to its original terminal server if that terminal server has failed and recovered. 

Note: Enforce Primary is not available with SmartSession.

· Instant Failover XE "Instant Failover"  - Allows a terminal to connect to two terminal servers in the Terminal Server Group. The terminal will have an active session on two terminal servers but will only display one session. If the first terminal server fails, the session of the second terminal server is immediately displayed, eliminating any downtown due to terminal server failure.

Note: A terminal requires an Instant Failover license to use this function. 

· Always maintain a session for this group – If checked, if the user closes his session, another session will be started automatically. If unchecked, the user can close a session and another session won’t start automatically. 

· Start a session at boot-up for this group – If checked, the terminal will start a session for this terminal server group at boot up. If unchecked, a user action is required to start the session.

· Allow Auto-Login XE "Auto-Login" 

 XE "Auto Login"  - If checked, the terminal will use the login information supplied in the terminal configuration to automatically logon to the terminal server. If unchecked, the user will be required to manually login to the terminal server. 

Once the Terminal Server Group parameters are configured, select Next to select the terminal servers for the group.
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Terminal Server Group Members

Once the Terminal Server Group is configured, the available Terminal Servers are listed in the Terminal Server Group Members page. Highlight the desired terminal server from the left-hand list and use the arrow to move it into the right-hand column. Use the Up arrow and Down arrow to prioritize the order of connection unless SmartSession is being used.

Select the Edit Server List button to configure additional Terminal Servers.

If the Terminal Server Group is using the SmartSession option, the Next button will launch the SmartSession Settings page. 

If the Terminal Server Group is not SmartSession Group the Finish button will complete the Terminal Server Group configuration.
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Smart Session Settings

The SmartSession Settings page sets the weight of the three parameters that ThinManager uses to determine availability for SmartSession.

ThinManager multiplies the CPU utilization, Memory utilization, and number of sessions on the terminal server by the Weight XE "Weight"  shown to define the SmartSession terminal server’s available resources. 

The higher the Weight, relative to the others, the greater the importance of that parameter has in determining the load for SmartSession.

Note: The Weighs are relative. Increasing all three Weights from “1” to “10” doesn’t change the relative values.

The Finish button will close the configuration of that terminal server and return to the beginning of the Terminal Server List Wizard for the configuration of other terminal servers.

If the Terminal Server Group uses the AppLink option, a Link Application page will be displayed by selecting the Next button.
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Linked Application Path

The Linked Application page allows a single application to be defined for the AppLink XE "AppLink"  session. Enter the path to the desired application in the Enter the path to the Linked Application field as shown in the example. 

Note: The path used must be valid for each and every terminal server in the AppLink group.

Note: Quotation marks may be needed when there is a space in the path.

Selecting the Finish button will close the Terminal Server Group List wizard and display the created terminal server groups.
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Available Groups

Additional groups can be configured by selecting the New Group button. 

The Terminal Server Group List wizard can be closed by selecting OK.

ThinManager Server List XE "ThinManager Server List" 
Selecting ThinManagerServer>Server List Management> ThinManager Server List or right clicking on a ThinManager Server in the tree and selecting Server List Management> ThinManager Server List will launch the ThinManager Server List Wizard to allow the definition of ThinManager Servers.
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ThinManager Server List Wizard - Introduction

The ThinManager Server List Wizard begins with an introduction screen. 

Select Next to proceed or click Finish to close.
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ThinManager Server List Wizard

The ThinManager Server List is the collection of ThinManager Servers on the network. These include ThinManager Servers that the terminal will communicate with to keep the connection status lights in the ThinManager tree updated. It also allows access to remote ThinManager Servers that allow network wide monitoring, control, and management.  XE "ThinManager Server List" 

 XE "ThinManager Server" 
· Remove Server clears a highlighted ThinManager Server from the list.  XE "Remove Server" 
· Add Server will launch a window that allows the entry of a ThinManager Server name and IP address.  XE "Add Server" 
· Edit Server will launch a window that allows the change of a highlighted ThinManager Server name and IP address.

Selecting Add Server will launch a ThinManager Server Definition window that allows the entry of the ThinManager Server name and IP address. 
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ThinManager Server Definition

Entering the network name of the ThinManager Server and its IP address allows the ThinManager Servers to be tied to a convenient name without the need of a DNS server.  XE "ThinManager Definition" 
Enter the computer name as found in the Microsoft System Properties in the ThinManager Server field. Add the IP address of the ThinManager Server in the ThinManager Server Address field, and select OK. This adds the ThinManager Server to the ThinManager Server list.
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ThinManager Server List

When all of the desired ThinManager Servers are added to the list, select Finish to close the ThinManager Server List wizard.

DNS Configuration XE "DNS Configuration" 

 XE "Domain Name Server" 
Selecting ThinManagerServer > Server List Management > DNS Configuration or right clicking on a ThinManager Server in the tree and selecting Server List Management> DNS Configuration will launch the ThinManager Server List Wizard to allow the definition of Domain Name Servers. 
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Domain Name Service Wizard - Introduction

The Domain Name Service Wizard Introduction screen will allow the use of DNS if a DNS server is being used.

· If the System without a DNS server radio button is selected, no configuration is needed. Select the Finish button to close the wizard.

· If the System using a DNS server radio button is selected, the Next button will launch the Domain Name Service Configuration screen.
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Domain Name Server Configuration

The Domain Name Service Configuration page allows DNS settings to be configured.

· The Add DNS Server button will launch a dialog box that allows a DNS Server to be added to the list.

· The Remove DNS Server button will remove a highlighted DNS server from the list.

· The Up and Down arrow keys will change the order of DNS servers used. Highlight a DNS server in the list and select the appropriate arrow.

· Domain  XE "Domain"  is a field for the DNS domain name.

· Search Domain  XE " Search Domain "  will add the contents of the field as a prefix to any DNS searches. 

· Selecting the Read DNS Setting from this computer button will transfer the DNS settings from the current computer into ThinManager. 

Selecting the Add DNS Server will launch a dialog box that allows the IP address of the DNS server to be added.
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Domain Name Server Configuration - Add DNS Server

Add the IP address of the DNS server into the DNS Server dialog and select OK. Additional IP addresses can be listed by selecting the Add DNS Server button again.

Select the Finish button when the DNS configuration is done.

Group Configuration Wizard XE "Group Configuration Wizard" 
 XE "Group Configuration" Using Groups allows a configuration to be defined for a group of terminals. Terminals added to a group will inherit the group properties to speed the configuration process. Using Groups can also aid in management because many tasks can be done on the group level instead of repeating them for multiple terminals.

The Group Name Configuration wizard can be launched by selecting Edit>Add Group or by or right clicking on a ThinManager Server in the tree and selecting Add Group.
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Group Configuration Wizard - Group Name

When a Group is first added, giving it a name is the first priority. Use numbers, letters, hyphens (-) and underscores (_), but don’t use spaces or other characters.

Selecting the Allow Terminals in this group to be replaced if offline XE "Allow Terminals in this group to be replaced if offline"  checkbox will allow all members of the group to show up in the replacement list during a new terminal connection.

Selecting the Allow terminal to be shadowed XE "Allow terminal to be shadowed"  checkbox will allow members of the Group to be viewed by ThinManager Power Users and controlled by Administrators from the Shadow XE "Shadow"  tab on the Details pane of the ThinManager program. Unselecting this will prevent shadowing from within ThinManager. See Shadowing
 and ThinManager Security Groups
 for details.

Select Next to continue or Cancel to quit.
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Terminal Server Specification

The Method of Terminal Server Selection radio button provides options for terminal server connections.

· Use Terminal Server Groups will allow terminals to connect to terminal servers in Terminal Server Groups for increased functionality like load balancing.  XE "Use Terminal Server Groups" 
· Select Individual Terminal Servers will allow terminals to connect to a list of terminal servers as it has been traditionally done in earlier versions of ThinManager.  XE "Select Individual Terminal Servers" 
The Enable MultiSession checkbox allows the terminals in the group to use the MultiSession functionality as described in MultiSession
. This is not available to a Group that is using individual terminal servers only.  XE "Enable MultiSession" 
Groups Using Individual Terminal Servers

Members of a Group may connect to a list of individual terminal servers by selecting the Select Individual Terminal Servers on the Terminal Server Specification page.

The Group Connection Type page is displayed next to allow the selection of the desired Client Communication Protocol.
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Group Configuration Wizard - Connection Type

Thin clients use a client communication protocol to connect to the Terminal Servers. Select the correct protocol and select the Next button.

· Select the Citrix MetaFrame radio button if that program is to be used to provide the ICA protocol. Citrix MetaFrame XE "Citrix MetaFrame" 

 XE "MetaFrame"  is an optional program sold by Citrix.

· Select the Citrix Device Services radio button if Citrix Device Services XE "Citrix Device Services"  is to be used to provide the ICA protocol. Citrix Device Services XE "Device Services"  is a legacy deployment of the ICA client but is no longer supported by Citrix. ThinManager Ready thin clients can still connect to terminal servers with Device Services, but no new Device Services terminal servers can be licensed.

· Microsoft Remote Desktop Protocol (RDP) is installed by default on all Windows Terminal Servers. The Microsoft Remote Desktop Protocol XE "Remote Desktop Protocol"  (RDP) XE "RDP"  radio button is selected by default unless you choose another protocol.

Selecting Citrix ICA with MetaFrame offers additional configuration options before displaying the Terminal Server Selection. Selecting Citrix ICA with Device Services and Remote Desktop Protocol (RDP) will jump to the Terminal Server Selection.

A Group using Citrix MetaFrame as its Client communication Protocol will be shown additional configuration screens beginning with the Citrix MetaFrame Configuration page.
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Group Configuration Wizard - Citrix MetaFrame Configuration

Citrix MetaFrame allows increased encryption in the ICA protocol. Select a level from the Encryption XE "Encryption"  drop-down box.

Citrix MetaFrame has a feature called Published Applications. If you are using Published Applications, select the Yes radio button, then select the Next button to continue to the Citrix Published Application dialog.

If you are not using Published Applications, select the No radio button, then select the Next button to continue to the Terminal Server Selection dialog.
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Group Configuration Wizard - Citrix Published Applications

Enter the name of the desired Published Applications XE "Published Application"  in the Published Applications field. Do not use spaces in the name when creating a Published Application for Terminal Services.

Citrix MetaFrame uses ICA Browsers XE "ICA Browser"  as part of the system. Because the ICA client may have problems detecting an ICA browser across a router or switch, an ICA Browser field is provided for entering the name of an ICA browser.

Select the Finish button to create the Group, or select the Next button to rejoin the main configuration path to configure more options.

Groups using the Select Individual Terminal Servers will be shown the Group Terminal Server Selection page to select the desired terminal servers to connect to.
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Group Configuration Wizard - Group Terminal Server Selection

The Group Terminal Server Selection page allows the selection of the terminal server or servers that the members of the group will connect to.

If the Available Terminal Server column is empty, the Terminal Server List Wizard needs to be run to add terminal servers to ThinManager. Select the Edit Server List button to launch the Terminal Server List Wizard as shown in the Terminal Server List Wizard
.
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Group Configuration Wizard - Terminal Server Selection

Once the Terminal Server List wizard has run, each Terminal Server that is identified in the Terminal Server List Wizard will initially appear in the Available Terminal Servers box on the left of the Group Terminal Server Selection.  XE "Available Terminal Servers" 

 XE "Selected Terminal Servers" 
To choose a terminal server for the Group, highlight it in the list on the left and click the Right arrow button. This will put the Terminal Server into the Selected Terminal Server list on the right. The Group will use all the Selected Terminal Servers as Terminal Servers, in the order listed.

The Terminal Server on the top of the Selected Terminal Server List will be the Primary Terminal Server, the first Terminal Server that the terminal will attempt to login to. If the Primary Terminal Server XE "Primary Terminal Server"  fails, or is unavailable, the terminal will connect to the other terminal servers in the order that they are listed. 

To change the order of the Terminal Servers in the Terminal Server Selection list, highlight a Terminal Server and use the Up arrow button and the Down arrow button to move it up or down in the list.

The Enforce Primary Terminal Server Connection will cause a terminal to return to the primary terminal server whenever that server is available.  XE "Enforce Primary" 
Select the Next button to continue configuration or select the Finish button to complete the Group configuration.

Groups Using Terminal Server Groups

Members of a Group may connect to Terminal Server Groups by selecting the Use Terminal Server Groups on the Terminal Server Specification page.
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Group Configuration Wizard - Terminal Server Specification

If Use Terminal Server Groups is selected, an Enable MultiSession checkbox will be displayed.  XE "Enable MultiSession" 
Check the Enable MultiSession checkbox to connect to two or more terminal server groups at once. See MultiSession
 for details.

Select Next to continue configuration.

The Group Terminal Server Selection page is displayed next to allow the selection of the desired Terminal Server Groups.

[image: image140.png]Ed Terminal Configuration

Group Terminal Server Selection

Selectthe Terminal Servers ta which members of the aroup il
connect,

Avaiable Terminal Server Groups Selected Terminal Server Graups

|
N

Edt Server Groups

The thin clients il corneet to the servers in the ader the they are sted, vith the
top setver s the Prinaiy Terminal Server.

I~ Enforce Pimary Terminal Server Connection

<Back | New> | Finsh Cancel Help





Group Configuration Wizard - Group Terminal Server Selection

The Group will need to connect to Terminal Server Groups that contain terminal servers that will host the sessions.  XE "Available Terminal Server Groups" 

 XE "Selected Terminal Server Groups" 
If the Available Terminal Server Groups column is empty, the Terminal Server Groups List wizard needs to be run to configure Terminal Server Groups. Select the Edit Server Groups button to launch the Terminal Server Group Wizard as shown in Terminal Server Group List
.
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Group Configuration Wizard - Terminal Server Selection

Once the Terminal Server Group wizard has run, each Terminal Server Group that is identified in the Terminal Server Group Wizard will initially appear in the Available Terminal Server Groups box on the left of the Group Terminal Server Selection page. 

To select a Terminal Server Group for a Group, highlight it in the list on the left and click the right arrow button. This will put the Terminal Server Group into the Selected Terminal Server Group list on the right. The Group will use the Selected Terminal Server Groups for the terminal servers that it can login to.

The Enforce Primary Terminal Server Connection will cause a terminal to return to the primary terminal server whenever that server is available. This is not available with Smart-Session.  XE "Enforce Primary" 
Select the Next button to continue configuration or select the Finish button to complete the Group configuration.
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Terminal Configuration Wizard - Terminal Server Group Options

A Group using MultiSession will have a page that allows the configuration of the hotkeys that allow switching between sessions. Select the Change Hotkey XE "Hotkey"   XE "Group Selector" button to configure hot keys.
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Terminal Configuration Wizard - Select HotKeys 

The hotkey to switch between the multiple sessions are set by default to Control+Page Up and Control+Page Down. The hot keys can be changed by using the dropdown boxes.

Select OK to continue.

Continuation of the Group Configuration

The configuration paths (Independent Terminal Servers vs. Terminal Server Groups, MetaFrame vs. Device Services and RDP) unite at the Login Configuration.
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Group Configuration Wizard - Login Information

It is recommended that each terminal login to a Terminal Server with a unique profile. For this reason, the Group Username XE "Username" , Password XE "Password" , and Domain XE "Domain"  are inactive. These need to be set individually during the Terminal Configuration.

The Initial Program XE "Initial Program"  loads the designated program instead of the Windows desktop when the terminal connects to the Terminal Server. If a program is launched as the initial program, it is the only program that will run. This provides a level of security and control because that program is the only program that will run in that session. If the Initial Program is closed on the terminal, the session on the Terminal Server will close and the ThinManager Ready Thin Client will reconnect to the Terminal Server and re-launch the Initial Program. This effectively makes the Initial Program the only program. See Initial Program
 for details.

To use the Initial Program, enter the path to the program in the Initial Program field as shown in the example.

Note: When using the Initial Program with failover, the path must be identical on all terminal servers.

Select the Next button to continue configuration or select the Finish button to complete the Group configuration.
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Group Configuration Wizard - Video Configuration

The Group Video Resolution page has a drop-down box that allows the video resolution to be set for all members of the Group.  XE "Video" 

 XE "Video Resolution" 
The standard terminal connection uses a 256-color depth. The 64K-color depth is available by using RDP connected to a Windows 2003 Terminal Server, or by using the ICA client with Citrix MetaFrame 1.8 FR1 or greater.

Select the Next button to continue configuration or select the Finish button to complete the Group configuration.
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Group Configuration Wizard - Module Selection

A Module XE "Module"  is a component of the firmware that is not needed for the basic functionality, but may be desired for advanced functionality. These features include Touch Screen drivers, serial mouse drivers, High Speed Serial drivers, Shared Keyboard and Mouse, USB Memory Card Reader, and Instant Failover. See Module Overview
 for details.

To add a Module to a Group, select the Add… button and select the Module from the list.
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Group Configuration Wizard - Module List

Selecting the Add… button will launch the list of available modules in the Attach Module to Terminal window.

Highlight the desired module and select OK.

Highlighting the module and selecting the Configure button can change some module parameters. Select the parameter to change, select the new value in the drop-down list and click the Set button. Details are found in Module Overview
.

Select the Next button to continue configuration or select the Finish button to complete the Group configuration.
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Group Configuration Wizard - Monitoring Configuration

The ThinManager Server Monitor List defines what Thin Manager Servers the terminal will communicate with to keep monitoring light status current. All ThinManager Servers defined in the ThinManager Server List Wizard will appear in the Available ThinManager Server column.

If this column is empty or is missing the desired ThinManager Server, select the Edit Server List button to launch the ThinManager Server List Wizard as shown in ThinManager Server List
.
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Group Configuration Wizard - Monitoring Configuration

Once the ThinManager Server List wizard has run, each ThinManager Server that is identified in the ThinManager Server List Wizard will initially appear in the Available ThinManager Server box on the left of the Group Monitoring Configuration page.  XE "Available ThinManager Servers" 
To select a ThinManager Server for the Group, highlight it in the Available ThinManager Server list on the left and click the right arrow button. This will put the ThinManager Server into the Selected ThinManager Server list  XE "Selected ThinManager Servers" on the right. The terminals of the Group will send connection status (red/green icon lights) to all ThinManager Servers in the Selected ThinManager Server list.

Select the Next button to continue configuration or select the Finish button to complete the Group configuration.
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Group Configuration Wizard - Monitoring Configuration

ThinManager Ready Thin Clients continuously monitor the Terminal Server to make sure that it stays online. If the Terminal Server goes offline, the terminal will disconnect and connect to the next Terminal Server in the Group Terminal Server Selection. The Monitoring Connection sets the frequency that the monitor occurs.

Use the Monitor Interval radio buttons to use a default frequency or select Custom and choose a setting of your own.

· Monitor Interval XE "Monitor Interval"  is the interval that the monitor checks occur.

· Monitor Timeout XE "Monitor Timeout"  is the time the terminal will wait for a response from the terminal server.

· Monitor Retry XE "Monitor Retry"  is the number of times the monitor check will be tried.

· Primary Up Delay Multiplier XE "Primary Up Delay Multiplier"  is the number that generates the Primary Up Delay time.

· Primary Up Delay XE "Primary Up Delay"  is a delay added (usually set to 30 or 60 seconds) to allow a Terminal Server to become fully booted before the terminal will try to login. This time period is equal to the Monitoring Interval times the Primary Up Delay Multiplier.

The Fast setting of the Monitor Connection will detect Terminal Server failure quickly. However, the faster the setting is, the more sensitive it is and it may drop the Terminal Server when the network is busy and not offline. Setting the Monitoring Connection to a slower setting gives the Terminal Server more time to respond when it is busy.

Select the Finish button to complete the Group configuration.

Terminal Configuration Wizard XE "Terminal Configuration Wizard" 
Configuring a Terminal is just like configuring a Group. 

If a terminal is created in a Group, or added to a Group, it will have the option of using the Group configuration. This is controlled with a Use Group Property XE "Use Group Property"  checkbox on each wizard page. To change the configuration from the Group, un-check the checkbox and use the desired settings. A terminal created outside a Group and not added to a Group, will not display the Use Group Property checkboxes.

Note: The following section shows a terminal that is configured as an individual and not as a member of a Group. Terminals created as a member of a Group will display a Use Group Setting checkbox and have Group settings grayed out. To use the individual settings, uncheck the Use Group Setting checkbox and apply the individual configuration.

The Terminal Creation Wizard can be launched by either:  XE "Add Terminal" 
· Selecting a ThinManager Server in the ThinManager tree and selecting Edit > Add Terminal from the menu bar, or 

· Selecting a ThinManager Server in the ThinManager tree, right-clicking on the ThinManager Server icon, and selecting the Add Terminal option, or 

· Selecting a Group in the ThinManager tree, right-clicking on the Group icon, and selecting the Add Terminal option. This puts the terminal in that group.
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Terminal Configuration Wizard - Terminal Name

When a Terminal is first created, giving it a name is the first priority. Use numbers, letters, hyphens (-), and underscores (_), but don’t use spaces or other characters.

Note: The terminal name should be less than 15 characters because of limitations on the terminal server.

It can be added to a Group by selecting the Group name in the Group drop-down box. Terminals added to a Group will be assigned the Group properties, but they can have the Group properties changed to individual settings by un-checking a Use Group Property checkbox on each wizard page.

The Copy Settings from another Terminal XE "Copy Settings from another Terminal"  checkbox will copy an established configuration to the new terminal, cutting setup time.

The Allow terminal to be replaced if offline XE "Allow terminal to be replaced if offline"  checkbox allows this terminal to be replaced in case of failure. Un-checking it will prevent it from being replaced until an administrator checks this box.

Select Next to continue or Cancel to quit.
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Terminal Configuration Wizard - Hardware Configuration

Select the make and model of the ThinManager Ready Thin Client from the drop-down boxes.  XE "Make" 

 XE "OEM" 

 XE "Model"  These parameters are from the Terminal Capability database (TermCap data base)  XE "TermCap"  as described the Install New TermCap Database
. 

If you do not know what model it will be, leave the default setting. When a terminal is connected and receives this configuration, ThinManager will update the configuration to match the actual settings.

Select Next to continue.
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Terminal Server Specification

The Method of Terminal Server Selection radio button provides options for terminal server connections.

· Use Terminal Server Groups XE "Use Terminal Server Groups"  will allow terminals to connect to terminal servers in Terminal Server Groups for increased functionality like load balancing.

· Select Individual Terminal Servers XE "Select Individual Terminal Servers"  will allow terminals to connect to a list of terminal servers as it has been done in earlier versions of ThinManager.

The Enable MultiSession XE "Enable MultiSession"  checkbox allows the terminals in the group to use the MultiSession functionality as described in MultiSession
. This is not available for terminals that are using individual terminal servers.

Terminals Using Individual Terminal Servers

Terminals may connect to a series of individual terminal servers by selecting the Select Individual Terminal Servers on the Terminal Server Specification page.

The Terminal Connection Type page is displayed next to allow the selection of the desired Client Communication Protocol.

[image: image154.png]Ed Terminal Configuration

Teminal Connection Type ACR
Select the lype of connection his cient il make o the Terminal -
Server, ]

Selectthe connecton ype
Gl ICA with Metafame
Gl ICA with Device Services
 emote Deskiop Protocal (FOFT
(s Device Services s included with ThinManager.
(i elaFrame i sold separaleh.
<Back. Firish Cancel Help





Terminal Configuration Wizard - Connection Type

Thin clients use a client communication protocol to connect to the Terminal Servers. Select the correct protocol and select the Next button.

· Select the Citrix MetaFrame radio button if that program is to be used to provide the ICA protocol. Citrix MetaFrame XE "Citrix MetaFrame" 

 XE "MetaFrame"  is an optional program sold by Citrix.

· Select the Citrix Device Services radio button if Citrix Device Services XE "Citrix Device Services"  is to be used to provide the ICA protocol. Citrix Device Services XE "Device Services"  is a legacy deployment of the ICA client but is no longer supported by Citrix. ThinManager Ready thin clients can still connect to terminal servers with Device Services, but no new Device Services terminal servers can be licensed.

· Microsoft Remote Desktop Protocol (RDP) is installed by default on all Windows Terminal Servers. The Microsoft Remote Desktop Protocol XE "Remote Desktop Protocol"  (RDP) XE "RDP"  radio button is selected by default unless you choose another protocol.

Selecting Citrix ICA with MetaFrame offers additional configuration options before displaying the Terminal Server Selection. Selecting Citrix ICA with Device Services and Remote Desktop Protocol (RDP) will jump to the Terminal Server Selection.

A Terminal using Citrix MetaFrame as its Client communication Protocol will be shown additional configuration screens beginning with the Citrix MetaFrame Configuration page.
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Terminal Configuration Wizard - Citrix MetaFrame Configuration

Citrix MetaFrame allows increased encryption in the ICA protocol. Select a level from the Encryption  XE "Encryption" drop-down box.

Citrix MetaFrame has a feature called Published Applications. If you are using Published Applications XE "Published Application" , select the Yes radio button, then select the Next button to continue to the Citrix Published Application dialog.

If you are not using Published Applications, select the No radio button, then select the Next button to continue to the Terminal Server Selection dialog.
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Terminal Configuration Wizard - Citrix Published Applications

Enter the name of the desired Published Applications in the Published Applications Name field. Do not use spaces in the name when creating a Published Application XE "Published Application"  for Terminal Services.

Citrix MetaFrame uses ICA Browsers XE "ICA Browser"  as part of the system. Because the ICA client may have problems detecting an ICA browser across a router or switch, an ICA Browser field is provided for entering the name of an ICA browser.

Select the Finish button to create the Terminal, or select the Next button to rejoin the main configuration path to configure more options.

Terminals using the Select Individual Terminal Servers will be shown the Terminal Server Selection page to select the desired terminal servers to connect to.
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Terminal Configuration Wizard -Terminal Server Selection

If Published Applications are not being used, the terminal will need to be assigned to a Terminal Server. The Terminal Server is a server that allows a terminal to logon and run applications in an independent session.

If the Available Terminal Server column is empty, the Terminal Server List wizard needs to be run to add terminal servers to the ThinManager system. Select the Edit Server List button to launch the Terminal Server List Wizard as shown in Terminal Server List Wizard
.
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Terminal Configuration Wizard - Terminal Server Selection

Once the Terminal Server List wizard has run, each Terminal Server that is identified in the Terminal Server List Wizard will initially appear in the Available Terminal Server  XE "Available Terminal Servers" box on the left side of the Terminal Server Selection page. 

To select a Terminal Server for the terminal, highlight it in the list on the left and click the Right arrow button. This will put the Terminal Server into the Selected Terminal Server  XE "Selected Terminal Servers" list on the right. The terminal will use all the Selected Terminal Servers as Terminal Servers.

The Terminal Server on the top of the Selected Terminal Server List will be the Primary Terminal Server, the first Terminal Server that the terminal will attempt to login to. If the Primary Terminal Server XE "Primary Terminal Server"  fails, or is unavailable, the terminal will connect to the other terminal servers in the order that they are listed. 

To change the order of the Terminal Servers in the Terminal Server Selection list, highlight a Terminal Server and use the Up arrow button and the Down arrow button to move it up or down in the list.

The Enforce Primary Terminal Server Connection will cause a terminal to return to the primary terminal server whenever that server is available.  XE "Enforce Primary" 
Select the Next button to continue configuration or select the Finish button to complete the terminal configuration.

Terminals Using Terminal Server Groups

Terminals may connect to Terminal Server Groups by selecting the Use Terminal Server Groups on the Terminal Server Specification page.
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Terminal Configuration Wizard - Terminal Server Specification

If Use Terminal Server Groups is selected, an Enable MultiSession checkbox will be displayed.  XE "Use Terminal Server Groups" 

 XE "Enable MultiSession" 
Check the Enable MultiSession checkbox to use Multi-Session. See MultiSession
 for details.
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MultiSession Not Enabled Warning

If two Terminal Server Groups are selected without the Enable MultiSession  XE "MultiSession not Enabled" checkbox selected, a message will be displayed warning that the Enable MultiSession checkbox needs to be checked to allow the MultiSession.

Select Next to continue configuration.

The Terminal Server Selection page is displayed next to allow the selection of the desired Terminal Server Groups.
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Terminal Configuration Wizard - Group Terminal Server Selection

The terminal will need Terminal Server Groups selected that contain the terminal servers that the terminals will connect to.  XE "Available Terminal Server Groups" 

 XE "Selected Terminal Server Groups" 
If the Available Terminal Server Groups column is empty, the Terminal Server Groups List wizard needs to be run to configure Terminal Server Groups. Select the Edit Server Groups button to launch the Terminal Server Group Wizard as shown in Terminal Server Group List
.
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Terminal Configuration Wizard - Terminal Server Selection

Once the Terminal Server Group wizard has run, each Terminal Server Group that is identified in the Terminal Server Group Wizard will initially appear in the Available Terminal Server Groups box on the left of the Terminal Server Selection page. 

To select a Terminal Server Group for a terminal, highlight it in the list on the left and click the right arrow button. This will put the Terminal Server Group into the Selected Terminal Server Group list on the right. The Group will use the Selected Terminal Server Groups for the terminal servers that it can login to.

The Enforce Primary Terminal Server Connection will cause a terminal to return to the primary terminal server whenever that server is available. This is not available with Smart-Session.  XE "Enforce Primary" 
Select the Next button to continue configuration or select the Finish button to complete the Group configuration.
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Terminal Configuration Wizard - Terminal Server Group Options

A terminal using MultiSession will have a page that allows the configuration of the hotkeys that allow switching between sessions. Select the Change Hotkey XE "Hotkey"  XE "Group Selector"  button to configure hot keys.
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Terminal Configuration Wizard - Select Hotkeys 

The hotkey to switch between the multiple sessions are set by default to Control+Page Up and Control+Page Down. The hot keys can be changed by using the dropdown boxes.

Select OK to continue.

Continuation of the Terminal Configuration

The configuration paths (Independent Terminal Servers vs. Terminal Server Groups, MetaFrame vs. Device Services and RDP) unite at the Login Configuration.
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Terminal Configuration Wizard - Login Information

It is recommended that each terminal should login to a Terminal Server with a unique profile. 

If the Username XE "Username" , Password XE "Password" , and Domain XE "Domain"  fields are filled with a valid Microsoft user account, ThinManager will pass this information to the Microsoft Terminal Server when the ThinManager Ready Thin Client connects, letting the terminal login automatically.

Note: RDP will not allow auto-login by default. See Configuring RDP for Auto-Login
 for details.

If the Username, Password, and Domain fields are left blank, or are filled with invalid data, the Microsoft Windows login window will be presented on the terminal and the user will need to login manually.

Note: Users may need to be added to Microsoft’s Remote Desktop Users Group when connecting to a Windows 2003 terminal server.
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Windows 2003 Computer Management – Local Users and Groups 

The Initial Program XE "Initial Program"  loads the designated program instead of the Windows desktop when the terminal connects to the Terminal Server. If a program is launched as the initial program, it is the only program that will run. This provides a level of security and control because that program is the only program that will run in that session. If the Initial Program is closed on the terminal, the session on the Terminal Server will close and the ThinManager Ready Thin Client will reconnect to the Terminal Server and re-launch the Initial Program. This effectively makes the Initial Program the only program. See Initial Program
 for details.

To use the Initial Program, enter the path to the program in the Initial Program field as shown in the example.

Note: When using the Initial Program with failover, the path must be identical on all terminal servers.

Select the Next button to continue configuration or select the Finish button to complete the Terminal configuration.
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Terminal Configuration Wizard - Video Configuration

The Video Resolution Configuration  XE "Video" has a drop-down box that allows the video resolution to be set for the terminal.

The standard terminal connection uses a 256-color depth.  XE "Color Depth"  The 64K-color depth is available by using RDP connected to a Windows 2003 Terminal Server or the ICA client with Citrix MetaFrame 1.8 FR1 or greater.

Select the Next button to continue configuration or select the Finish button to complete the Terminal configuration.
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Terminal Configuration Wizard - Module Selection

A Module XE "Module"  is a component of the firmware that is not needed for the basic functionality, but may be desired for advanced functionality. These features include Touch Screen drivers, serial mouse drivers, High Speed Serial drivers, Shared Keyboard and Mouse, USB Memory Card Reader, and Instant Failover. See Module Overview
 for details.

To add a Module to a Terminal, select the Add… button and select the Module from the list.
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Terminal Configuration Wizard - Module Selection

Terminals that are members of a Group XE "Group Modules"  may show icons to represent the properties of added modules.

· [image: image170.png]


 The Group icon represents properties assigned by the Group.

· [image: image171.png]


 The Group icon with yellow plus sign represents properties that are changed on the terminal from the Group settings.

· [image: image172.png]=)



 The Group icon and red circle represents a terminal that isn’t using an assigned Group module. The Use Modules from Group checkbox was un-selected.

· No icon indicates that the module was added to the Terminal and not the Group.

To add a Module to a Terminal, select the Add… button and select the Module from the list.

Highlighting the module and selecting the Configure button can change some module parameters. Select the parameter to change, select the new value in the drop-down list and click the Set button. A yellow plus sign will be displayed on the icon as an indicator.

To remove a Group Module, uncheck the Use Group Properties checkbox. This will put the red circle on the icon as an indicator.

Select the Next button to continue configuration or select the Finish button to complete the Terminal configuration.
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Terminal Configuration Wizard - ThinManager Server Monitor List

The ThinManager Server Monitor List defines what Thin Manager Servers the terminal will communicate with to keep monitoring light status current.

If the Available ThinManager Server column is empty, the ThinManager Server List Wizard needs to be run to define the ThinManager Servers. Select the Edit Server List button to launch the ThinManager Server List Wizard as shown in ThinManager Server List Wizard
.
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Terminal Configuration Wizard - ThinManager Server Monitor List

Once the ThinManager Server List wizard has run, each ThinManager Server that is identified in the ThinManager Server List Wizard will initially appear in the Available ThinManager Server  XE "Available ThinManager Servers" box on the left of the Group Monitoring Configuration page. 

To select a ThinManager Server for the terminal, highlight it in the Available ThinManager Server list on the left and click the right arrow button. This will put the ThinManager Server into the Selected ThinManager Server list  XE "Selected ThinManager Servers" on the right. The terminal will send connection status (red/green icon lights) to all ThinManager Servers in the Selected ThinManager Server list.

Select the Next button to continue configuration or select the Finish button to complete the Group configuration.
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Terminal Configuration Wizard - Monitoring Configuration

ThinManager Ready Thin Clients continuously monitor the terminal servers to which they are connected to make sure that the terminal server stays online. If the terminal server goes offline, the terminal will disconnect and connect to the next Terminal Server that it was assigned to in the Terminal Server Selection. The Monitoring Connection sets the frequency that the monitoring occurs.

Use the Monitor Interval radio buttons to use a default frequency or select Custom and choose a setting of your own.

· Monitor Interval XE "Monitor Interval"  is the interval that the monitor checks occur.

· Monitor Timeout XE "Monitor Timeout"  is the time the terminal will wait for a response from the terminal server.

· Monitor Retry XE "Monitor Retry"  is the number of times the monitor check will be tried.

· Primary Up Delay Multiplier XE "Primary Up Delay Multiplier"  is the number that generates the Primary Up Delay time.

· Primary Up Delay XE "Primary Up Delay"  is a delay added (usually set to 30 or 60 seconds) to allow a Terminal Server to get fully booted before the terminal will try to login. This time period is equal to the Monitoring Interval times the Primary Up Delay Multiplier.

A Fast setting of the Monitor Connection will detect Terminal Server failure quickly. However, the faster the setting is, the more sensitive it is and it may drop the Terminal Server when the network is busy but not offline. Setting the Monitoring Connection to a slower setting gives the terminal server more time to respond when it is busy.

Select the Finish button to complete the terminal configuration.

Classic Mode of Configuration

The Classic Mode XE "Classic Mode "  is the method of creating and configuring Groups and Terminals that was introduced in ThinManager 1.0. This method uses Property Tabs instead of a Wizard. This method has been superceded by the Wizard Mode, but has been left for users that are familiar with this method.

ThinManager uses the Classic Mode when View>Use Wizards is unselected. The Classic Mode only works for the properties that were available in ThinManager v2.3.1 or earlier. Trying to use the Classic Mode with new features like RDP, SmartSession, Multi-Session, and AppLink will launch an error window.
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Classic Mode Configuration Error

Note: The Wizard Mode must be used for recent features like RDP, SmartSession, Multi-Session, and AppLink.

Classic Mode of Group Configuration

The use of Groups provides several advantages:

· Groups help organize the ThinManager Tree and allow the terminals to use less space when the Groups are collapsed.

· Terminals added to a Group receive the Group configuration, speeding up configuration and deployment.

Adding Groups XE "Groups" 

 XE "Adding Groups" 
To add a new group either:

· Select Edit>Add Group from the ThinManager menu bar. 

· Right-click a ThinManager Server icon in the ThinManager tree window and select Add Group. 

This will launch the Create New Group XE "Create New Group"  dialog box. 
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Classic Mode - Add New Group

Type the chosen name for the group in the Name field in the Create New Group dialog box.

Select OK to continue. This will launch the Group Properties dialog box.

Group Identity XE "Identity" 

 XE "Group Identity" 
When a new group is created, the Identity tab of the Group Properties dialog box will be displayed. 
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Classic Mode - Group Identity Tab

The Identity tab  XE "Identity tab"  of the Group Properties dialog box contains the name of the group.

The next step in defining a group is to assign it to a Windows Terminal Server. This is done on the Session tab.

Select the Session tab to continue.

Note: A change or modification of group properties will affect terminals after they reboot.

Group Session XE "Session" 

 XE "Group Session" 
The Session tab of the Group Properties dialog box contains the field for the IP address for the Terminal Server. The Group can be assigned to multiple terminal servers to provide backup terminal servers for failover by listing several terminal server IP addresses, separated by a semi-colon (;).

Note: The Classic Mode requires the use of IP Addresses, not names, unless one is using a DNS server. 
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Classic Mode - Group Session Tab

Note: The Wizard Mode must be used if RDP is used.

Select the Server radio button and enter the IP address XE "IP Address"  (or DNS names if using DNS) of the desired Windows NT/2000 Terminal Server that the terminal is to connect to. One instance of ThinManager Server can manage the connection of thin clients to a number of terminal servers by assigning different groups or terminals to different terminal servers.

Failover XE "Failover"  is enabled by listing the IP addresses of the terminal servers, in order of preference, separated by semi-colons (spaces are optional).

· Published Application  XE "Published Application"  is an advanced function for Citrix MetaFrame users. This allows the thin client to use a Citrix Published Application.
Note: The Published Application must have a continuous name. It cannot contain a space.

· Filling in the Username  XE "Username"  and Password XE "Password"  fields will assign the same Windows User Profile to the entire group.

Note: It is recommended that the Username and Password be left blank in the Group Properties and assigned individually in the Terminal Properties so that each user will login with a unique username.
· The Domain  XE "Domain"  field assigns the terminal to a Windows domain.

· The Initial Program  XE "Initial Program"  field is a security feature. If the path to an executable file is entered into the Initial Program field, only the specific program will launch upon boot. If the initial program is closed, the ICA connection will close and reconnect with the initial program running again. This tool is useful for enforcing an operation of a single program, such as an HMI XE "HMI"  or SCADA XE "SCADA"  program. 

To start several initial programs that would allow closure or the running of other programs, use the Startup folder in Windows. Closing a program launched from Startup will not close and reconnect the session.

· The ICA Browser  XE "ICA Browser"  field is a back-up function for Citrix MetaFrame users. If the terminal is unable to browse the ICA network (find the server), the ICA Browser field can specify a server IP address. This might be used with server farms XE "Server Farms"  or published applications XE "Published Application"  are across a switch or a router. See your Citrix XE "Citrix"  documentation for help with server farms and published applications.

· The Encryption  XE "Encryption"  drop-down box allows Citrix MetaFrame users to configure SecureICA encryption.

Note: Each of these settings can be changed for individual terminals in the Terminal Properties. 

OK will accept the changes and close the dialog box when selected. 

Cancel will cancel the addition or change of the group when selected.

Help will launch ThinManager Help when selected.

Group Video

The Video  XE "Video"  tab of the Group Properties dialog box contains the settings for the video properties.

[image: image180.png]Group Properties

Idonity | Session Video | Moduls | DS | Moriotg | Gtrer |

Videa Madk

Custom Video Modelne (Advanced Users Dri)

A custom <Fiee88 video modelne can be inseted here. Fead the.
appropriate sections of the user’s manual for detals. Incarect selfings
an cause manitor damage.

For advanced users only, mostinstalstions willwork cortectly using the
standard video modes. [ your moritor doss rot work, even afer
‘eading all applicable documentaton, please cortact techrical
suppoil

Concsl | Hes





Classic Mode - Group Video Tab

· Video Mode  XE "Video Mode"  is a drop-down box that allows you to select a video resolution for the group. Standard thin client connections use the 256-color resolution. To use the 64K color depth one must use RDP with a Windows 2003 Terminal Server or ICA protocol with Citrix MetaFrame 1.8, Feature Release 1 or greater.

Note: To use RDP you must use the Wizard mode.

· Custom Video Modelines  XE "Custom Video Modelines" 

 XE "Video Modelines"  is a field for scripts that provide support for certain non-standard monitors. If the standard video modelines XE "Modelines"  do not work, please contact your technical support for assistance with this feature.

Note: Each of these settings can be changed for individual terminals in the Terminal Properties. 

OK will accept the changes and close the dialog box when selected. 

Cancel will cancel the addition or change of the group when selected.

Help will launch ThinManager Help when selected.

Group Modules

The Modules  XE "Modules"  tab of the Group Properties dialog box contains the settings for adding modules. Modules are software components that can be added to the firmware to increase the functionality of the terminal. Modules include touch screen drivers, sound drivers, and special device drivers. Some modules are included with ThinManager and are registered automatically during ThinManager installation. Other modules are obtained separately from ACP and need to be installed. See Module Overview
 for details.
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Classic Mode - Group Modules Tab

Selecting the Add… button will launch an Attach Modules window.

OK will accept the changes and close the dialog box when selected. 

Cancel will cancel the addition or change of the group when selected.

Help will launch ThinManager Help when selected.

See Module Overview
 for more details on modules.

Attaching a Module to a Group XE "Attaching a Module" 
Modules are attached from the Modules  XE "Modules"  tab of the Group Properties by selecting the Add… button. This will launch an Attach Module dialog box.
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Attach Group Module 

This shows all the registered modules. Highlight the desired module and select OK. This module will be added to the list on the Module tab and load on the next terminal reboot.
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Group Modules

This shows a number of modules attached to members of the group. These modules will load when the terminal boots.

Group DNS

The DNS  XE "DNS" tab of the Group Properties dialog box contains settings for using a Domain Name System (DNS) server. This will allow the use of DNS names to identify computers.
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Classic Mode - Group DNS Tab

· DNS Server  XE "DNS Server"  is a field for the IP address of a DNS server. 

· Domain  XE "Domain"  is a field for the DNS domain name.

· Search Domain  XE " Search Domain "  will add the contents of the field as a prefix to any DNS searches. 

· The Read DNS settings from server  XE "Read DNS settings from server"  button will load the DNS Server settings from the ThinManager server into the DNS Server field.

Note: Each of these settings can be changed for individual terminals in the Terminal Properties.

OK will accept the changes and close the dialog box when selected. 

Cancel will cancel the addition or change of the group when selected.

Help will launch ThinManager Help when selected.

Group Monitoring

The Monitoring  XE "Monitoring"  tab of the Group Properties dialog box contains parameters related to Failover. A ThinManager Ready thin client monitors the availability of its terminal server, and will disconnect the session if the server is down. These parameters are configurable.
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Classic Mode - Group Monitoring Tab

Note: The Wizard Mode has preset configurations of Fast, Medium, and Slow, in addition to custom settings. The Classic Mode offers uses custom settings.

· Monitor Interval  XE "Monitor Interval"  sets the frequency that the terminal checks the terminal server to see if it is connected. 

Note: Setting this value low will provide a quick detection of server failure. Setting it too low may end the Client Communication connection due to high network traffic or a short network interruption instead of a server failure. 

· Monitor Timeout  XE "Monitor Timeout"  sets the amount of time that the terminal will wait until retrying the server connection.

· Monitor Retry  XE "Monitor Retry"  sets the number of times that the terminal will retry the server before disconnecting the server connection.
· The Enforce Primary  XE "Enforce Primary"  field affects the return of a terminal back to its originally assigned terminal server. If Yes is selected, a terminal that has failed over to a secondary server will reconnect to the primary server once it returns online. If No is selected, a terminal that has failed over to a secondary server will remain connected to the secondary server, even when the primary server returns online.
· Primary Up Delay  XE "Primary Up Delay"  is the number of seconds the terminal will wait to reconnect to the primary after it has detected it. This is included because the terminal can detect the primary before the primary is available for session connections.
· The # secs field is the interval of time between when the primary terminal server returns online and when terminals will switch back to it with Enforce Primary. Its value equal to the Monitor Interval times the Primary Up Delay. This value should be at least 30 seconds.
· The ThinServer  XE "ThinServer"  field allows affects the monitoring lights on multiple ThinManager Servers. Any ThinManager Server in this field will monitor the status of the terminals to update the monitoring lights on the ThinManager tree.
Note: Each of these settings can be changed for individual terminals in the Terminal Properties. 

OK will accept the changes and close the dialog box when selected. 

Cancel will cancel the addition or change of the group when selected.

Help will launch ThinManager Help when selected.

Other Group Properties XE "Other Group Properties" 
The Other tab  XE "Other tab"  of the Group Properties dialog box contains miscellaneous settings.
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Classic Mode - Group Other Tab

· Allow this terminal to be replaced if offline  XE "Allow this terminal to be replaced if offline"  allows a terminal to be replaced quickly in case of failure. 

Note: There is a global Enable Replacement on the Server Properties dialog box. 

· Disable this terminal  XE "Disable this terminal" . On boot up, it will display a message and halt is a quick way to disable access to a terminal. To disable a group of terminals, select this box and reboot the group. This will disable the terminals and deny access to a session. It does not end the sessions; it just prevents access to them. Clearing the check box will allow a disabled boot to proceed.

· Terminate the ICA client on monitoring connection loss  XE "Terminate the ICA client on monitoring connection loss" : is a legacy command. It will terminate the ICA connection if the connection to the ThinManager Server is lost. This check box relates to the client/ThinManager Server connection and not the client/terminal server connection. It is not used with the current failover method. 

· Reboot the terminal when the ICA connection is lost  XE "Reboot the terminal when the ICA connection is lost"  is a legacy command. When selected, the terminal will reboot each time the ICA connection is lost. This can interfere with failover because failover does not require a reboot. Some network configurations may use this when the DHCP Server is the same machine as the terminal server.

Note: Each of these settings can be changed for individual terminals in the Terminal Properties. 

OK will accept the changes and close the dialog box when selected. 

Cancel will cancel the addition or change of the group when selected.

Help will launch ThinManager Help when selected.

Modifying Groups XE "Modifying Groups" 
Modifying  XE "Modifying"  makes changes to group configuration such as touch screen usage, video resolution, or to designated servers. 

To modify a group either:

· Highlight the group in the ThinManager tree by clicking on the group name or icon and select Edit>Modify from the ThinManager menu bar.

· Right-click on the group icon in the ThinManager tree and select Modify.
· Double-click on a group icon in the ThinManager tree.

The Group Properties window will launch. 

You can modify the group by:

· Changing the server on the Sessions tab.

· Changing a group username and password on the Sessions tab

· Changing the terminal video configuration on the Video tab. 

· Adding or removing modules on the Module tab.

· Changing the DNS and domain settings on the DNS tab.

· Changing the monitoring frequencies on the Monitoring tab.

· Changing the reboot options on the b tab. 

Make the modifications desired and select OK to close the Group Properties box.

Renaming a Group

Renaming  XE "Renaming"  groups is accomplished by either:

· Highlighting the Group and selecting Edit>Rename.
· Right clicking the Group and selecting Rename.
· The same way that files or directories are renamed in Windows Explorer. Single-click twice on the group name. This will draw a box around the name and highlight it. Type in the new group name.
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Renaming a Group

Tip on single clicking XE "Single clicking"  twice: Click once to highlight the name, move the mouse slightly and click again. This will prevent Windows from confusing the two single clicks with a double click.

Deleting a Group  XE "Deleting"  

A group can be deleted from the ThinManager Server by:

· Highlighting the group in the ThinManager tree pane and selecting Edit>Delete from the ThinManager menu bar. 

· Highlighting the group in the ThinManager tree pane pressing the Delete key. 

· Right clicking a group icon in the tree pane of ThinManager and selecting Delete Group. 

When a group is deleted, the option is given to delete all the group’s terminals or to move the terminals under the server without a group.

Rebooting a Group XE "Rebooting" 
A group can be rebooted by: 

· Highlight a group in the tree pane of ThinManager. Select Tools>Reboot Terminals from the ThinManager menu bar. This will reboot all the terminals in the highlighted group. This will reboot all the terminals in all the groups on the server if the server is highlighted when you selected Tools>Reboot Terminals. 

· Right clicking a group icon in the tree pane of ThinManager and selecting Reboot Terminals. This will reboot all the terminals in the group.

Classic Mode of Terminal Configuration XE "Create New Terminal" 
A new terminal can be created with the Create New Terminal Dialog Box. This can be opened by:

· Selecting Edit>Add Terminal from the ThinManager menu bar

· Or right clicking a ThinManager Server or Group in the tree of the ThinManager Server and selecting Add Terminal.

· Turning on a terminal for the first time when no terminals defined in ThinManager 

· Selecting Create New Terminal from the terminal selection list.

The thin client monitor will display the text “Please Wait While Terminal is Defined on Server”. This server is the ThinManager Server specified by the DHCP Boot Server Host Name or Static IP.

[image: image188.png]ACP Network Boot Loader va.5
Copyright 1999-2003 Automation Control Products

Status: Please Wait while Terminal is defined on Server XXXXX





ACP Network Boot Screen - Wait for Definition

The Create New Terminal dialog box will be launched on the ThinManager server.

Note: Use of RDP requires the Wizard Mode for configuration.
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Classic Mode - Create New Terminal 

The terminal configurations include: 

· The Server field  XE "Server field"  This is automatically filled with the name of the ThinManager Server one is creating a terminal on.

· The Name field  XE "Name field"  has a space for the name for the terminal. Type the desired name in this field, using letters, numbers, hyphens (-), and underscores (_) only.

· The Term ID or Terminal Identifier  XE "Identifier" 

 XE "Terminal Identifier"  is a unique number, the MAC address  XE "MAC address"  of the network card of the terminal, that ThinManager inserts into the Term ID field uses to identify the terminal. 

If a terminal is being pre-created in Classic mode, any unique combination numbers can be used as a temporary placeholder if the MAC address is not known. Type the desired name in this field, using letters, numbers, hyphens (-), and underscores (_) only.

Note: The Terminal name is a good temporary Terminal ID. The Wizard mode automatically inserts a Terminal ID and does not require the manual entry of the Term ID.

· The OEM field  XE "OEM field"  has a drop down list of manufacturers who produce ThinManager Ready thin clients. Select the manufacturer if you know it. If not, this will automatically fill with the appropriate model number from the TermCap database when the terminal is connected to the ThinManager Server. See Installing a New TermCap Database
 for details on updating the TermCap database.

· The Model field  XE "Model field"  has a drop-down list of model numbers for ThinManager Ready thin clients. Select the model if you know it. If not, this will automatically fill with the appropriate model number from the TermCap database XE "TermCap Database"  when the terminal is connected to the ThinManager Server. See Installing a New TermCap Database
 for details on updating the TermCap database.

If a terminal is added after another terminal is defined, two additional fields will be shown.

· The Replace Terminal  XE "Replace Terminal" check box allows the terminal to replace an existing off-line terminal by inheriting its configuration.

· The Copy Settings from Terminal  XE "Copy Settings from Terminal"  check box allows the new terminal to copy its settings from the terminal in the drop down list.

Fill in the fields and select OK to launch the Terminal Properties to continue with the terminal configuration.

Terminal Identity XE "Identity" 
The Identity tab of the Terminal Properties dialog box displays identifying parameters of the thin client. 
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Classic Mode - Terminal Identity Tab

· The Name  XE "Name"  field contains the name that was assigned to the terminal in the creation step.

· Terminal ID  XE "Terminal ID"  is the Terminal Identifier. XE "Terminal Identifier"  This field is the MAC address XE "MAC address"  of the ThinManager Ready thin client network card on terminals that have been or is a placeholder if the configuration hasn’t been applied to a terminal.

·  The Group field  XE "Group field"  has a drop down box that allows the terminal to be added to a group. This will apply the group configuration to the terminal.

Note: It is recommended that groups be configured before adding individual terminals. 

· The OEM field  XE "OEM field"  has a drop down list of manufacturers who produce ThinManager Ready thin clients. Select the manufacturer if you know it. If not, this will automatically fill with the appropriate model number from the TermCap database when the terminal is connected to the ThinManager Server. 

· The Model field  XE "Model field"  has a drop-down list of model numbers for ThinManager Ready thin clients. Select the model if you know it. If not, this will automatically fill with the appropriate model number from the TermCap database XE "TermCap Database"  when the terminal is connected to the ThinManager Server. 

· The OEM Model field  XE "OEM Model field"  shows the model number of the terminal, as detected by the ThinManager Server.

· The Video Chipset field  XE "Video Chipset field"  shows the type of the processor chipset of the terminal, as defined by the TermCap database for the make and model.

· The Touch Type field  XE "Touch Type field"  shows the type of touch screen if the terminal is an ThinManager Ready thin client with an integrated touch screen. 

Select the Session tab to continue configuration.

OK will accept the changes and close the dialog box when selected. 

Cancel will cancel the addition or change of the group when selected.

Help will launch ThinManager Help when selected.

Terminal Session

The Session  XE " Session"  tab of the Terminal Properties dialog box is where a terminal is assigned to a Windows Terminal Server using the IP address  XE "IP Address"  of the Windows Terminal Server. 

Note: The Wizard mode uses computer names, but the Classic mode uses IP addresses unless a DNS is used.

When a terminal is assigned to a group, it is assigned the group settings. Any of these can be changed or modified by unselecting the Use Group check box and making a change to the desired value. 
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Classic Mode - Terminal Session Tab

Terminals that are not members of a group will not have the Use Group check boxes on the tabs and must have all of its parameters configured.
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Classic Mode - Terminal Session Tab, Non-Group Member

Select the Server radio button and enter the IP address  XE "IP Address"  (or DNS names if DNS is used) of the desired Windows Terminal Server that the terminal is to connect to. One instance of ThinManager can manage the connection of thin clients to a number of terminal servers by assigning different groups or terminals to different terminal servers.

· Failover XE "Failover"  is enabled by listing the IP addresses of multiple terminal servers, in order of preference, separated by semi-colons (spaces are optional). 

Note: The Server field on the Session tab is the most important field in the Classic mode. Without correct data the terminal will not connect to the Terminal Server.

· Published Application  XE "Published Application"  is an advanced function for Citrix MetaFrame users. Selecting the Published Application radio button and entering the name of a published application will allow the terminal to use Citrix Published Applications.

Note: The Published Application name must be continuous. It cannot have a space in its name.

· The Username field  XE "Username field"  allows a Windows NT/2000 User Profile  XE "User Profile"  to be assigned to provide an automatic logon  XE "Automatic Logon"  at startup. Leaving this field blank will force a user to logon  XE "Logon"  at each start. 

· The Password  XE "Password"  field submits the password for the User Profile in the Username field to allow automatic login at startup.

· The Domain  XE "Domain"  field assigns the terminal to a Windows domain.

· The Initial Program  XE "Initial Program"  field is a security enhancement. If the path to an executable file is entered into the Initial Program field, only the specific program will launch upon boot. If the initial program is closed, the terminal will end the connection to the terminal server and reconnect, with the initial program running. This tool is useful for enforcing an operation of a single program, such as an HMI  XE "HMI"  or SCADA  XE "SCADA"  program. 

To start an initial program that would allow closure and or the running of other programs, use the Startup folder in Windows.

· The ICA Browser  XE "ICA Browser"  field is a back-up function for Citrix MetaFrame  XE "MetaFrame" 

 XE "Citrix MetaFrame"  users. If the terminal is unable to browse the ICA network (find the server), the ICA Browser field can specify a server IP address. This might be used with server farms  XE "Server Farms"  or published applications (which require Citrix MetaFrame)  XE "Published Application" . See your Citrix documentation for help with server farms and published applications.

· The Encryption  XE "Encryption"  drop-down box allows Citrix MetaFrame users to configure SecureICA encryption.

Select the Video tab to continue configuration.

OK will accept the changes and close the dialog box when selected. 

Cancel will cancel the addition or change of the group when selected.

Help will launch ThinManager Help when selected.

Terminal Video XE "Terminal Video" 
The Video tab of the Terminal Properties dialog box contains the settings for the video properties. The Use Group Video Settings check box assigns the group properties to the terminal. Terminals that are not members of a group will not have this check box.
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Classic Mode - Terminal Video Tab

· Video Mode  XE "Video Mode"  is a drop-down box that allows you to select a video resolution for the group. Terminals use the 256-color depth by default. To use a higher color depth use Citrix MetaFrame 1.8 Feature Release 1, or greater, or RDP with Windows 2003 Terminal Server.

· Custom Video Modelines  XE "Modelines" 

 XE "Video Modelines"  is a field for scripts that provide support for certain non-standard monitors. If the standard video modelines do not work, please contact your technical support for assistance with this feature.

Note: A terminal that “blacks out” upon connection to the terminal server usually needs the refresh rate lowered.

Select the Modules tab to continue configuration.

OK will accept the changes and close the dialog box when selected. 

Cancel will cancel the addition or change of the group when selected.

Help will launch ThinManager Help when selected.

Terminal Modules

The Modules  XE "Modules"  tab of the Terminal Properties dialog box contains the settings for adding modules. Modules are software components that can be added to the firmware to increase the functionality of the terminal. Modules include touch screen drivers, sound drivers, and special device drivers. Some modules are included with ThinManager and are registered automatically during ThinManager installation. Other modules are obtained separately from Automation Control Products and need to be installed.

Attaching a Module to a Terminal XE "Attaching a Module" 
Modules are added from the Modules tab of the Terminal Properties.
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Classic Mode - Terminal Module Tab

To attach a module, select the Add button on the Module tab. This will launch an Attach Module dialog box.
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Classic Mode - Terminal Modules Tab, Attach Module 

The Attach Module dialog box shows all the installed modules. Highlight the desired module and select OK. The module will be added to the list on the module tab and will load on the next terminal reboot.

Group Module Deactivation XE "Group Module Deactivation" 
A terminal that is assigned to a group with modules will display a Use Group Module check box selected by default and will load the group modules. To stop the terminal from using the group modules, uncheck the Use Group Module check box. This will put a red icon over the group icon to show that the group setting is no longer used.
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Classic Mode - Group Module Deactivation

This figure shows a Group module that is deactivated, a group module in use, and an individual terminal module. More detail can be found in Module Overview
.

Select the DNS tab to continue configuration.

OK will accept the changes and close the dialog box when selected. 

Cancel will cancel the addition or change of the group when selected.

Help will launch ThinManager Help when selected.

Terminal DNS Properties XE "DNS Properties" 
The DNS tab of the Terminal Properties dialog box contains settings for using a Domain Name System (DNS) server. This will allow the use of DNS names to identify computers.
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Classic Mode - Terminal DNS Tab

· DNS Server  XE "DNS Server"  is a field for the IP address of a DNS server.

· Domain  XE "Domain"  is a field for the DNS domain name.

· Search Domain  XE "Search Domain"  will add the contents of the field as a prefix to any DNS searches. 

· The Read DNS settings from server  XE "Read DNS settings from server"  button will load the DNS Server settings from the ThinManager server into the DNS Server field.

Select the Monitoring tab to continue configuration.

OK will accept the changes and close the dialog box when selected. 

Cancel will cancel the addition or change of the group when selected.

Help will launch ThinManager Help when selected.

Terminal Monitoring

The Monitoring  XE "Monitoring"  tab of the Terminal Properties dialog box contains parameters related to Failover. A ThinManager terminal monitors the availability of its terminal server, and will disconnect the session if the server is down. The terminal will then connect to the next terminal server in the Server field of the Session tab. 

These parameters are configurable.
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Classic Mode - Terminal Monitoring Tab

Note: The Wizard Mode has preset configurations of Fast, Medium, and Slow, in addition to custom settings. The Classic Mode offers uses custom settings.

· Monitor Interval XE "Monitor Interval"  sets the frequency that the terminal checks the terminal server to see if it is connected. 

Note: Setting this value low will provide a quick detection of server failure. Setting it too low may end the Client Communication connection due to high network traffic or a short network interruption instead of a server failure. 

· Monitor Timeout  XE "Monitor Timeout"  sets the amount of time that the terminal will wait until retrying the server connection.

· Monitor Retry  XE "Monitor Retry"  sets the number of times that the terminal will retry the terminal server before disconnecting the connection.
· The Enforce Primary  XE "Enforce Primary"  field affects the return of a terminal back to its originally assigned terminal server. If Yes is selected, a terminal that has failed over to a secondary server will reconnect to the primary server once it returns online. If No is selected, a terminal that has failed over to a secondary server will remain connected to the secondary server until a terminal reboot, even when the primary server returns online.
· Primary Up Delay  XE "Primary Up Delay"  is the number of seconds the terminal will wait to reconnect to the primary after it has detected it. This is included because the terminal can contact the primary terminal server and detect it before the primary is available for session connections.
· The # secs field is the interval of time between when the primary terminal server returns online and when terminals will switch back to it with Enforce Primary. Its value equal to the Monitor Interval times the Primary Up Delay. 
· The ThinServer  XE "ThinServer"  field allows affects the monitoring lights on multiple ThinManager Servers. Any ThinManager Server in this field will monitor the status of the terminals to update the monitoring lights on the ThinManager tree. Enter the IP addresses (or DNS names if DNS is used) of the ThinManager Servers in this field, in order of preference, and separated by semi-colons. 
Select the Other tab to continue configuration.

OK will accept the changes and close the dialog box when selected. 

Cancel will cancel the addition or change of the group when selected.

Help will launch ThinManager Help when selected.

Other Terminal Properties

The Other  XE "Other Properties"  tab of the Terminal Properties dialog box contains the settings for miscellaneous settings. The Use Group  XE "Use Group"  check boxes assign the group properties to the terminal if the terminal is the member of a group. They are checked by default. To change a setting, unselect a check box and make your changes. Terminals that are not a member of a group will not have the Use Group check box.
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Classic Mode - Terminal Other Tab

· Allow this terminal to be replaced if offline  XE "Allow this terminal to be replaced if offline"  allows a terminal to be replaced. Un-selecting this will prevent a terminal from appearing in the terminal selection list during new terminal addition. 

Note: There is a global Enable Replacement on the Server Properties dialog box

· Disable this terminal. On bootup, it will display a message and halt  XE "Disable this terminal" will disable a terminal if selected. This is a quick way to disable access to a terminal. Select this check box, and then reboot the terminal. This will deny access to the terminal session. It does not end the session on the terminal server; it just prevents access to it. Clearing the check box will allow a disabled boot to proceed.

· Terminate the ICA client on monitoring connection loss  XE "Terminate the ICA client on monitoring connection loss" : is a legacy command. It will terminate the ICA connection if the connection to ThinServer is lost. This check box relates to the client/ThinServer connection and not the client/terminal server connection. It is not used with the current failover method. 

· Reboot the terminal when the ICA connection is lost  XE "Reboot the terminal when the ICA connection is lost"  is a legacy command. When selected, the terminal will reboot each time the ICA connection is lost. This can interfere with failover because failover does not require a reboot. Some network configurations may use this when the DHCP Server is the same machine as the terminal server.

OK will accept the changes and close the dialog box when selected. 

Cancel will cancel the addition or change of the group when selected.

Help will launch ThinManager Help when selected.

Terminal Server Groups

Terminal Server Group Overview

Terminal Server Groups are collections of Terminal Servers. A ThinManager Ready thin client can connect to one or more terminal servers that are members of a Terminal Server Group. Instead of specifying individual terminal server that a terminal will connect to a terminal server defined in a terminal server group. The specific terminal server that the terminal connects to is based on the Terminal Server Group configuration and options.

· A standard Terminal Server Group has the terminal servers listed in a pre-defined order. The terminal connects to the first available member of the group.

· The SmartSession option of Terminal Services Groups provides load balancing by using CPU availability, memory, and the number of sessions on the member terminal servers to determine the resource availability on member terminal servers. A ThinManager Ready thin client connects to the terminal server in the Terminal Server Group with the most available resources.

· The Instant Failover option allows a terminal to connect to two terminal servers within a Terminal Server Group. The terminal will have an active session on two terminal servers but will only display one session. If the first terminal server fails, the session of the second terminal server is immediately displayed, eliminating any downtown due to terminal server failure.

· The AppLink option provides the Initial Program function to members of a Terminal Server Group. When specifying the Initial Program function, a program is started instead of the desktop. Closing the program will terminate the connection.

· MultiSession is a terminal configuration that allows a ThinManager Ready thin client to connect to multiple terminal servers from multiple Terminal Server Groups. The user can switch between groups using an on-screen menu or hot keys. These groups may be standard Terminal Server Groups, Terminal Server Groups with SmartSession, AppLink, and/or Terminal Server Groups with Instant Failover.

These Terminal Server Group options can be combined on the same Terminal Server Group, for example a Terminal Server Group could use SmartSession to choose the server connection order, Instant Failover to maintain a backup, while using AppLink to limit the terminal to a single application. Additionally, a terminal server may be a member of several Terminal Server Groups.

[image: image200.png]Ed Terminal Configuration

Terminal Server Specifiation

Selectthe method for choosing teminal servers availsbe for ths

terminl,

[x]
ACR
=2
-

(~Mathod o Teminal Servr Seection
& 3% Taimina Saver G

© Select Individual Terminal Servers

- MulliSession

I~ Enable MuliSession

<ok =

Cancel

Help





Terminal Configuration Wizard - Terminal Server Specification Page

A terminal will use Terminal Server Groups when the Use Terminal Server Groups radio button on the Terminal Server Specification page of the Terminal Configuration Wizard is selected.

SmartSession  XE "SmartSession" 
SmartSession is a load balancing strategy that allows terminals to connect to the member of a terminal server group that has the most available resources. ThinManager monitors the CPU load, memory availability, and number of sessions on the terminal servers and ranks them by availability. When a ThinManager Ready thin client connects to a member of a terminal server group with SmartSession, the terminal connects to the terminal server with the lightest load.
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SmartSession

Each member terminal server needs SmartSession configured in the Terminal Server List Wizard. See the Terminal Server List Wizard
 for details.
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Terminal Server Wizard – Terminal Server Capabilities

Selecting the Available for Smart Session Groups checkbox on the Terminal Server Capabilities page of the Terminal Server List Wizard allows the Terminal Server to become a member of a terminal server group using SmartSession. 

Note: MultiSession can also be enabled on this page.
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Terminal Server List Wizard - SmartSession Configuration

The SmartSession Configuration XE "SmartSession Configuration"  page allows the configuration of the three parameters that ThinManager uses to determine resource availability. ThinManager determines the availability of a terminal server by measuring:

· CPU Utilization

· Memory Utilization

· Number of Sessions

 ThinManager uses these values to rank the SmartSession server loads, with a lower number representing a smaller load and greater resources.

 Each parameter has two settings that set the range that ThinManager uses. 

· The Minimum field is the value that ThinManager will consider the parameter to be unused. 

· The Maximum field is the value that ThinManager will consider a parameter exceeded and unavailable.

Once ThinManager has polled the terminal servers and established the availability of their resources, ThinManager passes the Server Ranking XE "Server Ranking"  to the ThinManager Ready thin clients for its connection instructions.
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ThinManager Interface – Server Rank Tab

The Server Rankings are displayed on the Server Rank tab when a Terminal Server Group is highlighted in the ThinManager tree. In the example above a ThinManager Ready thin client would connect to Tan because it has the lowest load.

Instant Failover with Terminal Server Groups

Terminal Server Groups can provide Instant Failover without using the Instant Failover Module. By selecting the Instant Failover checkbox on the Group Option page of the Terminal Server Group Wizard, a terminal will connect to a session on two terminal servers. Both sessions are active but only one is displayed. If the first terminal server fails, the second session is immediately displayed, eliminating any downtown due to terminal server failure.

Instant Failover works within a Terminal Server Group, not between Terminal Server Groups. 

In a standard terminal server group, the terminal will use the first listed terminal server as the primary session and will use the second listed terminal server as the secondary session.

In a terminal server group with SmartSession, the primary session will be on the server with the lightest load and the backup session will be on the terminal server with the second lightest load.

The Instant Failover function requires an Instant Failover license for each terminal that uses it. 
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Terminal Server Group Wizard – Group Options

Instant Failover is a Group Option for Terminal Server Groups.
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Terminal Server Group Wizard – Terminal Server Group Options

It is possible to switch between the sessions using Instant Failover on the terminal. Check the Enable Instant Failover Hotkeys checkbox on the Terminal Server Group Options page of the Terminal Server Group Configuration Wizard to configure the hot keys.

MultiSession  XE "MultiSession " 
MultiSession allows a user to login to multiple terminal groups and switch between the various sessions. The user will have one session for each group that they have selected. This lets a user have access to several terminal servers through terminal server groups. These terminal server groups can be standard groups or have combinations of SmartSession, AppLink, and Instant Failover.

Note: Users can cut and paste XE "Cut and Paste "  between sessions even when they are on different terminal servers when using RDP XE "RDP " .
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Sample MultiSession Groups

MultiSession is useful in large installations with many servers. Instead of installing every application on every server, individual terminal servers or groups of terminal servers can be dedicated to a single application, a small collection, or a suite. This simplifies maintenance, upgrading, and security, while limiting the number of conflicts between programs.

Terminals can use MultiSession to access the Terminal Server Groups that they need. The groups can be standard terminal server groups, or combinations of the various options like SmartSession, Instant Failover, and AppLink.

Enabling MultiSession is a three-step process.

· First, the Terminal Servers need to be configured for MultiSession in the Terminal Server List Wizard.
See Terminal Server List Wizard
 for details.

· Second, the Terminal Server Groups need to be configured for MultiSession in the Terminal Server Group List Wizard.
See Terminal Server Group List Wizard
 for details.

· Third, the Group or Terminal needs to be configured to use MultiSession on the Terminal Server Specification page of the Terminal Configuration Wizard.
See Terminal Configuration Wizard
 for details.
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MultiSession Not Enabled Warning

If two Terminal Server Groups are selected without the Enable MultiSession  XE "MultiSession not Enabled" checkbox selected in the Terminal Configuration Wizard, a message will be displayed warning that the Enable MultiSession checkbox needs to be checked to allow the MultiSession.

Note: Users can switch between sessions using an onscreen Group Selector menu or hotkeys XE "Hotkey " . 
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MultiSession Group Selector

The Group Selector shows the Terminal Server Group that the terminal is currently displaying. When activated by the mouse it shows a dropdown list of available Terminal Server Groups.

Hotkeys can be used to switch between the terminal server groups if the Enable Group Hotkeys checkbox is selected on the Terminal Server Group Options page of the Terminal Configuration wizard. 
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Terminal Server Configuration – Terminal Server Group Options

The choice of the hot keys used can be set by selecting the Change Hotkeys button to launch the Select Hotkeys window.
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Terminal Configuration Wizard - Select Hotkeys Page

The default hotkeys are CTRL+Page Down and CTRL+Page Up. These can be changed in the dropdown box.

AppLink XE "AppLink" 
AppLink provides the Initial Program XE "Initial Program"  functionality to a Terminal Server Group. If AppLink is enabled, the path to an Initial Program is entered into the Terminal Server Group Wizard. This program will be the only program to run in that session. See Initial Program
 for details.

AppLink is configured during the Terminal Server Group Wizard. See Terminal Server Group Wizard
 for details.
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Terminal Server Group Wizard – Group Options

Selecting the Application Link Group XE "Application Link Group"  checkbox will make the Terminal Server Group an AppLink Group XE "AppLink Group" .

Selecting Next will allow the designation of the Initial Program.
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Terminal Server Group Wizard – Linked Application

The Linked Application page of the Terminal Server Group Wizard has an Enter the path to the Linked Application field. Fill in the field for the Initial Program  XE "Initial Program" with the valid path to the desired program. This may require the use of quotation marks if there are spaces in the path name. 

The AppLink Terminal Server Group may be a single terminal server or may contain many terminal servers. These may be Standard Groups, SmartSession Groups, or MultiSession Groups.

Note: If the AppLink Group contains several terminal servers, the path must be valid for all members of the Terminal Server Group. If different members of the AppLink group have different paths to the desired program, write a batch file to open the program.

AppLink and MultiSession 

MultiSession receives a major increase in functionality in combination with AppLink. Since AppLink adds the Initial Program XE "Initial Program"  functionality to Terminal Server Groups, a terminal server group with AppLink will display an application instead of a desktop. The user can switch between applications as they switch between AppLink sessions in the different Terminal Server Groups. This allows terminal servers to be set up and maintained by application instead of having every application installed on every terminal server.
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AppLink Servers

AppLink MultiSession is configured in the Terminal Server Group Wizard.
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Terminal Server Group Wizard – Group Options

Select the Make group available for MultiSession configurations checkbox and the Application Link Group checkbox to make the Terminal Server Group an AppLink MultiSession Group.
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Terminal Server Group Wizard – Linked Application

The Linked Application page of the Terminal Server Group Wizard has an Enter the path to the Linked Application field. Fill in the field for the Initial Program  XE "Initial Program" with the valid path to the desired program. This may require the use of quotation marks if there are spaces in the path name.

The AppLink MultiSession Terminal Server Group may be a single terminal server or may contain many terminal servers. These can be Standard Groups or SmartSession Groups.

Note: If the AppLink Group contains several terminal servers, the path must be valid for all members of the Terminal Server Group. If different members of the AppLink group have different paths to the desired program, write a batch file to open the program.
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AppLink MultiSession Terminal Screen

The terminal will display a Group Selector XE "Group Selector"  menu at the top edge of the session when it boots. The Group Selector lists the Terminal Server Group that the terminal is currently displaying. When activated by the mouse it shows a dropdown list of available AppLink Terminal Server Groups.
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Group Selector

The user can switch between the AppLink Terminal Server Groups by using an on-screen Group Selector  XE "Group Selector" or by using hotkeys.  XE "Hotkey" 
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Terminal Server Configuration – Terminal Server Group Options

The Show Group Selector on Terminal  XE "Show Group Selector" checkbox will display the mouse activated Group Selector at the top edge of the terminal screen. Hotkeys can be used if the Enable Group Hotkeys checkbox is selected on the Terminal Server Group Options page of the Terminal Configuration Wizard. Both methods can be used, but at least one method must be available.

Additional ThinManager Functionality

Module Overview

Modules XE "Modules"  are software components that can be loaded to increase the functionality of the terminal. Modules include touch screen drivers, sound drivers, and special device drivers. Some modules are included with ThinManager and are registered automatically during ThinManager installation. Other modules are obtained separately from Automation Control Products and need to be installed.

Note: “Installing a module” refers to the registration of the module with the ThinManager Server, while “Adding a module” refers to attaching the module to a particular group or terminal.

This section includes:

· A list of available Modules. 

· Instructions on adding and using Modules.

· Details on specific modules. 

Module List

Touch Screen Modules  XE "Touch Screen"   XE "Touch Screen Modules" 
ThinManager supports a wide range ot touch screen controllers. The current list includes:

· Arista ARP-16XXXAP-ACP Touch Screen Driver

· Carroll Touch Touch Screen XE "Touch Screen"  Driver

· Contec Touch Screen Driver

· DMC Touch Screen Driver

· Dynapro Touch Screen Driver

· Elographics Touch Screen Driver

· Gunze AHL Touch Screen Driver

· MicroTouch Touch Screen Driver

· PenMount Touch Screen Driver

· Ronics Touch Screen Driver


· Touch Control Touch Screen Driver

· Xycom 33XX Touch Screen Driver

Note: This list of modules is subject to change, with more modules being added as needed.

Some, but not all, touch screen modules have parameters that can be modified. These may include:

· Controller Type - Model of touch screen controller.

· COM Port - The serial port that the touch screen is connected to.

· Baud Rate - The speed used for communication between the terminal and the touch screen.

· Double Touch Area - The size of the area that a second touch will register as a double touch.

· Double Touch Time - The amount of time between touches that qualifies as a double touch.

· Touch De-Bounce Timeout - a time interval used to prevent a single touch from being registered as multiple touches.

· Calibration (entered automatically) - Set automatically by machine. These are the calibration values.

· Orientation (entered automatically) - Set automatically by machine. Used at the direction of Tech Support in error correction.

· Swap XY Coordinates – If X and Y are reversed, this setting will correct the orientation.

Sound Modules  XE "Sound Modules" 
The use of sound from an ACP Enabled thin client requires three things, ThinManager Ready hardware with a sound connection, the appropriate sound module, and either a Windows 2003 Server terminal server or MetaFrame. 

Some thin clients, like the Advantech PCM-5820, may require that a sound harness be plugged into the motherboard.

Current sound modules include: 

· ACP DC_30_100 Sound Module

· ACP DC_40_100 Sound Module

· ACP TC3500 Sound Module

· Advantech PCM-5820 Sound XE "Sound"  Module

· Advantech PCM-9372 Sound Module

· Allen-Bradley VersaView 200R Sound Module

· Arista 5824-ACP Sound Module

· TeleVideo TC7X30 Sound Module


· Xycom XA1300 Sound Module

These Sound modules can be set to use Low, Medium, or High bandwidth when using MetaFrame.

Note: This list of modules is subject to change, with more modules being added as needed.

Mouse Modules

Mouse Configuration Module – Allows USB or PS/2 mice to be configured. Allows the use of two mice. See Mouse Modules
 for details.
PS/2 Mouse Module – Allows the configuration of a PS/2 mouse to include wheel mouse capabilities. See Mouse Modules
 for details.

Serial Mouse Module  - Allows the usage of a serial mouse instead of a PS/2 mouse. See Mouse Modules
 for details.

Share Keyboard and Mouse Module – Allows multiple ThinManager Ready thin clients to be linked with a single mouse and keyboard. This is particularly useful in control rooms. See Share Keyboard and Mouse Module
 for details. 

Screen Saver Module

Screen Saver Module  XE "Screen Saver" is a module that loads a screen saver on the client. The screen saver will run when the terminal is idle to protect the monitor. Since the screen saver runs on the client, it saves CPU on the terminal server. 
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Screen Saver on Thin Client

The Screen Saver Module configuration includes:

· Screen Saver - the graphic that is displayed when the screen saver is active.

· Wait Time in Minutes - the length of time that the terminal needs to be idle before the screen saver starts.

· Use Disable Time Period - the screen saver can be set to be disabled, or unavailable during a time block. This could be used to prevent the screen saver from running during normal business hours.

· Disable Start Time (0-23) - This sets the start of the disabled time block. 0 is Midnight and 23 is 11:00 p.m.

· Disable End Time (0-23) - This sets the end of the disabled time block. 0 is Midnight and 23 is 11:00 p.m.

· Force Off when Start Hour is Reached - if set to Yes, this will turn the screen saver off when the Disable End Time is reached.

Additional Modules

Add Serial Port XE "Add Serial Port"   - Configures additional serial ports if additional serial port hardware is added.

· Configuration includes Port Number, Port Address, IRQ, and UART 

Disk On Chip Update XE "Disk On Chip Update"  - Allows Disk-on-Chip and Compact Flash embedded storage clients to have their firmware updated.

· Configuration includes Confirm at Terminal XE "Confirm at Terminal" . This allows an automatic firmware re-flashing when set to NO. If set to Yes, the terminal receives notification of the firmware update. 

See Disk-On-Chip
 for details.

High Speed Serial Driver XE "High Speed Serial Driver"  - Allows the transfer of serial data from an ACP Enabled thin client's serial port to the terminal server.

· Configuration is done with the ACP COM Redirection Program. XE "COM Redirection Program" 
See High Speed Serial Driver
 for details.

Instant Failover XE "Instant Failover"  Module - Allows the ACP Enabled thin client to log into two terminal servers at once for a hot backup during failover. 

· Configuration includes:

·  Hot Key Session Switching - allows the toggling between the two sessions. 

· Hot Key Combination - allows the choice of hot key combinations.

Key Block Module - Traps client keystroke combinations for security.

· Configuration allows blocking of CTL, CTL+ALT+DEL, CTL+ESC, ALT, ALT+F4, ALT+F, ALT+TAB, the Windows key, and Menu key. 

See Key Block Module
 for details.

Local Printer Module – Allows printing to a printer attached to a parallel port on a ThinManager Ready thin client.

· Configuration includes Local Print Driver name. 

See Local Print Module
 for details.

RDP Serial Port Redirection Module – Allows the usage of serial ports when using RDP. 

See RDP Serial Port Redirection Module
 for details.

USB Memory Card Reader Module – Allows USB ports on ThinManager Ready thin clients to access USB memory card readers or USB memory sticks when logged into a Windows 2003 terminal server or MetaFrame server. 

See USB Memory Card Reader Module
 for details.
 X Term Module XE "X Term Module"  - Allows and ACP Enabled thin client to boot as an X-terminal for connection to Unix and Linux servers.

· Configuration includes the XDM Host IP address XE "XDM Host IP address" 
See X Terminal Module
 for details.

Advanced User Module

Citrix ICA UseAlternateAddress Module XE "Citrix ICA UseAlternateAddress Module"  - Used by advance Citrix users.

· Configuration includes UseAlternate Address, Browser Protocol, and HttpBrowser Addresses.


Installing a Module XE "Installing a Module"   XE "Modules" 
Open the Modules window by selecting Tools>Modules from the ThinManager menu bar. 
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Install Module Window

This launched the Module window that shows all of the modules installed on the ThinManager Server. 

To install additional modules select the Install Module button. This will launch a file browser window.

Selecting the Remove Module from All Terminals  XE "Remove Module from All Terminals"  button will remove the highlighted module from all terminals. It does not uninstall the module from the ThinManager Server; it just removes its use by all groups and terminals.

Selecting the Done button will close the Module window.
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Module File Browser Window

If the Install Module button is selected it will launch a file browser window. Select the new module file and select Open. This will install the module.

Changing Module Parameters XE "Module Parameters" 
The parameters  XE "Module Parameters"  of a module can be individually configured on a module assigned to a Group or Terminal. Open the Terminal Property by double-clicking the desired terminal in the ThinManager tree. In Wizard mode click the Next button until the Module Selection window is displayed. 
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Terminal Module Selection - Wizard Mode

There are four icons that can be used for modules in the Terminal Properties.

· [image: image224.png]


 Two Monitors represents properties assigned by the Group.

· [image: image225.png]


 Two Monitors and a Yellow Plus Sign represent properties that are changed on the terminal from the Group settings.

· [image: image226.png]=)



 Two Monitors and a Red Slashed Circle represent a terminal that isn’t using an assigned Group module. The Use Modules from Group checkbox was un-selected.

· No icon indicates that the module was added to the terminal and not the group.

Select the Module to change and select the Configure button. A Module Properties dialog box will be displayed.
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Module Properties Window

Select the parameter to configure. If configuring a Group Module, uncheck the Use Group Value check box.

The Value field  XE "Value field"  will become active to allow a new value to be added, or a drop-down box will appear with values to choose from. Change the value and select the Set button to apply the parameter change.

Note: The Set button must be selected to apply the change.

Select the Done button to close the window.
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Module Icons in ThinManager

The status of the modules are displayed on the Module tab of the Details pane of ThinManager.

Module Loading Order XE "Loading Order" 

 XE "Module Loading Order" 
Highlighting a module and selecting the Move Up or Move Down button can change the order that the modules load.
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Module Loading Order

The loading order of modules rarely needs to be adjusted.

Disk-On-Chip 

Disk-On-Chip is used in this manual to refer to a number of firmware storage options, including compact flash XE "Compact Flash"  and disk-on-chip. 

Disk-On-Chip Configuration

A disk-on-chip terminal loads the firmware locally before connecting to the ThinManager server. The disk-on-chip terminals have a setup program that allows configuration of the connection. Enter the program by selecting any key when Select any key to configure is displayed during the boot process. A setup screen will be displayed.  XE "Disk-On-Chip" 
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Disk-On-Chip Configuration Screen

The IP Addressing method is set to DHCP by default. To change a value, navigate with arrow keys to the desired property. Pressing the Enter key will allow the input and acceptance of new values. The changes may be saved or discarded before the boot process is resumed.

Updating Disk-On-Chip 

ACP ThinManager has the ability to update the firmware on the disk-on-chip to keep the firmware current. Firmware updates for the disk-on-chip are done through the Disk-On-Chip Update module.

The Disk-On-Chip Update module, when installed on a ThinManager Ready thin client with disk-on-chip hardware, will compare the firmware on the disk-on-chip with the ThinManager server firmware when it connects to a ThinManager server. If the ThinManager firmware is different, it will download the ThinManager server firmware and update the disk-on-chip on the terminal. 

The ability to update disk-on-chip terminals eliminates the need to send the terminal back to the manufacturer to update the firmware.

Note: The firmware download can vary, depending on the bandwidth of the connection, and the size of the firmware update. 
It is recommended that updates be done over a wired LAN instead of over a wireless connection, when possible.

Disk-On-Chip Update Module

The Disk-On-Chip Update module installs with ThinManager. This module has one configurable parameter, Confirm at Terminal. If Confirm at Terminal XE "Confirm at Terminal"  is set to Yes, then the operator will be prompted to choose between immediately updating firmware or waiting until the next boot up. If Confirm at Terminal is set to No, the firmware download will take place immediately.

Note: The module will download firmware when it detects a different firmware. Since this will only happen at the first reboot after updating the ThinManager firmware, it is safe to leave this module added to the disk-on-chip terminals permanently. It does not need to be added and removed each time the firmware is updated. However, since it will update when the firmware is different, it will try to update the firmware if you connect it to a ThinManager server with older firmware.

Note: It is recommended that instead of updating over a wireless connection, you connect terminals with Ethernet cable to update the disk-on-chip.

To set the Confirm at Terminal parameter, highlight the disk-on-chip update module and select the Configure… button. This will launch the Module Properties window.
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Disk-On-Chip Module Properties

Highlight the Confirm at Terminal parameter. The Value field will change to a drop-down box containing Yes and No. Select the desired value and select Done.

Disk-On-Chip Update Program

Once the new firmware has downloaded, an update program will run on the disk-on-chip terminal to rewrite the new firmware to the disk-on-chip. The program will display a warning stating that the terminal must not be reset or powered off during the process, usually around 30 seconds. Ignoring the warning can corrupt the disk-on-chip, so it is important to leave the terminal alone for that period of time. 

Note: Heed the warning. The terminal must not be reset or powered off during the brief period that the update program is writing the firmware on the disk-on-chip. 

Initial Program

The Initial Program field on the Login Information page loads a program instead of the desktop in the terminal session.
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Initial Program

Normally a session loads explorer.exe when it starts, launching the desktop. Other programs can be launched from within this shell. 

If a program is set as the initial program, it is the only program that will launch. This provides a level of security and control because that program is the only program that will run in that session. If the Initial Program is closed on the terminal, the session on the Terminal Server will close and the ThinManager Ready Thin Client will reconnect to the Terminal Server and re-launch the Initial Program. This effectively makes the Initial Program the only program.
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Terminal Server Group Wizard – Linked Application Page

In Terminal Server Groups using the AppLink option, this Initial Program functionality is applied to each terminal server. Each group will have a single program that will launch. Closing it will kill the session and force a reconnect with the initial program running again.

Note: When using the Initial Program with failover, the path must be identical on all terminal servers.

Note: If the user launches explorer.exe, the initial program can be closed and other program run. The Key Block module can help close this loophole by preventing launching Task Manager with the CTL+ALT+DEL keys or launching the Start Menu with the Run command with CTL+ESC.

Failover  XE "Failover" 
Server crashes of any kind in any network or system can have devastating effects on productivity and data management. In the distributed computing world users may still be able to work on local applications but lose access to data. In a terminal server installation all the terminals rely on the terminal server for processing power. Failure of the terminal server leads to the failure of all the thin clients.

ACP ThinManager (version 2.3 and later) has a failover capability built into it that allows terminals to connect to a secondary terminal server if the terminal server that they are logged into fails. This will lessen the effect of server crashes on the terminal server network. The terminals can detect the server crash, drop the connection to it, and connect to a secondary server in seconds. 

To initiate ACP ThinManager Failover protection, four steps are needed.

· Multiple Servers: The first step is to have multiple terminal servers, with a Client Communication Protocol and appropriate licenses added.

· Sufficient Memory: The second step is to have sufficient memory capacity on the servers to accommodate the addition of terminals during failover. If you do not plan for the extra capacity, the servers can be taxed with the addition of the new terminals.

· User Permissions: Each terminal server needs the appropriate Windows NT/2000 user profiles and permissions. The terminals will not log into a secondary session unless it has a user profile on that server.

· Multiple Terminal Servers: The terminal needs be able to connect to multiple terminal servers. When using individual terminal servers, list multiple terminal servers in the Terminal Server Selection page of the Terminal Configuration Wizard. When using Terminal Server Groups, use multiple terminal servers in the groups.
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ACP Thin Client Network with Failover

ACP ThinManager allows the use of several terminal servers, defined as the primary and as backups. If the primary terminal server fails, the ThinManager Ready thin client will detect the server failure and will initiate a new session on a backup server. This allows the operator to continue their work and minimize the effect of a server failure.

Instant Failover XE " Instant Failover" 
The Instant Failover Module XE "Instant Failover Module"  allows a terminal to connect to a session on two terminal servers. Both sessions are active but only one is displayed. If the first terminal server fails, the second session is immediately displayed, eliminating any downtown due to terminal server failure.

The Instant Failover module is used if the terminal is connecting to individual terminal servers. If Terminal Server Groups are being used, Instant Failover is a Terminal Server Group option. Instant Failover works within a Terminal Server Group, not between Terminal Server Groups.

The Instant Failover function requires an Instant Failover license for each terminal that uses it.
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Instant Failover – Part 1

When the ThinManager Ready thin clients with the Instant Failover module boot, they connect to both servers, login, and start sessions.
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Instant Failover – Part 2

The ThinManager Ready thin client cascades both sessions, with the primary in front. You cannot see the secondary session as it is hidden in back.

There is an option that allows one to switch between sessions with a hot key. 

If using the Instant Failover module, this is configured in the module properties.
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Instant Failover Module Properties

If the Hot Key Session Switching  XE "Hotkey"  parameter is set to Enabled, the hot key combination will allow the toggling between sessions. The hot key is defaulted to CTRL+F9, but can be assigned to any function key.
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Terminal Server Group Options - Instant Failover Hotkey Configuration

If using the Instant Failover option in Terminal Server Groups, the Enable Instant Failover Hotkeys checkbox on the Terminal Server Group Options allows the switching between sessions. 
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Instant Failover – Part 2

If the primary server fails, the thin client-monitoring program will detect its failure. The thin client will then switch the focus of the window, showing the secondary session. This session is already initialized so the user is able to proceed at once.

If the Enforce Primary feature on the Monitoring tab is set to Yes, the thin client will switch back to the primary once it is back online.

Key Block Module

The Key Block XE "Key Block"  module traps certain keystrokes and prevents them from being sent to the terminal server for processing.
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Key Block Module

The key combinations to be blocked can be configured by in the Module Properties. To launch this, highlight the module on the Module Selection page and select the Configure button. A Module Properties dialog box will be displayed. Select the parameter to change in the Module Properties window, select the Value in the dropdown box and click the Set button.

The key combinations that have a value of YES will be blocked from reaching the terminal server.

Local Print Module

The Local Print Module simplifies printing through the parallel port on ThinManager Ready thin clients. 

There are three steps:

· Install the print driver on the terminal servers that the client will connect to.

· Add the Local Print Module to the ThinManager Ready thin client as described in the Module Overview
.

· Configure the Print Driver Name parameter in the module to contain the print driver’s name.
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Local Print Module Properties

The Local Print module works when the name of the print driver is entered in the Value field for the Printer Driver Name. The Print Driver name is provided by the properties page for the printer.

The Printer Property page for a printer can be launched by selecting Start>Settings>Printers and selecting the appropriate printer. This will launch the Printer Queue window.

[image: image242.png]&% Epson ActionLaser 1500
Printer_Document_Ulew Help

[_[CIx]

Document Name

Status

Ourer

Pages

Y

‘

10 document(s) in queue

NI





Printer Queue window

Select Printer>Properties to launch the Printer Properties page.
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Advanced Printer Properties

The Printer Property page shows the Print Driver name on the Advanced tab. This is the name that needs to be entered into the Local Print Module.
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Client Print Window

When printing from the client, the printer will be displayed as Printer/username/session number as shown in the example.

Mouse Modules

There are three mouse modules that allow the configuration of mice. They are:

· Mouse Configuration Module

· PS/2 Mouse Module 

· Serial Mouse Driver

Mouse Configuration Module

The Mouse Configuration Module allows the configuration of mouse settings including: 

· Mouse Type

· Mouse Protocol

· Scroll Mouse

· Acceleration Multiplier

· Acceleration Threshold

These parameters can be changed by highlighting the parameter and choosing a new value in the Value dropdown box. Use the Set button to accept the new parameter value.
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Mouse Configuration Module

ThinManager supports USB mice with the latest firmware. The Mouse Configuration Module allows configuration of USB XE "USB"  mice. 

A ThinManager Ready thin client can have both a USB and a PS/2 mouse installed. This module allows the selection of the primary mouse when using two mice.

PS/2 Mouse Module

The PS/2 Mouse Module is the forerunner of the Mouse Configuration Module. It allows the changing of PS/2 settings like mouse type, acceleration and threshold. All of these features are now available in the Mouse Configuration Module.

Serial Mouse Driver

The Serial Mouse Driver allows a serial mouse to be used with ThinManager Ready thin clients.
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Serial Mouse Module

Configuration for the Serial Mouse include the Mouse Type and the Serial Port to be used.

Share Keyboard and Mouse Module

The Share Keyboard and Mouse module  XE "Share Keyboard and Mouse"  allows several ThinManager Ready thin clients to be controlled with a single keyboard and mouse without the need of a KVM switch (Keyboard/Video/Mouse).
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Shared Keyboard and Mouse Layout

The Share Keyboard and Mouse can be used by placing several monitors connected to ThinManager Ready thin clients side-by-side or top-to-bottom. The Share Keyboard and Mouse Master module is loaded on the center thin client. This module is configured by adding the IP addresses of the secondary slave thin clients. The other terminals receive the Share Keyboard and Mouse Slave module.
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Share Keyboard and Mouse Master Module

Once the Share Keyboard and Mouse Master Module is added to a terminal, it can be configured by highlighting it in the Installed Module window and selecting the Configure button.
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Share Keyboard and Mouse Master Module Properties

Highlight the Slave location (Left, Right, Top, or Bottom) to activate the Value field. Enter the correct IP address for the Slave and select the Set button.

Select Done when finished.

The Share Keyboard and Mouse Slave module is loaded on the secondary thin clients using the same methods as other modules are loaded. It requires no additional configuration.

Once the ACP Enabled thin clients are booted, the mouse on the master thin client can be moved seamlessly into the other desktops. The keyboard will be active in whatever screen the mouse pointer is on.

This allows an operator to have control of several displays with only one keyboard and mouse. The mouse movement is seamless, allowing access to displays without switching.

Note: A Master Share Keyboard and Mouse session cannot be interactively shadowed in ThinManager.

The keyboards and mice for the slave thin clients can be left attached, but stowed away until a multi-user configuration is needed.

The Share Keyboard and Mouse Master module is licensed for each master thin client. The Share Keyboard and Mouse Slave module is free. Each master module can have 1 to 4 slave units. Future releases will expand the number of slaves that the master can control.

USB Memory Card Reader Module

Some ThinManager Ready thin client devices have USB XE "USB"  ports. These can be used for USB keyboards and mice without any special configuration. The USB port can also be used for USB memory card readers and USB memory sticks. This can provide local storage and a substitute for a floppy drive.

The USB Memory Card Reader requires a Windows 2003 terminal server or a MetaFrame server. 

X Terminal Module

The X Terminal Module  XE "X Terminal"  allows a ThinManager Ready thin client to boot and connect to a Unix or Linux server and run as an X terminal. 

· First - add the X Terminal module to the client. 

· Second – open the Module Property window by highlighting the module on the Module Selection page and select the Configure button.

· Third  - Point the terminal to the Unix or Linux server by highlighting the XDM Host parameter in the Module Properties window and entering the IP address of the Unix or Linux server. Press the Set button and then the Done button to accept the configuration.
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X Terminal Module Parameters

X Term Configuration requires the XDM Host IP address XE "XDM Host IP address" . XE "XDM" 
Note: The XDM service needs to run on the Unix or Linux servers that the terminal will connect to.

ThinManager Security XE "Security" 
ThinManager Security Groups XE "ThinManager Security Groups" 
ThinManager 2.5 allows three different levels of access and functionality based on standard Windows groups. 

Three standard Windows groups can be created in the Computer Management console and named ThinManager Administrators, ThinManager Power Users, and ThinManager Users.  ThinManager gives members of these groups different privileges.

· ThinManager Administrators XE "ThinManager Administrators"  have full permission to do anything within ThinManager including the power to logoff sessions, kill processes, send messages, reboot terminals, calibrate touch screens, change terminal configurations, update firmware, update the TermCap, and restore configurations. Administrators and members of ThinManager Administrators can shadow terminals and interactively control the terminal session.

· ThinManager Power Users XE "ThinManager Power Users"  can logoff sessions, kill processes, send messages, reboot terminals, and calibrate touch screens. They cannot change terminal configurations, update firmware, update the TermCap, and restore configurations. ThinManager Power Users can shadow terminals from within ThinManager but cannot interact with the session.

· ThinManager Users XE "ThinManager Users"  can view only. They cannot logoff sessions, kill processes, send messages, reboot terminals, or calibrate touch screens. ThinManager Users cannot shadow a terminal.
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Created ThinManager Security Groups

If these groups are not created, members of the standard Windows Administrator group has full privileges in ThinManager while members of the standard Windows User group will have view only privileges.

ThinManager Server Security 

ThinManager has a number of security settings for the ThinManager Server. Open the ThinManager Server Configuration Wizard by right clicking on the ThinManager Server in the tree and selecting Modify, or select ThinManager Server> Settings from the menu.
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ThinManager Server Configuration Wizard

The second page of the wizard has two settings related to security:

· Allow unknown terminals to connect - This, when unchecked, will prevent any new terminals connecting to the system.

· Require passwords on unknown terminals -  XE "Password"  This checkbox, if checked, allows new terminals to be added, but only if the installer has the password.
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Terminal Replacement

On the next page of the ThinManager Server Configuration Wizard is the Enable replacement checkbox. This allows failed terminals to be replaced. If this is unchecked, terminals can still be added, but only by using the Create New Terminal process.

Windows Security

The ACP ThinManager system delivers a Windows 2000/2003 desktop to each thin client by default. Each thin client has full access to the server resources, as if it is the server. However, just because the thin client has the ability to have full access to the server resources doesn’t mean that the user should be granted full access to the server. To prevent unauthorized changes to the server, it is recommended that each user profile have security policies applied through the System Policy Editor to limit access to the needed functions. Windows 2000/2003 Security procedures are discussed in the Windows on-line help and in many books and articles.

Administrators usually require that each user login to a terminal with their personal account and have the Microsoft policy determine the user’s access rights.

Note: Task Manager has a feature that allows the launching of applications. If using an Initial Application, access to Task Manager should be denied in the security policy or with the Key Block XE "Key Block"  Module to prevent a user from launching unauthorized programs.

Shadowing  XE "Shadowing" 
Shadowing of a ThinManager Ready terminal can be initiated from within ThinManager by using the new Shadow tab in the Detail pane of ThinManager. To shadow, highlight the desired terminal in the ThinManager tree and select the Shadow tab.
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Shadow – Shadow Scaled to Window

The shadowed terminal can be viewed full-sized or scaled to fit in the Details pane. Select View>Shadow scaled to Window to scale the session, and unselect the option to view it life sized.

Shadow Access

Access to the shadow function is control by membership in ThinManager User Groups.

· ThinManager Administrators XE "ThinManager Administrators"  and Administrators can shadow terminals and interactively control the terminal session.

· ThinManager Power Users XE "ThinManager Power Users"  can shadow terminals from within ThinManager but cannot interact with the session. They are in View-only mode.

· ThinManager Users XE "ThinManager Users"  cannot shadow a terminal.

View>Interactive Shadow on the menu bar prevents the interaction with the shadowed session if unselected.

Disable Shadow

Shadow can be turned off for a Group or a Terminal by unselecting the Allow terminal to be shadowed checkbox on Terminal Name page of the Terminal Configuration wizard or Group Configuration wizard.
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Terminal Configuration Wizard

The Allow terminal to be shadowed checkbox controls access to shadowing. If unchecked, shadowing is denied.

Shadow Keystrokes

Because the CTL+ALT+DEL and the CTL+ESC keystrokes can’t be sent to the local machine to the shadowed ThinManager Ready thin client, there is a menu item to send these commands. Select Tools> Shadowing>Send Ctl+Alt+Del or Tools> Shadowing>Send Ctl+Esc to send these commands.

Note: The Key Block Module will block these commands from being sent to a shadowed session.

Changing the tab or selecting another tree icon will break the shadow connection.

Serial Communications

Because the session of the thin client is actually running on the terminal server, referencing the serial XE "Serial"  port in the session will reference the server serial port. To access the serial port on the terminal, one must either map the serial port or use the High Speed Serial Driver.

· Serial Port mapping is available for ThinManager Ready thin clients using the RDP protocol through the addition of the RDP Serial Port Redirection Module. 

· Mapping a serial port using the ICA protocol requires a command prompt program. 

· The High Speed Serial Driver is available for ThinManager Ready thin clients using either ICA or RDP. 

RDP Serial Port Redirection Module for Windows 2003 XE "RDP Serial Port" 

 XE "Serial" 
The serial ports on a ThinManager Ready thin client can be remapped by adding the RDP Serial Port module to the thin client without additional configuration. Once the thin client is booted, the COM1 in the session will refer to the COM1 on the terminal, while the COM2 in the session will refer to the COM2 on the terminal. This function requires Windows 2003 to work.

Additionally the COM Port Mapping needs to be allowed. This is done on the Terminal Services Configuration Console. To open the Terminal Services Configuration Console in Windows 2003 select Start> Administrative Tools> Terminal Services Configuration.
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Terminal Services Configuration Console

Launch the RDP-tcp Properties page by highlighting the Connections folder in the tree pane and double-clicking the RDP-tcp in the right pane. This will launch the RDP-tcp Properties page.
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COM Port Mapping Allowed

The Com port mapping checkbox must be unselected to allow the RDP Serial Port module to function on the Windows 2003 terminal server.

Serial Port Mapping with ICA

Using a COM port on a ThinManager Ready thin client using ICA requires mapping the thin client COM port to a COM port in the session on the server.  XE "COM Port" 

 XE "Serial" 
To map a COM Port on the server to a COM Port on an ACP Enabled terminal, open a command prompt on the client and type:

net use comX: \\client\comY: 

Where "X" is number of the server COM port and "Y" is the number of the thin client COM port. Use "client" for the name of the terminal. 

For example: net use com3: \\client\com2:

The server COM port does not need to exist; it can be a virtual COM port. The example will map COM3 on the server to the COM2 Port on the client. Pointing to COM3 in the session on the server will display data from the client’s COM2.

Note: The space after the colon in “comX” is important. 
The “\\client” is the word “client”, that is “\\c-l-i-e-n-t”, not the client’s name.

This is a local mapping. It must be mapped on the client, and the COM port data is only available to that session.

This connection will last until the terminal server is rebooted. To maintain the mapping, use /persistent as a switch in the command.

For example: net use com3: \\client\com2: /persistent will keep the COM 3 on the session mapped to COM 2 on the terminal hardware. 
High Speed Serial Driver

Automation Control Products has a High-Speed Serial Driver XE "High-Speed Serial Driver"   XE "HSSD"   (HSSD) module that offers more reliable serial communication at speeds to 115K per second. This is a global serial redirection; a COM port on a client becomes available to all users on that machine.  XE "HSSD" 
This has two components

· The High Speed Serial Driver module is a module that is added to the terminal and provides the client application. 

· The ACP COM Redirector program is a server-side application that is loaded on the terminal server or other computer where the serial data is desired.

 Serial data is passed from the client-side High Speed Serial Driver module to the server-side ACP COM Redirector program. Configuration is done in the server-side ACP COM Redirector program.

Installation Requirements

The high speed serial driver can be installed on any PC running Microsoft Windows NT 4.0 Service Pack 5 or higher, Microsoft Windows NT Terminal Server Edition Service Pack 5 or higher, or Microsoft Windows 2000/2003. 

Note: The ACP COM Redirector program can be installed on a machine other than your Terminal Server machine. The high-speed serial driver must be installed on the terminal server from which the thin-client session is running to access the serial ports from your thin-clients. If you install the ACP COM Redirector software on another computer, you will be able to access the thin client serial ports from the ACP COM Redirection software on that machine.

High-Speed Serial Driver Installation 

Install the ACP COM Redirection in the install mode using the Add/Remove Programs to point to the setup.exe file of the High-Speed Serial Driver Install. Follow the instructions to complete the installation.

High-Speed Serial Driver Configuration

Once the High-Speed Serial Driver  XE "ACP Com Redirector"  program is installed, you will need to configure the serial ports you wish to access using the ACP COM Redirector. Open the ACP COM Redirector program by selecting Start>Programs>Acp>ACP Com Redirector.
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ACP Com Port Redirector

To configure a COM port click Add New Port, this will launch the Edit Properties dialog box.
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Com Redirection Port Properties

Type in a COM port number to assign a number to a “virtual” port in the NT Com Port field. This number will identify the COM port on the NT system. 

Type in the thin client IP address for the client with the actual serial port in the Client Name/IP Address field. 

You can leave the Client TCP Data Port field empty. The program will fill this in with a unique port number for every serial port that is on the same thin-client, starting with 6550.

Type in the actual serial port number of the thin client’s port that is being used into the Client Com Port field.

HSSD Module Installation

The High Speed Serial Driver module needs to be added to terminals whose serial ports are being used.

Module License Installation

Before using the High Speed Serial Driver module, you must obtain and install a license for the High Speed Serial Driver module. This license can be activated at www.acpthinclient.com.  The procedure is that same as for the ThinManager terminal licenses. Please refer to ThinManager Licensing
 for details. 

ThinAdapter and the ThinAdapter Plus

The ThinAdapter is a Network Interface Card with an ACP Boot ROM that allows a PC to boot as a ThinManager Ready thin client. This allows outdated hardware to be converted to modern thin clients. A PC with the ThinAdapter card and its hard drive removed or unplugged becomes a ThinManager Ready Thin Client.

The ThinAdapter Plus XE "ThinAdapter Plus"  is the ThinAdapter network card with a compatible video card. This eliminates video compatibility issues.

Note: It is recommended that the computer hard drive be unplugged or removed.

ThinAdapter Plus

ThinAdapter Plus XE "ThinAdapter Plus"  Includes a video card to eliminate the need to try to match the ThinAdapter with a video chip set. The ThinAdapter Plus has the same requirements as the ThinAdapter.

· Processor Requirement: Pentium 133 or better is required for ThinAdapters

· Memory Requirement: 64 MBs of RAM is required for ThinAdapters

· ThinManager Terminal Properties Configuration: Set the OEM field to Generic and the Model field to Other on the Identity tab.

· Video Card Requirement: Use the included video card to provide the supported video chipset.

Non-ThinManager Components

Configuring RDP for Auto-Login

RDP, the Remote Desktop Protocol XE "RDP"   XE "Auto-Login" 

 XE "Login Permissions"  is configured by default to require users to enter a password when logging on to a Windows 2000 Terminal Server. This prevents a terminal from logging in automatically when using an initial program. The change in the configuration to allow the auto-login XE " Auto-Login"  and initial program XE "Initial Program"  while using RDP is made in the Terminal Services Configuration. 

Note: The information included here is for your convenience. Because this information can change, please see Microsoft at www.microsoft.com for up-to-the-minute details. 

Select Start>Programs>Administrative Tools>Terminal Services Configuration to launch the Terminal Services Configuration Console.  XE "Terminal Services Configuration Console" 
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Terminal Services Configuration Console- Windows 2000

Double-click RDP-tcp in the right pane or highlight RDP-tcp and select Action>Properties to launch the RDP-tcp Properties.
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RDP-tcp Properties

Uncheck the Always prompt for password checkbox and click the OK button to allow auto-login.

Configuring Windows 2003 Terminal Services for Multiple Logins

Windows 2003 is set to prevent multiple logins by the same account. Although it is a “best practice” to have each user login with a unique account,  a terminal using MultiSession can use the same terminal server in several Terminal Server Groups, making multiple logins desirable. This setting, and others, is changed in the Terminal Services Configuration Console. See Configuring RDP for Auto-Login
.

Open the Microsoft Terminal Services Configuration Console by selecting Start>Control Panel>Administrative Tools> Terminal Services Configuration.
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Terminal Services Configuration Console- Windows 2003

The Server Settings in the Terminal Services Configuration Console the settings that can be changed by double-clicking them. Three that are of interest are Licensing, Permission Compatibility, and Restrict each user to one session.

Single Session Per User

The Single Session Per User XE "Single Session Per User"  setting controls multiple logins XE "Multiple Logins" . Double-clicking the setting will launch a settings window.
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Terminal Services Configuration Console- Single Session Per User

The Restrict each user to one session XE "Restrict each user to one session"  checkbox is selected by default in Windows 2003. Unselect it to allow multiple logins if needed for MultiSession XE "MultiSession" .

Licensing Mode

Microsoft has expanded the Terminal Server Client Access License (TS CAL) program in windows 2003. TS CALs are available in two types, TS Device CALs and TS User CALs. 

· The TS Device CAL licenses one device for any user to connect to Microsoft Terminal Servers. This functions like the previous Windows 2000 TS CAL.

· The TS User CAL licenses one user for any device to connect to Microsoft Terminal Servers.

To change between the Per Device licensing and Per User licensing, double-click Licensing to launch the Licensing Mode window.
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Terminal Services Configuration Console- Licensing Mode

Select the desired mode from the Licensing Mode dropdown box and click OK.

Permission Compatibility

Microsoft has increased the security in each successive release of its terminal server software. These new policies prevent users from accessing the system folder, *.ini files, the registry, and other resources. Some programs such as HMI, SCADA, database, and control software XE "HMI"   XE "SCADA"  needs access to these resources to function. Instead of making all the users administrators, the security can be set to the less strenuous Windows NT 4.0-style security.  XE "Security" 
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Terminal Services Configuration Console- Permission Compatibility

Launch the Permission Compatibility XE "Permission Compatibility"  window by double-clicking on the Permission Compatibility setting. Select the Relaxed Security XE "Relaxed Security" 

 XE "Full Security"  radio button and select the OK button.

Command Prompt

Terminal Services has several commands that aid in managing the terminal server. Some useful ones are:  XE "Command Prompt" 
	Command
	Action

	change logon
	Temporarily disables logons to a Terminal Server

	change port
	Changes COM port mappings for MS-DOS program compatibility

	change user /install
	Puts the server into “Install Mode”

	change user /execute
	Removes the server from “Install Mode”

	Ipconfig
	Displays the IP addresses of the network card

	Logoff
	Logs off a user from a session and deletes the session from the server

	net send username “message”
	Sends a message to a user. username is the NT/2000 user name that the person or terminal is logged in as. “message” is the text of the message. Quotation marks are needed for any messages containing a space.

	query process
	Displays information about processes running on a Terminal server

	query session
	Displays information about sessions on a Terminal server

	query termserver
	Displays a list of all Terminal servers on the network

	query user
	Displays information about user sessions on a Terminal server

	reset session
	Resets a session to known initial values

	Shadow
	Monitors another user's session

	Tsdiscon
	Disconnects a client from a terminal server session

	Tsshutdn
	Shuts down the terminal server in an orderly manner


See the Windows online help for additional commands and parameters.

DHCP Server Setup

Dynamic Host Configuration Protocol (DHCP)  XE "DHCP"  is a program that assigns IP addresses to devices on a network. Since a DHCP server can be used to provide IP addresses to ThinManager Ready thin clients, the instructions for configuring the Windows 2000 DHCP Server are provided. 

Note: The information included here is for your convenience. Because this information can change, please see Microsoft at www.microsoft.com for up-to-the-minute details. 

To add DHCP to a Windows Server after installation select Start>Settings>Control Panel>Add/Remove Programs>Add/Remove Windows Components. A Windows Configuration Wizard will launch.
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Windows Components Wizard

Highlight Networking Services in the list window and select the Details button.
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Networking Services

Check the Dynamic Host Configuration Protocol (DHCP) check box and select the OK button.

The wizard will install the DHCP server.
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Application Server Mode

As part of the Windows Components Wizard, you may be asked to confirm the terminal service mode. The terminal server needs to run in application server mode to work with thin clients.

DHCP Scope Configuration for Microsoft DHCP Server

A DHCP server, in its simplest form, will assign an IP address to a computer that joins a network and requests one. A DHCP scope is a range of IP addresses that are available for assignment.  XE "DHCP Scope" 

 XE "Scope" 
ACP Enabled thin clients need more information from the DHCP server than just an IP address. They need the IP address of the ThinManager server (Option 066) and the name of the firmware ( Option 067) to download. This information needs to be added to the DHCP scope in the form of options.

To establish a DHCP scope, open the Computer Management Console by selecting Start>Programs>Administrative Tools>Computer Management.
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Create a DHCP Scope

Highlight DHCP in the Services and Applications folder of the tree pane and select Action>New Scope.

A New Scope Wizard will launch that will guide the process of creating the scope.
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Scope Range

Set the range of IP addresses by entering the starting IP address for the scope and the ending IP address of the scope.

Enter the desired subnet mask.

Select the Next button to continue.
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Scope Exclusions

If computers are already assigned IP addresses in the scope range, they can be excluded from the range by adding the IP address(s) and selecting the Add button.

Scope Options

The DHCP Server  XE "Scope Options" needs two options configured before it will provide all the information that the terminal needs to boot. These options are Option 066 and Option 067 XE "Option 066" 

 XE "Option 067" .
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Boot Server Host Name

The Boot Server Host Name, Option 066, assigns a ThinManager server to the terminal. 

Open the Scope Options dialog box by highlighting the Scope Option folder in the tree pane of the Computer Management Console under the Services and Application>DHCP folder and selecting Action>Configure Options.
Scroll through the list window and check the Option 066 check box. 

Enter the IP address of the desired ThinManager server in the String Value field. 
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Boot Server Host Name for Dual ThinManager Servers

The DHCP Server can issue the IP address for a Primary ThinManager Server and a Secondary ThinManager Server by listing the IP addresses of both, separated with a space.

Do not select the OK button yet.  XE "Scope Options" 
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DHCP Options

The Option 067, Bootfile Name, tells the terminal what file to download during the boot process.

Scroll through the list window and check the Option 067 check box. 

Enter firmware.acp in the String Value field. 

Select the OK button to accept the configuration of options.
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Completed Scope

Once the scope is added, the range is set, and the options are configured, it needs to be activated. 

Highlight the scope in the tree pane of the Computer Management Console. Select Action > Activate. The scope is now active.

Scope Reservation

Reservations allows an IP address to be reserved for a specific terminal instead of being assigned randomly. An IP address can be matched with a MAC address to create a reservation. This allows DHCP to assign a “static” IP address.  XE "Reservation" 
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Scope Reservation

The New Reservation window is launched by selecting the Reservation folder in the tree pane of the Computer Management Console under the Services and Application / DHCP folder and selecting Action>New Reservation.

The MAC address of a terminal is displayed in the details-view pane of ThinManager.

Enter a Reservation Name, the desired IP address, and the MAC address from the terminal. Select OK to finish.

DHCP Properties

The DHCP Server can be configured to check for duplicate IP addresses before issuing a new address. This is a good feature to use.

Highlight DHCP under Services and Applications in the Computer Management tree and select Action>Properties, or right-click on DHCP and select Properties. The DHCP Properties window will launch.
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DHCP Properties – Advanced Tab

Select the Advanced tab. Replace the zero in the Conflict detection attempts field with an integer. This will prompt the DHCP Server to check for duplicate IP addresses before assigning an IP address.

Select OK when finished.

Creating Microsoft User Profiles

A terminal needs a valid Windows 2000/Windows 2003 User Profile XE "User Profile"  to log onto a terminal server. 

To create a user profile open the Computer Management Console by selecting Start>Programs>Administrative Tools>Computer Management in Windows 2000 or by selecting Start>Administrative Tools>Computer Management in Windows 2003. 
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Computer Management Console

Highlight the User sub-folder of Local Users and Groups in the Computer Management tree pane. 

Select Action>New User. This will launch a New User  XE "New User" dialog box.  XE "User Profile" 

 XE "Computer Management Console" 
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New User Dialog 

Enter the user name for the user in the User name field.

Enter a password in the Password field. 

Re-enter the password in the Confirm password field. 

The User must change password at next logon check box forces the user to change the password.

Select the Create button to finish the profile. 

Select the Close button to return to the Computer Management Console.

Microsoft TS CALs – Terminal Server Client Access Licenses

Microsoft Client Access Licenses (CALs)

ACP Enabled Thin Clients require a terminal server with Windows 2000 Server with Terminal Services enabled, or Windows 2003 Server with Terminal Services enabled as an operating system. XE "CAL" 

 XE "TS CAL" 

 XE "Client Access License" 
Each of these operating systems requires a standard Microsoft Client Access License (CAL) for each connection to the server. These are based on concurrent use; a 5-pack would allow more than five users to access server resources, but only five users at a time. 

Microsoft Terminal Server Client Access Licenses (TS CALs)

Terminals, such as thin clients and fat clients, require an additional license, the Microsoft Terminal Server Client Access License (TS CAL)  XE "TS CAL" 

 XE "Terminal Server Client Access License"  to connect to the server using either RDP or ICA. This licensing is per seat; ten terminals would require ten TS CALs, even if only two were connected at a time.  XE "Licensing" 

 XE "Microsoft Licensing"  

Windows NT 4.0 Terminal Server Edition were sold with TS CALs. These were installed on each NT 4.0 Terminal Server. Additional TS CALs are available from Microsoft.

Windows 2000 and Windows 2003 have an improved method of license management. All TS CALs are installed on a Terminal Services Licensing Server. This acts as a repository for all TS CALs. The terminal servers request TS CAL authentication from the Terminal Services Licensing Server as terminals attach to terminal servers.

Note: The Terminal Server Licensing Server does not need to be a separate computer, but can be run on any Windows 2000 or 2003 server, including Windows 2000/2003 Terminal Servers. 

In Windows 2000, Microsoft requires that the Terminal Server Licensing Server XE "Terminal Server Licensing Server"  be installed on the Primary Domain Controller in a domain.

The Terminal Services Licensing server is activated through the Internet by connecting to the Microsoft Certificate Authority and License Clearinghouse. 

Windows 2000/2003 Server with Terminal Services enabled will issue 90-day temporary licenses while the Terminal Services Licensing server is being setup and activated. If this period has elapsed, the terminal will not connect to the terminal server and will display an “Error Number 50” message box.

Windows 2000/2003 Server is not normally sold with TS CALs. These need to purchased separately and installed on the Terminal Services License server. 

Windows 2003 TS CALS

Microsoft has expanded the Terminal Server Client Access License (TS CAL) program in windows 2003. TS CALs are available in two types, TS Device CALs and TS User CALs. 

· The TS Device CAL licenses one device for any user to connect to Microsoft Terminal Servers. This functions like the previous Windows 2000 TS CAL.

· The TS User CAL licenses one user for any device to connect to Microsoft Terminal Servers.

To change between the Per Device licensing and Per User licensing, double-click Licensing to launch the Licensing Mode window.

Microsoft Terminal Server Licensing Activation

In Windows 2000 and 2003, all the TS CALs are installed on a single Terminal Server Licensing Server XE "TS CAL Activation" . This allows a single site for management and authentication of terminal server connections. A server becomes a Terminal Server Licensing Server by selection of the option during the installation phase or by selecting Add/Remove Programs> Add/Remove Windows Components from the Control Panel and selecting the Terminal Services Licensing.

Note: The information included here is for your convenience. Because this information can change, please see Microsoft at www.microsoft.com for up-to-the-minute details. 

The licensing of the Microsoft components of a Windows 2000 terminal server is a is a two-step process; one must first authorize the Terminal Server Licensing Server, then one must activate the licenses. The license activation will be repeated for each license pack.

Note: The Terminal Server Licensing Server does not need to be a separate computer, but is usually installed on a Terminal Server. Microsoft requires that the Terminal Server Licensing Server be installed on the Primary Domain Controller in a 2000 domain.

To begin the process select Start>Programs>Administrative Tools>Terminal Server Licensing on the Terminal Server Licensing Server.
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Selected Terminal Server

Select Action>Activate Server from the menu bar.

[image: image282.png]Welcome to the Licensing

Wizard

This wizard helps you activate you ense server.

For informalion about the use of data you provice during

aotivation, see Microsol's pivacy poicy statementin

Teminal Services Helo
License servr setings
Activated fo
Comnection method

Licensing Program:

PraductD: 12345-123-1234867-12345

Ta change seings, select the icense server,click View, and

then clck Fropetties. To continue, cick Nex(

et

Cancel





Licensing wizard

The Licensing Wizard will launch.

 Follow the steps of the wizard by selecting Next. 

Note: The ID numbers shown on screens have been changed to “1234”. Please use the appropriate numbers that apply to your server and licenses.
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Connection Method

There are several methods for connecting to the Microsoft License Clearinghouse.

· Internet - Allows activation through a direct connection to Microsoft. The Licensing Server must have Internet access.

· World Wide Web - Allows activation at Microsoft’s web site through a web browser.

· Fax - Allows activation through faxes to Microsoft.

· Telephone - Allows activation through the telephone.

Select the desired method from the drop-down box and select Next.

Note: This section will detail the World Wide Web method.
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License Server Activation

The server needs a License Server ID for authorization. This is done on the Microsoft web site.

Go to the https://activate.microsoft.com site mentioned in the dialog box.
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Microsoft Terminal Services Licensing Web Site

Select Activate a license server and select Next.
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Customer Information Entry Form

Fill out the information forms and select Next. The Product ID is supplied by the Licensing Wizard.
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Customer Information

Continue with web-based wizard. Verify the data and select Next.
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Server Activation Number

The Microsoft will provide the License Server ID.

Add this number to the form in the Licensing Wizard.
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Wizard Completion

Once the License Server ID is placed in the appropriate fields on the Licensing Wizard, you will have a choice to continue and activate the license packs, or to stop with the server activation.

Microsoft TS CAL License Authorization

To continue adding license packs, return to the https://activate.microsoft.com web site.  XE "TS CAL Activation" 
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Microsoft Terminal Services Licensing Web Site

Select the Install client license key packs and select Next.
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Customer Information

Fill out the form and select Next.
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TS CAL Information

Select the Product Type and fill in the fields with the Quantity, Authorization Number, and License Number from the Licensing Certificate that was included with the purchase of the licenses.

Select Next to continue.
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License Information

Verify that the information is correct and select Next to continue.
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License Key Pack ID

The Microsoft site will provide the License Key Pack ID. This needs to be installed in the Licensing Wizard.

[image: image295.png]Obtain Client License Key Pack
Pravide the client license key pack ID.

To instal Terminal Services licenses, you must obtain a client fcense key pack ID
fiom the Terminal Services Livensing Web sie ted below:

hitps:/actvate mirosol com

To obtain this D, you il need youtfcense server D and sither a icense code from
retai product packaging or Select, Enterprie Agreement o Dpen liense corlract
information. Yo lense server ID i

1234567330 ABCDE-12345.67380- ABCDE- 12345

Ente the license key pack ID i the boes below. This D i obtained from the Terminal
Services Livensing Web ste.

12345 [67830 [ABCDE [12345 [67890 [ABCDE [ 12385

<Back Next> Cancel





License Key Pack ID Fields

Fill in the fields of the Licensing Wizard with the License Key Pack ID from the Microsoft site and select Next.
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Licensing Completion

The licenses will be added and will be displayed in the Terminal Services Licensing window.

Software Installation On Windows 2000/2003

Microsoft Windows 2000 Server requires that software be added in the “Install Mode” through the Control Panel, Add/Remove Programs.  XE "Install Mode" 

 XE "Software Installation" 

 XE "Installation" 
Select Start>Settings>Control Panel>Add/Remove Programs to launch the Add/Remove Programs dialog box.
Note: Some software, especially downloaded software, doesn’t allow the installer to install it through the Add/Remove Programs tools. To manually put the machine into the install mode open a command prompt and type:
change user /install
This command sets the machine to install mode. When finished, type:
change user /execute
This command returns the machine to the normal run mode.
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Add/Remove Programs

Select the CD or Floppy button on the Add/Remove Programs  XE "Add Remove Programs" dialog box to open the Installation wizard.  XE "Installation" 

 XE "Change User" 
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Install Program Window

The wizard will prompt for the installation of the software disk. Select Next to display the Run Installation Program dialog box.

Note: If the new program starts in autorun and proceeds without going through the following procedures, either stop the autorun and use the wizard to initiate the installation, or use the change user /install command to place the machine in the install mode. Use the change user /execute command when finished to return the machine to the Run mode.
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Run Installation Program

Enter the command line of the installation program and select Finish, or select the Browse button to select the installation file.
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Browse File Window

Selecting the Browse button on the Run Installation dialog box will launch a Browse File window. Highlight the installation file and select Open. This will begin the application setup.
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After Installation Window

As the installation begins, an After Installation dialog box is displayed. It requests that the Next button be selected when the installation is finished. When this button is selected a second confirmation window is displayed.
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Finish Install Window

Select the Finish button when the installation is finished.

Note: If a choice is given to Reboot Now or Reboot Later, choose to reboot later once the entire setup is completed and the dialog boxes are cleared.

Terminal Services Management

Microsoft provides a utility for managing sessions on terminal servers. This program is called Terminal Server Administrator in Windows NT 4.0 TSE, and Terminal Services Manager in Windows 2000/2003. This program:

· Displays current users and connections

· Displays the status of terminal connections.

· Displays the processes running on each session. 

· Allows messages to be sent to various sessions.

· Allows the shadowing or remote control of other sessions. 

Note: Many of these features are incorporated into the ThinManager 2.5 interface and can be launched from within the ThinManager program. See the Details Pane
 for details.

Select Start>Programs>Administrative Tools> Terminal Services Manager to launch the Terminal Services Manager program.  XE "Terminal Services Manager" 

 XE "Terminal Server Administrator" 
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Terminal Services Manager 

If the server is highlighted in the tree pane, the program shows tabs that display the details of the Users, Sessions, and Processes of the server. 
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Terminal Services Manager – Session Processes

If a session is highlighted in the tree pane, the program displays Processes and Information tabs. 

Send Message

Terminal Service Manager can be used to send messages to terminals.  XE "Messages" 
Right click on a connection in the tree pane or right click on a user in the detail-view panel will launch a menu. 

[image: image305.png]BLUE - Terminal Services Manager
Actions_Yiew Tools _tielp

[_[CIx]

alolE[s| la) ) x|

59 A,
58 e

e TGt istener)
e ROP-Tep (istener)
Console (Administrator)
- ROP-Tep# (User1)
e ROP-Tep3 (Userd)
Discomnected (User2)
()
()

Users | Sessons | Proseses
= Sewion [ D[ Siwe  [1deTine] LogonTine
' Administrator  Console 0 Active 211972004 9:
OMEFE  oootew 1 acive a4 29200410
D lUse,  Lomnech 2 Disconnect.

D Use Disconnect 3 Active 2/19/2004 3:

Remole.
Beset
Status

Control

Log Off

For Help, press F1

4





Terminal Services Manager – Right-click Menu

Select Send Message. This will launch a message box.
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Send Message Dialog Box

Fill in the desired message.

Select OK to send.

Note: Messages can be sent from the command line by using C:\ net send username “message”, where username is the recipient’s login name and message is the desired message.

Shadowing and Remote Control

Shadowing is a Windows NT/2000 Terminal Server utility that allows a person logged in as an administrator to view a client session from another client. Additionally, the administrator’s keystrokes and mouse movements can be configured to provide input to the shadowed client. This feature allows an administrator to do remote troubleshooting and support.  XE "Shadowing" 
Note: This program is called Shadowing in Windows NT 4.0 TSE and Remote Control in Windows 2000/2003.

Note: This feature is incorporated into the ThinManager 2.5 interface and can be launched from within the ThinManager program. See the Details Pane
 for details.

Remote Control is initiated in the Microsoft Windows 2000 Terminal Services Manager. 

Open this program by selecting Start>Program Files>Administrative Tools>Terminal Services Manager. 

Either highlight a connection in the tree pane and select Action>Shadow from the menu bar, or right-click a client on the user tab of the detail-view pane and select Remote Control. This will initiate the Remote Control session.  XE "Remote Control" 
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Shadowing / Remote Control

Note: The server console is not available for shadowing. Only administrators can shadow. An administrator can run the shadow session from one client to another client, RDP to RDP or ICA to ICA.

Note: The default hot keys used to end a shadow session are CTRL + * (the star on the number keypad). These are configurable. It is wise to remember the escape hot key combination.

Windows 2000/2003 Remote Control Configuration

A Windows 2000/2003 session must have its user profile configured to allow shadowing/remote control. This is done in the User Properties dialog box. The User Profile is accessed from the Computer Management Console. 

Open this program by selecting Start>Programs>Administrative Tools>Computer Management. 
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Computer Management – User List

To launch a User Profile, select the System Tools > Local Users and Groups > Users folder in the Computer Management tree pane and double-click on the desired user. This will launch the User Properties for the selected user.
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Windows 2000 User Properties

There are several parameters on the Remote Control tab that allow shadowing/remote control to be configured.

· Enable remote control, if selected, will allow the user to be shadowed. Shadowing is not permitted if this is unchecked.

· Require user’s permission, if selected, will launch a dialog box on the user’s screen that needs accepted before shadowing can begin. The shadowing will take place without confirmation if this is unchecked.

· View the user’s session, if selected, will disable the administrator’s mouse and keyboard input, and make the administrator a passive viewer.

· Interact with the session, if selected, will allow the administrator to control the session with mouse and keyboard, becoming an active participant.

Note: The server console is not available for shadowing. Only administrators can shadow. An administrator can run the shadow session from one client to another client.

Note: A change to a profile requires that the session is logged off and re-established.

Duplicate Sessions

It is possible for a terminal to be turned off and its session stays active instead of being disconnected. This can occur if the terminal screen is static and the server has no need to update the screen while the terminal offline. When the terminal reconnects to the server it creates a new session, creating duplicate sessions. Terminal Services Manager can eliminate the duplicate sessions.  XE "Duplicate Sessions" 
To manage duplicate session, launch Terminal Server Administration/Manager by selecting Start>Programs>Administrative Tools (Common)> Terminal Services Manager.
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Duplicate Sessions

Any duplicate sessions will show up in the Users tab when the server is highlighted. Three commands are available, Disconnect, Reset, and Log Off. These are activated by highlighting a session and right clicking, or by highlighting a session and selecting Actions from the menu bar.

· Disconnect will disconnect an active session.

· Reset will end a disconnected session

· Log Off will end an active session

These tools allow an administrator to eliminate duplicate sessions.

Note: In Windows 2003 Terminal Server the number of logins allowed is configurable. See Configuring Windows 2003 Terminal Services for Multiple Logins for details.

Glossary of Terms

ACP

Automation Control Products.  

ACP Enabled Thin Client

A terminal that uses ACP technology. Also called ThinManager Ready

ACP Enabled Thin Client Network

A ThinManager server, a terminal server, and ACP enabled thin clients connected and configured on the same network.

AppLink

A function that applies the Initial Program to a Terminal Server Group.

BIOS

Basic Input/Output System. A program that the computer uses to control the keyboard, mouse, monitor, serial ports, and other devices before the hard drive is accessed .

CAL
Client Access License. A Microsoft license that is required to print or access files on a Windows Server. See also TS CAL.

Classic Mode

The method of configuring Groups and Terminals using property tabs that was introduced in ThinManager 1.0. See also Wizard Mode.

Client

A machine that requests data, resources, or services from a server. A software program that shares data with the server.

Client/Server

A relationship between two computers or programs where one, the client, requests data, resources, or services from the other, the server.

COM Port

A serial communication port on a PC.

Console

The administrative session that is run on the server.

DHCP

Dynamic Host Configuration Protocol. A protocol for assigning IP addresses and other boot information to computers on a network.

Disk-On-Chip

Storage device that contains firmware that allows an ACP Enabled thin client to boot locally. This may be a disk-on-chip or compact flash, depending on the make and model of the terminal. 

DNS

Domain Name Service. An Internet service that converts domain names to IP addresses.

Domain
A group of computers that are administered as a unit, with common rules, policies, and procedures.

Domain Name Service

An Internet service that converts domain names to IP addresses. Often abbreviated to DNS.

Enforce Primary

A ThinManager feature that allows terminals that failed over to a backup terminal server to return to their primary terminal server once the primary terminal server has returned online.

Failover

The ability of a terminal to switch to a backup server when the primary server fails. 

Fat Client

A computer with a hard drive and operating system that is acting as a client.

Firmware

The software that runs the ThinManager Ready thin client. 

Gateway

A device that connects two computer networks that use different protocols.

GUI

Graphical User Interface. The portion of an operating system or program that provides icons, symbols, or pictures for options and choices.

HMI

Human-Machine Interface. A software program that allows an operator to control a manufacturing process. Also known as MMI, Man-Machine Interface.

Hot key
A keyboard combination that triggers a function.

HSSD
High speed Serial Driver. A module that works with the ACP Com Redirection program to transfer serial data from the ThinManager Ready thin client to the session on the Terminal Server at speeds up to 115 Kbaud.

ICA

Independent Computing Architecture. A remote presentation services protocol from Citrix that allows thin clients to access the server. 

ICA Connection

The communication channel between an ICA server and an ICA terminal.

Initial Program

A function that loads a specific application instead of the desktop in a terminal server session. 

Instant Failover

A ThinManager function that allows a ThinManager Ready thin client to start sessions on two terminal servers, with only the session of the primary terminal server visible. If the primary terminal server fails, the secondary session is immediately displayed. 

IP

Internet Protocol. A widely used protocol for network communications.

IP Address

Four sets of numbers from 0 to 255 that represent an Internet address.

KeyBlock

A module that prevents certain keyboard combinations like CTL+ALT+DEL from functioning.

KVM

Keyboard/Video/Mouse. A device that allows several PCs to be displayed on a single monitor and controlled by a singe keyboard and mouse.

Load Balancing

A dynamic ability to connect a thin client to a group of servers and login to the server with the lightest load. 

Load Sharing

A static ability to connect a thin client to one of a group of servers in a predetermined fashion to share the load among the servers available. 

MAC

Media Access Control Layer. A protocol that controls access and communication on a network card.

Module

Modules are software components that can be added to the firmware to increase the functionality of the terminal. Modules include touch screen drivers, sound drivers, and special device drivers.

MultiSession

A function that allows a terminal to connect to several Terminal Server Groups at one time and to switch between sessions.

MultiSession License

A license that allows a server to be added to a Terminal Server Group that uses the MultiSession function.

OEM
Original Equipment Manufacturer. A company that manufactures computers.

PLC

Programmable Logic Controller. A device, often using ladder logic programs, that controls processes and devices in an industrial plant. 

POST

Power On Self Test. A diagnostic test that a computer runs when it is first turned on to make sure that the hardware is functioning.

Primary Up Delay

An interval of time given to a server to allow it to finish loading before terminals will connect to it.

Primary Terminal Server

The first terminal server that a terminal will log into. 

Published Application

An application in a server farm that is shared equally among the servers.

RAM

Random Access Memory. The computer's primary memory space.

Redundancy

The use of duplicate equipment so that if one unit fails, another one takes its place without downtime.

RDP

Remote Desktop Protocol. The client/server communication protocol used between Windows NT/2000/2003 servers and Windows clients.

Router

A device that manages data transmission between two networks.

SCADA

Systems Control And Data Acquisition. A software program that gathers and displays data, and allows for operator input, for control of a manufacturing process.

Secondary Server

Backup terminal servers that a terminal may log into. 

Server

A computer that holds applications, files, or data for use by other computers. 

Server Farm

A group of connected servers that share responsibilities and are usually configured to allow processing to continue if one or more server crashes.

Server Ranking

A number that represents the available resources on a terminal server using SmartSession. Lower numbers indicate a lighter load. 

Share Keyboard and Mouse

A module that allows several thin client to share a keyboard and mouse.

SmartSession

A function that allows a Terminal Server Group to be load balanced so that a ThinManager Ready terminal will connect to the terminal server in the terminal server group that has the lightest load.

SmartSession License

A license that allows a server to be added to a Terminal Server Group that uses the SmartSession function for load balancing.

Standard Group

A Terminal Server Group without additional options. The terminal servers are listed in a pre-defined order and a terminal connects to the first available terminal server in the order specified by the group.

Subnet

A group of TCP/IP addresses that communicate without going through a router and can be reached by broadcasts. 

TCP/IP

Transmission Control Protocol/Internet Protocol. A layered application that allows shared applications and data on PCs.

Terminal

A client device that relies on a server for operations. ThinManager Ready thin clients are terminals. 

Terminal Operating Software 

The Terminal Operating Software (TOPS) is the firmware operating software that runs the ThinManager Ready thin client.

Terminal Server

A server with a multi-user operating system that processes data for terminals. 

Terminal Server Groups

A managed collection of terminal servers that a terminal can connect to. 

Thin Client

A terminal without a hard disk that is used to access a server. 

ThinManager 

A thin client configuration and management software from ACP.

ThinManager Ready 

An ACP Enabled thin client.

ThinManager Server

A computer running both the ThinServer service and the ThinManager interface.

Since ThinManager will run on Windows workstations, a ThinManager “Server” can be a workstation.

ThinServer

The Windows NT service that is the engine for ThinManager. 

Trialware

A free demo version of ThinManager that can be downloaded from www.thinmanager.com. It can run for 30 days without a license.

TS CAL

Terminal Server Client Access License. A Microsoft license that is required for each client accessing a terminal server.

USB

Universal Serial Bus. A data port that allows peripherals to connect to a PC.

Wizard Mode

A method of configuring Groups and Terminals using a Wizard that was introduced in ThinManager 2.4. See Classic Mode.
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