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Introduction 
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ACP ThinManager 
ThinManager 2.4 is a software program that allows ACP Enabled Thin Clients, called terminals in 
this, to boot, receive a configuration, and connect to a terminal server. 

A thin client is a computer without a hard drive that connects to a server, logs onto a separate 
independent session, and runs its applications on the server and not locally on the terminal.  

ACP Enabled thin clients first connect to a ThinManager Server where it receives its 
configuration. This configuration assigns the terminal to its terminal server. The terminal then 
connects to its assigned terminal server, logs in and starts its session. The keystrokes and 
mouse movements from the terminal are sent to the terminal server. The terminal server session 
calculates the response and sends the screen display back to the terminal.  

This simplifies maintenance and management by eliminating the need to install and configure 
operating systems on the terminals. All configuration, management, installation and applications 
are on the server, not the thin client. 

ACP Enabled Thin Clients are terminals containing ACP technology that: 

• Allow for a network boot. 

• Use the ICA protocol from Citrix. 

• Have central configuration and management software. 

• Allow easy replacement in case of terminal failure. 

• Provide failover in case of terminal server failure. 

• Provide touch screen support. 

• Provide high-speed serial connections. 

• Have multiple hardware vendors. 

• Have Disk-On-Chip versions for low bandwidth applications. The disk-on-chip can be 
updated automatically, on location. 
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What�s New in Version 2.4 
There are many �behind the scenes� changes that make ACP ThinManager faster, stronger, and 
more reliable. The visible improvements in ThinManager 2.4 include: 

• Wizards for creation and configuration. See �Configuration Wizards� on page 67. 

• Improved Tree with greater details. See �Tree Pane� on page 28. 

• Server List Management allowing the use of names instead of IP addresses, even if 
DNS is not used. See �Server List Management� on page 42. 

• A Configuration Backup for keeping a copy of the ThinManager configuration. See 
�Backup Configuration� on page 51 

• A Synchronization wizard for keeping multiple copies of ThinManager identical. See 
�Synchronize Configuration� on page 51 
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Terminology 
The ACP ThinManager Technical Training Manual uses a number of terms to describe events in 
the Client/Server relationship between ACP Enabled thin clients and Microsoft Windows 
NT/2000 terminal servers. These are defined here: 

Note: This manual uses �terminal� to mean an ACP Enabled thin client. 

ACP - Automation Control Products.    

ACP Enabled Thin Client � A terminal that uses ACP technology. 
ACP Enabled Thin Client Network � A ThinManager server, a terminal server, and ACP enabled thin 
clients connected and configured on the same network. 

Classic Mode � The method of configuring Groups and Terminals using property tabs that was 
introduced in ThinManager 1.0. See also Wizard Mode. 

Client - A machine that requests data, resources, or services from a server. A software program 
that shares data with the server. 

Client/Server - A relationship between two computers or programs where one, the client, 
requests data, resources, or services from the other, the server. 

COM Port - A serial communication port on a PC. 

Console - The administrative session that is run on the server. 

DHCP - Dynamic Host Configuration Protocol. A protocol for assigning IP addresses and other 
boot information to computers on a network. 

Disk-On-Chip - Storage device that contains firmware that allows an ACP Enabled thin client to 
boot locally. 

DNS - Domain Name Service. An Internet service that converts domain names to IP addresses. 

Enforce Primary - Setting Enforce Primary to Yes will return terminals logged into a secondary 
server back to the primary server, once the primary server has returned online. 

Failover - The ability of a terminal to switch to a backup server when the primary server fails.  

Fat Client � A computer with a hard drive and operating system that is acting as a client. 

Firmware - The software that runs on the terminal.  

Gateway � A device that connects two computer networks that use different protocols. 

GUI - Graphical User Interface. The portion of an operating system or program that provides 
icons, symbols, or pictures for options and choices. 

HMI - Human-Machine Interface. A software program that allows an operator to control a 
manufacturing process. Also known as MMI, Man-Machine Interface. 

ICA - Independent Computing Architecture. A remote presentation services protocol from Citrix 
that allows thin clients to access the server.  

ICA Connection � The communication channel between an ICA server and an ICA terminal. 

IP - Internet Protocol. A widely used protocol for network communications. 

IP Address - Four sets of numbers from 0 to 255 that represent an Internet address. 

Load Balancing - The ability to connect a thin client to a group of servers and login to the server 
with the lightest load. Load balancing may include failover features. 
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Load Sharing - The ability to connect a thin client to one of a group of servers in a 
predetermined fashion to share the load among the servers available.  

MAC - Media Access Control Layer. A protocol that controls access and communication on a 
network card. 

Module � Modules are software components that can be added to the firmware to increase the 
functionality of the terminal. Modules include touch screen drivers, sound drivers, and special 
device drivers. 

PLC � Programmable Logic Controller. A device, often using ladder logic programs, that controls 
processes and devices in an industrial plant.  

Primary Up Delay - An interval of time given to a server to allow it to finish loading before 
terminals will connect to it. 

Primary Server - The main terminal server that a terminal will log into. This is the first server of a 
series added to the Server field on the ICA Session tab to enable Failover. 

Published Application - An application in a Citrix server farm that is shared equally among the 
servers. 

RAM - Random Access Memory. The computer's primary memory space. 

Redundancy - The use of duplicate equipment so that if one unit fails, another one takes its 
place without data loss. 
RDP - Remote Desktop Protocol. The client/server communication protocol used between 
Windows NT/2000 servers and Windows clients. 
Router � A device that manages data transmission between two networks. 

SCADA - Systems Control And Data Acquisition. A software program that gathers and displays 
data, and allows for operator input, for control of a manufacturing process. 

Secondary Server - Alternative terminal servers that a terminal may log into. These follow the 
first server of a series added to the Server field on the ICA Session tab to enable Failover. 

Server - A computer that holds applications, files, or data for use by other computers.  

Server Farm - A group of connected servers that share responsibilities and are usually 
configured to allow processing to continue if one or more server crashes. 

Subnet - A group of TCP/IP addresses that communicate without going through a router and can 
be reached by broadcasts.  

TCP/IP - Transmission Control Protocol/Internet Protocol. A layered application that allows 
shared applications and data on PCs. 

Terminal � A client device that relies on a server for operations. A dumb terminal has no local 
processing. A smart terminal relies on a server, but can do local processing. 

Terminal Server - A server with a multi-user operating system that processes data for terminals.  

Thin Client - A terminal without a hard disk that is used to access a server.  

ThinManager Server - A computer running both the ThinServer service and the ThinManager 
interface. 

Note: ThinManager software does not need to run on a server. Since 
ThinManager will run on Windows NT 4.0 SP5, a ThinManager �server� can be a 
workstation. 

ThinServer � A Windows NT service that does the real work within ThinManager.  
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TS CAL - Terminal Server Client Access License. A Microsoft license that is required for each 
client accessing a terminal server. 

TSE - Terminal Server Edition or Terminal Services Enabled. An abbreviation representing the 
terminal server edition of the Windows NT operating system. 
UPS - Uninterrupted Power Supply. A device that supplies power when the main power supply is 
stopped. 
Wizard Mode � A method of configuring Groups and Terminals using a Wizard that was 
introduced in ThinManager 2.4. See Classic Mode. 
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Simple Setup Summary 

 Build a terminal server whose operating system is either:  

• Microsoft Windows NT 4.0 Terminal Server Edition with Microsoft�s Service Pack 5 
installed 

• Microsoft Windows 2000 Server with Terminal Services enabled. 
See �Windows 2000 Server Building Instructions� on page 203. 

 Create a Licensing Server and add a TS CAL (Terminal Server Client Access License) for 
each thin client.  

See �Microsoft Terminal Server Licensing Activation� on page 221. 
 Install ACP ThinManager software onto a computer to create a ThinManager Server. 

The ThinManager Server can be a terminal server, but doesn't have to be. It can be a 
Windows NT 4.0 Workstation, SP5 or better. The clients will connect to the ThinManager 
Server and download the firmware and configuration.  

See �ThinManager Installation On Windows 2000 Server� on page 141. 
 Install an ACP License for each ACP Enabled thin client.  

See �ThinManager Licensing� on page 158. 
 Install the ICA protocol on each terminal server by using Citrix Device Services (included as 

part of the ThinManager installation) or Citrix MetaFrame (available separately).  

See �Citrix Device Services Installation On Windows 2000� on page 143 
 Add the Citrix License. ThinManager has the Citrix Device Services License on the CD. If 

using Citrix MetaFrame, use the license that comes with that CD. Activate the license within 
30 days of installation.  

�Citrix Device Services Licensing� on page 151 
 Create a Microsoft user profile for each user on the terminal server. 

See �Creating User Profiles� on page 219 
 Apply appropriate security to each user profile using the standard Microsoft techniques. 
 Establish the IP addressing scheme for the thin clients, Static IP or DHCP 

If using DHCP, Configure Option 066 to list the IP address of the ThinManager Server and 
configure 067 to list "firmware.acp" as the bootfile name. 

See �DHCP Server Setup� on page 209 
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 Attach the terminals to ThinManager by either: 

• Turning on the terminal and selecting the "Create New Terminal" option when the 
unit boots. 

• Pre-creating the terminals in ThinManager and selecting the proper terminal name 
when the terminal is turned on and offline terminals are listed. 

See �Adding Thin Client� on page 59 
 Make sure that the terminal servers you wish to connect and run on are defined. This is in 

the Terminal Server Selection list in the Wizard Mode or in the server field of the 
Session tab of the terminal properties in Classic Mode. 

See �Adding Thin Client� on page 59 
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The ACP Thin Client 
Components and Networks 
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Terminal Services 
In the early days of computing, mainframe computers provided centrally located resources. This 
allowed a central location for maintenance, security, backups and power management. The 
downside of mainframe computing was its reliance on text-based interfaces that made usage 
difficult for average users.  

The PC revolution was fueled by the user-friendly Graphic User Interface (GUI) that made 
computing much more accessible to the average user. PCs became a fixture on every desk and 
in every factory. The proliferation of PCs caused a system management nightmare, with the high 
cost of managing so many individually configured and personalized machines.  

The ACP thin client system returns to the concept of a centrally managed server for ease of 
management, with each client running a session of Microsoft Windows NT/2000 to provide a 
familiar, user-friendly interface for the end user. 

Unlike the traditional client/server environment that runs an application on the client hardware, 
thin clients run an application only on the server in the Microsoft Windows NT Terminal 
Server/Windows 2000 Server environment. The thin client does not perform any local 
processing of applications. Thin clients do not have, nor do they need, a hard drive. The client 
sends user inputs (mouse clicks and keystrokes) to the terminal server where they are 
processed. The resulting graphics are sent down to the client for display.  

Each user logs on to the terminal server as if it was the only user on the machine. Other 
sessions are transparently managed by the server operating system and are independent and 
isolated from any other client session.  

This provides stability and reliability. The application is not client-reliant. The client terminal can 
lose power, or even be destroyed, but the data is intact and running on the terminal server. Once 
the connection is restored or the terminal is replaced, the session will continue where it left off. 

Additionally, ACP ThinManager (v2.3 and later) has failover capabilities. Each thin client can 
have a terminal server designated as its primary server, and then have other terminal servers 
designated as secondary servers. If the primary server becomes unavailable, the terminal will 
connect to a secondary server where it can run a session.  

See �Windows 2000 Server Building Instructions� on page 203 for details on terminal services. 
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Three Main Components 
The ACP Enabled thin client system requires three main components to operate properly.  

Windows Terminal Server Operating 
System 

The first component is the Terminal Server operating system. Microsoft�s Windows NT 4.0 
Terminal Server Edition and Windows 2000 Server are versions of Microsoft's Windows 
operating system that allow multiple sessions of an application to run on a server. The operating 
system controls the server, provides security, controls user access, and runs the applications.  
Windows NT 4.0 Terminal Server Edition requires Microsoft�s Service Pack 5 for Terminal 
Server (or later) and terminal server client access licenses (TS CAL) installed on the computer. 
Windows 2000 Server needs Terminal Services enabled and TS CALs added. . 

Citrix ICA Communication Protocol 
The second component is the ICA (Independent Computer Architecture) communications 
protocol from Citrix, which provides the communication between the server and thin client. ACP 
ThinManager software contains a licensed copy of Citrix Device Services, an abbreviated 
version of Citrix MetaFrame that provides the Citrix ICA communications protocol across a 
TCP/IP network. Citrix Device Services or Citrix MetaFrame needs to run on each terminal 
server. 

The ACP ThinManager CD contains Citrix Device Services and ACP ThinManager. Citrix 
MetaFrame can be used instead of Citrix Device Services to provide advanced communication 
options and advanced server functionality such as joining servers into a server farm for 
advanced functionality. Citrix MetaFrame is available separately from Citrix (www.citrix.com). 

ThinManager Administrative Software 
The third component is ACP ThinManager software from Automation Control Products. 
ThinManager is used to configure, manage, and control the thin clients. Although ThinManager is 
treated as a single component, it really has two main components, the ThinManager interface 
and the ThinServer service.  

• ThinServer is the NT service that does the main work of the program. It starts 
automatically and runs in the background and provides essential functions to control 
the thin clients. ThinServer is installed during ThinManager installation.  

• ThinManager is the administrative software that facilitates the configuration and 
organization of the thin clients. This is the visible component of the ThinManager 
software. ThinManager displays information generated by ThinServer. ThinManager 
can be installed on any computer on the network (NT 4.0, SP5 or better), including 
the terminal server.  

Note: ThinManager Server is used to describe a computer running 
ThinManager and ThinServer that provides control and configuration to ACP 
Enabled Thin Clients.  
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One instance of ThinManager can provide client connection to several terminal servers. The 
terminals would boot from the ThinManager server, but could be assigned to any of several 
terminal servers.  
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Sample Network Configurations 
One of the strengths of ThinManager and ACP Enabled Thin Clients is their versatility in 
networking. They don�t demand a rigid proprietary network configuration, but have the flexibility 
to run in almost any network configuration. 

ACP Networks require: 

• A ThinManager Server, that is, a computer running ThinManager. This doesn�t have 
to be a �server�, but can be a Windows NT 4.0 Workstation SP5 or better. 

• A Microsoft Terminal Server with the Citrix ICA Protocol and any desired 
applications. 

• A Microsoft Terminal Server Licensing Server for the Microsoft Terminal Server 
Client Access Licenses (TS CALs). This does not need to be a separate computer, 
but can run on a terminal server. 

• A DHCP Server or Static IPs. 

• ACP Enabled Thin Client hardware 

• A standard Ethernet network. 

The simplest network consists of a single computer, configured as a terminal server with the TS 
CALs, ThinManager, and the applications. 

Note: ThinManager does not have to run on a terminal server. 
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Sample ACP Thin Client Network � Single Computer 

Note: One server is shown. The ACP Enabled thin client network functions can 
be combined into one server, or be spread to multiple servers. 

Sample ACP Thin Client Network with Failover 



18 Copyright 1999-2003 © Automation Control Products 

 

Sample ACP Thin Client Network � Multiple Computers 

 

This is a representation of an ACP Enabled thin client network.  

• When a terminal is powered on, an IP address is requested from a DHCP server by 
default. The DHCP server needs to have Option 066 set to the ThinManager Server 
IP address and Option 067 set to firmware.acp to specify a ThinManager 
Server IP address. 

• Alternately, the terminal may be assigned a static IP address and the ThinManager 
Server address.  

• The terminal connects to the ThinManager Server to download its configuration. 

• The ThinManager configuration will tell the terminal which terminal server to log into. 

• The terminal will connect to that terminal server and display the Windows login 
dialog box or will automatically login with help from the ThinManager configuration. 
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• The terminal will create a session on the terminal server, allowing applications to 
run. 

Note: Three servers are shown to separate machines. These can be combined 
into one server, or be spread to multiple redundant servers. 
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Failover Overview 
Server crashes of any kind in any network or system can have devastating effects on productivity 
and data management. In the distributed computing world users may still be able to work on 
local applications but lose access to data. In a terminal server installation, a terminal server 
crash stops the functions of all terminals logged into the failed terminal server. 

In a thin client system all the terminals rely on the terminal server for processing power. Failure 
of the terminal server leads to the failure of all the thin clients. 

ACP ThinManager (version 2.3 and later) has a failover capability built into it that allows 
terminals to connect to a secondary terminal server if the terminal server that they are logged 
into fails. This will lessen the effect of server crashes on the terminal server network. The 
terminals can detect the server crash, drop the connection to it, and connect to a secondary 
server in seconds.  

To initiate ACP ThinManager Failover protection, four steps are needed. 

• Multiple Servers: The first step is to have multiple terminal servers, with Citrix 
Device Services and appropriate licenses added. 

• Sufficient Memory: The second step is to have sufficient memory capacity on the 
servers to accommodate the addition of terminals during failover. If you do not plan 
for the extra capacity, the servers can overload with the addition of the new 
terminals. 

• User Permissions: Each terminal server needs the appropriate Windows NT/2000 
user profiles and permissions. The terminals will not log into a secondary session 
unless it has a user profile on that server. 

• IP Addressing In ThinManager: When configuring the terminal, list the terminal 
servers, in the order of preferred connection, in ThinManager. Upon boot, each 
terminal will try to connect to the first server in the list (the primary server). If it is not 
available, it will try the next on the list (a secondary server) until a connection is 
made 
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ACP Thin Client Network with Failover 

ACP ThinManager allows the use of several terminal servers, defined as the primary 
and as backups. If the primary terminal server fails, the ACP Enabled thin client will 
detect the server failure and will initiate a new session on a backup server. This 
allows the operator to continue their work and minimize the effect of a server 
failure. 

Instant Failover 
Instant Failover allows the terminal to login to two terminal servers at once. The sessions are 
cascaded on the terminal, with the primary session on top. If the primary terminal server fails, the 
pre-logged in secondary session is switched to the forefront. 
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Instant Failover � Part 1 

When the ACP Enabled thin clients with the Instant Failover module boot, they connect to both 
servers, login, and start sessions. 
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Instant Failover � Part 2 

The ACP Enabled thin client cascades both sessions, with the primary in front. You cannot see 
the secondary session as it is hidden in back. 

There is a toggle option that allows one to switch between sessions with a hot key. 
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Instant Failover Module Properties 

If the Hot Key Session Switching is set to Enabled, the hot key combination will allow the 
toggling between sessions. 
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If the primary server fails, the thin client monitoring program will detect its failure. The thin client 
will then switch the focus of the window, showing the secondary session. This session is already 
initialized so the user is able to proceed at once. 
If the Enforce Primary feature on the Monitoring tab is set to Yes, the thin client will switch 
back to the primary once it is back online. 
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ThinManager 2.4 Interface 

Opening ThinManager  
ThinManager is used for the configuration of ACP Enabled thin clients in the ACP thin client 
system. 

ThinManager can be started using any of the traditional Windows methods, based on the 
administrator's preference: 

• Run from the Start Menu, Start>Programs>ACP>ThinManager. 

• Run from the Run line, Start>Run> C:\Program Files\Automation Control 
Products\ThinManager\ThinManager.exe.  

• From a command prompt, C:\Program Files\Automation Control 
Products\ThinManager\ThinManager.exe.  

• From a shortcut on the desktop. 

• From a ThinManager icon in the system tray, if this option is selected in 
View>Options from the menu bar. See Options on page 57. 

• From Windows Explorer.  

Note: ThinManager can be run from a terminal if the user is an administrator. 
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ThinManager Graphic User Interface 

 

ACP ThinManager 2.4 Graphic User Interface 

The ThinManager administration interface provides "at-a-glance management". The groups and 
terminals are displayed in the tree pane. The configuration data is displayed in the detail panel. 
Color-coded icons in the tree pane show the on-line status of terminals. 

The sections of the ThinManager interface include: 
A Title Bar with the standard Windows Minimize/Maximize/Close shortcut icons. 

A Menu Bar with commands. See Menu Items on page 33. 

A Tree Pane with an expandable/collapsible tree showing the ThinManager Servers, 
Terminal Servers, groups and terminals in the ThinManager network. Terminals that are on-
line have a green monitor icon, while stopped or rebooting terminals have a red monitor icon. 
More information is found at �Tree Pane� on page 28 

A Detail-view pane with information about settings and configurations. The blue group icon 
denotes a property that was obtained from the group.  

A Status Bar that shows advice and tips.  

The Communication Indicator  shows green when ThinManager is talking to a 
ThinManager Server. ThinManager will wait until this communication is finished before 
processing additional requests. 
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Tree Pane 
The tree pane shows the members of the ACP Thin Client Network in an expandable tree. 

 

ACP ThinManager 2.4 With Tree 

The current version of the Tree separates the ThinManager Servers from the Terminal Servers. 
Although a single computer can be both a ThinManager Server and a Terminal Server, as shown 
in the example, these are two distinct functions that are displayed in the tree. 

Icons 
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Tree Icons 

 

ThinManager Server Icons 

A Blue ThinManager Server icon represents the top level of the tree and can be collapsed or 
expanded. 

A Red ThinManager Server icon represents a ThinManager Server that is not communicating 
with the program. 

A Green ThinManager Server icon represents a ThinManager Server that has an active 
communication with the program. 

 

Terminal Server Icons 

A Blue Server icon represents the top level of the Terminal Server tree and can be collapsed or 
expanded. 

A Gray Server icon represents individual terminal server. These can be collapsed or expanded. 

 

Group and Terminal Icons 

A Group is represented by an icon of two monitors with a blue screen. 

A Terminal is represented by an icon of a single monitor. 

A Red terminal screen indicates that the Terminal is off or not communicating with the 
ThinManager Server. 
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A Green terminal screen indicates that the Terminal is on and communicating with the 
ThinManager Server. 

Each item of this tree level can be expanded. 

 

Expanded Tree Showing Icon Variety 

The tree in ThinManager has been expanded to provide greater detail about the status of the 
terminals.  

 

Group and Terminal Nesting 
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Each Group can be expanded to show the terminals that are members of the group. 

Each Terminal can be expanded to show the Terminal Servers that it is assigned to. 

Each color represents a status state. 

 

Terminal Server Connection Icons 

Under each Terminal are icons representing the Terminal Servers that they are assigned to. The 
lightening bolt color indicated the connection status. 

A Red lightening bolt represents a lack of connection to the terminal server. 

A Green lightening bolt represents a connection to the terminal server with an active session. 

A Yellow lightening bolt represents a connection to the terminal server with an active session 
that is the backup in Instant Failover mode. 

 

 

Terminal Server Nesting 

The top level Terminal Server icon can be expanded to show the Terminal Servers that have 
terminals assigned to them. The Monitor Screen color and the Lightening Bolt color indicate the 
terminal�s status on the Terminal Server.  
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Terminal Server Connection Icons 

The monitor screen color indicates the ThinManager Server connection status. 

• A Red monitor screen indicates that the terminal is off or unable to communicate. 

• A Green monitor screen indicates that the terminal is on and able to communicate. 

The lightening bolt color indicates the Terminal Server connection status. 

• A Red lightening bolt represents a lack of active connection to the terminal server. 

• A Green lightening bolt represents a connection to the terminal server with an 
active session. 

• A Yellow lightening bolt represents a connection to the terminal server with a 
session that is the backup session in Instant Failover mode. 

 

Locked Icons 

Terminals and Groups that are undergoing modification will display a lock icon. 
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Menu Items 



34 Copyright 1999-2003 © Automation Control Products 

Edit 
Edit contains commands for adding, deleting, and changing configurations. 

Add Terminal 
Add Terminal will launch the Terminal Creation Wizard in Wizard Mode or the Create New 
Terminal dialog box in Classic Mode to start the process of adding a new terminal. See 
�Terminal Configuration Wizard� on page 87  

Add Group 
Add Group will launch the Group Creation Wizard in Wizard Mode or Create New Group 
dialog box in Classic Mode to start the process of adding a new group. See �Group Configuration 
Wizard� on page 68 

Add ThinManager Server 
ThinManager allows the remote administration of multiple ThinManager Servers. A user logged 
in with administrative rights can connect to multiple ThinManager servers for management.  

Selecting Add ThinManager Server will launch a dialog box. 

 

Add ThinManager Server Dialog Box 

Enter the IP address or computer name of a ThinManager server. This adds the ThinManager 
Server and its configuration to the tree pane of the local ThinManager.  
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ThinManager with Second ThinManager Server Added 

A user with administrative powers has full control of the remote ThinManager Server and can 
monitor status or make changes as needed. 

Delete 
Delete will launch a message box that will remove a highlighted ThinManager Server, group or 
terminal. Deleting a group will give the option of deleting the group terminals or moving them 
under the server without a group. 

 

Delete Group Message Box 

Modify 
Modify will launch the Server Properties dialog box for a highlighted server. This allows the 
server to be configured as described in Settings on page 55. 

Modify will launch the Group Creation Wizard in Wizard Mode or the Group Properties in 
Classic Mode for a highlighted group. Modifications can be made as described in Group 
Configuration Wizard 
Modify will launch the Terminal Creation Wizard in Wizard Mode or the Terminal Properties in 
Classic Mode for a highlighted terminal. Modifications can be made as described in Terminal 
Configuration Wizard 
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Rename 
Rename will allow a highlighted group or terminal to have its name changed in the tree of 
ThinManager. 

Lock 
When a group property or a terminal property is opened, the entry in the configuration is 
automatically locked to prevent two people from making changes at one time.  

Lock will manually lock the configuration of a group or terminal to prevent it from being changed. 
A lock icon will designate a locked group or terminal. 

 

Lock Icons 

Unlock 
Unlock will manually unlock a terminal or group that was locked while being modified. This is 
useful if the server was shut down while the terminal was locked, preventing the terminal from 
being unlocked automatically when the modifications are done. 

Note: This tool is to be used only when a terminal remains locked due to an 
unexpected server shut down while a terminal is being configured. Using this 
tool while another is configuring that terminal can lead to corruption of the 
database. 
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Tools 
Tools contain commands that affect the terminals. 

Reboot Terminals 
Selecting this command will restart the terminals, reload the firmware, and reconnect them to the 
terminal server. 

Highlight a terminal in the ThinManager tree pane and select this command to reboot a terminal.  

Highlight a group in the ThinManager tree pane and select this command to reboot all the 
terminals of the group. 

Highlight a ThinManager Server in the ThinManager tree pane and select this command to 
reboot all the terminals on the ThinManager Server. 

Calibrate Touch Screen 
ThinManager has a touch screen configuration utility that can calibrate a thin client touch screen. 
The utility can be started two ways:  

On the thin client, select Start>Program Files>Automation Control Products>Calibrate 
Touch Screen (or Start>Program Files>Acp>CalTouchScreen). This is useful because it 
allows the operator to calibrate the touch screen without administrative support. 

On the ThinManager Server, Highlight the desired terminal in ThinManager and select 
Tools>Calibrate Touch Screen from the menu bar. This will launch the calibration on the 
selected terminal.  

 

Touch Screen Calibration Screen 

When the calibration image appears, first touch the center of the lower left X and then touch the 
center of the upper right X to provide touch screen mapping to the system.  
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Note: The touch screen module must first be added through the Module tab in 
Terminal Properties. 
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 ThinManager Server 
The ThinManager Server contains commands for configuring the ThinManager Server. These 
options will be grayed out unless the ThinManager Server is highlighted in the tree. 

Licensing 
Licensing opens up the Licensing dialog box. See ThinManager Licensing on page 158. 

 Modules   
Modules open the Modules dialog box. This displays the modules that are available to the ACP 
Enabled thin clients. See �Modules in Depth� on page 130. 

 

Installed Modules Windows 

Selecting Install Module� will launch a dialog box that allows modules files to be selected. 

A module can be added to the list of available modules by highlighting the desired module file 
and selecting Open.  
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Open Module File 

See �Modules in Depth� on page 130 for more details  

Install New TermCap Database 
ThinManager has a Terminal Capability Database (termcap.db) that provides ThinManager 
with the configuration parameters for each thin client model. At each terminal connection, the 
TermCap database is checked and an integrity check is performed. If the configuration does not 
match the terminal specifications, ThinManager may reconfigure the terminal to acceptable 
parameters. 

 

Terminal Capabilities Integrity Check 

The Terminal Capability database can be updated with the current release from the ACP web 
site (www.acpthinclient.com). 

To update the Terminal capabilities database, select Tools>Install New TermCap Database. 
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Install New TermCap Database 

An Open dialog box will be launched.  

Select the new version of the termcap.db and select the Open button. This will install the 
new version. 

Install New Firmware 
ThinManager allows the firmware for the ACP Enabled thin client to be upgraded with the latest 
version from the ACP web site (www.acpthinclient.com).  

Select Tools>Install New Firmware to launch a file browser.  

 

Install New Firmware 

Select the new version of the firmware.acp and select Open. This will install the new version of 
the firmware. 
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Server List Management 
Server List Management is a launching point for the three server wizards. These allow the 
usage of names to identify the computers during configuration without the need of a DNS Server. 
The Server List Wizards are: 

• The Terminal Server List Wizard 

• The ThinManager List Wizard 

• The DNS List Wizard  

Terminal Server List 
Selecting Terminal Server List will launch the Terminal Server List Wizard to allow terminal 
servers to be defined by name. 

 

Terminal Server List Wizard Introduction 

The Terminal Server List Wizard allows each Microsoft Terminal Server to be listed for easy 
selection by name during group and terminal configuration. 

Select Next to continue. 
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Terminal Server List Wizard � Available Server List 

The Available Terminal Server List allows the identification all of the Terminal Servers on the 
network.  

Remove Server clears a highlighted Terminal Server from the list. 

Add Server will launch a window that allows the entry of the Terminal Server name and IP 
address. 

Edit Server will launch a window that allows the change of the Terminal Server name and IP 
address. 

Select the Add Server button to define the terminal servers. 
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Terminal Server List Wizard � Enter a New Terminal Server Definition 

Add Server will launch a window that allows the entry of a Terminal Server name and IP 
address. This allows the terminal servers to be tied to a convenient name without the need of a 
DNS server. Type the name associated with a terminal server in the Terminal Server field, add 
the IP address in the Terminal Server Address field, and select OK. This adds the terminal 
server to the Terminal Server list. 

Select Finish to close the Terminal Server List wizard. 

ThinManager Server List 
Selecting ThinManager Server List will launch the ThinManager Server List Wizard to allow the 
definition of ThinManager Servers. 
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ThinManager Server List Wizard - Introduction 

The ThinManager Server List Wizard begins with an introduction screen.  

Select Next to proceed or click Finish to close. 
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ThinManager Server List Wizard 

The ThinManager Server List is the collection of ThinManager Servers that the terminal will 
communicate with to keep the connection status lights in the ThinManager tree updated. Adding 
ThinManager Servers allows network wide monitoring, control, and management. 

Remove Server clears a ThinManager Server from the list. 

Add Server will launch a window that allows the entry of the ThinManager Server name and IP 
address. 

Edit Server will launch a window that allows the change of the ThinManager Server name and 
IP address. 
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ThinManager Server List Wizard � Enter the New ThinManager Server 

Add Server will launch a window that allows the entry of the ThinManager Server name and IP 
address. This allows the ThinManager servers to be tied to a convenient name without the need 
of a DNS server. Type the name associated with the ThinManager Server in the ThinManager 
Server field, add the IP address in the ThinManager Server Address field, and select OK. This 
adds the ThinManager server to the ThinManager Server list. 

Select Finish to close the ThinManager Server List wizard. 

DNS Configuration 
Selecting DNS Configuration will launch the Domain Name Server Wizard to allow the definition 
of Domain Name Servers. 
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Domain Name Service Wizard � Introduction 

The Domain Name Service Wizard Introduction screen will ask if a DNS server is being used. 

If the System without a DNS server radio button is selected, no configuration is needed. Select 
the Finish button to close the wizard. 

If the System using a DNS server radio button is selected, the Next button will launch the 
Domain Name Service Wizard Configuration screen. 
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Domain Name Server Configuration 

The Add DNS Server button will launch a dialog box that allows a DNS Server to be added to 
the list. 

The Remove DNS Server button will remove a highlighted DNS server from the list. 

The Up and Down arrow keys will change the order of DNS servers used. Highlight a DNS 
server in the list and select the appropriate arrow. 

Selecting the Read DNS Setting from this computer will transfer the DNS settings from the 
current computer into ThinManager.  

The Domain field and the Search Domain field can be filled manually. 

Selecting the Add DNS Server will launch a dialog box that allows the IP address of the DNS 
server to be added. 
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Domain Name Server Configuration � Add DNS Server 

Add the IP address of the DNS server into the DNS Server dialog and select OK. Additional IP 
addresses can be listed by selecting the Add DNS Server button again. 

Select the Finished button when the DNS configuration is done. 

Restore Configuration 
Restore Configuration will allow a backed up ThinManager configuration to be applied to the 
ThinManager Server. Select the desired ThinManager Configuration file in the browse window 
and select Open. The backup copy will overwrite the existing configuration. 
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Restore ThinManager Configuration  

Backup Configuration 
Backup Configuration allows the ThinManager Configuration to be saved. Select a location in 
the browse window and select the Save button to save a backup copy. 

 

Backup ThinManager Configuration 

Synchronize Configuration 
Synchronized Configuration allows the configuration of multiple ThinManager Servers to be 
kept identical so that a terminal will have the same configuration regardless of what 
ThinManager Server the terminal boots from. This is useful for ThinManager Redundancy. 
Selecting Synchronized Configuration will launch the ThinManager Server Configuration 
Synchronization Wizard. 
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Synchronize ThinManager Server Configuration Wizard 

Highlight the configuration source and the configuration destination and select Next.  

Note: You may highlight multiple destinations to synchronize multiple 
ThinManager Servers by holding down the CTRL key while you select them with 
a mouse. 
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Synchronization Differences 

The ThinManager Synchronization Wizard will list the files being updated, including the firmware, 
TermCap database, modules, and the configuration. Select Next to continue.  
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ThinManager Server Synchronization Confirmation 

The ThinManager Server Configuration Wizard will prompt for a conformation of the 
synchronization before proceeding. Select Finish to finalize the changes.  

 

Synchronization Progress Meter 

ThinManager will display the progress of the synchronization as it updates the files. 
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Settings 

 

Server Properties 

The Allow unknown terminals to connect checkbox lets new terminals be added to the 
ThinManager Server. Replacements and new terminals are prevented if this box is un-selected. 

The Require password on unknown terminals checkbox allows a password so that only 
authorized personnel can add terminals to the ThinManager Server. If checked, the password 
fields become active and allow the addition of a password. 

The Enable AutoCreate checkbox allows the auto-creation of an array of terminals as described 
in Auto-Creation of Terminals. The AutoCreate Mask field is the base name used in the array. 

The Enable replacement checkbox gives global permission for terminals to be replaced. Un-
selecting this will prevent all terminals from showing up in the replacement list when a new 
terminal is added, making �Create New Terminal� the only option as shown in Replace or Create 
New Terminal Mode. This feature is also available on the Group and terminal level on the Other 
tab in classic mode and on the first page of the Wizard mode. 

Configure Default Terminal 
Selecting Configure Default will launch the Terminal Properties for a �Default� terminal. This 
default terminal is used as a template for terminals during Auto-Create. Use this terminal to 
configure the auto-create terminals. See �Auto-Creation of Terminals� on page 192 for details on 
Auto-Creation of terminals. 

Reconnect to ThinManager Server 
Selecting Reconnect to ThinManager Server will reinitialize the connection to the selected 
ThinManager Server. 
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Disconnect to ThinManager Server 
Selecting Disconnect to ThinManager Server will stop the connection to the selected 
ThinManager Server. 
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View 

 Status Bar 
The Status Bar shows advice and comments on the bottom of the ThinManager window. When 
the Status Bar command is checked, the Status Bar text is visible. When the Status Bar 
command is unchecked, the Status Bar text is invisible. 

Use Wizards 
Use Wizards allows group and terminal configuration in the Wizard Mode if checked.  

If un-checked, the Group Properties and Terminal Properties will launch in Classic Mode. 

Options 
Selecting Options will launch the Options dialog box. 

 

Options 

The Display �Create New Terminal� dialog for unknown terminals check box, if selected, will 
display the Create New Terminal when new terminals are attached. 

The Minimize to the System Tray checkbox will send the ThinManager icon in the system tray 
when ThinManager is minimized.  

Warn if license will expire within __ day(s) will configure the warning period before license 
expiration. This is useful for time-limited demonstration licenses. 
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 Help 

 Help Topics 
ThinManager has an on-line help file. Selecting this will launch the ThinManager Help file. 

 About ThinManager 
Selecting this command will display a dialog box with ThinManager version information, copyright 
information, and contact information for ThinManager. 
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Adding Thin Client Hardware 
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The Boot Process  
Most ACP Enabled thin clients use a network or LAN boot to transfer the firmware to the 
terminal. This allows for an easy update of the firmware and ensures that all the terminals share 
the same firmware. The exceptions are disk-on-chip terminals that contain the firmware on a 
local storage device. They boot locally before connecting to a ThinManager Server. Disk-on-chip 
terminals will be discussed later at Disk-On-Chip. 

An ACP Enabled thin client goes through a number of steps from the initial power on to the 
complete connection to a terminal server. Understanding this process will aid in terminal 
configuration and troubleshooting.  

The steps are: 

• POST: Once an ACP Enabled thin client is turned on it begins the Power On Self-
Test to examine the hardware and to test the memory.  

• IP Address Assignment: The terminal needs an IP address to connect to the 
network. By default, it receives an IP Address from a DHCP server, but this can be 
changed to use an assigned static IP. This will be discussed later in IP Address 
Assignment 

• ThinManager Server Connection: After receiving an IP address the terminal will 
connect to the ThinManager Server. This is the Boot Server Host as defined in the 
DHCP scope Option 066 or the Primary ThinManager Server defined in the static IP 
address configuration.  

• Firmware Loading: Next the terminal will download the firmware from the 
ThinManager Server.  

• Terminal Configuration Download: Established terminals will receive their 
configuration and proceed. New terminals will need to be defined on the 
ThinManager server, either through the Terminal Configuration Wizard as described 
in Terminal Configuration Wizard or the Create New Terminal method as described 
in Create New Terminal in Classic Mode. 

• ACP Logo Screen: After the terminal receives its configuration, it will display an 
ACP splash screen with the ACP logo.  

• Citrix Connection: Next the terminal will display a Citrix splash screen while it 
makes an ICA connection to the terminal server.  

• NT Login: Next the terminal will display the NT Login dialog box, prompting for a 
valid username and password. If these have been entered into the username and 
password fields on the Sessions tab of ThinManager, the terminal will login 
automatically and display the NT desktop or a defined initial program.  

• NT Session: The terminal is logged onto a session on terminal server.  The terminal 
will pass mouse clicks and keystrokes to the terminal server. The terminal server will 
process the data and send the graphics back to the terminal for display, giving a full 
Windows experience to the user. 
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IP Address Assignment 
ACP Enabled Thin Clients require an IP address to connect to the network. The terminals are set 
by default to use DHCP so that the units can be attached without any necessary configuration. 
The DHCP Server needs to have Option 066 set to the IP address of the ThinManager Server 
and Option 067 needs to set to �firmware.acp�. Information on configuring these can be 
found at DHCP Server Setup. 

A Static IP can be used to give the terminal is IP address. Doing this is the only configuration 
that needs to be done on the terminal. While entering the terminal�s IP address one also enters 
the IP address of the ThinManager Server and subnet information. Information on configuring 
these can be found at Static IP. 

DHCP 
ACP Enabled thin clients use DHCP (Dynamic Host Configuration Protocol) by default. The 
DHCP Server needs two options configured for the terminals. 

 

DHCP Options 

Option 066 Boot Server Host Name must be set to the IP address of the ThinManager Server. 

Option 067 Bootfile Name must be set to firmware.acp. 

Details are at DHCP Server Setup on page 209. 

ACP Enabled thin clients use DHCP (Dynamic Host Configuration Protocol) by default. If they 
have been set to a static IP they can be reset to DHCP from static IP by pressing any key when 
prompted during the boot sequence to open the IP Configuration Menu.  



62 Copyright 1999-2003 © Automation Control Products 

 

IP Configuration Menu - DHCP 

Press the A key to allow a change to DHCP.  

Press D key to set the configuration to DHCP.  

Press S key to save the configuration and continue with the boot process. 

 

Boot Process - Firmware Download 

The terminal will connect to the ThinManager Server and download the firmware. 

Static IP 
Most models allow the usage of static IPs. These are set by interrupting the boot process to 
launch the IP Configuration Menu and adding the static IPs.  
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Boot Process - Press Any Key Prompt 

To set the terminal to use a static IP, press any key at the appropriate moment of the boot 
sequence. 

 

IP Configuration Menu � Static IP 

Press the A to allow the client IP to change from DHCP. 

Type in the static IP address for the client, including the separating periods and press the Enter 
key. 
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IP Configuration Menu - Options 

Once the Terminal has a static IP assigned, the IP Configuration Menu will be shown to allow the 
setting of other values. 

• (A) Terminal IP Address � This should be a unique address for the terminal. 

• (B) Primary ThinManager Server IP Address � This should be a unique address 
for your main ThinManager Server. 

• (C) Secondary ThinManager Server IP Address - The Secondary ThinManager 
field allows the terminal to use two ThinManager Servers. If the terminal cannot 
connect to the Primary ThinManager Server, it will connect to the Secondary 
ThinManager Server to receive its configuration. If you are not using a Secondary 
ThinManager Server, set the IP address to 0.0.0.0. 

• (D) Router IP Address � Fill in the IP address of the router or gateway, if one is 
being used. If not this should be set to 0.0.0.0. 

• (E) Subnet Mask � Set this to your subnet mask. 255.255.255.0. is a standard 
setting. 

• (F) Password Status � Allows a password to be set to prevent unauthorized people 
from changing the configuration. 

• (H) Help � Will launch a Help to explain the IP Configuration Menu. 

• (Q) Abort Changes and Exit � This will cancel any setting changes and let the 
terminal continue to boot with the old settings. 

• (S) Save Changes and Exit � This will apply any changes and allow the terminal to 
continue to boot with the new settings. 

Type the letter of the desired setting and type the IP address, with periods. Press the Enter key 
on the keyboard to accept each change. 

Once configured the terminal will connect to the ThinManager Server and download the firmware 
and configuration. 
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Configuring New Hardware 
The configuration of terminals is done on the ThinManager Server, and is not done on each 
individual terminal. When a new, undefined ACP Enabled Thin Client is first connected to a 
ThinManager Server one of three things will happen. 

• If the ThinManager Server has no terminals that are configured and offline, then the 
terminal will go into the Create New Terminal Mode and launch the Terminal 
Configuration Wizard on the ThinManager Server. Once the terminal is configured 
on the Terminal Server it will automatically download its configuration upon boot up. 

• If the ThinManager Server has terminals that are created and offline, the terminal will 
go into Replace or Create Mode and list the offline terminals that are available for 
selection. Once a configuration is selected, the terminal will take that identity. During 
any following boot up the terminal will automatically download its configuration. 

• A third scenario is to use the Auto-Create Terminal Mode to create an array of 
terminals. Details can be found at Auto-Creation of Terminals. 

Create New Terminal Mode 
Turning on a terminal for the first time will initiate the Create New Terminal mode if: 

• No terminals are defined in ThinManager  

• Or, all the defined terminals are currently connected 

• Or, if all the defined terminals that are turned off have the Allow This Terminal To 
Be Replaced If Off Line check box unselected. 

 

Create New Terminal Mode Screen 

When a terminal enters the Create New Terminal Mode, the terminal will launch the Terminal 
Configuration Wizard on the ThinManager Server as shown in on page 67. The terminal will 
display a screen indicating that it will wait until the configuration is finished before progressing 
further.  

Replace or Create New Terminal Mode 
Turning on a terminal for the first time will initiate the Replace or Create New Terminal Mode if 
one or more of the defined terminals are offline and they have the Allow This Terminal To Be 
Replaced If Off Line check box selected. 
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Replace or Create Mode 

The screen will display all the offline terminals that the terminal can replace. Highlight the desired 
terminal name and press the Enter button. The terminal will retrieve the selected configuration 
and assume its identity.  

Auto-Create Mode 
Turning on a terminal for the first time will initiate the Replace or Auto-Create Terminal mode if 
selecting the Auto-Create check box on the Server Property and having the �Default� terminal 
configured enables the Auto-Create mode.  

 

AutoCreate Mode 

If Auto-Create Terminal is selected from the Terminal list, the ThinManager Server will create 
the terminal as a member of the Auto-Create array as described in Auto-Creation of Terminals. 
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Configuration Wizards 

ACP ThinManager version 2.4 introduces Configuration Wizards to simplify the creation and 
configuration of ACP Enabled Thin Clients.  

The Wizard is the default method of configuration, but it can be turned off by going to the menu 
bar of ThinManager and un-checking the View>Use Wizard option. 

The Wizard will automatically launch from ThinManager when: 

• A new ACP Enabled Thin Client is connected to ThinManager and no terminals are 
configured, or 

• A new ACP Enabled Thin Client is connected to ThinManager and no terminals are 
offline, or 

• A new ACP Enabled Thin Client is connected to ThinManager and Create New 
Terminal is selected as the option on the terminal. 

The Wizard can be launched by: 

• Selecting a ThinManager Server in the ThinManager tree and selecting Edit>Add 
Group or Edit>Add Terminal from the menu bar, or  

• Selecting a ThinManager Server in the ThinManager tree, right�clicking on the 
ThinManager Server icon, and selecting the Add Group or Add Terminal option.  

• Selecting a Group in the ThinManager tree, right�clicking on the Group icon, and 
selecting the Add Terminal option. This puts the terminal in that group. 

The wizards for the Terminal Server List, ThinManager Server List, and Domain Name Server 
List can be launched by selecting ThinManager Server>Server List Management from the 
menu bar. 
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Group Configuration Wizard 

Group Name Configuration 

 

Group Configuration Wizard � Group Name 

When a Group is first added, giving it a name is the first priority. Use numbers, letters, hyphens (-
) and underscores (_), but don�t use spaces or other characters. 

Selecting the Allow Terminals in this group to be replaced if offline checkbox will allow all 
members of the group to show up in the replacement list during a new terminal connection. 

Select Next to continue or Cancel to quit. 
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Group Connection Type Configuration 

 

Group Configuration Wizard � Connection Type 

Thin clients use a communication protocol to connect to the Terminal Servers. The Citrix ICA 
protocol can be provided by the Citrix Device Services that is included with ThinManager, or by 
Citrix MetaFrame that is sold as a separate product. Select whether you are using MetaFrame 
and select the Next button. 

If you choose No, the next dialog will allow the selection of Terminal Servers as shown in Group. 

If you choose Yes, for using the MetaFrame purchased separately, the next dialog will allow the 
configuration of Citrix MetaFrame properties. 
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Citrix MetaFrame Configuration 

 

Group Configuration Wizard � Citrix MetaFrame Configuration 

Citrix MetaFrame allows increased encryption in the ICA protocol. Select a level from the 
Encryption drop-down box. 

Citrix MetaFrame has a feature called Published Applications. If you are using Published 
Applications, select the Yes radio button, then select the Next button to continue to the Citrix 
Published Application dialog. 

If you are not using Published Applications, select the No radio button, then select the Next 
button to continue to the Terminal Server Selection dialog as shown in Group Terminal Server 
Selection. 
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Group Configuration Wizard � Citrix Published Applications 

Enter the name of the desired Published Applications in the field. Do not use spaces in the name 
when creating a Published Application for Terminal Services. 

Citrix MetaFrame uses ICA Browsers as part of the system. Because the ICA client may have 
problems detecting an ICA browser across a router or switch, a field is provided for entering the 
name of an ICA browser. 
Select the Finish button to create the Group, or select the Next button to configure more 
options. 



72 Copyright 1999-2003 © Automation Control Products 

Group Terminal Server Selection 

 

Group Configuration Wizard � Group Terminal Server Selection 

If Published Applications are not being used, the terminal will need to be assigned to a Terminal 
Server. The Terminal Server is a server that allows the terminals to logon and run the 
applications in independent sessions. 

Select the Edit Server List button to launch the Terminal Server List Wizard. 
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Terminal Server List Wizard 

 

Terminal Server List Wizard 

The Terminal Server List Wizard allows each Microsoft Terminal Server to be listed for easy 
selection during group and terminal configuration. 

Select Next to continue. 
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Available Terminal Server List 

The Available Terminal Server List allows the identification all of the Terminal Servers on the 
network.  

Remove Server clears a highlighted Terminal Server from the list. 

Add Server will launch a window that allows the entry of the Terminal Server name and IP 
address as shown next. 

Edit Server will launch a window that allows the change of the Terminal Server name and IP 
address. 

Select the Add Server button to define the terminal servers. 
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New Terminal Server Definition 

Add Server will launch a window that allows the entry of the Terminal Server name and IP 
address. This allows the terminal servers to be tied to a convenient name without the need of a 
DNS server. Type the name associated with a terminal server in the Terminal Server field, add 
the IP address in the Terminal Server Address field, and select OK. This adds the terminal server 
to the Terminal Server list. 

Select Finish to close the Terminal Server List wizard and return to the Group Wizard. 
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Group Configuration Wizard � Terminal Server Selection 

Each Terminal Server that was identified in the Terminal Server List Wizard will initially appear in 
the Available Terminal Server box on the left.  

To have the Group use a Terminal Server, highlight it in the list on the left and click the right 
arrow button. This will put the Terminal Server into the Selected Terminal Server list on the 
right. The Group will use all the Selected Terminal Servers as Terminal Servers that it can login 
to. 

The Terminal Server on the top of the Selected Terminal Server List will be the Primary 
Terminal Server, the first Terminal Server that the terminal will attempt to login to. To change 
the order of the Terminal Servers in the list, highlight a Terminal Server and use the Up arrow 
button and the Down arrow button to move it up or down in the list. 

The Enforce Primary Terminal Server Connection will cause a terminal to return to the 
primary terminal server whenever that server is available. 

Select the Next button to continue configuration or select the Finish button to complete the 
Group configuration. 
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Group Login Configuration 

 

Group Configuration Wizard � Login Information 

It is recommended that each terminal should login to a Terminal Server with a unique profile. For 
this reason, the Group Username, Password, and Domain are inactive. These need to be set 
individually during the Terminal Configuration as shown in Terminal Login Configuration. 

The Initial Program loads the entered program instead of the Windows desktop when the 
terminal connects to the Terminal Server. If the Initial Program is closed on the terminal, the 
session on the Terminal Server will end and the ACP Enabled Thin Client will reconnect to the 
Terminal Server and re-launch the Initial Program. This effectively makes the Initial Program the 
only program. 

To use the Initial Program, enter the path to the program in the Initial Program field as shown it 
the example. 

Select the Next button to continue configuration or select the Finish button to complete the 
Group configuration. 
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Group Video Configuration 

 

Group Configuration Wizard � Video Configuration 

The Group Video Resolution Page has a drop-down box that allows the video resolution to be 
set for all members of the Group. 

The standard terminal connection uses a 256-color depth. The 64K-color depth is available by 
using Citrix MetaFrame 1.8 FR1, or greater. 

Select the Next button to continue configuration or select the Finish button to complete the 
Group configuration. 
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Group Module Configuration 

 

Group Configuration Wizard � Module Selection 

A Module is a component of the ACP Enabled Thin client operating system that is not needed 
for the basic functionality, but may be desired for advanced functionality. These features include 
Touch Screen drivers, serial mouse drivers, High Speed Serial drivers, Shared Keyboard and 
Mouse, and Instant Failover. 

To add a Module to a Group, select the Add� button and select the Module from the list. 
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Group Configuration Wizard � Module List 

Selecting the Add� button will launch the list of available modules in the �Attach Module to 
Terminal� window. 

Highlight the desired module and select OK. 

Highlighting the module and selecting the Configure button can change some module 
parameters. Select the parameter to change, select the new value in the drop-down list and click 
the Set button.  Details are found in Modules in Depth 

Select the Next button to continue configuration or select the Finish button to complete the 
Group configuration. 
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Group ThinManager Server Monitoring  

 

Group Configuration Wizard � Monitoring Configuration 

The ThinManager Server Monitor List defines what Thin Manager Servers the terminal will 
communicate with to keep monitoring light status current. 

Select the Edit Server List button to launch the ThinManager Server List Wizard as shown in 
ThinManager Server List Wizard. 

Select the Next button to continue configuration or select the Finish button to complete the 
Group configuration. 



82 Copyright 1999-2003 © Automation Control Products 

ThinManager Server List Wizard 

 

ThinManager Server List Wizard Introduction 

The ThinManager Server List Wizard begins with an introduction screen.  

Select Next to proceed or click Finish to return to the Group Configuration Wizard. 
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ThinManager Server List Wizard � ThinManager Server List 

The ThinManager Server List is the collection of Thin Manager Servers the terminal will 
communicate with to keep monitoring light status current. These will appear in the ThinManager 
Server tree pane and show Terminal, Group, and Terminal Server connection status. Adding 
ThinManager Servers allows network wide control and management. 

Remove Server clears a ThinManager Server from the list. 

Add Server will launch a window that allows the entry of the ThinManager Server name and IP 
address. 

Edit Server will launch a window that allows the change of the ThinManager Server name and 
IP address. 
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ThinManager Server List Wizard � Enter New ThinManager Server 

Add Server will launch a window that allows the entry of the ThinManager Server name and IP 
address. This allows the ThinManager servers to be tied to a convenient name without the need 
of a DNS server. Type the name associated with the ThinManager Server in the ThinManager 
Server field, add the IP address in the ThinManager Server Address field, and select OK. This 
adds the ThinManager server to the ThinManager Server list. 

Select Finish to close the ThinManager Server List wizard and return to the Group Wizard. 
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Group Monitoring Configuration 

 

Group Configuration Wizard � Monitoring Configuration 

ACP Enabled Thin Clients continuously monitor the Terminal Server to make sure that it stays 
online. If the terminal server goes offline, the terminal will disconnect and connect to the next 
Terminal Server that it was assigned to in the Group Terminal Server Selection. The Monitoring 
Connection sets the frequency that the monitor occurs. 

Use the Monitor Interval radio buttons to use a default frequency or select Custom and choose 
a setting of your own. 
Monitor Interval is the interval that the monitor checks occur. 

Monitor Timeout is the time the terminal will wait for a response from the terminal server. 

Monitor Retry is the number of times the monitor check will be tried. 

Primary Up Delay Multiplier is the number that generates the Primary Up Delay time. 

Primary Up Delay is a delay added (usually 30 to 60 seconds) to allow a Terminal Server to get 
fully booted before the terminal will try to login. This time period is equal to the Monitoring 
Interval times the Primary Up Delay Multiplier. 

A fast setting of the Monitor Connection will detect Terminal Server failure quickly. However, the 
faster the setting is, the more sensitive it is and it may drop the Terminal Server when it was 
busy and not offline. Setting the Monitoring Connection to a slower setting gives the Terminal 
Server more time to respond when it is busy. 
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Select the Finish button to complete the Group configuration. 
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Terminal Configuration Wizard 
Configuring a terminal is just like configuring a Group.  

If a terminal is created in a Group, or added to a group, it will have the option of using the group 
configuration. This is controlled with a Use Group Property checkbox on each wizard page. The 
following section shows the terminal with the Use Group Property checkbox selected and the 
options grayed out. To change the configuration from the Group, un-select the checkbox and use 
the setting of your choice. A terminal created outside a Group and not added to a Group, will not 
display the �Use Group Property� checkboxes. 

The Terminal Creation Wizard can be launched by either: 

• Selecting a ThinManager Server in the ThinManager tree and selecting Edit>Add 
Terminal from the menu bar, or  

• Selecting a ThinManager Server in the ThinManager tree, right�clicking on the 
ThinManager Server icon, and selecting the Add Terminal option.  

• Selecting a Group in the ThinManager tree, right�clicking on the Group icon, and 
selecting the Add Terminal option. This puts the terminal in that group. 
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Terminal Name Configuration 

 

Terminal Configuration Wizard � Terminal Name 

When a Terminal is first created, giving it a name is the first priority. Use numbers, letters, 
hyphens (-), and underscores (_), but don�t use spaces or other characters. 

It can be added to a Group by selecting the Group name in the Group drop-down box. Terminals 
added to a Group will be assigned the Group properties, but they can have the Group properties 
changed to individual settings by un-checking a use Group Property checkbox on each wizard 
page. 
Select Next to continue or Cancel to quit. 
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Terminal Hardware Configuration 

 

Terminal Configuration Wizard � Hardware Configuration 

Select the make and model of the ACP Enabled Thin Client from the drop-down boxes. These 
parameters are from the Terminal Capability database (TermCap data base) as described in 
Install New TermCap Database.  

If you do not know what model it will be, leave the default. When a terminal is connected and 
receives this configuration, ThinManager will update the configuration to match the actual 
settings. 
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Terminal Connection Type 

 

Terminal Configuration Wizard � Connection Type 

Thin clients use a communication protocol to connect to the Terminal Servers. The Citrix ICA 
protocol can be provided by the Citrix Device Services that is included with ThinManager, or by 
Citrix MetaFrame that is sold as a separate product. Select whether you are using MetaFrame 
and select the Next button. 

If you choose No, the next dialog will allow the selection of Terminal Servers as shown in 
Terminal Server Selection 
If you choose Yes, for using the MetaFrame purchased separately, the next dialog will allow the 
configuration of Citrix MetaFrame properties as shown in Citrix MetaFrame Configuration. 
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Terminal Configuration Wizard � Citrix MetaFrame Configuration 

Citrix MetaFrame allows increased encryption in the ICA protocol. Select a level from the 
Encryption drop-down box. 

Citrix MetaFrame has a feature called Published Applications. If you are using Published 
Applications, select the Yes radio button, then select the Next button to continue to the Citrix 
Published Application dialog. 
If you are not using Published Applications, select the No radio button, then select the Next 
button to continue to the Terminal Server Selection dialog. 
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Terminal Configuration Wizard � Citrix Published Applications 

Enter the name of the desired Published Applications in the Published Applications field. Do 
not use spaces in the name when creating a Published Application for Terminal Services. 

Citrix MetaFrame uses ICA Browsers as part of the system. Because the ICA client may have 
problems detecting an ICA browser across a router or switch, The ICA Browser field is provided 
for entering the name of an ICA browser. 
Select the Finish button to create the Group, or select the Next button to configure more 
options. 
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Terminal Server Selection 

 

Terminal Configuration Wizard � Terminal Server Selection 

If Published Applications are not being used, the terminal will need to be assigned to a Terminal 
Server. The Terminal Server is a server that allows the terminals to logon and run the 
applications in independent sessions. 

Select the Edit Server List button to launch the Terminal Server List Wizard.  
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Terminal Server List Wizard 

 

Terminal Server List Wizard - Introduction 

The Terminal Server List Wizard allows each Microsoft Terminal Server to be listed for easy 
selection during terminal configuration. 

Select Next to continue. 
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Terminal Server List Wizard � Available Terminal Server List 

The Available Terminal Server List allows the identification all of the Terminal Servers on the 
network.  

Remove Server clears a highlighted Terminal Server from the list. 

Add Server will launch a window that allows the entry of the Terminal Server name and IP 
address as shown next. 

Edit Server will launch a window that allows the change of the Terminal Server name and IP 
address. 

Select the Add Server button to define the terminal servers. 
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Terminal Server List Wizard � Add New Terminal Server 

Add Server will launch a window that allows the entry of the Terminal Server name and IP 
address. This allows the terminal servers to be tied to a convenient name without the need of a 
DNS server. Type the name associated with the terminal server in the Terminal Server field, add 
the IP address in the Terminal Server Address field, and select OK. This adds the terminal 
server to the Terminal Server list. 

Select Finish to close the Terminal Server List wizard and return to the Terminal Wizard. 
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Terminal Configuration Wizard � Terminal Server Selection 

Each Terminal Server that was identified in the Terminal Server List Wizard will initially appear in 
the Available Terminal Server box on the left.  

To have the terminal use a Terminal Server, highlight it in the list on the left and click the right 
arrow button. This will put the Terminal Server into the Selected Terminal Server list on the 
right. The terminal will use all the Selected Terminal Servers as Terminal Servers that it can login 
to. 

The Terminal Server on the top of the Selected Terminal Server List will be the Primary 
Terminal Server, the first Terminal Server that the terminal will attempt to login to. To change 
the order of the Terminal Servers in the list, highlight a Terminal Server and use the Up arrow 
button and the Down arrow button to move it up or down in the list. 

The Enforce Primary Terminal Server Connection will cause a terminal to return to the 
primary terminal server whenever that terminal server is available. 

Select the Next button to continue configuration or select the Finish button to complete the 
terminal configuration. 
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Terminal Login Configuration 

 

Terminal Configuration Wizard �Terminal Login Configuration 

Note: It is recommended that each terminal should login to a Terminal Server 
with a unique profile.  

If the Username, Password, and Domain fields are filled with a valid Microsoft user account, 
ThinManager will pass this information to the Microsoft Terminal Server when the ACP Enabled 
Thin Client connects, letting the terminal login automatically. 

If the Username, Password, and Domain fields are left blank, or are filled with invalid data, the 
Microsoft Windows login window will be presented on the terminal and the user will need to login 
manually. 

The Initial Program loads the entered program instead of the Windows desktop when the 
terminal connects to the Terminal Server. If the user closes the Initial Program on the terminal, 
the session on the Terminal Server will end and the ACP Enabled Thin Client will reconnect to 
the Terminal Server and re-launch the Initial Program. This effectively makes the Initial Program 
the only program. 

To use the Initial Program, enter the path to the program in the Initial Program field. 

Select the Next button to continue configuration or select the Finish button to complete the 
Terminal configuration. 
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Terminal Video Configuration 

 

Terminal Configuration Wizard � Video Configuration 

The Video Resolution Configuration has a drop-down box that allows the video resolution to 
be set for the terminal. 

The standard terminal connection uses a 256-color depth. The 64K-color depth is available by 
using Citrix MetaFrame 1.8 FR1, or greater. 

Select the Next button to continue configuration or select the Finish button to complete the 
Terminal configuration. 
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Terminal Module Configuration 

 

Terminal Configuration Wizard � Module Selection 

A Module is a component of the ACP Enabled Thin client operating system that is not needed 
for the basic functionality, but may be desired for advanced functionality. These features include 
Touch Screen drivers, serial mouse drivers, High Speed Serial drivers, Shared Keyboard and 
Mouse, and Instant Failover. 

There are four icons that can be used for modules in the Terminal Properties. 

1.  represents properties assigned by the Group. 

2.  represents properties that are changed on the terminal from the Group settings. 

3.  represents a terminal that isn�t using an assigned Group module. The �Use 
Modules from Group� checkbox was un-selected. 

4. No icon indicates that the module was added to the terminal and not the group. 

To add a Module to a Terminal, select the Add� button and select the Module from the list. 
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To remove a Group Module, uncheck the Use Group Properties checkbox. This will put the red 
circle on the icon as an indicator. 

Highlighting the module and selecting the Configure button can change some module 
parameters. Select the parameter to change, select the new value in the drop-down list and click 
the Set button. A yellow plus sign will be displayed on the icon as an indicator. 

Select the Next button to continue configuration or select the Finish button to complete the 
Terminal configuration. 

ThinManager Server Monitor List 

 

Terminal Configuration Wizard � ThinManager Server Monitor List 

The ThinManager Server Monitor List defines what Thin Manager Servers the terminal will 
communicate with to keep monitoring light status current. 

Select the Edit Server List button to launch the ThinManager Server List Wizard as shown in 
Terminal. 

Select the Next button to continue configuration or select the Finish button to complete the 
Terminal configuration. 
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Terminal Monitoring Configuration 

 

Terminal Configuration Wizard � Monitoring Configuration 

ACP Enabled Thin Clients continuously monitor the Terminal Server to make sure that it stays 
online. If the terminal server goes offline, the terminal will disconnect and connect to the next 
Terminal Server that it was assigned to in the Terminal Server Selection as shown in Terminal 
Server Selection. The Monitoring Connection sets the frequency that the monitor occurs. 

Use the Monitor Interval radio buttons to use a default frequency or select Custom and choose 
a setting of your own. 
Monitor Interval is the interval that the monitor checks occur. 

Monitor Timeout is the time the terminal will wait for a response from the terminal server. 

Monitor Retry is the number of times the monitor check will be tried. 

Primary Up Delay Multiplier is the number that generates the Primary Up Delay time. 

Primary Up Delay is a delay added (usually 30 to 60 seconds) to allow a Terminal Server to get 
fully booted before the terminal will try to login. This time period is equal to the Monitoring 
Interval times the Primary Up Delay Multiplier. 

A fast setting of the Monitor Connection will detect Terminal Server failure quickly. However, the 
faster the setting is, the more sensitive it is and it may drop the Terminal Server when it was 
busy and not offline. Setting the Monitoring Connection to a slower setting gives the Terminal 
Server more time to respond when it is busy. 
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Select the Finish button to complete the terminal configuration. 
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Classic Mode of Group Configuration 
The Classic Mode is the method of creating and configuring Groups and Terminals that was 
introduced in ThinManager 1.0. This method uses Property Tabs instead of a Wizard. The two 
modes are interchangeable.  

Note: ThinManager uses the Classic Mode when View>Use Wizards is 
unselected. 

The use of Groups provides several advantages. 
• Groups help organize the ThinManager Tree and allow the terminals to use less 

space when the Groups are collapsed. 

• Terminals added to a Group receive the Group configuration, speeding up 
configuration and deployment. 

Adding Groups 
To add a new group either: 

• Select Edit>Add Group from the ThinManager menu bar.  

• Right-click a ThinManager Server icon in the ThinManager tree window and select 
Add Group.  

This will launch the Create New Group dialog box.  

 

Classic Mode � Add New Group 

Type the chosen name for the group in the Name field in the Create New Group dialog box. 

Select OK to continue. This will launch the Group Properties dialog box. 
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Group Identity 
When a new group is created, the Identity tab of the Group Properties dialog box will be 
displayed.  

 

Classic Mode � Group Identity Tab 

The Identity tab of the Group Properties dialog box contains the name of the group. 

The next step in defining a group is to assign it to a Windows Terminal Server. This is done on 
the Session tab. 

Select the Session tab to continue. 

Note: A change or modification of group properties will affect terminals after they 
reboot. 

Group Session 
The Session tab of the Group Properties dialog box contains the field for the IP address for the 
Terminal Server. The Group can be assigned to multiple terminal servers to provide backup 
terminal servers for failover by listing several terminal server IP addresses, separated by a semi-
colon (;). 

Note: The Classic Mode requires the use of IP Addresses, not names, unless 
one is using a DNS server.  
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Classic Mode � Group Session Tab 

Select the Server radio button and enter the IP address (or DNS names if using DNS) of the 
desired Windows NT/2000 Terminal Server that the terminal is to connect to. One instance of 
ThinManager Server can manage the connection of thin clients to a number of terminal servers 
by assigning different groups or terminals to different terminal servers. 

Failover is enabled by listing the IP addresses of the terminal servers, in order of preference, 
separated by semi-colons (spaces are optional). See �Failover Overview� on page 20 for details. 

• Published Application is an advanced function for Citrix MetaFrame users. 
• Filling in the Username and Password fields will assign the same Windows NT 

User Profile to the entire group. 

Note: It is recommended that the Username and Password be left blank in the 
Group Properties and assigned individually in the Terminal Properties so that 
each user will login with a unique username. 

• The Domain field assigns the terminal to a Windows domain. 

• The Initial Program field is a security feature. If the path to an executable file is 
entered into the Initial Program field, only the specific program will launch upon 
boot. If the initial program is closed, the ICA connection will close and reconnect with 
the initial program running again. This tool is useful for enforcing an operation of a 
single program, such as an HMI or SCADA program.  

• To start several initial programs that would allow closure or the running of other 
programs, use the Startup folder in Windows. Closing a program launched from 
Startup will not close and reconnect the session. 

• The ICA Browser field is a back-up function for Citrix MetaFrame users. If the 
terminal is unable to browse the ICA network (find the server), the ICA Browser field 
can specify a server IP address. This might be used with server farms or published 
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applications are across a switch or a router. See your Citrix documentation for help 
with server farms and published applications. 

• The Encryption drop-down box allows Citrix MetaFrame users to configure 
SecureICA encryption. 

Note: Each of these settings can be changed for individual terminals in the 
Terminal Properties.  

OK will accept the changes and close the dialog box when selected.  

Cancel will cancel the addition or change of the group when selected. 

Help will launch ThinManager Help when selected. 

Group Video 
The Video tab of the Group Properties dialog box contains the settings for the video properties. 

 

Classic Mode � Group Video Tab 

• Video Mode is a drop-down box that allows you to select a video resolution for the 
group. Standard thin client connections use the 256-color resolution. To use the 64K 
color depth one must use Citrix MetaFrame 1.8, Feature Release 1 or greater. 

• Custom Video Modelines is a field for scripts that provide support for certain non-
standard monitors. If the standard video modelines do not work, please contact your 
technical support for assistance with this feature. 

Note: Each of these settings can be changed for individual terminals in the 
Terminal Properties.  

OK will accept the changes and close the dialog box when selected.  

Cancel will cancel the addition or change of the group when selected. 
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Help will launch ThinManager Help when selected. 

Group Modules 
The Modules tab of the Group Properties dialog box contains the settings for adding modules. 
Modules are software components that can be added to the firmware to increase the functionality 
of the terminal. Modules include touch screen drivers, sound drivers, and special device drivers. 
Some modules are included with ThinManager and are registered automatically during 
ThinManager installation. Other modules are obtained separately from Automation Control 
Products and need to be installed. 

 

Classic Mode � Group Modules Tab 

Selecting the Add� button will launch an Attach Modules window. 

Selecting OK will accept the changes and close the dialog box.  

Selecting Cancel will cancel the addition or change of the group. 

Selecting Help will launch ThinManager Help. 

See �Error! Reference source not found.� on page Error! Bookmark not defined. for more 
details on modules 

Attaching a Module 
Modules are attached from the Modules tab of the Group Properties by selecting the Add� 
button. This will launch an Attach Module dialog box. 
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Attach Group Module  

This shows all the registered modules. Highlight the desired module and select OK. This module 
will be added to the list on the Module tab and load on the next terminal reboot. 

 

Group Modules 

This shows a number of modules attached to members of the group. These modules will load 
when the terminal boots. 
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Group DNS 
The DNS tab of the Group Properties dialog box contains settings for using a Domain Name 
System (DNS) server. This will allow the use of DNS names to identify computers. 

 

Classic Mode � Group DNS Tab 

• DNS Server is a field for the IP address of a DNS server.  

• Domain is a field for the DNS domain name. 

• Search Domain will add the contents of the field as a prefix to any DNS searches.  

• The Read DNS settings from server button will load the DNS server settings from 
the ThinManager server into the DNS Server field. 

Note: Each of these settings can be changed for individual terminals in the 
Terminal Properties. 

OK will accept the changes and close the dialog box when selected.  

Cancel will cancel the addition or change of the group when selected. 

Help will launch ThinManager Help when selected. 

Group Monitoring 
The Monitoring tab of the Group Properties dialog box contains parameters related to Failover. 
An ACP Enabled thin client monitors the availability of its terminal server, and will disconnect the 
session if the server is down. These parameters are configurable. 
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Classic Mode � Group Monitoring Tab 

Note: The Wizard Mode allows custom settings as well as a Fast, Medium and 
Slow rate. The Classic Mode only uses custom settings. 

• Monitor Interval sets the frequency that the terminal checks to see if the terminal 
server is connected.  

Note: Setting this value low will provide a quick detection of server failure. 
Setting it too low may end the ICA connection due to high network traffic or a 
short network interruption instead of a server failure.  

• Monitor Timeout sets the amount of time that the terminal will wait until retrying the 
server connection. 

• Monitor Retry sets the number of times that the terminal will retry the server before 
disconnecting the server connection. 

• The Enforce Primary field affects the return of a terminal back to its originally 
assigned terminal server. If Yes is selected, a terminal that has failed over to a 
secondary server will reconnect to the primary server once it returns online. If No is 
selected, a terminal that has failed over to a secondary server will remain connected 
to the secondary server, even when the primary server returns online. 

• Primary Up Delay is the number of seconds the terminal will wait to reconnect to 
the primary after it has detected it. This is included because the terminal can detect 
the primary before the primary is available for session connections. 

• The # secs field is the interval of time between when the primary terminal server 
returns online and when terminals will switch back to it with Enforce Primary. Its 
value equal to the Monitor Interval times the Primary Up Delay. This value should 
be at least 30 seconds 
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• The ThinServer field allows affects the monitoring lights on multiple ThinManager 
Servers. Any ThinManager Server in this field will monitor the status of the terminals 
to update the monitoring lights on the ThinManager tree. 

Note: Each of these settings can be changed for individual terminals in the 
Terminal Properties.  

OK will accept the changes and close the dialog box when selected.  

Cancel will cancel the addition or change of the group when selected. 

Help will launch ThinManager Help when selected. 

Other Group Properties 
The Other tab of the Group Properties dialog box contains miscellaneous settings. 

 

Classic Mode � Group Other Tab 

• Allow this terminal to be replaced if offline allows a terminal to be replaced 
quickly in case of failure.  

Note: There is a global Enable Replacement on the Server Properties dialog 
box.  

• Disable this terminal. On bootup, it will display a message and halt is a quick 
way to disable access to a terminal. To disable a group of terminals, select this box 
and reboot the group (see �Rebooting a Group� on page 114. This will disable the 
terminals and deny access to a session. It does not end the sessions; it just prevents 
access to them. Clearing the check box will allow a disabled boot to proceed. 

• Terminate the ICA client on monitoring connection loss: is a legacy command. It 
will terminate the ICA connection if the connection to the ThinManager Server is lost. 
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This check box relates to the client/ThinManager Server connection and not the 
client/terminal server connection. It is not used with the current failover method.  

• Reboot the terminal when the ICA connection is lost is a legacy command. 
When selected, the terminal will reboot each time the ICA connection is lost. This 
can interfere with failover because failover does not require a reboot. Some network 
configurations may use this when the DHCP Server is the same machine as the 
terminal server. 

Note: Each of these settings can be changed for individual terminals in the 
Terminal Properties.  

OK will accept the changes and close the dialog box when selected.  

Cancel will cancel the addition or change of the group when selected. 

Help will launch ThinManager Help when selected. 

Modifying Groups 
Modifying makes changes to group configuration such as touch screen usage, video resolution, 
or to designated servers.  

To modify a group either: 

• Highlight the group in the ThinManager tree by clicking on the group name or icon 
and select Edit�Modify from the ThinManager menu bar. 

• Right-click on the group icon in the ThinManager tree and select Modify. 
• Double-click on a group icon in the ThinManager tree. 

The Group Properties window will launch.  

You can modify the group by: 

• Changing the server on the Sessions tab. 

• Changing a group username and password on the Sessions tab 

• Changing the terminal video configuration on the Video tab.  

• Adding or removing modules on the Module tab. 

• Changing the DNS and domain settings on the DNS tab. 

• Changing the monitoring frequencies on the Monitoring tab. 

• Changing the reboot options on the Other tab.  

Make the modifications desired and select OK to close the Group Properties box. 

Renaming a Group 
Renaming groups is accomplished by either : 

• Highlighting the Group and selecting Edit>Rename 

• Right-clicking the Group and selecting Rename 

• The same way that files or directories are renamed in Windows Explorer. Single-
click twice on the group name. This will draw a box around the name and highlight it. 
Type in the new group name. 
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Renaming a Group 

Tip on single clicking twice: Click once to highlight the name, move the mouse 
slightly and click again. This will prevent Windows from confusing the two single 
clicks with a double click. 

Deleting a Group 
A group can be deleted from the ThinManager Server by: 

• Highlighting the group in the ThinManager tree pane and selecting Edit�Delete 
from the ThinManager menu bar.  

• Highlighting the group in the ThinManager tree pane pressing the Delete key.  

• Right-clicking a group icon in the tree pane of ThinManager and selecting Delete 
Group.  

When a group is deleted, the option is given to delete all the group�s terminals or to move the 
terminals under the server without a group. 

Rebooting a Group 
A group can be rebooted by:  

• Highlight a group in the tree pane of ThinManager. Select Tools>Reboot Terminals 
from the ThinManager menu bar. This will reboot all the terminals in the highlighted 
group. This will reboot all the terminals in all the groups on the server if the server is 
highlighted when you selected Tools>Reboot Terminals.  

• Right-clicking a group icon in the tree pane of ThinManager and selecting Reboot 
Terminals. This will reboot all the terminals in the group. 
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Create New Terminal in Classic Mode 
A new terminal can be created with the Create New Terminal Dialog Box. This can be opened 
by: 

• Selecting Edit>Add Terminal from the ThinManager menu bar 

• Or right-clicking a ThinManager Server or Group in the tree of the ThinManager 
Server and selecting Add Terminal. 

• Turning on a terminal for the first time when no terminals defined in ThinManager  

• Selecting Create New Terminal from the terminal selection list as shown in Replace 
or Create New Terminal Mode. 

The thin client monitor will display the text �Please Wait While Terminal is Defined on Server�. 
This server is the ThinManager server specified by the DHCP Boot Server Host Name or Static 
IP. 

 

ACP Network Boot Screen � Wait for Definition 

The Create New Terminal dialog box will be launched on the ThinManager server. 
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Classic Mode � Create New Terminal  

The terminal configurations include:  

• The Server field This is automatically filled with the name of the ThinManager 
Server one is creating a terminal on. 

• The Name field has a space for the name for the terminal. Type the desired name in 
this field, using letters, numbers, hyphens (-), and underscores (_) only. 

• The Term ID or Terminal Identifier is a unique number, the MAC address of the 
network card of the terminal, that ThinManager inserts into the Term ID field uses to 
identify the terminal.  

• If a terminal is being pre-created in Classic mode, any unique combination numbers 
can be used as a temporary placeholder if the MAC address is not known. Type the 
desired name in this field, using letters, numbers, hyphens (-), and underscores (_) 
only. 

Note: The Terminal name is a good temporary Terminal ID. The Wizard mode 
automatically inserts a Terminal ID and does not require the manual entry of the 
Term ID. 

• The OEM field has a drop down list of manufacturers who produce ACP Enabled 
thin clients. Select the manufacturer if you know it. If not, this will automatically fill 
with the appropriate model number from the TermCap database when the terminal is 
connected to the ThinManager Server. See �Install New TermCap Database� on 
page 40 for details on updating the TermCap database. 

• The Model field has a drop-down list of model numbers for ACP Enabled thin 
clients. Select the model if you know it. If not, this will automatically fill with the 
appropriate model number from the TermCap database when the terminal is 
connected to the ThinManager Server. See �Install New TermCap Database� on 
page 40 for details on updating the TermCap database. 

If a terminal is added after another terminal is defined, two additional fields will be shown. 
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• The Replace Terminal check box allows the terminal to replace an existing off-line 
terminal by inheriting its configuration. 

Note: If this terminal is a replacement for a terminal that is already defined, see 
�Replace or Create New Terminal Mode� on page 65 

• The Copy Settings from Terminal check box allows the new terminal to copy its 
settings from the terminal in the drop down list. 

Fill in the fields and select OK to launch the Terminal Properties to continue with the terminal 
configuration. 

Terminal Identity 
The Identity tab of the Terminal Properties dialog box displays identifying parameters of the 
thin client.  

 

Classic Mode � Terminal Identity Tab 

• The Name field contains the name that was assigned to the terminal in the creation 
step. 

• Terminal ID is the Terminal Identifier. This field is the MAC address of the ACP 
Enabled terminal network card on terminals that have been or is a placeholder if the 
configuration hasn�t been applied to a terminal. 

•  The Group field has a drop down box that allows the terminal to be added to a 
group. This will apply the group configuration to the terminal. 

Note: It is recommended that groups be configured before adding individual 
terminals. See �Adding Groups� on page 104. 
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• The OEM field has a drop down list of manufacturers who produce ACP Enabled 
thin clients. Select the manufacturer if you know it. If not, this will automatically fill 
with the appropriate model number from the TermCap database when the terminal is 
connected to the ThinManager Server.  

• The Model field has a drop-down list of model numbers for ACP Enabled thin 
clients. Select the model if you know it. If not, this will automatically fill with the 
appropriate model number from the TermCap database when the terminal is 
connected to the ThinManager Server.  

• The OEM Model field shows the model number of the terminal, as detected by the 
ThinManager server. 

• The Video Chipset field shows the type of the processor chipset of the terminal, as 
detected by the ThinManager server. 

• The Touch Type field shows the type of touch screen if the terminal is an ACP 
Enabled thin client with an integrated touch screen,  

Select the Session tab to continue configuration. 

Select OK to accept the changes and close the dialog box.  

Select Cancel to cancel the addition or change of the terminal. 

Select Help to launch ThinManager Help. 

Terminal Session 
The Session tab of the Terminal Properties dialog box is where a terminal is assigned to a 
Windows NT/2000 Terminal Server using the IP address of the Windows NT/2000 Terminal 
Server.  

Note: The Wizard mode uses computer names, but the Classic mode only uses 
IP addresses unless a DNS is used. 

When a terminal is assigned to a group, it is assigned the group settings. Any of these can be 
changed or modified by unselecting the Use Group check box and making a change to the 
desired value.  
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Classic Mode � Terminal Session Tab 

Terminals that are not members of a group will not have the Use Group check boxes on the tabs 
and must have all of its parameters configured. 

 

Classic Mode � Terminal Session Tab, Non-Group Member 

Select the Server radio button and enter the IP address (or DNS names if DNS is used) of the 
desired Windows NT/2000 Terminal Server that the terminal is to connect to. One instance of 
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ThinManager can manage the connection of thin clients to a number of terminal servers by 
assigning different groups or terminals to different terminal servers. 

Failover is enabled by listing the IP addresses of multiple Terminal Servers, in order of 
preference, separated by semi-colons (spaces are optional). See �Failover Overview� on page 
20 for details. 

Note: The Server field on the Session tab is the most important field in the 
Classic mode. Without correct data the terminal will not connect to the Terminal 
Server. 

Published Application is an advanced function for Citrix MetaFrame users. Selecting the 
Published Application radio button and entering the name of a published application will 
allow the terminal to use Citrix Published Applications. 

Note: The Published Application name must be continuous. It cannot have a 
space in its name. 

The Username field allows a Windows NT/2000 User Profile to be assigned to provide an 
automatic logon at startup. Leaving this field blank will force a user to logon at each start.  

The Password field submits the password for the User Profile in the Username field to allow 
automatic login at startup. 

The Domain field assigns the terminal to a Windows domain. 

The Initial Program field is a security enhancement. If the path to an executable file is 
entered into the Initial Program field, only the specific program will launch upon boot. If the 
initial program is closed, the terminal will end the connection to the terminal server and 
reconnect, with the initial program running. This tool is useful for enforcing an operation of a 
single program, such as an HMI or SCADA program.  

To start an initial program that would allow closure and or the running of other programs, use 
the Startup folder in Windows. 

The ICA Browser field is a back-up function for Citrix MetaFrame users. If the terminal is 
unable to browse the ICA network (find the server), the ICA Browser field can specify a 
server IP address. This might be used with server farms or published applications (which 
require Citrix MetaFrame). See your Citrix documentation for help with server farms and 
published applications. 

The Encryption drop-down box allows Citrix MetaFrame users to configure SecureICA 
encryption. 

Select the Video tab to continue configuration. 

Select OK to accept the changes and close the dialog box.  

Select Cancel to cancel the addition or change of the terminal. 

Select Help to launch ThinManager Help. 

Terminal Video 
The Video tab of the Terminal Properties dialog box contains the settings for the video 
properties. The Use Group Video Settings check box assigns the group properties to the 
terminal. Terminals that are not members of a group will not have this check box. 
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Classic Mode � Terminal Video Tab 

• Video Mode is a drop-down box that allows you to select a video resolution for the 
group. Terminals use the 256-color depth by default. To use a higher color depth 
use Citrix MetaFrame 1.8 Feature Release 1, or greater. 

• Custom Video Modelines is a field for scripts that provide support for certain non-
standard monitors. If the standard video modelines do not work, please contact your 
technical support for assistance with this feature. 

Note: A terminal that �blacks out� upon connection to the terminal server usually 
needs the refresh rate lowered. 

Select the Modules tab to continue configuration. 

Select OK to accept the changes and close the dialog box.  

Select Cancel to cancel the addition or change of the terminal. 

Select Help to launch ThinManager Help. 

Terminal Modules 
The Modules tab of the Terminal Properties dialog box contains the settings for adding 
modules. Modules are software components that can be added to the firmware to increase the 
functionality of the terminal. Modules include touch screen drivers, sound drivers, and special 
device drivers. Some modules are included with ThinManager and are registered automatically 
during ThinManager installation. Other modules are obtained separately from Automation 
Control Products and need to be installed. 

Attaching a Module 
Modules are added from the Modules tab of the Terminal Properties. 
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Classic Mode � Terminal Module Tab 

To attach a module, select the Add button on the Module tab. This will launch an Attach 
Module dialog box. 

 

Classic Mode � Terminal Modules Tab, Attach Module  
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The Attach Module dialog box shows all the installed modules. Highlight the desired module 
and select OK. The module will be added to the list on the module tab and will load on the next 
terminal reboot. 

Group Module Deactivation 
A terminal that is assigned to a group with modules will display a Use Group Module check box 
selected by default and will load the group modules. To stop the terminal from using the group 
modules, uncheck the Use Group Module check box. This will put a red icon over the group 
icon to show that the group setting is no longer used. 

 

Classic Mode � Group Module Deactivation 

This figure shows a Group module that is deactivated, a group module in use, and an individual 
terminal module. More detail can be found in Error! Reference source not found. 
Select the DNS tab to continue configuration. 

Select OK to accept the changes and close the dialog box.  

Select Cancel to cancel the addition or change of the terminal. 

Select Help to launch ThinManager Help. 

 

Terminal DNS Properties 
The DNS tab of the Terminal Properties dialog box contains settings for using a Domain Name 
System (DNS) server. This will allow the use of DNS names to identify computers. 
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Classic Mode � Terminal DNS Tab 

DNS Server is a field for the IP address of a DNS server. 

Domain is a field for the DNS domain name. 

Search Domain will add the contents of the field as a prefix to any DNS searches.  

The Read DNS settings from server button will load the DNS server settings from the 
ThinManager server into the DNS Server field. 

Select the Monitoring tab to continue configuration. 

Select OK to accept the changes and close the dialog box.  

Select Cancel to cancel the addition or change of the terminal. 

Select Help to launch ThinManager Help. 

Terminal Monitoring 
The Monitoring tab of the Terminal Properties dialog box contains parameters related to 
Failover. A ThinManager terminal monitors the availability of its terminal server, and will 
disconnect the session if the server is down. The terminal will then connect to the next terminal 
server in the Server field of the Session tab.  

These parameters are configurable. 
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Classic Mode � Terminal Monitoring Tab 

• Monitor Interval sets the frequency that the terminal checks to see if the terminal 
server is connected.  

Note: Setting this value low will provide a quick detection of server failure. 
Setting it too low may end the connection due to high network traffic or a short 
network interruption instead of a server failure.  
The Wizard mode provides a Fast, Medium, and Slow settings in addition to the 
Custom mode provided in the Classic mode. 

• Monitor Timeout sets the amount of time that the terminal will wait until retrying the 
terminal server connection. 

• Monitor Retry sets the number of times that the terminal will retry the terminal 
server before disconnecting the connection. 

• The Enforce Primary field affects the return of a terminal back to its originally 
assigned terminal server. If Yes is selected, a terminal that has failed over to a 
secondary server will reconnect to the primary server once it returns online. If No is 
selected, a terminal that has failed over to a secondary server will remain connected 
to the secondary server until a terminal reboot, even when the primary server returns 
online. 

• Primary Up Delay is the number of seconds the terminal will wait to reconnect to 
the primary after it has detected it. This is included because the terminal can contact 
the primary terminal server and detect it before the primary is available for session 
connections. 

• The # secs field is the interval of time between when the primary terminal server 
returns online and when terminals will switch back to it with Enforce Primary. Its 
value equal to the Monitor Interval times the Primary Up Delay.  
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• The ThinServer field allows affects the monitoring lights on multiple ThinManager 
Servers. Any ThinManager Server in this field will monitor the status of the terminals 
to update the monitoring lights on the ThinManager tree. Enter the IP addresses (or 
DNS names if DNS is used) of the ThinManager Servers in this field, in order of 
preference, and separated by semi-colons.  

Select the Other tab to continue configuration. 

Select OK to accept the changes and close the dialog box.  

Select Cancel to cancel the addition or change of the terminal. 

Select Help to launch ThinManager Help. 

Other Terminal Properties 
The Other tab of the Terminal Properties dialog box contains the settings for miscellaneous 
settings. The Use Group check boxes assign the group properties to the terminal if the terminal 
is the member of a group. They are checked by default. To change a setting, unselect a check 
box and make your changes. Terminals that are not a member of a group will not have the Use 
Group check box. 

 

Classic Mode � Terminal Other Tab 

• Allow this terminal to be replaced if offline allows a terminal to be replaced. Un-
selecting this will prevent a terminal from appearing in the terminal selection list 
during new terminal addition.  

Note: There is a global Enable Replacement on the Server Properties dialog 
box 

• Disable this terminal. On bootup, it will display a message and halt will disable 
a terminal if selected. This is a quick way to disable access to a terminal. Select this 
check box, and then reboot the terminal (see �Rebooting a Terminal� on page 128). 
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This will deny access to the terminal session. It does not end the session on the 
terminal server; it just prevents access to it. Clearing the check box will allow a 
disabled boot to proceed. 

• Terminate the ICA client on monitoring connection loss: is a legacy command. It 
will terminate the ICA connection if the connection to ThinServer is lost. This check 
box relates to the client/ThinServer connection and not the client/terminal server 
connection. It is not used with the current failover method.  

• Reboot the terminal when the ICA connection is lost is a legacy command. 
When selected, the terminal will reboot each time the ICA connection is lost. This 
can interfere with failover because failover does not require a reboot. Some network 
configurations may use this when the DHCP Server is the same machine as the 
terminal server. 

Select OK to accept the changes and close the dialog box.  

Select Cancel to cancel the addition or change of the terminal. 

Select Help to launch ThinManager Help. 

Changing a Terminal�s Group 
Group membership can be changed on the Identity tab of the Terminal Properties dialog box. 
Launch the Terminal Property dialog box by either: 

• Selecting a terminal by highlighting it. Select Edit...Modify from the ThinManager 
menu bar 

• Right-clicking the terminal icon in the ThinManager tree pane and selecting Modify 
Terminal. 

• Double-clicking the terminal icon in the ThinManager tree pane. 

On the Identity tab of the Terminal Properties dialog box, use the Group drop-down box to 
select the new group that the terminal is to be placed in. This will apply the new group 
configuration to the terminal. If �None� is selected, the terminal will keep its configuration, but will 
be removed from the group and is treated as an independent terminal. 

Note: The terminal will need to be rebooted for the changes to take effect.  

Modifying a Terminal 
Modifying a terminal allows you to reconfigure the terminal or change group settings such as 
touch screen usage, video resolution, or to designate servers.  

To modify a terminal open the Terminal Configuration Wizard or the Terminal Properties by 
either: 

• Highlight the terminal in the ThinManager tree pane by clicking on the terminal 
name or icon and select Edit>Modify from the ThinManager menu bar. 

• Right-click on the terminal icon in the ThinManager tree pane and select Modify. 

• Double-click on a terminal icon in the ThinManager tree pane. 

This will launch the Terminal Configuration Wizard in Wizard mode or the Terminal Properties 
in Classic mode. 
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Deleting a Terminal 
A terminal can be deleted from the ThinManager by: 

• Highlighting the terminal in the ThinManager tree pane and selecting Edit>Delete 
from the ThinManager menu bar  

• Right-clicking a terminal icon in the tree pane of ThinManager and selecting Delete 
Terminal.  

• Highlighting the terminal in the ThinManager tree pane and selecting the Delete 
key. 

Rebooting a Terminal  
A terminal or group can be rebooted by:  

• Selecting Tools>Reboot Terminals from the ThinManager menu bar. This will 
reboot all the terminals on the server if the server is highlighted. If a group is 
highlighted, all members of the group will be highlighted. If a terminal is highlighted, 
the terminal is rebooted. 

• Right-clicking a group icon in the tree pane of ThinManager and selecting Reboot 
Terminals. This will reboot all the terminals in the group. 

• Right-clicking a terminal icon in the tree pane of ThinManager and selecting Reboot 
Terminal. This will reboot only the highlighted terminal. 

Renaming a Terminal 
Terminals can be renamed by: 

• Highlighting the Terminal and selecting Edit>Rename. 

• Right-clicking the Terminal and selecting Rename. 

• Renaming terminals is accomplished the same way that files or directories are 
renamed in Windows Explorer. Single click twice on the terminal name; this will 
draw a box around the name and highlight it. Type the new terminal name. 
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Renaming a Terminal 

Tip on single clicking twice: Click once to highlight the name, move the mouse 
slightly and click again. This will prevent Windows from confusing the two single 
clicks with a double click. 
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Modules in Depth 

Modules are software components that can be loaded to increase the functionality of the 
firmware. Modules include touch screen drivers, sound drivers, and special device drivers. Some 
modules are included with ThinManager and are registered automatically during ThinManager 
installation. Other modules are obtained separately from Automation Control Products and need 
to be installed. 

 �Installing a module� refers to the registration of the module with the ThinManager Server, while 
�Adding a module� refers to attaching the module to a group or terminal. 
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Installing a Module 
Open the Modules window by selecting Tools>Modules from the ThinManager menu bar.  

 

 

Install Module Window 

Select the Install Module button. This will launch a file browser window. 
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Module File Browser Window 

Select the new module file and select Open. This will install the module. 

 

Install Module Window 

Selecting the Remove Module from All Terminals button will remove the highlighted module 
from all terminals. It does not uninstall the module. 
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Changing Module Parameters 
The parameters of a module can be individually configured. Open the Terminal Property by 
double-clicking the desired terminal in the ThinManager tree. In Wizard mode click the Next 
button until the Module Selection window is displayed. In Classic mode select the Module tab. 

Highlight the desired module and select the Configure� button.  

 

Terminal Module Selection � Wizard Mode 

A Module Properties dialog box will be displayed. 

There are four icons that can be used for modules in the Terminal Properties. 

1.  represents properties assigned by the Group. 

2.  represents properties that are changed on the terminal from the Group settings. 

3.  represents a terminal that isn�t using an assigned Group module. The �Use 
Modules from Group� checkbox was un-selected. 
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4. No icon indicates that the module was added to the terminal and not the group. 

Select the Module to change and select the Configure button. 

 

Module Properties Window 

Select the parameter to configure. If configuring a Group Module, uncheck the Use Group Value 
check box. 
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Module Properties Window 

The Value field will become active to allow a new value to be added, or a drop-down box will 
appear with values to choose from. Change the value and select the Set button to apply the 
parameter change. 

Select the Done button to close the window. 



136 Copyright 1999-2003 © Automation Control Products 

 

Module Properties Window � Group Parameter Changed 

An icon with a yellow plus sign will be displayed to show that a module parameter was changed. 

 

Module Icons in ThinManager 
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The status of the modules are displayed in the detail pane of ThinManager. 
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Module Loading Order 
The order that the modules load can be changed by highlighting a module and selecting the 
Move Up or Move Down button. 

 

Module Loading Order 

The loading order of modules rarely needs to be adjusted. 
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Installation  
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Windows 2000 Terminal Server  
Microsoft Windows 2000 Servers can be easily converted to Terminal Servers. See the Microsoft 
web site at www.microsoft.com for official information.  

Open the Windows Components Wizard by selecting Start>Settings>Control 
Panel>Add/Remove Programs>Add/Remove Windows Components. 

 
Windows Components Wizard 

Checking the Terminal Services checkbox and selecting Next will install the components for 
terminal services on the server. It is recommended that the terminal server gets a clean install of 
the operation system instead of adding the feature to an established server. See �Windows 2000 
Server Building Instructions� on page 203 for more details. 

The Microsoft component requires a Terminal Services Licensing Server. See �Microsoft CALs 
and TS CALs� on page 208 for details. 
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ThinManager Installation On Windows 2000 
Server 
In Microsoft Windows NT Terminal Server Edition and Windows 2000 with Terminal Services 
enabled, software needs to be added in the Install Mode through the Control Panel� 
Add/Remove Programs. Failure to use the Install Mode can prevent an application from 
working properly. 

Select Start�Settings�Control Panel�Add/Remove Programs to open the Add/Remove 
Programs dialog box.  

 

Add/Remove Programs 

Select the CD or Floppy button on the Add/Remove Programs Properties dialog box to open 
the Installation wizard. The wizard will prompt for the insertion of the ThinManager CD. When the 
CD is inserted, the wizard will ask for the path to the setup program. The setup program path is 
X:\SETUP.EXE, where �X� is the CD-ROM drive letter containing ThinManager.  

Enter the path, or select the Browse button and select setup.exe through Explorer, and 
continue with the wizard.  

Note: ThinManager does not need to be reinstalled to add more licenses. Add 
additional licenses as described in ThinManager Licensing on page 158 
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ThinManager Installation � Application Selection 

An Application dialog box will open that displays the available software programs on the 
ThinManager CD. Check the desired components and select Next.  

Note: ThinServer is a vital component that needs to be installed with 
ThinManager to allow ACP Enabled thin clients to operate. It is separated from 
ThinManager in the installation to allow additional instances of ThinManager to 
be installed for remote administration.  

 

Note: Citrix Device Services should not be installed if Citrix MetaFrame is 
installed. 
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Citrix Device Services Installation On Windows 
2000 
Citrix Device Services is an important component of the ACP Enabled thin client system. It needs 
to be installed on each terminal server. It installs as an option during the ThinManager 
installation.  

Note: Citrix Device Services should not be installed if Citrix MetaFrame is 
installed. 

If Citrix Device Services is selected during the ThinManager installation, a Citrix Device Services 
for Windows 2000 Server Setup dialog box will be displayed 

.  

Citrix Device Services � Installation Introduction 

Select the Next button to continue the installation. 

 

Citrix Device Services Licensing 
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Citrix Device Services requires a license. It can be installed now by selecting the Add Citrix 
Device License button, or later after the installation is finished.  

If the Add Citrix Device License button is selected, an Enter License Number dialog box will 
be displayed. The Citrix License Number from the inside of the ThinManager CD case is entered 
into the Serial Number field.  

 

Citrix License Entry Box 

Select Next to continue. Reboot the server if prompted. 



 

Installation � 145 

Additional Software Installation On Windows 2000 
Microsoft Windows 2000 Server requires that software be added in the �Install Mode� through 
the Control Panel, Add/Remove Programs. 

Select Start>Settings>Control Panel>Add/Remove Programs to launch the Add/Remove 
Programs dialog box. 

Note: Some software, especially downloaded software, doesn�t allow the 
installer to install it through the Add/Remove Programs tools. To manually put 
the machine into the install mode open a command prompt and type: 

change user /install 
This sets the machine to install mode. When finished, type: 

change user /execute 

 

Add/Remove Programs 

Select the CD or Floppy button on the Add/Remove Programs dialog box to open the 
Installation wizard.  
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Install Program Window 

The wizard will prompt for the installation of the software disk. Select Next to display the Run 
Installation Program dialog box. 

Note: If the new program starts in �autorun� and proceeds without going through 
the following procedures, either stop the autorun and use the wizard to initiate 
the installation, or use the change user /install command to place the 
machine in the install mode. 
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Run Installation Program 

Enter the command line of the installation program and select Finish, or select the Browse 
button to select the installation file. 

 

Browse File Window 

Selecting the Browse button on the Run Installation dialog box will launch a Browse File 
window. Highlight the installation file and select Open. This will begin the application setup. 



148 Copyright 1999-2003 © Automation Control Products 

 

After Installation Window 

As the installation begins, an After Installation dialog box is displayed. It requests that the Next 
button be selected when the installation is finished. When this button is selected a second 
confirmation window is displayed. 

 

Finish Install Window 

Select the Finish button when the installation is finished. 

Note: If a choice is given to Reboot Now or Reboot Later, choose to reboot 
later once the entire setup is completed and the dialog boxes are cleared. 
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Licensing  

ACP Enabled thin clients rely on three programs: Microsoft Terminal Server, the Citrix ICA 
Protocol, and ACP ThinManager. Each of these programs requires installation and licensing. 

Each program is sold with one serial number or license number. Each program generates a 
second serial number or license number during installation. The installer needs to take both 
numbers to the respective company�s web site for license registration. When this is completed an 
activation number or file will be generated that will activate the component�s license. 
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Microsoft CALs and TS CALs  
ACP Enabled thin clients require a terminal server running Microsoft�s Windows NT 4.0 
Terminal Server Edition or Windows 2000 Server with Terminal Services enabled as an 
operating system. .. 

Each of these operating systems requires a standard Microsoft Client Access License (CAL) for 
each connection to the server. These are based on concurrent use; a 5-pack would allow more 
than five users to access server resources, but only five users at a time.  

Terminals require an additional Microsoft Terminal Server Client Access License (TS CAL) to 
connect to the server using either RDP or ICA. This licensing is per seat; ten terminals would 
require ten TS CALs, even if only two were connected at a time.   

Windows NT 4.0 Terminal Server Edition is sold with TS CALs. These are installed on the NT 4.0 
Terminal Server. Additional TS CALs are available from Microsoft. 

Windows 2000 has an improved method of license management. All TS CALs are installed on a 
Terminal Services Licensing Server. This acts as a repository for all TS CALs. The terminal 
servers request TS CAL authentication from the Terminal Services Licensing Server as terminals 
attach to terminal servers. 

Note: The Terminal Server Licensing Server does not need to be a separate 
computer, but can be run on any Windows 2000 server, including Windows 2000 
Terminal Servers.  

Microsoft requires that the Terminal Server Licensing Server be installed on the 
Primary Domain Controller in a domain. 

The Terminal Services Licensing server is activated through the Internet by connecting to the 
Microsoft Certificate Authority and License Clearinghouse.  

Windows 2000 Server with Terminal Services enabled will issue 90-day temporary licenses while 
the Terminal Services Licensing server is being setup and activated. If this period has elapsed, 
the terminal will not connect to the terminal server and will display an �Error Number 50� 
message box. 

Windows 2000 Server is not normally sold with TS CALs. These need to purchased separately 
and installed on the Terminal Services License server.  
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Citrix Device Services Licensing 
The second component is the ICA (Independent Computer Architecture) communications 
protocol from Citrix that provides the communication between the server and the thin client. ACP 
ThinManager software contains a licensed copy of Citrix Device Services on the ACP 
ThinManager CD to provide the ICA protocol. Citrix Device Services needs to be installed on 
each terminal server.  
Citrix Device Services needs a license added immediately to allow terminal-to-server 
communication. The license can be added during the installation process or it can be added 
when the installation is finished. A license number that is located on the ThinManager CD label is 
used for licensing. Instructions are provided with ThinManager. 

The Citrix Device Services License will need to be activated within a 35-day grace period 
to continue functionality. The activation is done within the Citrix web site at 
http://www.citrix.com/activate. Instructions are provided with ThinManager. 

Note: A license is needed immediately for the ICA connection. The license will 
need to be activated within a 35-day grace period. 

 

Note: MetaFrame is licensed in a similar manner. Please see the documentation 
that comes with MetaFrame for details. 
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Citrix Device Services Licensing Flow Chart 

Open the Citrix Licensing dialog box by selecting Start>Programs>Citrix Device Services 
Tools (Common)>Citrix Licensing.  
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Citrix Licensing Dialog Box 

Note: The Citrix Device Services for Windows license is installed during setup. It 
is not enough to provide functionality. A Citrix Device license is needed. 

Select License>Add from the menu bar to launch the Enter Licensing Serial Number dialog 
box  

 

Enter License Serial Number  

Enter the Citrix License number found inside the ACP ThinManager CD Case.  

Note: This number may be called the License Code, Serial Number, or License 
Serial Number. 

Select OK to continue. 
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License Serial Number and License Code 

The License Serial Number will have a Machine Code of eight numbers added to it and will be 
displayed in the Citrix Licensing window as the License Number. Although the license is now 
installed, it needs to be activated within 35 days to keep it functional. 
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Citrix License Activation  
The Citrix Device Services has a 35-day grace period, after which it is not fully functional until it 
has been activated. Adding an Activation Code activates the license. This Activation Code is 
obtained from the Internet at the Citrix web site at http://www.citrix.com or through the Activation 
Wizard. The Activation Code can be obtained from Citrix with any machine that has an Internet 
connection.  

Note: Since web sites are dynamic, the exact layout of the web screens may 
change, but the functionality should remain the same. If you have problems, 
please contact Citrix or e-mail support@acpthinclient.com for help. 

 

www.citrix.com 

Select the Product Activation hyperlink on the Citrix home page. It will link to 
http://ww.citrix.com/activate. 

Citrix requires the creation of a user account to access the licensing area. 
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Citrix License Activation Screen 

After entering the Citrix site and navigating through the site as described in Citrix Device 
Services Licensing, the License Activation screen will be displayed. 

Enter the License Code that was generated during installation. This is the License Serial 
Number that is on the ThinManager CD, with the 8 digit Machine Code added. 

Select the Continue button to proceed. 
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Citrix License Activation 

A new screen will appear that displays the Activation Code for the installation.  

Write this Activation Code down for use in activating the license. 

Print a copy of this page for a record, and then exit the Citrix web site. 
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ThinManager Licensing 
The third component is ACP ThinManager software from Automation Control Products. 
ThinManager is used to configure, manage, and control the thin clients. ThinManager will allow a 
single client to connect without a license, but will require a ThinManager license for more 
terminals. This license is included with the ThinManager software. Activation is done within the 
ACP web site at http://www.acpthinclient.com. Details of licensing are provided with 
ThinManager 

ThinManager will only allow one connection until it is licensed.  
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ThinManager Licensing Flow Chart 

When an unlicensed copy of ThinManager is run, a message box will appear with notification 
that a license needs to be installed. 
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No Valid License Message Box 

ThinManager licensing begins with the Licensing dialog box. Open this by selecting 
Tools>Licensing from the ThinManager menu bar. 

 

 

Licensing Dialog box 

The Installation ID at the bottom left-hand corner of the screen is used to obtain the License 
File from ACP. 

Note: The Installation ID is important for obtaining a License File. 

ThinManager License File Download 
To obtain a license file you need two numbers:  

• The Installation ID that is generated by ThinManager during installation.  

• The License Number that is provided on the ACP ThinManager CD. 

The License File needed to activate ThinManager is obtained from the ACP web site at 
http://www.acpthinclient.com.  

Note: Since web sites are dynamic, the exact layout of the web screens may 
change, but the functionality should remain the same. If you have problems, 
please contact your distributor or e-mail support@acpthinclient.com for help. 
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www.acpthinclient.com 

Select a License Files link. This will launch the ThinManager License Site. 
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ThinManager License Site 

There are three links at the ACP Licensing Site: 

• Login � This link allows previously registered users to enter the site. 

• Passcode � This link allows previously registered users who have forgotten their 
username and password to receive an entrance code through an e-mail. 

• New User � This link allows a person to become a registered user of the site so that 
they can activate a license. 

If you are a new user, select the New User link. Previously registered users should login by 
selecting the Login link. 
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New User Login 

Enter a name to be your ACP User Name. Select Submit to continue. 
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User Information Form 

Fill in the User Information form.  

Note: The e-mail address is very important because all correspondence, 
including your password will be sent to that address. 

Select Submit when finished. 
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New Account Completion 

Your user name and password will be promptly sent to your e-mail address.  

Select the Login link to continue. 
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Licensing Site Login 

Enter the user name and password that you received in your e-mail into the appropriate fields. 

Select the Login button to continue. 
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ACP Licensing Site 

Inside of the ACP Licensing Site are four functions for the registered user.  

• Logout � This link will allow exiting from the secure site. 

• Manage Account � This link allows user information to be changed or updated. 
Passwords are changed here. 

• Activate License � This link allows the activation of a license and the retrieval of a 
license file. 

• History � This link displays past actions for the user account. 

Select the Activate License link to activate a license and retrieve a license file. 

Note: The initial password that is sent is complex and hard to remember. Going 
to Manage Account will allow the password to be changed. 
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License Request Page 

The new web page will have a field for the License Number and a field for the Installation ID. 

Note: The License Number is located on a label inside of the ThinManager CD 
case. The Installation ID is on the ThinManager Licensing dialog box that is 
launched by selecting Tools>Licensing from the ThinManager menu bar and is 
shown in ThinManager License File Installation 

Fill in both fields. These numbers are case sensitive and cannot have extra spaces added.  

Select the Submit button to continue.  
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Download License File 

The License File will begin to download. A dialog box will appear that allows the option of 
opening the file from its current location or saving the file to disk. Saving the file to disk is 
recommended. 

Print a copy of this page for your records. 

 

Saving File to Disk 
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Select OK to continue.  

A dialog box will appear that allows the selection of the download directory. 

 

Save As Window 

Select a directory or drive to copy the file to, and select Save. 

The license file is now ready for installation. 
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ThinManager License File Installation 
Open the Licensing dialog box by selecting Tools>Licensing from the ThinManager menu bar. 

 

Licensing Dialog Box 

Select the Install License button on the Licensing dialog box. An Open File dialog box will be 
displayed.  

 

Open License File 

Select the License File that was downloaded from the ACP web site and select Open. This will 
install the License File. 



172 Copyright 1999-2003 © Automation Control Products 

 

Add License 

When the License File has been successfully installed, a message box will appear to confirm it. 
The License Number and properties will appear in the Licensing dialog box. 

Select OK to close the message box. 

Selecting the Delete License button on the Licensing dialog box will open a message box that 
will allow the deletion of a selected license. 

Selecting the Details button on the Licensing dialog box when a license is selected will display a 
window with the details of the selected license. 

 

License Details 

Double-clicking a license in the Licensing dialog box can also open this window. Selecting OK 
will close the License Details window. 

Selecting the Done button on the Licensing dialog box will close the Licensing dialog box. 
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ThinManager Module Licensing 
Certain modules, like the High Speed Serial Driver, Instant Failover, and the Shared Keyboard 
and Mouse module require an ACP license to activate. These are activated through the ACP 
web site using the same procedures as the ThinManager license. 
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Additional Software Licensing 
Additionally, software on the terminal server may need licensing based on the number of users. 
Each software company determines the details of licensing. Contact your software vendor for 
details 
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Additional ThinManager 
Features and Functions 
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Best Practices for Graphics and Design  
ACP Enabled thin clients pass keyboard and mouse commands over the network to a terminal 
server for processing. The resulting GDI call (Graphics Display Interface) is sent over the 
network to the terminal processor for display. Proper design of graphics for thin clients screens, 
especially those used by HMIs (Human Machine Interface) and SCADAs (System Control and 
Data Acquisition) can keep performance equal to PCs. Poor graphic design and utilization can 
saturate the network or overload the terminal processor, hindering performance. 

The World Wide Web provides many examples of the relationship between intelligent design and 
speedy graphic display. Some web sites are attractive, well designed, full of visual treats and 
information, and yet load quickly onto a computer. This is because text loads quickly, the colors 
are standardized colors, and the graphics are optimized to provide the best appearance in the 
smallest size.  

Other sites may look similar, or even less intense; yet take much longer to load. This might be 
due to excessive, redundant code or scripts, using non-standard colors that require dithering, 
and the use of large-file graphics like bitmaps. 

Here are some guidelines for good graphic design with HMIs and SCADAs: 

• Design The Project In The Color Resolution That The Thin Clients Will Display The 
Project In. 

The ICA protocol supports 256 colors. Designing the project in 256 colors will keep the project 
color consistent. If the project is designed in a higher color resolution, the terminal may be forced 
to substitute, approximate, or dither the colors, causing inconsistencies. 

Note: MetaFrame 1.8, Feature Release 1, supports greater color depth. 

• Close Unneeded Windows to Free Colors. 

ICA has a 256-color table that it populates with colors as they are requested. Once this table is 
full, no additional colors will display, and dithering and substitution will occur. Keeping a window 
open, but in the background, will keep the colors reserved in the table. Closing unneeded 
windows may free colors that can be used to display needed colors. 

• Use a Black Background on Client Desktops. 

Using a black background for client desktops will eliminate the need to send the information to 
paint the background with a color or pattern, saving bandwidth. 

• Limit Bitmap Usage. 

Bitmaps, which store images pixel by pixel, are much larger, and require more processing 
resources than other graphic file formats. Files that use compression or vector graphics are 
much smaller, are easier to pass across the network, and are easier to display on the terminal 
screen. Many of these file formats can have the color depth reduced, decreasing the size and 
improving its display on a 256-color palette. 

• Avoid Moving Bitmaps 

Although bitmaps are large, they can be used effectively if they are constant, and not redrawn 
often. An effective HMI screen could consist of a photograph of the equipment or a portion of the 
plant, with the HMI graphics overlaying the photo. The photo would draw once when the screen 
is loaded, then changes would occur to the smaller, more efficient vector-based HMI graphics.  
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Moving bitmaps or screen savers, however, will require large amounts of the server�s processing 
resources and may overload the terminal processor with a constant stream of processing 
demands. 

• Continue to Use Traditional Blinking Graphics, Varied Text, and Buttons. 

The traditional HMI display elements like text, blinking lights, numeric displays, and color blocks 
work well on terminals. These graphics are not as resource intensive as the pixel-by-pixel display 
of the bitmap. 

• Disable Smooth Scrolling on Microsoft Internet Explorer.  

Microsoft Internet Explorer displays better on thin clients if the �Use smooth scrolling� option is 
unselected on the Internet Options>Advanced tab of Internet Explorer 

• Use a Small, Dynamic Feature Like a Clock on the Screens. 

When a terminal is turned off (powered off, not logged off), the session will continue to run on the 
terminal server. If the server session sends a graphic update to the terminal, it will detect the 
change in the terminal status and will mark the session as disconnected. When the terminal is 
powered back on, it will boot and reconnect to the disconnected session, continuing the session 
where it left off. 

However, if a terminal screen is static, the server session will have no need to send a graphic 
update to the terminal. A terminal may be powered off and the server may not realize that a 
terminal has been powered off. If the terminal is turned back on, the server may not realize that 
the terminal belongs to the still active session when it connects to the server. The terminal will 
create a new connection, causing a duplicate session on the terminal server. 

The easiest way to prevent the creation of duplicate sessions is to have something change on 
the screen at least every minute to keep the communication between the server and the terminal 
active. If the terminal server sends an update to the terminal and can�t communicate, it will mark 
the session as disconnected. Showing the clock in the desktop taskbar will provide the regular 
screen updates. Most HMI designers will display a navigational bar/status bar/function key bar 
with a clock on it that will serve the same purpose. 

If duplicate sessions are created, Microsoft provides Terminal Services Manager, a session 
administration tool to manage this. This is described in Duplicate Sessions on page 200. 
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Installing a Local Printer in Windows 2000 
Begin the printer installation by attaching the printer to a parallel port on an ACP Enabled thin 
client.  

Select the Start>Settings>Printers>Add Printer to launch the Add Printer Wizard. 

 

Add Printer � Windows 2000 

Select Next to begin the printer installation. 

 

Local Printer Selection 

Select a Local Printer or Network Printer and select Next to continue. 
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Plug and Play Printer Detection 

The plug and play hardware detection system may not detect the printer on the terminal. Select 
Next to continue. 

 

Printer Port Selection 

Scroll through the ports and select a port attached to the proper terminal. Select Next to 
continue. 
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Printer Selection 

Select the printer manufacturer and model from the lists. Select Next to continue. 

 

Printer Naming 

Select a printer name. Select whether the printer is to be the default printer. Select Next to 
continue. 
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Printer Sharing 

Select a whether sharing is desired. Select Next to continue. 

 

Print Wizard Completion 

The Print Wizard will display the configuration of the printer. Select Finish to finish the printer 
installation. 
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Security 
The ACP Enabled thin client system provides a Windows NT/2000 desktop on each thin client. 
Each thin client has full access to the server resources, as if it is the server. However, just 
because the thin client has the ability to have full access to the server resources doesn�t mean 
that the user should be granted full access to the server. To prevent unauthorized changes to the 
server, it is recommended that each user profile have security policies applied through the 
System Policy Editor to limit access to the needed functions. Windows NT/2000 Security 
procedures are discussed in the Windows on-line help and in many books and articles. 

In the industrial setting, administrators will often set the sessions to display the HMI/SCADA 
software as the initial application, and then let the HMI control access to administrative and 
supervisory screens.  

Note: Task Manager has a feature that allows the launching of applications. If 
an initial application is defined on the ICA Sessions tab of the Terminal 
Properties, access to Task Manager should be denied in the security policy to 
prevent a user from launching unauthorized programs. 

 

Server Properties 

The Require password on unknown terminals field on the Server Properties dialog box increases 
security by requiring a password to add terminals to a network. 
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Disk-On-Chip 

Disk-On-Chip Configuration 
A disk-on-chip terminal loads the firmware locally before connecting to the ThinManager server. 
The disk-on-chip terminals have a setup program that allows configuration of the connection. 
Enter the program by selecting any key when Select any key to configure is displayed during 
the boot process. A setup screen will be displayed.  

 

Disk-On-Chip Configuration Screen 

The IP Addressing method is set to DHCP by default. To change a value, navigate with arrow 
keys to the desired property. Pressing the Enter key will allow the input and acceptance of new 
values. The changes may be saved or discarded before the boot process is resumed. 

Updating Disk-On-Chip  
ACP ThinManager has the ability to update the firmware on the disk-on-chip to keep the 
firmware current. Firmware updates for the disk-on-chip are done through the Disk-On-Chip 
Update module. 

The disk-on-chip software module, when installed on an ACP Enabled thin client with disk-on-
chip hardware, will compare the firmware on the disk-on-chip with the ThinManager server 
firmware when it connects to a ThinManager server. If the ThinManager firmware is different, it 
will download the ThinManager server firmware and update the disk-on-chip on the terminal.  

The ability to update disk-on-chip terminals eliminates the need to send the terminal back to the 
manufacturer to update the firmware. 

Note: The firmware download can take from 5 seconds to 30 minutes, 
depending on the bandwidth of the connection, and the size of the firmware 
update. 
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Disk-On-Chip Module 
The disk-on-chip module installs with ThinManager. To attach the module to a group or terminal, 
open the desired Group Property or Terminal Property as described in Modifying a Terminal  

Select the Add button on the Modules tab. This will launch the Attach Module dialog box. 
Highlight the Disk On Chip Update module and select OK. This will attach the disk-on-chip 
update module to the terminal. 

 

Disk-On-Chip Module 

This module has one configurable parameter, Confirm at Terminal. If Confirm at Terminal is 
set to Yes, then the operator will be prompted to choose between an immediate firmware update 
updating later. If Confirm at Terminal is set to No, the firmware download will take place 
immediately. 

Note: The module will download firmware when it detects a different firmware. 
Since this will only happen at the first reboot after updating the ThinManager 
firmware, it is safe to leave this module added to the disk-on-chip terminals 
permanently. It does not need to be added and removed each time the firmware 
is updated. However, since it will update when the firmware is different, it will try 
to update the firmware if you connect it to a ThinManager server with older 
firmware. 

 



 

Additional ThinManager Features and Functions � 185 

Note: It is recommended that instead of updating over a wireless connection, 
you connect terminals with Ethernet cable to update the disk-on-chip. 

To set the Confirm at Terminal parameter, highlight the disk-on-chip update module and select 
the Configure� button. This will launch the Module Properties window. 

 

Disk-On-Chip Module Properties 

Highlight the Confirm at Terminal parameter. The Value field will change to a drop-down box 
containing Yes and No. Select the desired value and select Done. 

Disk-On-Chip Update Program 
Once the new firmware has downloaded, an update program will run on the disk-on-chip terminal 
to rewrite the new firmware to the disk-on-chip. The program will display a warning stating that 
the terminal must not be reset or powered off during the process, usually around 30 seconds. 
Ignoring the warning can corrupt the disk-on-chip, so it is important to leave the terminal alone 
for that period of time.  

Note: Heed the warning. The terminal must not be reset or powered off during 
the brief period that the update program is writing the firmware on the disk-on-
chip.  
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Serial Communications 

Serial Port Mapping 
Using a COM port on an ACP Enable thin client requires mapping the thin client COM port to a 
COM port in the session on the server. If the server does not have enough COM ports, �virtual� 
COM ports can be created and used.  

To map a COM Port on the server to a COM Port on an ACP Enabled terminal, open a command 
prompt on the client and type: 

net use comX: \\client\comY: 

Where "X" is number of the server COM port and "Y" is the number of the thin client COM port. 
Use "client" for the name of the terminal.  

For example: net use com3: \\client\com2: 

The server COM port does not need to exist; it can be a virtual COM port. The example will map 
COM3 on the server to the COM2 Port on the client. Pointing to COM3 in the session on the 
server will display data from the client�s COM2. 

Note: The space after the colon in �comX� is important. 

This is a local mapping. It must be mapped on the client, and the COM port data is only available 
to that session. 

High Speed Serial Driver 
Automation Control Products has a High-Speed Serial Driver (HSSD) module that offers more 
reliable serial communication at speeds to 115K per second. This is a global serial redirection; a 
COM port on a client becomes available to all users on that machine.  

Installation Requirements 
The high speed serial driver can be installed on any PC running Microsoft Windows NT 4.0 
Service Pack 5 or higher, Microsoft Windows NT Terminal Server Edition Service Pack 5 or 
higher, or Microsoft Windows 2000.  

Note: The high-speed serial driver can be installed on a machine other than 
your Terminal Server machine. However to access the �serial ports� from your 
thin-clients, the high-speed serial driver must be installed on the server from 
which the thin-client session is running. If you install the software on another box 
you will be able to access the thin-clients serial ports from software on that 
machine. 

HSSD Installation  
Install the high-speed serial driver in the install mode using the Add/Remove Programs to point 
to the setup.exe file of the ACP High Speed Serial Driver Install. Follow the instructions to 
complete the installation. 
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HSSD Configuration 
Once the driver is installed, you will need to configure the serial ports you wish to access. The 
serial ports are configured on the computer the HSSD was installed on using the 
acpcomredirector.exe program. This program can be accessed from 
Start>Programs>Acp>ACP Com Redirection. 

 

ACP Com Port Redirector 

To configure a COM port click Add New Port, this will launch the Edit Properties dialog box. 

 

Com Redirection Port Properties 

• Type in a COM port number to assign a number to a �virtual� port in the NT Com Port 
field. This number will identify the COM port on the NT system.  

• Type in the thin client IP address for the client will the actual serial port in the Client 
Name/IP Address field.  

• You can leave the Client TCP Data Port field empty. The program will fill this in with a 
unique port number for every serial port that is on the same thin-client, starting with 
6550. 

• Type in the actual serial port number of the thin client�s port that is being used into the 
Client Com Port field. 
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Module Installation 
Before you can redirect a serial port from a thin client, you must install the High Speed serial 
module in ThinManager. From the ThinManager menu bar, select Tools>Modules. This will 
launch the Module dialog box. 

 

Module Dialog Box 

Select the Install Module button. This will launch a Browse dialog box. 

 

Browse Dialog Box 

The high-speed serial module is copied to the install directory of the high-speed serial driver. 
Use the Browse button to find the module in this directory. Highlight the module and select 
Open. 

This will install the HSSD module and make it available to thin clients through Terminal 
Properties. 
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Module License Installation 
Before using the high-speed serial module, you must install the license for the high-speed serial 
module. This license can be obtained from www.acpthinclient.com.  The procedure is that same 
as for the ThinManager terminal licenses. Please refer to ThinManager Licensing on page 158 
for details.  
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ThinAdapter and the ThinAdapter Plus 
The ThinAdapter is a Network Interface Card with an ACP Boot ROM that allows a PC to boot as 
an ACP Enabled thin client. This allows outdated PCs to be converted to modern thin clients. A 
PC with the ThinAdapter card and its hard drive removed or unplugged becomes an ACP 
Enabled Thin Client. 

The ThinAdapter Plus is the ThinAdapter network card with a video card. This eliminates video 
compatibility issues. 

Note: It is recommended that the computer hard drive be unplugged or 
removed. 

ThinAdapter  
The requirements for using a ThinAdapter include:  

• Processor Requirement: Pentium 133 or better is required for ThinAdapters 

• Memory Requirement: 64 MBs of RAM is required for ThinAdapters 

• ThinManager Terminal Properties Configuration: Set the OEM field to Generic 
and the Model field to Other on the Identity tab. 

• Video Card Requirements: The following video chipsets are compatible. However, 
not all cards with these chipsets are guaranteed to work due to the variation in board 
components among vendors. 

ThinAdapter Plus 
ThinAdapter Plus Includes a video card to eliminate the need to try to match the ThinAdapter 
with a video chip set. The ThinAdapter Plus has the same requirements as the ThinAdapter. 

• Processor Requirement: Pentium 133 or better is required for ThinAdapters 

• Memory Requirement: 64 MBs of RAM is required for ThinAdapters 

• ThinManager Terminal Properties Configuration: Set the OEM field to Generic 
and the Model field to Other on the Identity tab. 

• Video Card Requirements: Use the included video card to provide the supported 
video chipset 

Supported Video Chips for ThinAdapters 
Chips & Technologies Cirrus Logic CyberPro National 

Semiconductor 
Silicon 
Motion 

65520 69000 5420 5465 2010 
GXLV (Media 

GX) 
 
LynxEM 

65525 64200 5222 5480 5000 SC1400A  

65530 64300 5424 6205  SC1200  

65535  5426 6215    
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65540  5428 6225    

65545  5429 6235    

65546  5430 7541    

65548  5434 7542    

65550  5436 7543    

65554  5446 7548    

65555  5462 7555    

68554  5464 7556    
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Auto-Creation of Terminals 
Turning on a terminal for the first time will initiate the Replace or Auto-Create Terminal mode if: 

The Auto-Create mode is enabled by the selection of the Enable AutoCreate check box on 
the Server Properties window. 

And 
The Default terminal is configured as a template for the new terminals  

New terminals can be added to the system and configured without additional input from the 
server.  
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Help With Non-ACP 
Components 
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Terminal Services Management 
Microsoft provides a utility for managing sessions on terminal servers. This program is called 
Terminal Server Administrator in Windows NT 4.0 TSE, and Terminal Services Manager in 
Windows 2000. This program: 

• Displays current users and connections 

• Displays the status of terminal connections. 

• Displays the processes running on each session.  

• Allows messages to be sent to various sessions. 

• Allows the shadowing or remote control of other sessions. 

Select Start>Programs>Administrative Tools> Terminal Services Manager to launch this 
program.  

 

Terminal Services Manager  

If the server is highlighted in the tree pane, the program shows tabs that display the details of the 
Users, Sessions, and Processes of the server.  
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Terminal Services Manager � Session Processes 

If a session is highlighted in the tree pane, the program displays Processes and Information 
tabs.  

Send Message 
Terminal Service Manager can be used to send messages to terminals.  

Right click on a connection in the tree pane or right click on a user in the detail-view panel will 
launch a menu.  
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Terminal Services Manager � Right-click Menu 
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Select Send Message. This will launch a message box. 

 

Send Message Dialog Box 

Fill in the desired message. 

Select OK to send. 

Note: Messages can be sent from the command line by using C:\ net send 
username “message”, where username is the recipient�s login name and 
message is the desired message. 

Shadowing and Remote Control 
Shadowing is a Windows NT/2000 Terminal Server utility that allows a person logged in as an 
administrator to view a client session from another client. Additionally, the administrator�s 
keystrokes and mouse movements can be configured to provide input to the shadowed client. 
This feature allows an administrator to do remote troubleshooting and support.  

Note: This program is called Shadowing in Windows NT 4.0 TSE and Remote 
Control in Windows 2000. 

Remote Control is initiated in the Microsoft Windows 2000 Terminal Services Manager.  
Open this program by selecting Start>Program Files>Administrative Tools>Terminal 
Services Manager.  
Either highlight a connection in the tree pane and select Action>Shadow from the menu bar, or 
right-click a client on the user tab of the detail-view pane and select Remote Control. This will 
initiate the Remote Control session.  
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Shadowing / Remote Control 

Note: The server console is not available for shadowing. Only administrators 
can shadow. An administrator can run the shadow session from one client to 
another client. 

The default hot keys used to end a shadow session are CTRL + * (on the 
number keypad). Please remember this escape hot key. 

Windows 2000 Remote Control 
Configuration 

A Windows 2000 session must have its user profile configured to allow shadowing/remote 
control. This is done in the User Properties dialog box. The User Profile is accessed from the 
Computer Management Console.  

Open this program by selecting Start>Programs>Administrative Tools>Computer 
Management.  
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Computer Management � User List 

To launch a User Profile, select the System Tools > Local Users and Groups > Users folder in 
the Computer Management tree pane and double-click on the desired user. This will launch the 
User Properties for the selected user. 

 

Windows 2000 User Properties 



200 Copyright 1999-2003 © Automation Control Products 

There are several parameters that allow shadowing/remote control to be configured. 

• Enable remote control, if selected, will allow the user to be shadowed. Shadowing 
is not permitted if this is unchecked. 

• Require user�s permission, if selected, will launch a dialog box on the user�s 
screen that needs accepted before shadowing can begin. The shadowing will take 
place without confirmation if this is unchecked. 

• View the user�s session, if selected, will disable the administrator�s mouse and 
keyboard input, and make the administrator a passive viewer. 

• Interact with the session, if selected, will allow the administrator to control the 
session with mouse and keyboard, becoming an active participant. 

Note: The server console is not available for shadowing. Only administrators 
can shadow. An administrator can run the shadow session from one client to 
another client. 

 

Note: A change to a profile requires that the session is logged off and re-
established. 

Duplicate Sessions 
It is possible for a terminal to be turned off and its session stays active instead of being 
disconnected. This can occur if the terminal screen is static and the server has no need to 
update the screen while the terminal offline. When the terminal reconnects to the server it 
creates a new session, creating duplicate sessions. Terminal Services Manager can eliminate 
the duplicate sessions.  

Best Practices for Graphics and Design on page 176 provides tips to preventing duplicate 
sessions. 

To manage duplicate session, launch Terminal Server Administration/Manager by selecting 
Start>Programs>Administrative Tools (Common)> Terminal Services Manager. 
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Duplicate Sessions 

Any duplicate sessions will show up in the Users tab when the server is highlighted. Three 
commands are available, Disconnect, Reset, and Log Off. These are activated by highlighting 
a session and right clicking, or by highlighting a session and selecting Actions from the menu 
bar. 

• Disconnect will disconnect an active session. 

• Reset will end a disconnected session 

• Log Off will end an active session 

These tools allow an administrator to eliminate duplicate sessions. 
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Command Prompt 
Windows 2000 has several commands that aid in managing the terminal server. Some useful 
ones are:  
Command Action 

change logon Temporarily disables logons to a Terminal server. 

change port Changes COM port mappings for MS-DOS program 
compatibility.  

change user /install Puts the server into �Install Mode�  

change user /execute Removes the server from �Install Mode� 

ipconfig Displays the IP addresses of the network card 

Logoff Logs off a user from a session and deletes the session 
from the server. 

net send username “message� 

Sends a message to a user. username is the NT/2000 
user name that the person or terminal is logged in as. 
�message� is the text of the message. Quotation marks 
are needed for any messages containing a space. 

query process Displays information about processes running on a 
Terminal server. 

query session Displays information about sessions on a Terminal 
server. 

query termserver Displays a list of all Terminal servers on the network. 

query user Displays information about user sessions on a Terminal 
server. 

reset session Resets a session to known initial values. 

shadow Monitors another user's session. 

tsdiscon Disconnects a client from a terminal server session. 

tsshutdn Shuts down the terminal server in an orderly manner 

 

See the Windows online help for additional commands and parameters. 
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Windows 2000 Server Building Instructions 
Ingredients: 

• A computer with the latest processor, and sufficient RAM for each session. We recommend 
at least 128 MB of RAM, plus 16 to 48 MB of RAM per client. 

• Windows 2000 Server Installation Disk and Terminal Server Client Access Licenses 

• ACP ThinManager CD Installation Disk 

Installing Windows 2000 
Reformatting the Hard Drive 

1. Set the computer (in CMOS) to boot from the CD-ROM drive. Insert the Windows 2000 
Server Installation Disk into the CD-ROM drive and reboot the machine (Turn the power off 
and on). If the computer is not set to boot from the CD-ROM drive, you need the 3-disk boot 
setup from Microsoft. 

2. Windows 2000 will auto-detect old copies of the OS (operating system) and analyze the hard 
drive. It will provide the option of setting up Windows 2000, repairing Windows 2000, or 
quitting. Select Enter to install Windows 2000. A number of files will be copied at this time. 

3. Select F8 to accept the licensing when prompted.  

4. Delete the existing partitions and create a new one(s). This will take a number of steps and 
confirmations. Highlight an old partition, type �D� to delete, type �L� to confirm, then type �C� 
to create a new partition. 

5. Decide if you want the FAT or NTFS file system. NTFS is recommended because it provides 
better security. 

6. Reformat the hard drive. There will be a lot of confirmations at this step. 

7. The setup files will be copied. 

8. You will be prompted to remove the CD and restart.  

9. Restart the computer. Re-insert the Windows 2000 Installation disk when prompted. 

Windows 2000 Setup Wizard 
A Windows 2000 Setup Wizard provides step-by-step configuration of the computer. Select the 
appropriate choices at each step, then select Next to continue. A Back button allows the 
retracing of steps. 

1. Installing Devices - Detects and installs devices and drivers. 

2. Regional Settings - Allows the location and keyboard settings to be changed from the USA 
default. 

3. Name & Organization - Allows the user�s name and company to be listed. 

4. Licensing Mode - Lets you list the �Per Server� or �Per Seat� licensing. If these are not 
selected now, use Licensing in Administrative Tools to record the number of Client Access 
Licenses (CAL) purchased. 

5. Computer Name and Administrative Password - Allows the name and password to be 
set. 



204 Copyright 1999-2003 © Automation Control Products 

6. Windows 2000 Components - A list appears with options and components to add to the 
server. Several components need to be selected.  

 

Windows Components 

The Windows 2000 Setup Components are shown in the following list. Sub-
categories are indented. 

√ The �Check� bullet indicates a default selection  

� The �Box� bullet indicates an optional selection 

� The �Bold Box� indicates a feature that needs selection 

 

√ Accessories & Utilities 
√ Accessibility Wizard 
√ Accessories 
√ Communications 
√ Games 
√ Multimedia 

� Certificate Services 
� Certificate Services CA 
� Certificate Services Web Enrollment Support 

√ Indexing service 
√ Internet Information Services (IIS) 

√ Common Files 
√ Documentation 
√ File Transfer Protocol (FTP) Server 
√ FrontPage 2000 Server Extensions 
√ Internet information Services Snap-In 
√ Internet Service Manager (HTML) 
� NNTP Services 
√ SMTP Service 
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� Visual InterDev RAD Remote Deployment Support 
√ World Wide Web Server 

� Management and Monitoring Tools 
� Connection Manager Components 
� Network Monitoring Tools 
� Simple Network Management Protocol 

� Message Queuing Services 
� Networking services 

� COM Internet Services Proxy 
� Domain Name System (DNS) 
� Dynamic Host Configuration Protocol (DHCP) (if desired) 
� Internet Authentication Service 
� QoS Admission Control Service 
� Simple TCP/IP Service 
� Site Server ILS Services 
� Windows Internet Name Service (WINS) 

� Other Network File and Print Services 
� File Services for Macintosh 
� Print services for Macintosh 
� Print Services for Unix 

� Remote Installation Services 
� Remote Storage 
√ Script Debugger 
� Terminal Services  

� Client Creator Files  
� Enable Terminal Services  

� Terminal Services Licensing (One server on the network needs configuration as a 
Terminal Services Licensing Server) 

� Windows Media Services 
� Windows Media Services 
� Windows Media Services Admin 

7. Windows 2000 Components - Highlight Networking Services, select Details, 
check Dynamic Host Configuration Protocol (DHCP) if needed (One server per 
network needs this enabled if you plan to use DHCP). 

8. Windows 2000 Components - Check Terminal Services. 

Note: Terminal Services needs to be selected to make the server a terminal 
server. 

9. Windows 2000 Components - Check Terminal Services Licensing if needed (one 
server on the network needs this enabled). 

10. Windows 2000 Components - Check any other needed options. 

11. Date and Time Settings - Set the Date and Time. 

12. Terminal Services Setup - Change the default selection from �Remote Administration 
Mode� to �Application Server Mode�. The Application Server Mode requires that a Terminal 
Server Licensing server be established on the network within 90 days. 
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13. Permissions - Select between �Permissions compatible with Windows 2000 Server� and the 
default �Permissions compatible with Terminal Server 4.0 Users�. The latter may be required 
for legacy applications. 

If Windows 2000 permission is chosen, the user has no access to the registry. HMI 
software users may need administrative or power user membership to operate. 

If Windows NT 4.0 permission is chosen, the user will have full access to registry. HMI 
users may function normally. 

Networking Settings - Choose �Typical� or �Custom� depending on specific needs. 

14. Workgroup or Domain - Choose the workgroup setting, if desired, and add the workgroup 
name, or choose the domain setting and add the domain name. 

15. Installing Components - The computer will copy the files needed for configuration. This 
takes several minutes. 

16. Performing Final Tasks - The computer registers components, saves settings, and 
removes temporary files. 

17. Finished - The Windows 2000 Setup Wizard is complete. It will prompt for CD removal and 
system reboot. Select Finish to finish. 

Note: The video may be set to 640x480. You may want to adjust the resolution 
when the install is complete. 
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Windows 2000 Start Up � Configuring the Server 
1. Windows 2000 Configuring Your Server � A configuration screen is shown when the 

server boots for the first time with the new operating system. The Configure The Server 
dialog box is similar to an HTML page, with a sidebar with configuration categories and a 
main panel with instructions and configuration details. The main panel shows three choices 
at the initial boot: 

• This is the only server on the network 

• One or more servers will be used on the network 

• Configure the server later 

Each of these options opens a wizard to configure the installed components of the server. If 
you choose to configure the server later the Configuring The Server dialog box is access by 
selecting Start�Programs�Administrative Tools�Configure Your Server. 

2. Sidebar of Configure the Server � The side bar lists categories for configuration. Selecting 
a category or sub-category will display a configuration wizard in the main panel that provides 
step-by-step configuration of server features. 

• Home 
• Register Now 
• Active Directory � Used by Domain Controllers 
• File Server  
• Print Server  
• Web/Media Server 

• Web Server (IIS)  
• Streaming Media Server 

• Networking 
• DHCP (If Desired) Select this to configure the Dynamic Host Configuration 

Provider, or select Start�Programs�Administration Tools�DHCP 
• DNS 
• Remote Access 
• Router 
• Application Server 
• Component Server 
• Terminal Services  
• Terminal Services Configuration -  
• Add/Remove Programs 
• Terminal Services Client Creator � Makes disks for creating clients 
• Terminal Services Manager 
• Terminal Services Licensing 
• Database Server 
• E-mail Server 

• Advanced 
• Message Queuing 
• Support Tools 
• Optional Components 
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Microsoft CALs and TS CALs  
ACP Enabled thin clients require a terminal server running Microsoft�s Windows NT 4.0 
Terminal Server Edition or Windows 2000 Server with Terminal Services enabled as an 
operating system. .. 

Each of these operating systems requires a standard Microsoft Client Access License (CAL) for 
each connection to the server. These are based on concurrent use; a 5-pack would allow more 
than five users to access server resources, but only five users at a time.  

Terminals require an additional Microsoft Terminal Server Client Access License (TS CAL) to 
connect to the server using either RDP or ICA. This licensing is per seat; ten terminals would 
require ten TS CALs, even if only two were connected at a time.   

Windows NT 4.0 Terminal Server Edition is sold with TS CALs. These are installed on the 
terminal server. Additional TS CALs are available from Microsoft. 

Windows 2000 has a new method of license management. All TS CALs are installed on a 
Terminal Services Licensing Server. This acts as a repository for all TS CALs. The terminal 
servers request TS CAL authentication from the Terminal Services Licensing Server as terminals 
attach to terminal servers. 

The Terminal Services Licensing server is activated through the Internet by connecting to the 
Microsoft Certificate Authority and License Clearinghouse.  

Windows 2000 Server with Terminal Services enabled will issue 90-day temporary licenses while 
the Terminal Services Licensing server is being setup and activated. If this period has elapsed, 
the terminal will not connect to the terminal server and will display an �Error Number 50� 
message box. 

Windows 2000 Server is not normally sold with TS CALs. These need to purchased separately 
and installed on the Terminal Services License server.  
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DHCP Server Setup 
A DHCP server can be installed on a number of different platforms. In this class, we will be using 
the Windows 2000 DHCP Server.  It can be installed during installation or added later. 

To add DHCP to a Windows Server after installation select Start>Settings>Control 
Panel>Add/Remove Programs>Add/Remove Windows Components. A Windows 
Configuration Wizard will launch. 

 

Windows Components Wizard 

Highlight Networking Services in the list window and select the Details button. 
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Networking Services 

Check the Dynamic Host Configuration Protocol (DHCP) check box and select the OK button. 

The wizard will install the DHCP server. 

 

Application Server Mode 
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As part of the Windows Components Wizard, you may be asked to confirm the terminal service 
mode. The terminal server needs to run in application server mode to work with ACP Enabled 
thin clients. 

DHCP Scope Configuration for Microsoft 
DHCP Server 

A DHCP server, in its simplest form, will assign an IP address to a computer that joins a network 
and requests one. A DHCP scope is a range of IP addresses that are available for assignment.  

ACP Enabled thin clients need more information from the DHCP server than just an IP address. 
They need the IP address of the ThinManager server and the name of the firmware to download. 
This information needs to be added to the DHCP scope in the form of options. 

To establish a DHCP scope, open the Computer Management Console by selecting 
Start>Programs>Administrative Tools>Computer Management. 

 

Create a DHCP Scope 

Highlight DHCP in the Services and Applications folder of the tree pane and select Action>New 
Scope. 

A New Scope Wizard will launch that will guide the process of creating the scope. 
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Scope Range 

Set the range of IP addresses by entering the starting IP address for the scope and the ending 
IP address of the scope. 

Enter the desired subnet mask. 

Select the Next button to continue. 

 

 

Scope Exclusions 
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If computers are already assigned IP addresses in the scope range, they can be excluded from 
the range by adding the IP address(s) and selecting the Add button. 

Scope Options 
The DHCP Server needs two options configured before it will provide all the information that the 
terminal needs to boot. These options are Option 066 and Option 067. 

 

Boot Server Host Name 

The Boot Server Host Name, Option number 066, assigns a ThinManager server to the 
terminal.  

Open the Scope Options dialog box by highlighting the Scope Option folder in the tree pane of 
the Computer Management Console under the Services and Application>DHCP folder and 
selecting Action>Configure Options. 

Scroll through the list window and check the Option 066 check box.  

Enter the IP address of the desired ThinManager server in the String Value field.  
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Boot Server Host Name for Dual ThinManager  Servers 

The DHCP Server can issue the IP address for a Primary ThinManager Server and a Secondary 
ThinManager Server by listing the IP addresses of both, separated with a space. 

Do not select the OK button yet.  
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DHCP Options 

The Bootfile Name, Option number 067, tells the terminal what file to download during the boot 
process. 

Scroll through the list window and check the Option 067 check box.  

Enter firmware.acp in the String Value field.  

Select the OK button to accept the configuration of options. 
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Completed Scope 

Once the scope is added, the range is set, and the options are configured, it needs to be 
activated.  

Highlight the scope in the tree pane of the Computer Management Console. Select 
Action>Activate. The scope is now active. 
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Scope Reservation 

 

Scope Reservation 

Even though DHCP assigns IP addresses dynamically on a first come, first served basis, 
Reservations allows an IP address to be reserved for a specific terminal. An IP address can be 
matched with a MAC address to create a reservation. This allows DHCP to assign a �static� IP 
address.  

The New Reservation window is launched by selecting the Reservation folder in the tree pane of 
the Computer Management Console under the Services and Application / DHCP folder and 
selecting Action�New Reservation. 

The MAC address of a terminal is displayed in the details-view pane of ThinManager. 

DHCP Properties 
The DHCP Server can be configured to check for duplicate IP addresses before issuing a new 
address. This is a good feature to use. 

Highlight DHCP under Services and Applications in the Computer Management tree and select 
Action>Properties, or right-click on DHCP and select Properties. The DHCP Properties 
window will launch. 
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DHCP Properties � Advanced Tab 

Select the Advanced tab. Replace the zero in the Conflict detection attempts field with an 
integer. This will prompt the DHCP Server to check for duplicate IP addresses before assigning 
an IP address. 

Select OK when finished. 
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Creating User Profiles 
A terminal needs a valid Windows NT/Windows 2000 User Profile to log onto a terminal server.  

To create a user profile in Windows 2000 open the Computer Management Console by 
selecting Start>Programs>Administrative Tools>Computer Management.  

 

Computer Management Console 

Highlight the User sub-folder of Local Users and Groups in the Computer Management tree 
pane.  

Select Action>New User. This will launch a New User dialog box.  
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New User 

Enter the user name for the non-administrative user in the User name field. 

Enter a password in the Password field.  

Re-enter the password in the Confirm password field.  

Uncheck the User must change password at next logon check box. This allows auto-logon of 
the terminal. 

Select the Create button to finish the profile.  

Select the Close button to return to the Computer Management Console. 
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Microsoft Terminal Server Licensing Activation 
In Windows 2000, all the TS CALs are installed on a single Terminal Server Licensing Server. 
This allows a single site for management and authentication of terminal server connections. A 
server becomes a Terminal Server Licensing Server by selection of the option during the 
installation phase or by selecting Add/Remove Programs> Add/Remove Windows 
Components from the Control Panel and selecting the Terminal Services Licensing. 

The licensing of the Microsoft components of a Windows 2000 terminal server is a is a two-step 
process; one must first authorize the Terminal Server Licensing Server, then one must activate 
the licenses. The license activation will be repeated for each license pack. 

Note: The Terminal Server Licensing Server does not need to be a separate 
computer, but is usually installed on a Terminal Server. Microsoft requires that 
the Terminal Server Licensing Server be installed on the Primary Domain 
Controller in a domain. 
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To begin the process select Start>Programs>Administrative Tools>Terminal Server 
Licensing on the Terminal Server Licensing Server. 

 

Terminal Services Licensing 

Highlight desired server 

 

Selected Terminal Server 

Select Action>Activate Server from the menu bar. 
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Licensing wizard 

The Licensing Wizard will launch. 

 Follow the steps of the wizard.  

Note: The ID numbers shown on screens have been changed to �1234�. Please 
use the appropriate numbers that apply to your server and licenses. 

 

Connection Method 

 

There are several methods for connecting to the Microsoft License Clearinghouse. 
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• Internet � Allows activation through a direct connection to Microsoft. The Licensing 
Server must have Internet access. 

• World Wide Web � Allows activation at Microsoft�s web site through a web browser. 

• Fax � Allows activation through faxes to Microsoft. 

• Telephone � Allows activation through the telephone. 

Select the desired method from the drop-down box and select Next. 

Note: This will detail the World Wide Web method. 

 

License Server Activation 

The server needs a License Server ID for authorization. This is done on the Microsoft web site. 

Go to the https://activate.microsoft.com site mentioned in the dialog box. 
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Microsoft Terminal Services Licensing Web Site 

Select Activate a license server and select Next. 
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Customer Information Entry Form 

Fill out the information forms and select Next. The Product ID is supplied by the Licensing 
Wizard. 



 

Help With Non-ACP Components � 227 

 

Customer Information 

Continue with web-based wizard. Verify the data and select Next. 
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Server Activation Number 

The Microsoft will provide the License Server ID. 

Add this number to the form in the Licensing Wizard. 
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Wizard Completion 

Once the License Server ID is placed in the appropriate fields on the Licensing Wizard, you will 
have a choice to continue and activate the license packs, or to stop with the server activation. 

Microsoft TS CAL License Authorization 
To continue adding license packs, return to the https://activate.microsoft.com web site. 
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Microsoft Terminal Services Licensing Web Site 

Select the Install client license key packs and select Next. 
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Customer Information 

Fill out the form and select Next. 
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TS CAL Information 

Select the Product Type and fill in the fields with the Quantity, Authorization Number, and 
License Number from the Licensing Certificate that was included with the purchase of the 
licenses. 

Select Next to continue. 
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License Information 

Verify that the information is correct and select Next to continue. 
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License Key Pack ID 

The Microsoft site will provide the License Key Pack ID. This needs to be installed in the 
Licensing Wizard. 
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License Key Pack ID Fields 

Fill in the fields of the Licensing Wizard with the License Key Pack ID from the Microsoft site and 
select Next. 

 

Licensing Completion 

The licenses will be added and will be displayed in the Terminal Services Licensing window. 
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Citrix Device Services 

Citrix Device Services Licensing 
The second component is the ICA (Independent Computer Architecture) communications 
protocol from Citrix that provides the communication between the server and the thin client. ACP 
ThinManager software contains a licensed copy of Citrix Device Services on the ACP 
ThinManager CD to provide the ICA protocol. Citrix Device Services needs to be installed on 
each terminal server.  

Citrix Device Services needs a license added immediately to allow terminal-to-server 
communication. The license can be added during the installation process or it can be added 
when the installation is finished. A license number that is located on the ThinManager CD label is 
used for licensing. Instructions are provided with ThinManager. 

The Citrix Device Services License will need to be activated within a 35-day grace period 
to continue functionality. The activation is done within the Citrix web site at 
http://www.citrix.com/activate. Instructions are provided with ThinManager. 

Note: A license is needed immediately for the ICA connection. The license will 
need to be activated within a 35-day grace period. 

 

Note: MetaFrame is licensed in a similar manner. Please see the documentation 
that comes with MetaFrame for details. 
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Citrix Device Services Licensing Flow Chart 

Open the Citrix Licensing dialog box by selecting Start>Programs>Citrix Device Services 
Tools (Common)>Citrix Licensing.  
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Citrix Licensing Dialog Box 

Note: The Citrix Device Services for Windows license is installed during setup. It 
is not enough to provide functionality. A Citrix Device license is needed. 

Select License>Add from the menu bar to launch the Enter Licensing Serial Number dialog 
box  

 

Enter License Serial Number  

Enter the Citrix License number found on the inside of the ACP ThinManager CD case in the 
Serial Number field. 

Note: This number may be called the License Code, Serial Number, or License 
Serial Number. 

Select OK to continue. 
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License Serial Number and License Code 

The License Serial Number will have a Machine Code of eight numbers added to it and will be 
displayed in the Citrix Licensing window as the License Number. Although the license is now 
installed, it needs to be activated within 35 days to keep it functional. 

Citrix License Activation  
The Citrix Device Services has a 35-day grace period, after which it is not fully functional until it 
has been activated. Adding an Activation Code activates the license. This Activation Code is 
obtained from the Internet at the Citrix web site at http://www.citrix.com or through the Activation 
Wizard. The Activation Code can be obtained from Citrix with any machine that has an Internet 
connection.  

Note: Since web sites are dynamic, the exact layout of the web screens may 
change, but the functionality should remain the same. If you have problems, 
please contact Citrix or e-mail support@acpthinclient.com for help. 
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Citrix Web Site at www.citrix.com 

Select the Product Activation hyperlink on the Citrix home page. It will link to 
http://ww.citrix.com/activate. 
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Citrix Product Activation System 

Select the Follow this link to activate any Citrix product hyperlink. This launches the Citrix 
Activation System. 
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Citrix Login Page 

Previously registered users can fill in the Login ID and Password fields to enter the Citrix 
Activation System.  

New users need to select the Register for a Login ID Password link. This will launch the 
Company Search page. 
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Company Search 

Users can search for their company�s registration on the Company Search page. Users whose 
company is not registered should select the Enter Information for a New Company hyperlink to 
begin the registration procedure.  
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Company Search 

An on-line form will be displayed with fields for information about registering the company. Fill 
these in to continue and select the Continue button.  
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Citrix Activation System 

A page will be displayed that allows the choice of activating licenses, renewing subscriptions, or 
editing login information.  

Select the Citrix Activation System hyperlink. This will launch the Activated License page. 
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Activated License Page 

The Activated License Page will be displayed showing the activated licenses that the registered 
company holds. If this is a new company registration, no licenses will be displayed.  

Select the New License button to continue. 

Note: The ID numbers shown on screens have been changed to �1234�. Please 
use the appropriate numbers that apply to your server and licenses. 
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License Activation � Step 1 

The License Activation screen will be displayed. 

Enter the License Code that was generated during installation, as shown in Citrix Device 
Services Installation On Windows 2000. This is the License Serial Number that is in the 
ThinManager CD case, with the Machine Code added. 

Select the Continue button to proceed. 
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License Activation � Step 2 

The Select Reseller screen will be displayed. 

Select the I cannot find my reseller link to continue. 
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License Activation � Step 3 

A new screen will appear that displays the Activation Code for the installation.  

Write this Activation Code down for use in activating the license. 

Print a copy of this page for a record, and then exit the Citrix web site. 

Obtaining an Activation Code through the 
Activation Wizard 

An alternative way to obtain an Activation Code from Citrix is through the Activation Wizard. 
This provides the option of using TCP/IP, a Web Browser (as explained in the previous section), 
or by dialing up with a modem.  

To use this method select Start>Programs>Citrix Device Services Tools 
(Common)>Activation Wizard. When the Activation Wizard is displayed, follow the 
instructions for contacting Citrix to obtain an Activation Code. 
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Citrix License Activation Wizard 

Activation of a Citrix License 
Once an Activation Code is received, open the Citrix Licensing window by selecting 
Start>Programs�> Device Services Tools (Common)>Citrix Licensing. 

 

Citrix Licensing 

When the Citrix Licensing window is displayed, highlight the inactive license and select the blue 
check mark icon from the toolbar or select License>Activate License� from the menu bar.  

This will display the Activate License dialog box. 
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Activate License Dialog Box 

Enter the Activation Code from the Citrix web site in the Activate License dialog box.  

Select OK to finish the license activation. A dialog box will confirm the license activation. 

 

License Activation Confirmation 

The Citrix Device Services is now active on the server. 
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Appendix  
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History 
The Technology of Thin Clients  
By David Hancock, 3/23/2000 
Reprinted with permission of VerticalNet Inc. (Horsham, PA).  
This article first appeared on Plant Automation.com in March 2000. 
Thin client computing is getting ready to move onto the factory floor and its impact on plant 
automation promises to be substantial. While it is a new technology, the methodology comes 
from the earliest days of computing.  

Most of us remember the days when a company or university had just one or two computers. 
They were always locked up in a special, limited access room, and tended to by specially trained 
people (sometimes even wearing lab coats). Our only access to this machine was through a 
computer terminal, which served only as an input/output and display device.  

If you stop and think about it, this computing model was very easy to maintain. While users could 
run whatever software was loaded on the central computer (or �mainframe�), the programs and 
data files were protected in the same room with the expensive and delicate computer equipment.  

With the advancement of computer technology it became possible to distribute the computing 
power around to individual users. The use of �dumb� terminals began to fade and the era of the 
Personal Computer (PC) began.  

While the PC allowed users to run programs with complex, windows-based controls, it also 
created a situation where the highly trained computer people had to get out of their central office 
more. Now rather than being able to support the computers for an entire company from a single 
room, the IT department had to spend more and more time scattered throughout an organization.  

There was always a user that couldn�t get the latest software update working, or had installed a 
game package that wiped out parts of his accounting package or, worse still, had loaded an 
unauthorized application that included some type of virus.  

Back to Centralization  

Several years ago, it was discovered that the capabilities of computer hardware and networking 
systems allowed for a movement back to the centralized computing model that was so easy to 
support.  

A startup company called Citrix modified Microsoft�s NT 3.51 product and produced an operating 
system that was capable or running multiple client sessions, while sending the video output to be 
displayed on another computer. Microsoft liked what they saw enough to team up with Citrix and 
produce a version of Windows NT 4.0 (called Windows NT 4.0 Terminal Server Edition, or TSE) 
that was able to support these remote terminals.  

The original displays for the sessions running on the server were full PCs that had special 
software (loaded on top of their standard Windows OS) to receive and display the video images, 
and pack and send the user�s keyboard and mouse commands back to the server.  

Several hardware manufacturers quickly realized that in many applications a full PC was overkill, 
and started to make clients designed specifically to respond to the server sessions. They 
reduced cost and complexity by taking out some RAM, limiting the number of expansion slots 
and, most importantly, removing all of the disk drives, replacing them with a small, embedded 
operating system. Since these clients were created essentially by removing components from 
standard PCs, they became known as �thin clients�.  

The new thin client technology had some tangible advantages. Any software that needed to be 
run could now simply be loaded or updated on the server, and all of the clients had access. As 
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no software actually ran on the clients (it all runs on the server) any client can be powered down 
without having an effect on the user�s program or data. Clients can be swapped with almost the 
same ease that ASCII terminals were replaced 15 years ago. And, because the new clients are 
diskless, users can no longer add their own programs or remove company data.  

With thin clients, support can again shift back to a central server located in a secure area with 
limited access. New clients can be added anywhere a standard Ethernet network cable can be 
run.  

We all know that the industrial market follows the commercial market by several years and, using 
that formula, now is the time for thin clients to start moving onto the factory floor.  

As much sense as the thin client makes in the office environment, it makes even more sense in 
the factory. The last thing that the average plant manager wants is a full PC located at each line. 
His goal is simply to have the same HMI or SCADA displays that his operators have grown 
accustomed to without the maintenance nightmare of distributed computers. With a thin client 
system, he can have just that. All of the software that he has been running on his NT machines 
can now run on one or more servers located off of the floor in a protected environment.  

User Driven  

Unlike many of the advances in plant automation, the movement to a thin client architecture is 
not being driven by the software manufacturers. It is the users that are demanding that the major 
HMI and SCADA companies provide support for customers who want to run their software from 
clients rather than PCs.  

Within the next several months, there will be announcements about products that are designed 
specifically with thin clients in mind. And, as Microsoft built support for thin clients into Windows 
2000 Servers, new software designed for that operating system will start out thin client ready.  

HMI and SCADA applications are not the only packages that can take advantage of thin clients. 
Almost anywhere that a full PC is currently running standard Windows software, it can be 
replaced with a thin client terminal.  

This can be especially useful to companies that want to run software around the plant simply to 
record and display information about part production and inventory. Where previously a full 
Windows PC was required, the software can be moved back to the server and a thin client 
substituted for the PC. Plug in a hand scanner or barcode reader, and the display looks exactly 
the same to the operator. But the cost, both for the initial hardware and for the long-term support, 
looks decidedly different to management.  

What does this mean to the typical PC based factory installation? It means that they can now 
install or upgrade their software one time, on the server, and have it immediately available to all 
of the clients. It also means that they can have their expensive software available in more 
locations than before. If they need, say, 50 clients running on the floor, they can now buy 60 
licenses and have 10 licenses available for any manager who wants to take an occasional peak 
at how the machines are running. Since the server controls the number of sessions that are 
started, the 61st user will not be able to bring up a session until some other user goes offline.  

The software companies are happy because they just sold an additional 10 licenses, and the end 
user is happy because he just got the ability for 25 managers to have occasional access to the 
software without buying 25 more licenses.  

Right now there are very few companies making thin clients designed for the harsh environment 
of the factory floor. However, as the benefits of thin client computing become known, the number 
of vendors will rise dramatically. As that begins to happen, it won�t be long before you or one of 
your competitors will have found that a thin client system is the preferred way to run Windows 
software in a manufacturing environment.  

"Reprinted with permission of VerticalNet Inc. (Horsham, PA).  

This article first appeared on Plant Automation.com in March 2000." 
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